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1. Managing a Moodle site 

 1.1 Managing accounts 
 An administrator can perform various tasks relating to user accounts in Administration > Site administration > 

Users > Accounts.  

 1.1.1 Browse list of users 

 An administrator can browse and search the list of all user accounts in Settings > Site administration > Users > 

Accounts > Browse list of users. 

 Administrators can search for a particular user, using their name or email address as the search term, and then 

edit their profile. Editing a user's profile is a way to reset the user's passwords when they are unable to log in. Another 

reason for needing to edit a user’s profile is to disable their email address if the site is receiving lots of undelivered mail. 

 1.1.2 Bulk user actions 

 The bulk user actions feature in Administration > Site administration > Users > Accounts > Bulk user actions 

enables administrators to select users by creating a filter and then perform any of the following actions: 

 Send a message (requires Messaging to be enabled) 

 Delete user accounts 

 Display a list of users on a page 

 Download user data in text, ODS or Excel file format 

 Force users to change their passwords 

 Add users to a cohort 

 To perform a bulk user action 

 If you know them, choose your users from the available 

list or else click Show Advanced to create a filter. 

 Users can be filtered according to full name, surname, 

first name, email address, city/town, country, 

confirmed, first access, last access, last login, 

username, authentication.  

 If you have set a custom profile field, this is available 

too from the "Profile" dropdown box  

 Select users from the list. 

 Choose an action from the dropdown menu ] 

 

 

 1.1.3 Adding a new user 

 An administrator or manager (or any other user with the capability moodle/user:create) can create 

new user accounts in Settings > Site administration > Users > Accounts > Add a new user. 
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 Username 

 The user will use this username to log in to the Moodle instance. It needs to be unique. This may be 

changed. A user's name can only contain alphabetical letters in lowercase, numbers, hyphen '-', underscore 

'_', period '.', or an at character '@'. 

 Authentication method 

 Choose Joomdle if you want to have the user also created in Joomla. 

 Suspended account 

 Suspended user accounts cannot log in or use web services, and any outgoing messages are discarded. 

 Generate password and notify user 

 Moodle will generate a temporary password and email the user with instructions on how to log in and change it. 

The email message (as in the screenshot below)may be changed in Site 

administration>Administration>Language>Language settings. Select 'moodle.php' and the string identifier 

newusernewpasswordtext                               

                                       

 Password 

 This is the user's password. It is subject to the password policy in Site policies. A user can change their password 

by the Settings block > My Profile settings > Change password link. 

 First Name 

 The user's first name. It is displayed along with the last name in messages, forum posts, participants list, reports 

and anywhere where something about the user is shows on the page. 

 Surname 

 The user's surname. It is displayed along with the first name in messages, forum posts, participants list, reports 

and anywhere where something about the user is shows on the page. 

 Email address 

 Password reset notices, forum digests and other messages are sent to this email address from the Moodle site. 

 Email display 

 This setting controls who can see the user's email address. 

 Email format 

 This setting can be used such that Moodle will send text-only emails to the user. 
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 Email digest type 

 This setting set whether the user will receive an email for each new forum post in subscribed forums, or if new 

posts should be sent once per day in a digest, and which type of digest. 

 No digest (one receives individual emails), 

 Complete (a single digest daily) or 

 Subjects (a single digest daily with only the post topics included). 

 Forum auto-subscribe 

 If a user subscribes to a forum, new posts will be sent in the digest as specified. This setting sets whether a user 

is automatically subscribed to forums or if a manual click on the subscription button in each forum is required. 

 Forum tracking 

 This setting specifies whether new posts written since the user's last visit should be highlighted as such. 

 When editing text 

 This setting specifies whether the user prefers to see the WYSIWYG text editor or just a plain text box. 

 Screen Reader 

 Enabling this setting will improve the display of Moodle to make it more compatible with screen readers. 

 City/town 

 The user's city or town 

 Country 

 The user's country 

 Timezone 

 This setting is used to adjust the times of messages and assignment/quiz due dates to match the user's local 

time 

 Preferred language 

 This will cause the Moodle interface to be displayed in the specified language. (See Language packs) 

 Note: Content will not be translated automatically, but if multi-language content is entered the appropriate 

language content will be displayed, if available. 

 Description 

 Information about the user that other users can see. 

 User Picture 

 The user's picture can be displayed next to the user's name next to any content he/she has posted in Moodle 

activities such as the forum. See User pictures for details. 

 Interests 

 The list of interests can be used as a way of connecting users with similar interests. Tags must be enabled on the 

site. 
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 Optional 

 There are several optional fields that come with an standard install. These include: Web Page, ICA number, 

Skype ID, AIM ID, Yahoo ID, MSN ID, ID number, Institution, Department, Phone, Mobile Phone, Address. 

 1.1.4 Cohorts 

 Cohorts are site-wide or category-wide groups. Cohorts enable all members of a cohort to be enrolled in a 

course in one action, either manually or synchronised automatically. 

 Creating a cohort 

 Cohorts can be created by site administrators and other users with appropriate permissions. 

 Access Administration > Site administration > Users > Accounts > Cohorts 

 

 Click the Add button 

 NOTE In the dropdown you can choose between making your cohort available throughout the site "system" or 

in a named category. 

 Cohorts are visible to teachers by default but unchecking the 'Visible' link will mean they are not available for 

teachers to use in their courses. New feature 

 Complete the details and save the changes. 

 Follow the assign link opposite the cohort name in the list of available cohorts. 
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 Select potential users from the list then click the Add button. 

 To synchronise cohort members with course participants, the Cohort sync enrolment plugin should be enabled 

in Administration > Site administration > Plugins > Enrolments > Manage enrol plugins. 

 Adding users to a cohort in bulk 

 Access Administration > Site administration > Users > Accounts > Bulk user actions 

 Find users by setting an appropriate filter 

 Add users from the available list to the selected list 

 Choose 'Add to cohort' with selected users 

 Managing category cohorts 

 Cohorts which have been created for a category rather than the system can be located by selecting the 

appropriate category and then clicking the Cohorts link in Administration>Category (name)>Cohorts 

 1.2 Enrolments 
 Enrolment, or 'enrollment', is the process of marking users as participants in the course, that includes both 

students and teachers. At the same time users are usually give a role in the course which specifies what they are 

allowed to do. 

 1.2.1 Enrolment plugins 

 Moodle provides a number of ways of managing course enrolment, called enrolment plugins. 

 

 To set an enrolment method: 
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 Click on Administration > Site administration > Plugins > Enrolments > Manage enrol plugins. 

 Click on the enable checkboxes opposite your chosen enrolment plugin(s). If you wish, you may choose more 

than one enrolment method.  

 Click the "Save changes" button. 

 Click the settings link opposite the enrolment plugin(s) you have chosen. 

 Configure the required settings and click the "Save changes" button. 

 Repeat until you have edited all the plugins you have enabled. 

 The order in which enrolment plugins are applied can be set. This may be important for some plugins. It also 

affects the order of enrolment options on the course enrol page. 

 

 1.2.2 Manual enrolment 

 The manual enrolments plugin allows users to be enrolled manually via a link in the course administration 

settings. The plugin has to be enabled by the site administrator (see Enrolment plugins) and should normally be enabled 

as certain other enrolment plugins, such as self enrolment, require it. 

 Course settings 

 Checking you have manual enrolment in your course 

 In a course, go to Administration > Course administration > Users > Enrolment methods 

 Make sure Manual enrolments has its "eye" opened. 

 

 Editing manual enrolment settings 

 Managers (and any other users with the capability enrol/manual:config) can edit the manual enrolment method 

in the course and set the default enrolment period and default role in Administration > Course administration > Users > 

Enrolment methods. 
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 It is possible also for students and/or teachers to be notified when enrolments expire by selecting either 

"Enroller only" or "Enroller and enrolled user" from the dropdown "Notify before enrolment expires" and a time in 

"Notification threshold". 

 Enrolling users 

 Method 1 

1. Go to Administration > Course administration > Users > Enrolled users 

2. Click the 'Enrol users' button at the top right or bottom left of the page 

3. Use the 'Assign roles' dropdown if you wish to change the role 

4. Select enrolment options as appropriate 

5. Browse or search for the user (Note that when searching for users, exact matches are listed first) 

6. Click the Enrol button opposite the user. The user will indent in the list and the enrol button will disappear, 

indicating that the user is enrolled. 

7. When you have finished, click the 'Finish enrolling users' button (or simply close the enrol users box) 

 The user will then appear in the list of enrolled users. 

 Note: The enrolment option 'Recover user's old grades if possible' is not ticked by default and is easy to miss. An 

admin can make it so that the checkbox is ticked for all courses on the site by enabling the setting 'Recover grades 

default' in Administration > Site administration > Grades > General settings. 

 

 Method 2 

1. Go to Administration > Course administration > Users > Enrolment methods 
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2. Click the 'Enrol users' icon in the edit column opposite manual enrolment 

3. Select users from the not enrolled users list, using Ctrl + click to select multiple users 

4. Click the add button to add the users to the enrolled users list 

 

 Editing individual enrolment start and end dates 

 Enrolment start and end dates may be edited for individual students as follows: 

1. Go to Administration > Course administration > Users > Enrolled users 

2. Click the edit icon in the enrolment methods column for a particular user. 

3. Edit dates as required, then click the 'Save changes' button. 

 

 Admin settings 

 The manual enrolment plugin may be enabled or disabled site-wide in Administration > Site administration > 

Plugins > Enrolments > Manage enrol plugins. 

 Site-wide settings, including default settings for manual enrolment in new courses, may be set via 

Administration > Site administration > Plugins > Enrolments > Manual enrolments. 

 Enrolment expiration action - specifies what happens when user enrolments reach expiration date. Please 

note that option "Unenrol user from course" purges grades, group memberships, preferences and other 

user related data from the courses. 

 Hour to send enrolment expiry notifications - specify hour for sending expiration notifications. 

 Add instance to new courses- if this is enabled, then whenever a new course is created, manual enrolments 

will automatically added to new courses. 

 Enable manual enrolments - this specifies if enrol instances are enabled by default in new courses, it is 

strongly recommended to keep this setting enabled. 

 Default role - this sets the default role, which is normally student and may be altered by a teacher in a 

course. 

 Default enrolment duration - this sets the default length of enrolment in new courses. 

 Notify before enrolment expires - specifies if teacher or optionally students should be notified before the 

expiration. 

 Notification threshold - specify how many days should be users notified before the enrolment expiration. 

 1.2.3 Self enrolment 

 Self enrolment is the method whereby users can choose to enrol themselves into a course, either immediately 

by clicking "enrol me in this course" or by typing in an enrolment key they have been given. The enrolment plugin needs 
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to be enabled by the site admin in enrolment plugins and has to be enabled within the course. The manual enrolment 

plugin has to be enabled in the same course as well. 

 Course settings for self enrolment 

 Checking self enrolment is enabled 

In a course, go to Administration > Course administration > Users > Enrolment methods and ensure the "eye" is opened 

for self enrolment. 

 

 Adding an enrolment key to a course 

 A course enrolment (or enrollment) key is one method of restricting Self enrolment to a smaller group. The 

default setting is not to set a key and allow anyone to enrol themselves into the course. 

 An enrolment key is often used as a simple method of having someone else beside the teacher determine if a 

particular student can self enrol in the course. The idea is that one or more people will supply the course key to 

authorized people. Sometimes this distribution is private email, snail mail, on the phone or even verbally in a face to 

face meetings such as a class or counselor's office. 

 In the course administration block, click Users>Enrolment methods 

 Make sure self enrolment is enabled (has its eye open) and then click the edit icon on the right: 

 

 Add your enrolment key in the box provided. (Click Unmask to see what you are typing.) 
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 Click Save changes 

 Setting a group enrolment key 

 If you wish your users to enrol themselves directly into a group in the course then you can set a group 

enrolment key which you then tell them to use when they access the self-enrolment screen.  

 To do this, you first need to add the course enrolment key as in the section above. 

o If you do not set a master course enrolment key for the course, then anyone can enrol without a key 

and users will not be put into groups. 

o Users in groups do not need to know the master course enrolment key, only their own group 

enrolment key. 

o Users not in a group can use the master course enrolment key as usual 

 Change the setting Use group enrolment keys to Yes 

 Save the changes and then in the Course administration settings, click Groups>Create groups 

 Add an enrolment key to the group. This will be the key they type in to access the course. (The course 

enrolment key is simply there to keep others out) 

 Making an enrolment key required in every course 

 By default, enrolment keys are not set. However, if the administrator wants to ensure all teachers set enrolment 

keys then this can be forced in Administration>Site Administration>Plugins>Enrolments>Self enrolment This means that 

self enrolment settings will not "stick" until the teacher adds an enrolment key. 
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 NOTE: It does NOT provide a site wide enrolment key. 

 Using the password policy for enrolment keys 

 To ensure that teachers use secure keys that follow your Moodle's password policy, check the box in 

Administration>Site Administration>Plugins>Enrolments>Self enrolment. 

 Giving users a hint of the enrolment key 

 By default, for security reasons, Moodle will not give any clues as to what the enrolment key is. Checking the 

box in Administration>Site Administration>Plugins>Enrolments>Self enrolment will provide the first letter of the 

enrolment key if needed. 

 Setting the enrolment period 

 Tick the "enable" box to the right of Enrolment period and then choose your dates. 

 Enrolment duration 

 Set the amount of time a user enrolment is valid, starting with the moment the user enrols themselves. If 

disabled, the enrolment duration will be unlimited. 

 Notifying users when their enrolment expires 

 It is possible also for students and/or teachers to be notified when enrolments expire by selecting either 

"Enroller only" or "Enroller and enrolled user" from the dropdown "Notify before enrolment expires" and a time in 

"Notification threshold". 

 

 Deciding the maximum number of users in your course 

 Type the maximum number of users you want in your course in "Max enrolled users". When this limit is 

reached, nobody will be able to self-enrol. If you leave the number at 0 then there will be no maximum number. 

 Sending a welcome message to new users 

 If enabled, users receive the following message via email when they self-enrol in a course: 

Welcome to {Course name} If you have not done so already, you should edit your profile page so 

that we can learn more about you: {link to profile page} 

 If you want to send a different message, simply type it in the custom welcome message text box. 
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 An admin can customise the message for the whole site by editing the welcometocoursetext language string. 

 Admin settings 

 The self enrolment plugin may be enabled or disabled throughout the site in Administration > Site 

administration > Plugins > Enrolments > Manage enrol plugins. 

 Shared settings for all courses 

The page Administration > Site administration > Plugins > Enrolments > Self enrolment. contains options for defaults that 

admin can set: 

 Require an enrolment key - if this box is ticked then all courses with self-enrolment enabled will need to 

have an enrolment key. The setting won't save until the teacher adds a key - something to be aware of as 

this can cause confusion:) 

 Use password policy - tick this box if you want enrolment keys set by teachers to follow the password policy 

of the site. 

 Show hint - tick this box if you are prepared to allow the first letter of a key to be given as a "hint" 

 Enrolment expiration action - specifies what happens when user enrolments reach expiration date. Please 

note that option "Unenrol user from course" purges grades, group memberships, preferences and other 

user related data from the courses. 

 Hour to send enrolment expiry notifications - specify hour for sending expiration notifications. 

 Default enrolment settings in new courses 

 These can be set in Administration > Site administration > Plugins > Enrolments > Self enrolment but teachers in 

individual courses can alter them to suit their needs: 

 Add instance to new courses - if admin selects this, then any new course created will include the self 

enrolment plugin 

 Enable self enrolments- if this is enabled then users by default can self enrol into a course. 

 Use group enrolment keys - the setting for group enrolment keys in a course will be set to "yes" by default 

 Default role assignment - normally, when users self enrol, they have the student role. If necessary that role 

can be changed by default here - for example - if your Moodle has a dedicated role you wish to use instead. 

 Enrolment duration - this sets the default enrolment length for new courses (but again, may be altered by 

the course teacher.) 

 Notify before enrolment expires - specifies if teacher or optionally students should be notified before the 

expiration. 

 Notification threshold - specify how many days should be users notified before the enrolment expiration. 

 Unenrol inactive after- this sets the default time after which a student will be unenrolled if they haven't 

accessed the courses. (Teachers may change this) 

 Max enrolled users - adding a number here will specify the maximum number of users who can self-enrol 

into new courses. Teachers in the course can change this. If it is left at 0, there will be no maximum. 

 Send course welcome message- if this box is checked then newly enrolled users will receive a welcome 

message by default. 

 Self enrolment method options 

 One course may contain multiple self enrolment methods. User may be enrolled once in each instance only. 

 Custom instance name - specify custom enrolment method name. 
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 Enable existing enrolments - if disabled all users enrolled via this plugin can not access course. 

 Allow new enrolments - disable if you do not want to allow students to self enrol in the future. 

 Enrolment key - specify key required for enrolment. 

 Use group enrolment keys - optionally use group keys for enrolment too. 

 Default assigned role - specify role to be assigned to users during enrolment, this can be changed manually 

after enrolment. 

 Enrolment duration - specify enrolment length, this can be manually after user enrolment. 

 Notify before enrolment expires - specifies if teacher or optionally students should be notified before the 

expiration. 

 Notification threshold - specify how many days should be users notified before the enrolment expiration. 

 Unenrol inactive after- specify time after which a student will be unenrolled if they haven't accessed the 

courses. 

 Max enrolled users - adding a number here will specify the maximum number of users who can self-enrol 

into this course. 

 Only cohort members - optionally restrict this enrolment method to members of specified cohort. 

 Send course welcome message- if this box is checked then newly enrolled users will receive a welcome 

message by default. 

 Custom welcome message - specify custom message if necessary. 

 1.2.4 Cohort sync 

 Cohorts, or site-wide groups, enable all members of a cohort to be enrolled in a course in one action, either 

manually or synchronised automatically. 

 Note: Teachers can add cohorts to courses by default but a manager or admin can hide certain cohorts from 

teachers by unchecking the 'Visible' box in the Cohort settings or by clicking the 'eye' icon on the Cohorts screen. 

 Enrolling a cohort in a course 

 In order to actually enrol users from a Cohort into courses the Cohort-Sync Enrollment plugin needs to be added 

to the enrollment methods for the course. The Administrator will first need to enable the Cohort-Sync enrolment plugin 

site wide (Administration > Site administration > Plugins > Enrolments) 

 Adding a whole cohort 

 Available cohorts may be selected from Course administration>Enrolment methods and then selecting from the 

dropdown the 'Cohortsync' method.  
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 Enrolling cohorts this way means that if members are added or removed from the cohort they are added or 

removed in the course too - ie, enrolment is synchronised. 

 When synchronising a cohort it is also possible to automatically add all cohort members to the group: 
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 Adding cohort members 

 Cohort members may be enrolled from Course administration>Enrolled users and clicking the 'Enrol users' 

button, and then 'Browse cohorts'. 

 

 Enrolling cohorts this way means that members may be removed individually from the course, i.e., there is no 

cohort synchronisation. 

 1.2.5 Guest access 

 The Guest access plugin allows users with the Guest role to view the contents of a course. This might be used, 

for example, if a Moodle site serves as a website where certain courses contain publicly available information, or else 

with a commercial Moodle site where courses with guest access can offers a "taster" of the kind of courses which may 

be purchased. (Note that the guest cannot participate in any activities; they can only view content.) 

 Course settings for guest access 

 In Administration > Course administration > Users > Enrolment methods, first ensure that you have added 

"guest access" as an enrollment method, and that it has its eye open. 

 Ensure that self enrolment is also enabled. 

 In Administration > Course administration > Edit settings, scroll to "Guest access" 

 Set the drop down to "Yes" 

 If you wish guests to use a password to access the course then add it here. 
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 Admin settings for guest access 

 In Administration > Site administration > Plugins > Enrolments > Manage enrol plugins,ensure Guest access 

is enabled (has its eye open.) This enables Guest access. 

 In Administration > Site administration > Plugins > Manage authentication set the Guest login button to 

Show if you want the button on the Frontpage. 

 Also Guest accounts can be logged - check the Administration> Site administration > Server > Cleanup > Log 

guest access setting 

 Default settings for guest access 

 Clicking on Administration > Site administration > Plugins > Enrolments > Guest access brings up the screen 

where admin can set defaults for guest access in courses. 

 Clicking the 'Advanced' button next to 'Allow guest access' will hide this setting in a course and will instead 

display a 'Show more' link to click on to access the setting. 

 Guest access can be turned on by default in all new courses and you can also: 

 require each course with guest access to have a password for guests. (Note: this can confuse teachers who 

are not aware of the requirement.) 

 use or ignore your Moodle's standard password policy for guest access passwords 

 offer if needed the first letter of the password as a hint. 

 Auto-login guests 

 In Administration > Site administration > Users > Permissions > User policies, you can tick the box so that 

visitors are automatically logged in as guests when accessing a course with guest access (i.e. they don't have 

to click the "login as guest button". 

 In Administration > Site administration > Plugins > Authentication > Manage Authentication, you must have 

"Guest login button" set to "Show". 

 In Administration > Site administration > Security > Site policies you can check "Open to Google" setting so 

that the Google search robot will be allowed to enter your site as a Guest. In addition, people coming in to 

your site via a Google search will automatically be logged in as a Guest. 

 1.2.6 Category enrolments 

 The category enrolments plugin allows users to be enrolled in a category as opposed to individual courses. The 

plugin has to be enabled by the site administrator (see Enrolment plugins). The category enrolment plugin will 

synchronise any role assignments at category context with the capability enrol/category:synchronised set to allow. 
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 Note: It is recommended that Cohort sync is used in preference to category enrolments. There are performance 

issues with category enrolments. 

 Settings for category enrolment 

 Go to the category into which you wish to enrol users. Note: You need to have category rights (manager or 

administrator) 

 In the Administration block, click Assign roles. The list of possible roles you can assign will appear: 

 

 NOTE: The roles you see here are roles which have been assigned at the category context and which you are 

able to assign, ie, the role has been checked in Site administration>Accounts>Users>Permissions>Define roles>Allow role 

assignments. 

 Admin settings for category enrolment 

The category enrolment plugin may be enabled or disabled throughout the site in Administration > Site administration > 

Plugins > Enrolments> Manage enrol plugins. 

 Assigning teachers or students to a category 

 By default, only managers and course creators can be assigned category-wide. If you want to add teachers 

or students then the site administrator needs to tick the "category" box in their role in Administration > Site 

administration > Users > Permissions > Define roles. 

 To ensure they will be automatically assigned as teachers/students in any new courses you make, the 

administrator needs to set to "allow" the capability enrol/category:synchronised for the role in question 

in Administration > Site Administration > Users > Permissions > Define roles. 

 

 Allowing teachers to assign category roles 

 If you wish teachers to be able to assign roles in the category context, you must ensure that the selected roles 

are available in the category context and that your category teacher role has the selected role checked in Site 

administration>Accounts>Users>Permissions>Define roles>Allow role assignments. If you simply assign a teacher to a 
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category without taking these extra steps, then they will see a message "You cannot assign roles" when 

clicking Category administration>Assign roles.  

 1.3 Roles and permissions 
 A role is a collection of permissions defined for the whole system that you can assign to specific users in specific 

contexts. The combination of roles and context define a specific user's ability to do something on any page. The most 

common examples are the roles of student and teacher in the context of a course. 

 1.3.1 Managing roles 

 Managing overall role capabilities can be done by an administrator using Administration > Site administration > 

Users > Permissions > Define roles. This is the place to add custom roles or modify existing roles. The "Manage roles" 

tab, allows the system administrator to edit any one of over 350 different capabilities associated with any role. The 

"Allow role assignments", "Allow role overrides" and "Allow role switches" contain a matrix which give the ability for a 

specific role to work with other specific roles. 

 Manage roles 

 The 'Manage roles' tab contains a list of roles on your site. The edit column contains icons for editing, deleting 

roles and copying roles, and for moving them up or down in the list (affecting the way that roles are listed around 

Moodle). 

 

 To edit a role: 

1. Go to Administration > Site administration > Users > Permissions > Define roles. 

2. Click the edit icon opposite the role you want to edit. For example "student". 

3. On the editing role page, change permissions as required for each capability. 

4. Scroll to the bottom of the page and click the "Save changes" button. 

 Role name localization 

 If a standard role name or description is empty Moodle uses a default string from the current language pack. 

Custom roles can be customized using multilang syntax. 

 You may also override the role names separately in each course. 

 Resetting a role 

 To reset a role back to the default permissions: 
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1. Go to Administration > Site administration > Users > Permissions > Define roles. 

2. Click on the name of the role, for example "student". 

3. Click the 'Reset' button. 

 Note that if you have students who have been given extra permissions at course and/or activity levels (such as 

forum ratings), then they will no longer be able to do this once the role has been reset to its default. A teacher would 

need to go back and set up these extra permissions in the course/activity levels again. 

 Allow role assignments 

 The "Allow role assignments" tab allows (or does not allow) a specific role to be able to assign specific roles to a 

user. 

 

Enabling teachers to assign other teachers 

By default, teachers can only assign other users the roles of non-editing teachers, students and guests. If you want 

teachers to be able to assign other teachers in their course, you can allow the role assignment: 

1. Click on Administration > Site administration > Users > Permissions > Define roles. 

2. Click the Allow role assignments tab. 

3. Click the checkbox where the teacher row and column intersect. 

4. Click the "Save changes" button. 

 Allow role overrides 

 The "Allow role overrides" tab allows (or does not allow) a specific role to be able to override specific roles for a 

user. For example, it might allow a teacher role to override a student's role to a non-editing teacher's role. 

 Note that the settings only apply to roles that have the capabilities moodle/role:override or 

moodle/role:safeoverride allowed. 

 Allow role switches 

 The "Allow role switches" tab allows (or does not allow) a specific role to be able to temporarily change their 

role to another specific role. For example, this might allow a users assigned to a custom role in a course to see "Student" 

in the Settings > Switch role list. 

 Note: the selected role must also have the moodle/role:switchroles capability to be able to switch. 
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 1.3.2 Assign roles 

 Context and roles 

 In Moodle, apart from the site administrator, users do not normally have a global, site-wide role. In other words, 

even though you may be a tutor offline, when you are in Moodle you could have a tutor role in the course you teach in 

but a student role in another course where you are studying for a diploma. There are a few exceptions but this is 

generally the case. 

 Because of the way Moodle works, assigning roles is done for a particular context. A site and course are 

examples of two different contexts. When you create a new role or tweak a pre-existing role via Administration > Site 

Administration > Users > Permissions > Define roles, you are asked in which context(s) you want the role to be assigned: 

 

  Here are some examples of contexts; how to get to the assign roles screen, and when/why you would 

assign roles here: 

 System context 

 Administration > Site Administration > Users > Permissions > Assign system roles 

 Any roles assigned here apply to the whole Moodle site. It makes sense therefore that only roles that need 

this functionality can be assigned here. The Manager role and Course creator role are examples of two such 

roles. Assigning a teacher or student here would result in their being able to teach/study in every single 

course on the site, which is not usually desirable. 

 If you really feel your Moodle needs to have teachers or students assigned in the system context, go to the 

teacher/student role in Administration > Site administration > Users > Permissions > Define roles and check 

the "system" box. Then search for and allow the capability moodle/course:view 

 Front page context 

 Administration > Site Administration > Front Page>Users>Permissions>Assigned roles 

 Those with a role in the system context do not need to be assigned a role here as well. 

 However you might want to allow a teacher to manage items on the front page; in this instance, you would 

assign them the role on the Front page. 

 Course Category context 

 See Category enrolments 

 Users may be enrolled in the category to save enrolling them in each individual course in that category. 

 Course context 

 Go to Administration > Course administration > Enrolled users 
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 Click the "Enrol users" button and click those users you wish to enroll 

 The dropdown menu at the top shows roles for which you are allowed to enrol; typically those users with lower 

roles than you.  

 

 Block context 

 (Within the block) Administration > Assign roles 

 You may wish to assign roles to a block if, for instance you want specific people to see the block but for it to 

be hidden from others 

 Activity Module context 

 (Within the activity settings) Administration > Locally assigned roles 

 An example of this is assigning a student the teacher role locally in an individual activity like a forum so they 

can moderate their classmates' posts while still retaining the student role in the rest of the course. 

 Hierarchy 

 By assigning a role to a user in a certain context, you grant them the permissions contained in that role for the 

current context and all lower contexts. 

 The list of contexts in hierarchical order is as follows: 

 System (no parent) 

 Front page (parent = system) - 

 Course category (parent = parent category or system) 

 Course (parent = category or system) 

 Module (parent = course or system) 

 Block (parent = course or system) 

 User (parent = system) 

 Roles can be inherited. For example if a user is assigned a Teacher role in a specific course category then the 

user will have this role in ALL courses within the category. Tip: use the override feature in a specific context for 

exceptions. 

 Roles will only work if the role assignment is made in the correct context. Some examples: a Teacher role should 

be assigned to a user in the course or course category context, a Forum moderator for a particular forum should be 

assigned in that specific forum. 
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 Assigning someone the role of Site administrator 

 Site administrators are assigned via a special page: Administration > Site Administration > Users > 

Permissions > Site Administrators. Select the name from the right and move it over to the left: 

 

 The original (primary) administrator cannot be deleted. 

 Checking a user's role assignments 

 A user's role assignments can be checked by going to their profile page then in the administration block under 

the profile settings for the user, clicking 'This user's role assignments'. 

 Hidden roles 

 If you want to provide users with access to the course, but don't want them to be visible in the participants list, 

use the Other users link in the course administration menu (Administration > Course Administration > Users > Other 

Users). Assigning roles here provides course access, and editing rights according to the permissions set for the role 

assigned without actually enrolling the user in the course. This is similar to the functionality of the "hidden user" check 

box in previous versions of Moodle. 

 Note: By default, the only role which can be assigned to other users is the manager role. To enable other roles, 

such as teacher to be assigned, the capability moodle/course:view should be allowed for the role (see below). 

 Enabling teachers to assign the role of teacher 

 By default, teachers are only allowed to assign the roles of non-editing teacher, student and guest. To enable 

teachers to assign the role of teacher: 

1. Access Administration > Users > Permissions > Define roles. 

2. Click the tab "Allow role assignments". 

3. Click the checkbox where the teacher row and column intersect. 

4. Click the "Save changes" button. 

 Beware of assignments that don't make sense 

 There are many role assignments that do not make sense as the underlying functionality does not exist. Just 

because you give someone the "right" to do something does not guarantee that the interface or facility actually exists 

within the context that you have assigned that right. For example, you can assign a user the right to create new 

categories in the category context. However there is no interface within Moodle to do that (category creation is only 

available at the system level). 

 Multiple assignments 

 A significant part of the roles infrastructure is the ability to assign a user into multiple roles (at the same time). 

The capabilities of each role are merged to produce the effective set of capabilities. For example, a user could be both a 

Teacher and Student in the same course. You should be careful to ensure that if you change a user's role that you 

remove them from any other roles as required as this will no longer be done automatically. 
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 1.3.3 Roles settings 

 User policies 

 The following settings may be changed by an administrator in Administration > Site administration > Users > 

Permissions > User policies. 

 Role for visitors 

 Users who are not logged in to the site will be treated as if they have the role specified here, granted to them at 

the site context. The role of Guest is the default and the recommended setting for standard Moodle sites. The user will 

still be required to login to participate in an activity. 

 Role for guest 

 This option specifies the role that will automatically be assigned to the guest user. This role is also temporarily 

assigned to non enrolled users when they enter a course that allows guests without password. 

 Deny Guest Access to a site altogether 

 Go to Site administration > Plugins > Authentication > Manage authentication and there is a switch there that 

allows you to turn the Guest Access button off altogether. 

 Default role for all users 

 It is recommended that the default role for all users is set to Authenticated user. To set it to a custom role, the 

custom role must be assignable in the system context and have role archetype set to none. 

 Note: It is not recommended that the default role for all users is set to student. 

 Auto-login guest 

 If not set, then visitors must click the "Login as a guest" button before entering a course which allows guest 

access. 

 Note: If auto-login guest is set, the guest login button also needs to be set to show (in Administration > Site 

administration > Plugins > Authentication > Manage authentication), even though visitors won't necessarily use it. 

 Hide user fields 

 The following user fields appear on users' profile pages. Certain user fields are also listed on the course 

participants page. You can increase student privacy by hiding selected user fields. 

 Description, city/town, country, web page, ICQ number, Skype ID, Yahoo ID, AIM ID, MSN ID, last access, My 

courses and first access and groups 

 User fields on users' profile pages are hidden from all users with the 

capability moodle/user:viewhiddendetails not set. 

 User fields on the course participants page are hidden from all users with the 

capability moodle/course:viewhiddenuserfields not set. 

 Unsupported role assignments 

 Unsupported role assignments are role assignments in contexts that make no sense for that role, such as the 

course creator role in the course or activity context, or the teacher role in the user context. 
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 Prior to Moodle 2.0, there was no 'Context types where this role may be assigned' setting in the edit role form, 

and so any role could be assigned in any context. Upon upgrading a site from 1.9, any role assignments in contexts that 

make no sense for that role are listed as unsupported role assignments in Settings > Site administration > Users > 

Permissions > Unsupported role assignments. 

 In general, it is safe to delete all unsupported role assignments. In doing so, the worst that can happen is for a 

user to be unassigned a custom role; no other data loss will occur. 

 1.3.4 Using roles 

 Below are just a few creative examples of uses of roles and permissions in various settings. 

 Give a student forum moderator rights 

 How: Assign the role of non-editing teacher in the module context, via the "Locally assigned roles" link in the 

forum administration section of the Settings block. 

 

 Enables a user to edit or delete forum posts, split discussions and move discussions to other forums 

 See Forum moderator role for more details 

 Consider assigning this role to two students, and guiding them in learning to facilitate a forum together; for 

example, they can share the "coverage" of the Forum on certain dates. 

 Enable a student to grade assignment submissions 

 How: Assign the role of non-editing teacher in the module context, via the "Locally assigned roles" link in the 

assignment administration section of the Settings block 

 A form of peer assessment/evaluation 

 Similar use: Enable a student to grade essay questions in a quiz 

 Give a student the rights to approve database module entries 

 How: Assign the role of non-editing teacher in the module context, via the "Locally assigned roles" link in the 

database administration section of the Settings block 

 Enables a user to approve, edit and delete database module entries 
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 Similar use: Give a student the rights to approve glossary entries 

 Allow a student to clean up saved chat sessions 

 How: Assign the role of non-editing teacher in the module context, via the "Locally assigned roles" link in the 

chat administration section of the Settings block. 

 Allows a user to delete chat logs for conversations which don't go anywhere 

 Allows a user to save chat logs for a longer period of time 

 Allows a user to put together group chat sessions 

 Enable students to rate forum posts 

 How: Override the student role in the module context, via the "Permissions" link in the forum administration 

section of the Settings block, and allow the capability to rate forum posts. 

 

 A formative assessment 

 Peer evaluation 

 See Forum permissions for more details 

 Similar uses: Enable students to rate database or glossary entries 

 Allow students to unenrol themselves from a course 

 How: Override the student role in the course context, via the "Permissions" link (Users > Permissions) in the 

Course administration area of the settings block and allow the "Unenrol self from the course" capability. 

 Useful for taster courses, revision courses and any other courses which are optional 

 See Unenrolment for more details 

 Hide a block from guests 

 How: Override the guest role in the block context, via the "Permissions" link (Users > Permissions) in the block 

administration area of the Settings block and prevent the capability to view blocks.  
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 Provide temporary access to a Guest Speaker in a completely online class 

 How: Create a non-editing teaching role blocking access to everything but post to forum. 

 Steps to prevent guests from seeing confidential student information: 

1. Assign a guest role without access to grades and assignments. 

2. Only grant access to the guest for the minimal amount of time they need to be in the class. 

 1.3.5 Standard roles 

 1.3.5.1 Site administrators 

 Site administrators have permissions to do anything. 

 Users may be assigned the role of site administrator by another site administrator in Administration > Site 

administration > Users > Permissions > Site administrators, but the role itself cannot be edited (or deleted!). 

 

 Note: The primary administrator (created when the site was created) cannot be removed from the site 

administrator role. 

 1.3.5.2 Manager role 

 The default Manager role enables users assigned the role to access courses and modify them, as well as perform 

certain administrative level tasks related to courses, users, grade settings, etc. 
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 Unlike the administrator role, the Manager role is a 'real role', whose capabilities you can edit, but is similar to 

Administrator (but much safer to use) due to its broad default powers. As a normal role, like Course Creator or Teacher, 

while the Manager role has almost very many capabilities by default, you can edit that role if you choose. 

 Adopting a best-practice based on the Principle of Least Privilege suggests that Admins should normally use a 

Manager role, and not use an Administrator account, similar to the way you are recommended not to log into Linux as 

root. 

 The Manager role therefore allows a site Administrator to give very powerful roles to others who are assigned a 

Manager role, but without having to give them a full Administrator role. 

 Assigning the role of Manager at the Site level 

 You can give someone the Manager role sitewide (to enable them for instance to add new users) by going 

to Settings>Site Administration>Users>Permissions>Assign system roles, selecting the Manager role and moving over 

your chosen user. 

 When you do so, users in that role will have access to only some of the items in Site administration. They do not 

have access to areas such as Security, Server, Plugins, Appearance, or Advanced Features, which are reserved for those 

in the Site administrators group. They have access to most of the tools for User, Course and Grade system settings and 

tools. 

 Specifically the sitewide Manager role can see these in Site administration: 
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 Notes: 

 Some of these can further restricted by editing specific capabilities of the role, e.g., create users, upload 

users from a file, manual enrolments, managing cohorts, language customisation, et cet. 

 Manager has access to Front page same as with other courses (as it is technically a course). 

 Manager has access to most system level reports but not the Configuration report. 

 Manager has the ability to assign other users as a sitewide Manager 

 Also, a Manager has the ability to edit the role of Manager itself - to disable this, you could prohibit the 

Create and manage roles moodle/role:manage capability 

 Assigning the role of Manager at the Category level 

 The Manager role can also be assigned in the context Category rather than sitewide. 

 Do this if you want someone to be able to have access to all the courses in a single category and manage them, 

but do not want them to have access to any of Site administration tools. 

 Assign this as follows: Site administration > Courses > Add/edit courses > (select a category) > Edit this category > 

Administration block: Assign roles > Manager > (select user) Add 

 Notes: 
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 A category-level manager is so only for the assigned category: to manage more than one category, you will 

need to assign them that role in each category separately 

 Category-level managers also manage any sub-categories beneath the category they are assigned, including 

create new subcategories and move courses 

 They can create courses in the their assigned categories 

 A category-level manager will not have as many capabilities as a site-level manager, since certain 

capabilities can only be applied in the system context i.e. via a system role 

 Regarding the capability to login as another user, for courses within the category that they manage, a 

category-level manager can only login as another course participant and browse within that course only 

 Note that in some commands are in the Administration block. Managers must Turn editing on in order to 

have Edit category and Add category links. The screenshot below is a view of the Administration block for a Category 

level Manager with Editing turned on, showing the Edit this category and Add a sub-category commands: 

 

 1.3.5.3 Course creator role 

 A user assigned the role of course creator can (as the name suggests!) create a course. If the setting "Creators' 

role in new courses" is left as default (teacher), then the course creator is enrolled as a teacher in the course they have 

just created and can then edit the course settings and enrol other users. 

 A course creator can also view hidden courses. 

 The role of course creator could typically be assigned to a master teacher, department head or program 

coordinator. 

 Deleting a course 

There is no user interface for course creators to delete courses they have created, however they can do so by editing 

the URL of the course from http://yourmoodlesite.net/course/view.php?id=N to 

http://yourmoodlesite.net/course/delete.php?id=N (replacing 'view' with 'delete'). 
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 Role assignment 

 A user may be assigned the role of course creator as a system role (in Administration > Site administration > 

Users > Permissions > Assign system roles) or in the course category context. 

 Role permissions 

 If you require a course creator to have additional permissions, it is recommended that the Manager role is used, 

rather than changing the course creator role permissions. Otherwise, allowing additional capabilities for the course 

creator role may result in course creators having access to courses which they have not created. 

 The role of course creator is ONLY intended for enabling users to create courses; it is not intended for enabling 

users to edit existing courses! 

 1.3.5.4 Teacher role 

 Teachers can do almost anything within a course, including adding or changing the activities and grading 

students. By default, teachers can also assign a Non-editing teacher role and a Student role to other users.  

 By default users are not assigned the role of Teacher throughout the site, but are only assigned (enrolled) as a 

teacher to a single course/class at a time. The same applies to students. Teachers can only teach in the courses they 

have been enrolled in.  

 Enrolling a user as a teacher in a course 

1. As a manager or administrator, go to Administration > Course administration > Users > Enrolled users 

2. Click the 'Enrol users' button at the top right or bottom left of the page 

3. From the 'Assign roles' dropdown choose the teacher role 

4. Select enrolment options as appropriate 

5. Browse or search for the user 

6. Click the Enrol button opposite the user. The user will indent in the list and the enrol button will disappear, 

indicating that the user is enrolled. 

7. When you have finished, click the 'Finish enrolling users' button (or simply close the enrol users box) 

 The user will then appear in the list of enrolled users and will no longer be available in the search list. 

 Changing Teacher Permissions 

 Note: if you need to modify the Teacher role significantly, it is advisable to create a new role rather than editing 

the default teacher role. 

 If you really need to change the default Teacher role, go to  Administration>Site 

administration>Users>Permissions>Define roles. In the right pane you will see Manage Roles with a list of user roles. To 

the right of the teacher description, click on the edit icon. 

 From the Editing role 'Teacher' page you can change what a teacher can or cannot do by checking or unchecking 

the Allow check-boxes under Capability/Permission. Be careful what you allow a teacher to do here. Consider the 

security vulnerabilities of giving a teacher an inappropriate permission. Only give the teacher permissions that are 

necessary or appropriate. To the right of many of the Allow check boxes are colored triangles the notify you of possible 

security warnings for each choice. Use those warnings to help you decide which permissions you will or won't give to 

your teachers. 
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 Assigning The Teacher Role category or sitewide 

 As stated above, by default teachers are not given the role of teacher. However, under some conditions (such as 

for homeschool parents) you may want to assign a user, or some users, the role of teacher for all the courses in one 

category, or for all the courses in your whole site without having to enroll as a teacher for each class. If so, you can (If 

necessary, add a new role and) give that permission on this same Editing role 'Teacher' page, under Role archetype. 

Under Context types where this role may be assigned check whichever apply. 

 Course: (Default setting-already checked) allows you to enroll a teacher to a specific course. 

 Category: (Allows the user to be a teacher in any course contained in the specific category).If you click on 

the check-box for Category, it enables a user to access all the courses in a particular category or multiple 

categories (depending to which they are assigned). To assign a Teacher to a Category, navigate to that 

category, then use the Administration menu to Assign roles. (If you are not inside the category the Assign 

roles menu item will not show.) If you want one Teacher to apply to all the Course Categories, then navigate 

to every category and Assign roles for each category. 

 If you want to give only some teachers these privileges, you may want to create another Teacher role that gives 

those permissions only to those trusted teachers who have been assigned that role. 

 1.3.5.5 Non-editing teacher role 

 A non-editing teacher is able within a course to view and grade students' work but may not alter or delete 

any of the activities or resources. 

 This role might typically be given to a classroom assistant for example. 

 1.3.5.6 Student role 

 A user with the Student role in Moodle can participate in course activities and view resources but not alter 

them or see the class gradebook. They can see their own grades if the teacher has allowed this. 

 When a student first joins Moodle they see all available courses. Once they have enrolled or been enrolled 

into at least one course they then only see their own courses in the My Courses section of the navigation 

block or via the My home link. 

 A student's view and navigation in Moodle will be different from the course teacher's or from students 

assigned to a different group. 

 Administrators and Teachers determine how a student enrolls, and what they can do or see in a Moodle 

site. These permissions can vary with each course or with any of Moodle's many kinds of activities. For 

example, in some contexts, students may correct or grade other students' work, be encouraged to explore 

everything in a course and interact with other participants. In a different context, the student maybe guided 

upon a very defined path, with minimal interaction with others. 

 1.3.5.7 Guest role 

 Moodle has a built-in "Guest account". Visitors can log in as guests using the "Login as a guest" button on the 

login screen and enter any courses which allow guest access. In addition, logged-in users can enter any courses which 

allow guest access without being required to enrol. 

 Guests ALWAYS have "read-only" access - meaning they can't leave any posts or otherwise mess up the course 

for real students. 

They cannot: 
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 Post in forums 

 Edit wiki pages 

 Participate in a chat 

 Take quizzes or Questionnaire (or Feedback) 

 Submit assignments 

 Add glossary or database activity entries or comments 

 Receive any scores or grades (because of the read-only access) 

 This feature can be handy when you want to let a colleague in to look around at your work, or to let students 

see a course before they have decided to enrol. 

 If you want guests to be able to take quizzes, or any of the other activities listed above, and have considered the 

security implications, you can create a visitor account, say with username = password = visitor, for everyone to share. 

 Skip login page for guest account 

 All users will be automatically logged in as guests if you enable Auto-login guests in Administration > Site 

administration > Users > Permissions > User policies. The standard login page is displayed after users visit page that 

requires real user login. 

 1.3.5.8 Authenticated user role 

When a user logs in, they are automatically assigned the role of authenticated user. A user will have additional roles as 

well as the authenticated user role according to where they are in Moodle, such as student in a course. 

By default, authenticated users have permission to edit their own profile, send messages, blog and do other things 

outside of courses. 

 1.3.6 Creating custom roles 

 Creating a new role 

 To create a custom role: 

1. Go to Administration > Site administration > Users > Permissions > Define roles. 

2. Click the "Add a new role" button. 

3. Select template for the new role or upload a preset 

4. Give the role a Short name e.g. 'Parent'.The short name is necessary for other plugins in Moodle that may 

need to refer to the role (e.g. when uploading users from a file or setting enrolments via an enrolment 

plugin). 

5. You must provide a full name for all custom roles. If you need to name the role for multiple languages you 

can use multi-lang syntax if you wish. 

6. Give the role a description (optional). 

7. Select an appropriate role archetype (see below for further information). 

8. Select the contexts where the role may be assigned e.g. 'User' for Parent role. 

9. Set permissions as required. 

10. Scroll to the top or bottom of the page and click the "Create this role" button. 
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 Creating a duplicate role 

 To create a duplicate role: 

1. Go to Administration > Site administration > Users > Permissions > Define roles. 

2. Click the "Add a new role" button. 

3. Select existing role as a template 

4. Give a name and set permissions for your new role; scroll down and click "Create this role". 

 New role considerations 

 A new role is not automatically listed in course descriptions even if was created by copying a role that is listed, 

such as Teacher. If you want the new role to appear in the course listing, you must set it explicitly via Administration > 

Site administration > Appearance > Courses>Course Contacts". 

 1.3.7 Example custom roles 

 Forum moderator role 

 A forum moderator for a particular forum is able to edit or delete forum posts, split discussions and move 

discussions to other forums. This role could be useful for example if you wish a student to be able to moderate a 

student forum but not have editing rights over the whole course. 

 Role assignment 

 A user can be made a forum moderator for a particular forum by assigning them the role of non-editing teacher 

(or teacher) in the module context, as follows: 

1. Access the forum as an editing teacher. 

2. In the Administration block for the forum (often towards the bottom left of your screen),click the Locally 

assigned roles link and assign the role of non-editing teacher to your chosen user or users. 
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 Alternative method of creating a forum moderator 

1. Create a new role, with some (or all) of the forum capabilities enabled. This technique allows a more flexible 

approach. For example, you can create an account with delete but not editing. 

2. Assign the role to the users, for a course, a course category, or even at site or system context, without giving 

all teacher capabilities.  

 Forum poster role 

 The forum poster role is a highly restricted custom role which may be given to a visitor account to enable them 

to post in forums in a guest access course. 

 Note that guests (ie, non-logged in users) are not able to post in forums even though the permissions suggest 

otherwise. 

 This role provides a workaround for situations where you have a course open to guests and you want to allow 

users not usually in your Moodle site to be able to contribute to discussions. 

 Note that you first need to create an account to be used by any visitor, for example: username = visitor and 

password = visitor (or a password following your own restrictions). 

 Creating a new role 

 As an administrator, go to Site administration>Users>Permissions>Define roles and click the 'Add a new role' 

button at the bottom of the screen. 

 On the next screen, ignore archetypes and presets and click 'Continue' 

 Give the role a name and if desired a description and tick the "System" and "Course" context: 
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 Click the 'Show advanced' button. 

 In the filter, type forum and from the search results, set 'Reply to posts', 'Start new discussions' and 'View 

discussions' to Allow 

 In the filter, type profile and from the search results, set Edit own profile', and 'View user profiles' and 

toProhibit 

 In the filter, type password and from the search results, set 'Change own password' to Prohibit 

 You may, according to the needs of your organisation, want to restrict other capabilities too, for example  

sending messages 
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 Click the 'Create this role' button. 

 Assigning the role to a visitor 

 Note: All these steps must be done as an administrator: 

 If you have not already done so, go to Site administration>Users>Accounts>Add a new user and create an 

account which will be used by any visitor to your guest access course. 

 Go to Site administration > Users > Permissions > Assign system roles. 

 You should now see your newly created role here 

 Assign the role to the visitor account user. 

 Go to your the guest access course where you wish the visitor to contribute to forums. 

 From Course administration>Users>enrolled users select the 'forum poster' role from the dropdown and give 

this role to your visitor. 

 Information for users 

 If your course has guest access, then it will not be immediately obvious that the visitor must log in to post. It 

might be helpful to add a label at the top of the course page with the details of the visitor username and 

password. 

 Remember to that visitor forum posts will all display the same name, so you could suggest in your 

explanatory note that they might wish (or not) to add their name when contributing. 

 Note that this role is very restricted, as it simply allows posting in forums. Some activities such as Quiz and 

Wiki are no longer accessible once the visitor is logged in. 

 Quiz user with unlimited time role 

 The role of Quiz user with unlimited time allows a user unlimited time to attempt a quiz which has a time limit 

set. 

 Role set-up 

 Access Administration > Users > Permissions > Define roles. 

 Click the button "Add a new role". 
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 Give the role a name e.g. Quiz user with unlimited time, short name and description. 

 Change the capability mod/quiz:ignoretimelimits to allow. 

 Click the button "Add a new role". 

 Role assignment 

 This role may be assigned in the system, course or module context, depending upon whether the user should 

have unlimited time in all quizzes in every course, all quizzes in selected courses or just in selected quizzes. 

 To allow a user unlimited time in all quizzes: 

 Access Administration > Users > Permissions > Assign system roles. 

 Choose the quiz user with unlimited time role to assign. 

 Select a user in the potential users list, and use the left-facing arrow button to add it to the existing users 

list. 

  Comment 

This method only allows you to give that student unlimited extra time. Or at least, if you do this, Moodle will not impose 

any time limit. If you need to give a specific amount of extra time, say 50% extra, you will need to enforce that some 

other way. For example, you could use an invigilator to monitor the student. Or you could point out to the student that 

Moodle tracks how long they spend on each quiz attempt, and ask them to monitor themselves. 

 1.3.8 Permissions 

 Moodle allows specific roles to be able to change other specific role capabilities based on the context. For 

example, a teacher in a course may want all students (users with a student role) to be able to edit all forums in that 

course. Or a teacher may want all students in a specific forum to be able to edit that forum. 

 If you want to give a specific student the ability to edit a specific activity, see Override permissions. 

 Course and activity permissions 

 Role permissions for a course can be changed in Administration > Course administration > Users > 

Permissions and for a particular activity in Administration > Activity administration > Permissions. 

 Click the Allow icon (+) opposite a capability to give permission to additional roles or the Prevent icon (X) to take 

away permission. 

 

 Block permissions 

 Block permissions can be changed by: 

 Turn editing on in the course 

 Click the assign roles icon (a face and mask) in the header of the block 
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 Scroll down to the settings block and click the Permissions link 

 

 Checking permissions 

 The check permissions feature provides a method to view all roles both in the current context and higher 

contexts (in Moodle 2.3.2 onwards) and capabilities for a selected user based on their role assignments. These 

capabilities determine whether or not the selected user is allowed to perform associated tasks within the system or 

course. 

 A teacher can check permissions for their course in Administration > Course administration > Users > 

Permissions > Check permissions and for a particular activity in Administration > Activity administration > Check 

permissions. 

 An administrator can check system permissions in Administration > Site administration > Users > Permissions > 

Check system permissions. 

 The review permissions for others capability (allowed for the default roles of manager, teacher and non-editing 

teacher) controls whether a user can check permissions. 

 

 Capability overview report 

 An administrator can generate a capability overview report in Site Administration > Users > Permissions > 

Capability report. 

 The report allows the administrator to select a capability and one or more roles. The report will show the role 

and its permission level for that capability. And if that capability was overridden for the role where in the site. For 

example, it might show that the gradereport:user view capability for a student role is set at the system level as "Allow" 

and for Course 1 it is set to "Prohibit". 
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 It is possible to select more than one capability with more than one role and have an overview of all. 

 

 1.3.9 Override permissions 

 Overrides are specific permissions designed to override a role in a specific context, allowing you to "tweak" your 

permissions as required. 

 Overrides may be used to "open up" areas by giving users extra permissions. For example, an override may be 

used to enable students to rate forum posts. 

 Overrides may also be used to prevent actions, such as starting new discussions in an archived forum. 

 Permissions 

 There are four settings for each permission capability: 

 Inherit 

 The default setting. If a capability is set to inherit, the user's permissions remain the same as they are in a less 

specific context, or another role where the capability is defined. For example, if a student is allowed to attempt quiz 

questions at the course level, their role in a specific quiz will inherit this setting. Ultimately, if permission is never 

allowed at any level, then the user will have no permission for that capability. 

 Allow 

 This enables a user to use a capability in a given context. This permission applies for the context that the role 

gets assigned plus all lower contexts. For example, if a user is assigned the role of student in a course, they will be able 

to start new discussions in all forums in that course (unless a forum contains an override with a prevent or prohibit 

value for the capability). 
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 Prevent 

 By choosing this you are removing permission for this capability, even if the users with this role were allowed 

that permission in a higher context. 

 Prohibit 

 This is rarely needed, but occasionally you might want to completely deny permissions to a role in a way that 

can NOT be overridden at any lower context. An example of when you might need this is when an admin wants to 

prohibit one person from starting new discussions in any forum on the whole system. In this case they can create a role 

with that capability set to "Prohibit" and then assign it to that user in the system context. 

 

 Conflict resolution of permissions 

 Permissions at a "lower" context will generally override anything at a "higher" context (this applies to overrides 

and assigned roles). The exception is PROHIBIT which can not be overridden at lower levels. 

 If two roles are assigned to a person in the same context, one with ALLOW and one with PREVENT, then ALLOW 

will win. 

 Special exceptions 

Note that the guest user account will generally be prevented from posting content (eg forums, calendar entries, blogs) 

even if it is given the capability to do so. 

 Locations for overriding permissions 

 Front page context: Administration > Front Page settings > Users > Permissions 

 Course category context (when used):Category > Administration > Permissions 

 Course context: Administration > Course administration > Users > Permissions 

 Module context: (from the chosen module) Administration > Module administration > Permissions 

 Block context: (from the chosen block) Administration > Block administration > Permissions 

 User context: (from the user's profile) Administration > Roles > Permissions 

 Ability to override permissions 

 Users who have the capability moodle/role:override allowed or the 

capability moodle/role:safeoverride allowed) can override permissions for selected roles. 

 The default manager role has the capability moodle/role:override allowed, and can override permissions for all 

other roles. 
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 The default teacher role has the capability moodle/role:safeoverride allowed, and can override permissions for 

the roles of non-editing teacher, student and guest. 

 Enabling non-editing teachers to override safe permissions 

1. Access Administration > Site Administration > Users > Permissions > Define roles. 

2. Edit the non-editing teacher role and change the capability Capabilities/moodle/role:safeoverride to allow. 

3. Click the button "Save changes". 

4. Click the tab "Allow role overrides" (in Administration > Site administration > Users > Permissions > Define 

roles). 

5. Check the appropriate box(s) in the non-editing teacher row to set which role(s) they can override. Most 

likely it will just be the student role (you don't want non-editing teachers to be able to override managers), 

so check the box where the non-editing teacher row intersects with the student column. 

6. Click the button "Save changes". 

 If preferred, a new role for overriding permissions may be created and selected non-editing teachers assigned to 

it. 

 Overriding permissions for selected students 

 Sometimes a teacher will want to over ride permissions for selected students. Typically they will assign a 

student a role locally. For example, assign a student as a non-editing teacher. However, managers can override specific 

permission in a role. This does not create a new role. It modifies an existing specific role and affects all users assigned to 

that role in the context. 

 Sometimes the administrator (or someone with the permissions to) will create a new role. For example, the 

administrator will copy all the student permissions to a new role, then change specific permissions. The teacher then 

assigns specific students to this role without having to worry about checking off the correct role permissions. 

 1.4 Backup 

 1.4.1 Course backup 

 A course can be saved with some or all of its parts by using the course backup. Typically, the site administrator 

will set a schedule of automated course backups for the whole site. A teacher with editing privileges can create a backup 

or download an existing backup for safe keeping, or for use on another Moodle site. 

 Backing up a course 

 To backup a course 

 Go to Administration > Course administration > Backup 

 Initial settings - Select activities, blocks, filters and other items as required then click the Next button. Users with 

appropriate permissions, such as administrators and managers, can choose whether to include users, 

anonymize user information, or include user role assignments, user files, comments, user completion details, 

course logs and grade history in the backup. 

 Schema settings - Select/deselect specific items to include in backup, then click the Next button. 

 If desired, select specific types of activity to be backed up by clicking the link 'Show type options'. 
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 Confirmation and review - Check that everything is as required, using the Previous button if necessary, 

otherwise click the 'Perform backup' button 

 Complete - Click the Continue button 

 A backup file (with distinctive .mbz extension to avoid confusion with .zip files) is then saved in the course 

backup area. Backup file names are of the form backup-moodle2-course-coursename-date-hour.mbz, ending in-

nu.mbz when backed up with no users and -an.mbz with anonymized names. 

 Quick backup 

 If you are satisfied with the default settings and don't wish to go through all the backup screens, you can simply 

click 'Jump to final step' to perform the backup. 

 

 Anonymizing user information 

 Anonymize user information is a backup feature which "protects user identities" by making each user 

anonymous. If this box is checked in the backup initial settings, Moodle will substitute aliases for real names, 

substituting @doesntexist.com email addresses and so forth. For example "Max Manager" might become 

"anonfirstname4 anonlastname4". 

 Backing up courses larger than 4GB 

 Site administrators can enable a compression format for .mbz files (internally stored as a .tar.gz file) from Site 

administration>Development>Experimental>Experimental settings which removes the 4GB backup size restriction and 

may improve performance. If this box is checked then future courses will be backed up in this format. It won't affect 

restoring courses. 

 Creative uses 

 The backup and restore processes can offer the teacher and administrators many creative solutions. 
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 Duplicating courses or specific activities in one course to another course (similar to Import) 

 Updating a production Moodle site course, with material from a localhost site course 

 Transferring a course to a new Moodle site. 

 In earlier versions of Moodle, a way of rolling a course forward without past student activity 

 Creating a blank activity, save just that activity and then restore it to the course or another course one or more 

times. 

 General backup defaults 

 Default settings for course backups can be set by a site administrator in Administration > Site administration > 

Courses > Backups > General backup defaults. 

 Selected settings may be locked, so that they cannot be changed when creating a course backup. 

 By selecting a time in the "Keep logs for.." dropdown, it is possible to specify how long backup logs information 

is kept before being deleted. As this information may be very large, it is recommended the length of time chosen be 

quite short. 

 1.4.2 Course restore 

 Restoring a course backup 

 A course backup file (.mbz) may be restored from within any existing course for which you have permission. 

During the restore process, you will be given the option to restore as a new course or into an existing course. 

 Note (1) If you are restoring a course with user data (forum posts for example) then be careful when setting the 

course start date as all data will display within the same timeframe but from the new start date. So if your course 

originally began in 2010 and participants posted in 2012, then if you restore your new course with a start date of 2014, 

these forum posts will display with a date of 2016, ie, 2 years after the original course start date.  

 Note (2) If your new course has fewer sections than the course you are restoring, the extra sections will appear 

as "orphaned activities". Increase the number of sections in the new course to make them visible. 

1. Go to Administration > Front page settings > Restore (if you have front page permissions) orAdministration > 

Course administration > Restore (if you have an empty course to restore into.) 

2. Upload the backup file or choose a file in the course backup area or user private backup area and click 

Restore 

3. Confirm - Check that everything is as required then click the Continue button 

4. Destination - Choose whether the course should be restored as a new course or into an existing course then 

click the Continue button 

5. Settings - Select activities, blocks, filters and possibly other items as required then click the Next button 

6. Schema - Select/deselect specific items and amend the course name, short name and start date if necessary 

then click the Next button 

7. Review - Check that everything is as required, using the Previous button if necessary, then click the 'Perform 

restore' button 

8. Complete - Click the continue button 
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 Restoring from course and category management screens 

 Users with permission to access Site administration>Courses>Manage courses and categories or Site 

administration>Courses>Manage courses and categories>(Category name) can restore courses from here: 

               

 1.4.3 Automated course backup 

 A site administrator can configure a schedule for automated course backups in Administration > Site 

administration > > Courses > Backups > Automated backup setup. 
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 Automated course backups runs the same functions as individual course backups. It's a good idea to schedule 

backups for when your server isn't usually busy. Running the backup tool over all the courses can be processor-

intensive, so you shouldn't run it when there are a lot of students trying to access the server. You should always alert 

users with an announcement on the first page that if they log on during the backup hours they may notice a decrease in 

performance. 

 Setting an automated course backup schedule 

 To set the backup schedule: 

1. Go to Administration > Site administration > > Courses > Backups > Automated backup setup. 

2. Set backup_auto_active to enabled. 

3. Select the days of the week to run the backup. 

4. Set the execution time for the backup process. For most servers, early morning will be the best time. Keep 

in mind the time zone your server is using. 

5. Set the "Save to..." path. If you can, choose a backup path on another machine or on a different drive than 

the one Moodle is on. You don’t want to lose your backups at the same time you lose your Moodle site if 

the drive fails. If you leave the field blank, then backup zip files will be saved in the backup folder of each 

course files folder. On a Linux server the path might look like: /home/(your user or 

domain)/public_html/archive/ or if it's below the publicly accessible folders: /home/(your user or 

domain)/archive/ if the path is not recognized a red X is shown after saving, otherwise a green check. 

6. Choose whether to skip the backup of hidden courses or courses which have not been modified within a 

specified number of days, or not modified since the last backup (new settings in Moodle 2.4 onwards). 

7. Click the "Save changes" button. 

 Once you've set up your backup schedule, Moodle will automatically create archives of all the courses on the 

server at the time you specified. Once the backup is complete, Moodle will send you an email describing the status of 

the backup. 

 Use course names for your backups 

 By default, the backups will be named according to the course ID, which is not always easily recognisable. Check 

the box Use course name in backup filename in Settings > Site Administration > Courses > Backups > Automated backup 

setup to have them saved with the course shortname instead. 

 Backups report 

 A last execution log of scheduled course backups can be found in Administration > Site administration > Reports 

> Backups. It displays a list of all course backups made, the time taken to create them, their status (see below), and the 

next scheduled automated backup execution time. 

 A detailed backup log for a particular course, including date, hour and minute when each step of the backup was 

performed, can be accessed by clicking the 'View logs' icon next to the course name (Moodle 2.8.4 onwards). This log is 

useful for troubleshooting backup errors. 

 Backup status 

 OK - The course backup was successfully completed. 

 Skipped - The course was skipped (not backed up) because the course was unavailable to students and had 

not been changed in the last 31 days. This is not an error, but a feature designed to save process time. 
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 Unfinished - The backup was not finished. This might have happened because the job to execute backups 

ran out of time or resources (e.g., the cron running the backups ran out of time before finishing all the 

courses waiting). The unfinished jobs should be completed when the next scheduled backups are repeated. 

 Error - There were errors in the backup process for the course, so a backup was not completed. For 

additional details about the error (1) check the backup log for the affected course (i.e. click the 'View logs' 

icon next to the course name) or (2) back up the course manually with debugging turned on to see what 

error message is displayed. 

 1.5 Site-wide reports 

 1.5.1 Standard Reports for Administrators 

In addition to reports available at both site and course level, the following site-wide reports are available for 

administrators: 

 Comments report 

A list of all comments added may be found in Site administration > Reports > Comments. 

 

 Backups  

Displays a list of all course backups made, the time taken to create them, their status, and the next scheduled 

automated backup execution time. 

 Config changes report 

The config changes report enables an Administrator to see at a glance which aspects of the Moodle site have 

been recently altered and, where applicable, by which administrator. 

The report is found in Administration>Site Administration>Reports>Config changes. 
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 Logs  

Activity reports for course or site. 

 Live Logs  

Live logs from the past hour as a table 

 Performance overview 

 The performance overview report in Administration > Site administration > Reports > Performance overview lists 

issues which may affect performance of the site. 

 

 For each of the issues, it is possible to edit the setting by clicking the icon and either enable or disable it. 

Reasons are given for keeping the settings as defaut and the consequences of changing them. 

 Security overview report 

 A security overview report is available for site administrators in Administration > Site administration > Reports > 

Security overview. 
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 Register globals - register_globals is a PHP setting that must be disabled for Moodle to operate safely. 

 Insecure dataroot - The dataroot is the directory where Moodle stores user files. It should not be directly 

accessible via the web. 

 Displaying of PHP errors - If PHP is set to display errors, then anyone can enter a faulty URL causing PHP to 

give up valuable information about directory structures and so on. 

 No authentication - Use of the "no authentication" plugin can be dangerous, allowing people to access the 

site without authenticating. 

 Allow EMBED and OBJECT - Allowing ordinary users to embed Flash and other media in their texts (eg forum 

posts) can be a problem because those rich media objects can be used to steal admin or teacher access, 

even if the media object is on another server. 

 Enabled .swf media filter - Even the flash media filter can be abused to include malicious flash files. 

 Open user profiles - User profiles should not be open to the web without authentication, both for privacy 

reasons and because spammers then have a platform to publish spam on your site. 

 Open to Google - Allowing Google to enter your site means that all the contents become available to the 

world. Don't use this unless it's a really public site. 

 Password policy - Using a password policy will force your users to use stronger passwords that are less 

susceptible to being cracked by a intruder. 

 Password salt - Setting a password salt greatly reduces the risk of password theft. 

 Email change confirmation - You should generally always force users to confirm email address changes via 

an extra step where a confirmation link is sent to the user. 
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 Writable config.php - The config.php file must not be writeable by the web server process. If it is, then it is 

possible for another vulnerability to allow attackers to rewrite the Moodle code and display whatever they 

want. 

 XSS trusted users - Make sure that you trust all the people on this list: they are the ones with permissions to 

potentially write XSS exploits in forums etc. 

 Administrators - Review your administrator accounts and make sure you only have what you need. 

 Backup of user data - Make sure that only roles that need to backup user data can do so and that all users 

who have the capability are trusted. 

 Default role for all users - This checks that the registered user role is defined with sane permissions. 

 Guest role - This checks that the guest role is defined with sane permissions. 

 Frontpage role - This checks that the frontpage user role is defined with sane permissions. 

 Question instances report 

 An administrator can generate a question instances report in Administration > Site administration > Reports > 

Question instances. The Manager can also generate this report. 

 This report lists all the places a specific question type is used. It provides a list by course that shows the total, 

visible and hidden number of that question type. Clicking on a context link such as course title will take you to the 

relevant question in the question bank. 

 One practical use of this report is to find questions that may have inadvertently been created in a course which 

should have been created at the System default or a particular category context. 
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 1.6 Comments 
 A comments block can be added to any page in Moodle, enabling users to easily add comments. A similar 

interface enables comments to be added to glossary, database activity and blog entries.  

 

 1.6.1 Enabling comments 

 Comments can be disabled/enabled by an administrator in Administration > Site administration > Advanced 

features. 

 Note that if this is disabled then students will not be able to add comments on assignment submissions. 

 1.6.2 Blog comments 

 Blog comments are enabled by default. The feature may be disabled in Site administration > Appearance > Blog. 

 1.7 Messaging 
 "Messaging" refers both to automatic alerts from Moodle about new forum posts, assignment submission 

notifications etc, and also to conversations using the instant messaging feature. 

 1.7.1 Message alerts 

 Users can receive message alerts from Moodle in a number of ways and for a number of reasons: users may 

for instance receive instant messages via the Messages block; students may be messaged by their course 

tutor via the People block; teachers might receive automatic notifications of assignment submissions and 

admins might receive notification of problems with the site. 

 How these messages and others are received can be set by each user from the Messaging link in their 

profile. Check boxes allow the user to select how they wish to be notified of incoming messages. 

See Messaging settings for more information. 
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 1.7.2 Instant messaging 

 If enabled for the site, users in Moodle have the option to send each other messages. Messages can be sent 

from the following places: 

 as admin in Bulk user actions 

 as a teacher from the People block 

 as any logged in user from the Messages block or Online Users block 

 as any logged in user by clicking on the profile of another user (if admin has allowed profiles to be viewed) 

 

 1.7.3 Using Messaging 

 Sending messages 

 To send a message to an individual 

 From the Messages block or from your profile 

 Click on the blue link Messages in the Messages block or click the Messages link from Navigation>My 

profileand then type a name into the Search people and messages box. To narrow the search down further, 

click the blue Advanced link to search for a person "only in my courses" or with keywords in messages: 
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 Type the message in the box and click the Send a message button 

 

 From the Online users block 

 Click the name of one of the people currently online and click the Send message link in their profile. 

 Type the message in the box and then click on the Send a message button. 

 To read and reply to a message 

 If the Messages block shows you have a message, click the envelope icon (with the number of messages) 

 

 Type your reply into the box and then click on the Send a message button. 

 If you receive a popup notification of a message, click Go to message to read and reply to it. 
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 To send a message to selected course participants (for teachers only) 

 Click on the Participants link in the People block on the course page. 

 Select participants from the list or use the "Select all" button at the bottom of the list. 

 Choose "Add/send message" from the "With selected users..." drop-down menu. 

 Type the message then click the "Preview" button. 

 Assuming you are satisfied with the message, click the "Send" button. 

 To send a message to users in many courses (admins and managers only) 

 Use bulk user action 

 Managing contacts 

 People may be added to your list of contacts (or blocked from contacting you) by clicking the Add contact 

(or Block contact) icon under their name in the Messages window. 

 By default the contact list is empty. In order to send a message or to create a shortcut to the person you are 

sending, search for them in the search box. 

 Message history 

 A record of messages sent to/from a person may be obtained by clicking the "History" icon by their name or by 

clicking Recent messages/All messages when they are displayed on the page - see screenshot below: 

 

 1.7.4 Messaging settings 

 Enabling / disabling instant messaging sitewide 

 The instant messaging system in Moodle is enabled by default. It may be disabled by a site administrator in 

Administration > Site administration > Advanced features > Enable messaging system. 

 Site administration settings 

 Manage Message outputs 

 There are four default types of output methods for messaging: popup notices, Jabber IM type messages, 

messages sent as email and mobile notifications 
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 Each of these can be enabled or disabled independently by a site administrator in Administration > Site 

administration > Plugins > Message outputs > Manage message outputs. 

 By default Popup and Email are both enabled, though email will only work of course if the site has been properly 

configured to deliver email. Jabber and Mobile notifications are off by default and need to be configured first. 

 

 Default message outputs 

 The user defaults for these are set in Administration > Site administration > Plugins > Message outputs > Default 

message outputs. 

 You can specify the default outputs for each type of message that Moodle can send. 

 Permittedness 

 You can also set to what degree each type of message is enabled, and whether users are able to change these 

default settings in their profiles: 

 Disallowed - This particular type of message is not allowed at all and users will never not see any settings 

related to them. Message of the chosen type will never be delivered. 

 Permitted - Users are permitted or allowed to change the settings. When the user account is created, the 

new user will inherit the settings the administrator sets here, but will be allowed to change them afterward 

in their Messaging settings. Messages will be delivered as the user sets them on their own Messaging 

settings page. 

 Forced - Users are not permitted or allowed to change these settings. When the user account is created, the 

new user will inherit the settings the administrator sets here and will never be allowed to change them. 

Messages will be delivered for all users as you set them on this page. 

 Logged in/Offline 

 You can set whether each of these will be sent when the user is online through the messaging system interface 

available to users in their profiles, and/or whether each output is sent via email. 

 Ordering of messaging settings 

 Because users might have many different messaging options, they are ordered into different components -for 

example, Forum, Assignment, System, Enrolments etc. 
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 List of message type 

Output Name Description Recipients 

Assignment notifications Student has submitted an  Teacher 

Warning when your quiz attempt 

becomes overdue 

See Quiz settings Time limit Student 

Available update notifications Notice of new releases of Moodle 

code 

Site administrators 

Backup notifications Automated backup schedule run 

completed 

Site administrators 

Badge creator notifications Notify creator of a badge when it is 

awarded to someone 

Any badge creator (typically Teacher or 

Manager role) 

Badge recipient notifications Notify recipient of a badge when it 

is awarded to them 

Any badge recipient (typically Student role) 

Confirmation of your own quiz 

submissions 

Notice your quiz was successfully 

submitted 

Student 

Course creation request approval 

notification 

Notice a requested course has 

been approved 

Defined in Site admin > Courses > Course 

request > Course request notification 

Course creation request notification Notice a course has been 

requested - See course requests 

Defined in Site admin > Courses > Course 

request > Course request notification 
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Course creation request rejection 

notification 

Notice a requested course has 

been rejected 

Defined in Site admin > Courses > Course 

request > Course request notification 

Important errors with the site Important errors Site administrators 

Manual enrolment expiry 

notifications 

Notice if manual enrolment about 

to expire 

Manual enrolees 

Self enrolment expiry notifications Notify users when their enrolment 

expires 

Enroller only, or Enroller & Enrolled user 

Essay graded notification Notify students a teacher has 

graded an essay question 

Student 

Personal messages between users Using the Messaging interface tool Authenticated Users 

Message to confirm that an inbound 

message came from you 

 Authenticated Users 

Feedback reminder Feedback non-respondent 

reminder message 

Student feedback activity non-responders 

Warning when an inbound message 

could not be processed 

 Authenticated Users 

Confirmation that a message was 

successfully processed 

 Authenticated Users 

Notices about minor problems  Site administrators 

Notification of rule subscriptions Notifications from Event 

monitoring rules  

Site administrators 

Subscribed forum posts Master switch for forum 

subscription handling 

Anyone subscribed to a forum 

Feedback notifications Notices from setting Enable 

notification of submissions 

Teacher, Feedback administrator 

Notification of quiz submissions Message that student has 

submitted a quiz 

Teacher 

 Except for Personal messages between users which refers to the interaction messaging tool on a user profile, 

the other messages are generated by events in Moodle. 
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 User profile settings 

 Users can receive message alerts for a number of different reasons and can also send and receive instant 

messages. How a user receives notification of incoming messages can be set in Administration > My profile > Messaging. 

 This brings up a screen with check boxes where users can choose how they wish to be notified both when 

logged in and logged out. They can choose between a pop up, Jabber message or an email. 

 

 Note: The choices a user has on this screen depends on their role and permissions within Moodle. For example, 

an administrator would see options for notifications about backups or important errors with the site. 

 An administrator can receive update notifications for both Moodle core code and any contributed plugins 

installed on the site if the automatic check for available updates is enabled in Administration > Site Administration > 

Server > Update notifications. 

 Pop up 

 When a user is logged into Moodle, the message will pop up from the bottom right corner of the page. The user 

can choose to read the message immediately or to ignore it. If they choose to ignore it, the message returns until it is 

read. 

 Email 

 Users cannot by default automatically choose to have notifications sent to a different email address from their 

official Moodle email. However, the administrator has the option to override this so that users can have an alternative 

email. This is done from Administration > Site administration > Advanced features and when activated, a box will appear 

for users to enter another email address. 

 Note: The 'messagingallowemailoverride' setting does not affect failed log in notifications as they do not go 

through the messaging system, and will therefore still go to the original email specified. 

 Prevent non-contacts from messaging me 

 Non-contacts can be prevented from sending messages by ticking this box in General Settings at the bottom of 

the screen. 

 1.8 Calendar 
 The calendar can display site (1), course (2), group and or user (3) events in addition to assignment and quiz 

deadlines, chat times and other course events. Note the colour coding on the screenshot below. 

 A calendar may be included in a course or the site Front page by adding a Calendar block or an Upcoming Events 

block. 
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 1.8.1 Calendar settings 

 Preference settings 

 Both the daily detail screen and the monthly detail screen have the Preferences button in the upper right. Here 

you can set the time format, first day of the week, number of events to show in the calendar block, days to look forward 

for events and if the filters on this calendar should be saved as the default for all calendars. 

 Site administration settings 

 The following settings can be changed by a site administrator in Administration > Appearance > Calendar: 

 Calendar type 

 The admin can choose a default calendar type for the whole site here. Individual users can override this in the 

course settings or in their user profile. 

 Admins see all 

 Whether admins see all calendar events or just those that apply to themselves. 

 Time display format 

 Whether a 12 or 24 hour format is used. This setting can be overridden by user preferences. 

 Start of week 

 Default is Sunday. 

 Weekend days 

 Weekend days are shown in a different colour. 

 Days and events to look ahead 

 For determining how many events are listed in the Upcoming Events block. If the Upcoming Events block 

becomes too long you can reduce the number of days and events to lookahead. 
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 Calendar export days to look ahead and back 

 A custom range of dates, such as a school term or year, may be set as a calendar export option. 

 Calendar export salt 

 The calendar export salt is a random string of characters used for improving of security of authentication tokens 

used for exporting of calendars. 

 1.8.2 Using Calendar 

 Adding an event 

 To add a calendar event: 

1. Click month on Calendar to get an expanded month view 

2. In Calendar view click the New Event button 

3. On a New Event page select the type of event 

 A User Event will only be visible by the user currently logged in (i.e. the one creating the event) 

 A Group Event will be visible to a particular Group on the course (chosen from a drop-down list) 

 A Course Event will be visible to participants on the course in question. Only users with the 

capability to manage calendar entries at the course level can add course events. 

 A Site Event is a "global" event - visible in every course and on the calendar on the home page. Only 

users with the capability to manage calendar entries at the system level can add site events. 

4. Set the event properties 

5. Click Save changes 

 The different types of events can be visually filtered. 

 For example, if you (as a teacher) wanted to hide Group event dates (events assigned to learner Groups you 

create), click "Group events" on the bottom of the Calendar. This would hide all group events, and the color code would 

disappear from the link on the calendar. To show the events again, click the Group Events link again. This can make the 

calendar easier to read (especially if there are many events on the calendar). 

 Other features 

 Adding closing dates to course activities — assignments, quizzes etc. will cause them to show up in 

thecalendar block as course events. 

 View previous or future months. 

 Current date is outlined. 

2. Managing a Moodle course 
 A course in Moodle is an area where a teacher will add resources and activities for their students to complete. It 

might be a simple page with downloadable documents or it might be a complex set of tasks where learning progresses 

through interaction.  

 The course page is made up of central sections which contain the tasks and (if desired) blocks to the side. The 

course teacher has control over the layout of the course homepage and can change it at any time. Progress can 

be tracked in a number of ways. 
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 Students can be enrolled manually by the teacher, automatically by the administrator, or they can be allowed to 

enrol themselves. Students can also be added to groups if they need to be separated from classes sharing the same 

course or if tasks need to be differentiated. 

 2.1 Courses 
 Courses are the spaces on Moodle where teachers add learning materials for their students. Courses are created 

by admins, course creators or managers. Teachers can then add the content and re-organise them according to their 

own needs. The links below the image will provide more information about creating, organising and managing courses. 

 

 2.1.1 Adding a new course 

 By default a regular teacher can't add a new course. To add a new course to Moodle, you need to have either 

Administrator, Course Creator or Manager rights. 

 Adding a course 

 To add a course: 

 Go to Administration>Site Administration>Courses>Manage courses and categories 

                                                         

 Click on the category where you want your course to be.  

 Click the "New course" link 
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 Enter the course settings, then click the "Save changes" button. 

 On the next screen, choose your students/teachers to assign to the course. 

 Deleting a course(s) 

 A regular teacher can't delete a course. Administrators and managers (i.e. users with a role for which the 

capability moodle/course:delete is allowed) can delete courses. A Course creator can delete courses they have created 

themselves. 

 To delete a course (as an administrator or manager): 

 Go to Administration>Site Administration>Courses>Manage courses and categories 

 Click the course's category and click the course in the screen on the right. 

 Click the Delete link. 

 

 You can delete multiple courses by: 

 Creating a new (temporary) category. You can name it "To be deleted". 

 Select and move the "About to be deleted" courses to that category ("To be deleted"). 

 Delete the category ("To be deleted") and choose "Delete ALL - cannot be undone". 

 Sorting courses 

 Courses may be sorted by an admin or manager from Administration > Site administration > Courses > Manage 

courses and categories. 

 Courses may be sorted by ascending/descending and by time created. 

 

 2.1.2 Course categories 

 Course categories organize courses for all Moodle site participants. The default course category on a new 

Moodle site is "Miscellaneous" (although this can be renamed) A Course creator, Administrator or Manager can put all 

courses in the Miscellaneous category. However, teachers and students will find it easier to find their classes if they are 

organized in descriptive categories. 

 The list of courses within a category by default shows the teachers and the summary of each course. If the 

number of courses within a category exceeds 9 (10 or more), then a short list without teachers and summary is shown. 
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 Adding a category 

 Most people organize their courses by department and college or by topic. Be sure to test the organizational 

scheme with a few users before entering a large number of courses, to save time in moving them later. 

 Adding categories is very simple: 

 Go to Administration > Site administration > Courses > Add a category 

 Complete the details required and click 'Create category.' 

 Alternatively, you can go to Administration>Site administration>Courses>Manage courses and 

categories and click the link 'Create new category'. 

 

 If the category is visible, the course category description will be displayed to users when they enter the 

category, above the list of courses. 

 Editing or moving a category 

 You can edit the details of a course category by clicking the actions icon next to its name 

inAdministration>Site administration>Courses>Manage courses and categories. and selecting 'Edit'. 

 You can move categories up or down by clicking the up/down arrow next to the category you wish to move. 

You can bulk move categories by checking the box to the left of their name and then by selecting from the 

dropdown 'Move selected categories to'. 
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 Adding sub-categories 

 Sometimes it might be useful to have a sub-category of a course. For example, you might have a category 

"Science" and wish to have sub-categories "Biology", "Chemistry" and "Physics". 

 You can make one category a subcategory of another by checking the box to the left of its name and then by 

selecting from the drop down menu 'Move selected categories to' You can create a new, empty sub-

category by clicking the actions icon next to its name in Administration>Site 

administration>Courses>Manage courses and categories. and selecting 'Create new subcategory.' 

 Hiding categories 

 Categories may be easily hidden or shown via Administration>Site administration>Courses>Manage courses 

and categories and clicking the 'eye' icon of the category you wish to hide. Hidden categories are only visible 

to site administrators or those with the capability to "view hidden courses". 

 Sorting categories 

 Categories may be sorted by ascending/descending names or ID numbers from Administration>Site 

administration>Courses>Manage courses and categories. 

 

 Courses within categories may also be sorted. 
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 Setting category depth 

 You can limit the number of categories that are displayed in the front page 'List of Categories' or 'Combo List' 

from Administration>Site administration>Front page>Front page settings Deeper level categories will appear as links 

and the user can expand them. 

 2.1.3 Course settings 

 A teacher, or other user with the update course settings capability, can change course settings in Administration 

> Course administration > Edit settings. 

 General 

 

 Course full name 

 This is the name of the course. It is displayed as a link on course lists on the Front page and on My home and in 

reports. It is also used in the browser title bar when the course is viewed. 

 Short name 

 Many institutions have a shorthand way of referring to a course, such as BP102 or COMMS. Even if you do not 

already have such a name for your course, make one up here. It will be used in several places where the long name is 

not appropriate, such as the Navigation block. 

 By default, only course full names are displayed in the list of courses. However an administrator can enable 

short names to be displayed too if required by ticking the checkbox in Administration > Site administration > 

Appearance > Courses. 

 Course category 

 The site administrator may have created course categories to help teachers and students find their courses 

easily. Course categories may be reflected in the Navigation block. 

 Course start date 

 This setting affects the display of logs and the weekly format topic dates. 

 If you use the "Weekly" course format, the start date will appear in the first section of the course. For example 

selecting 27 July, will display "27 July - 2 August" in the first section (when default display is selected for that section). 

 This setting will have an effect on the display of logs. This will be the earliest possible date the log activity will 

display. 

 This setting will not affect courses using the 'social' or 'topics' formats. 
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 TIP: If your institution runs on a weekly schedule, you may want to consider setting the start date for courses on 

the first day of the week, like a Monday. 

 TIP: In general, if your course does not have a real starting date then set the date to yesterday and use the 

availability setting to reveal the course to students. 

 TIP: See self enrolment course settings to prevent students from entering the course before a certain date/time. 

 Visible 

 Here you can "hide" your course completely. It will not appear on any course listings, except for managers, 

course creators, teachers and any other users with the view hidden courses capability. Even if students try to access the 

course URL directly, they will not be allowed to enter. 

 Course ID number 

 The ID number is an alphanumeric field. It has several potential uses. Generally, it is not displayed to students. 

However, it can be used to match this course against an external system's ID, as your course catalogue ID or can be used 

in the certificate module as a printed field. 

 Description 

 

 Course summary 

 The summary appears on the course listings page. This field is searched when searching for a course and also 

appears in the Course/Site description block. 

 Course summary files 

An image (and if allowed by the administrator, other file types) may be attached to the course summary. They will be 

accessible by anyone from outside of the course just like the course name and/or summary. Only users 

withmoodle/course:changesummary capability are able to upload/change course summary files. Note that if this is not 

allowed by the administrator, then no box will appear to upload course summary files. 
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 By default, only jpg, gif and png file types are allowed as course summary files. An administrator can change the 

allowed file types in Administration > Site administration > Appearance > Courses. 

 Course format 

 (These settings are collapsed by default.) 

 

 Number of sections 

 This setting is only used by the 'weekly' and 'topics' course formats. In the 'weekly' format, it specifies the 

number of weeks that the course will run for, starting from the course starting date. In the 'topics' format, it specifies 

the number of topics in the course. Both of these translate to the number of "boxes" down the middle of the course 

page. 

 If the number of weeks/topics is changed for an existing course so that the number is less than the number of 

course sections containing activities (for example the course contains activities in 3 sections and the number or 

weeks/topics is set to 2) then when editing is turned on section(s) at the bottom of the course page will be shown with 

the title 'Orphaned activities'. 

 The number of weeks/topics may be set to 0, so that only the top general section is displayed on the course 

page and there are no numbered sections. 

 By default, the maximum number of weeks/topics is 52, but an administrator can set a different maximum 

number which will apply to all courses on the site (see below). 

 Hidden sections 

 This option allows you to decide how the hidden sections in your course are displayed to students. By default, a 

small area is shown (in collapsed form, usually grey) to indicate where the hidden section is, though they still cannot 

actually see the hidden activities and texts. This is particularly useful in the Weekly format, so that non-class weeks are 

clear, or if you have quizzes you don't want your students to see. 

 TIP: If you choose, these non-available items can be completely hidden, so that students do not even know that 

sections or an activity in the course are hidden. 

 Course layout 

 The Course layout setting determines whether the whole course is displayed on one page or split over several 

pages. The setting currently applies to the topics and weekly core course formats and contributed collapsed topics 

course format only. 

 Teachers choose from the dropdown whether they wish to "show all sections on one page" in the familiar 

scrolling format, or "show one section per page". 
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 If one section per page is selected, the course page is abbreviated to a list of links to individual sections. If an 

individual section is shown, next and previous sections may be accessed via links above and below the section. 

 
 Course page for course using one section per page course layout 

 

 
 Individual section of a course using one section per page course layout 

 Appearance 

 (These settings are collapsed by default.) 
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 Force theme 

 If the site administrator has allowed the teacher to set a course theme, this pull down menu will appear with a 

list of themes on the site. Teachers can use this to choose a different look for the course from the rest of the Moodle 

site. 

 Force language 

 If you force a language in a course, the interface of Moodle in this course will be in this particular language, even 

if a student has selected a different preferred language in his/her personal profile. 

 The capability moodle/site:forcelanguage may be allowed by the admin for users who need to override this 

language (for example, when testing problems in a course in a language they do not know.) 

 News items to show 

 How many news items should show the Latest news block. Set it to 0 and Latest news block will not appear. 

 The Latest News block relies on the use of the associated News Forum. News posted in other forums do not 

display in the latest News block 

 Show gradebook to students 

 Here you can decide whether to allow students to see the link to grades in the Administration block. If your 

course doesn't use graded activities, it makes sense to disable this. If grades are used and this link is disabled, students 

can still see their grade from the actual activity itself, such as an assignment. 

 Show activity reports 

 Here you can decide whether to show students their activity reports. Doing so places a load on the server 

however, which is why the setting is disabled by default. 

 Files and uploads 

 (These settings are collapsed by default.) 

 Maximum upload size 

 Here you can decide the largest size of file that students can upload to a course. The site administrator can 

determine sizes available for the teacher to select. 
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 Editing teachers or other users may be allowed to upload files larger than the maximum size by giving them the 

capability moodle/course:ignorefilesizelimits. 

 Completion tracking 

 (These settings are collapsed by default.) 

 Completion tracking must be enabled for Activity completion. Course completion criteria may also be based 

upon Activity completion values found in the activity's settings. 

 Guest access 

 (These settings are collapsed by default.) 

 

 Here you can decide whether to allow logged in users to access the course as a guest, and whether or not they 

need to enter a password.  

 Groups 

 (These settings are collapsed by default.) 

 

 Group mode 

 Here you can define the group mode at the course level by a pull down menu. "No groups", "Separate groups" 

and "Visible groups" are the choices. The selected setting will be the default group mode for all activities defined within 

that course. The group setting can affect what users see in the Participants list and who they can interact with in 

activities. 

 Force 

 If the group mode is "forced" at a course-level, then this particular group mode will be applied to every activity 

in that course. This will override any activities that may have a special group setting. 

 Default grouping 

 If groupings are enabled, a default grouping for course activities and resources may be set. 
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 Role renaming 

 (These settings are collapsed by default.) 

 

 You can rename the roles used in your course. For example, you may wish to rename the Teacher role as 

"Facilitator", "Tutor" or "Guide". These new role names will appear within the course. For example on the 

participants and the override permissions pages. 

 Please note that the site administrator or a course manager may have changed the names or added new roles. 

These names will appear and the teacher may rename them. 

 Site administration settings 

 An administrator can set course default settings in Administration > Site administration > Courses > Course 

default settings. 

 The maximum number of weeks/topics may be set for all courses on the site. The default value is 52. 

 Preventing teachers from editing course settings 

 Any/all of the following fields - course full name, short name, ID number and category, summary - may be 

locked to prevent teachers from editing them. To do so: 

1. Access Site Administration > Users > Permissions > Define roles. 

2. Click the edit icon opposite the teacher role. 

3. Change any/all of the capabilities moodle/course:changefullname, moodle/course:changeshortname, 

moodle/course:changeidnumber, moodle/course:changecategory, moodle/course:changesummaryfrom 

allow to not set. 

4. Click the "Save changes" button at the bottom of the page. 

 2.1.4 Course formats 

 A course format refers to the layout of a course. The course format can be selected in Administration > Course 

administration > Edit settings. 
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 An administrator can enable, disable or delete course formats for courses in Administration > Site administration 

> Plugins > Course formats > Manage course formats. They can also change the order in which available course formats 

are displayed to teachers in the course settings. 

 

 Standard course formats 

 Weekly format 

 The course is organized week by week, with a clear start date and a finish date. Moodle will create a section for 

each week of your course. You can add content, forums, quizzes, and so on in the section for each week. 

 TIP: If you want all your students to work on the same materials at the same time, this would be a good format 

to choose. 

 NOTE: Make sure your course start date is correct. If it is not your weeks will have the wrong date on it. This is 

especially important if you are restoring a course to use with a new section of students. 

 

 Topics format 

 The course is organised into topic sections that a teacher can give titles to. Each topic section consists of 

activities, resources and labels. 

 TIP: This is great to use if your course is objective based and each objective may take different amounts of time 

to complete. An example of this would be scaffolding where the students are building upon the knowledge from earlier 

topics. 
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 "Show only one section" 

 With the Weekly, Topics and any contributed format that implements the functionalty, it is possible 

via Administration > Course administration > Edit settings to "show one section per page". Here is a course with eight 

topics, with the third one currently shown. The links left and right lead to topics two and four: 

 

 Notes: 

 The course home page shows just the section names and any text in the section description along with activity 

and resource numbers, with the names being click-able. This is what you see the first time you access the 

course. Once you have selected a topic by clicking on its name, you then see one section at a time. 

 If editing is ON, then the Main course page will display all the content in all the sections. 

 There is a 'Jump to...' menu at the bottom of each single section page. 

 Social format 

 This format is oriented around one main forum, the social forum, which appears listed on the main page. It is 

useful for situations that are more free form. They may not even be courses. The Moodle Lounge is an example of a 

social format course. 
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 The social forum can be edited by clicking the 'Update this forum' button on the social forum page. The forum 

introduction is displayed at the top of the course page. Activities and resources can be added on side utilising the Social 

activities block. 

 Single activity format 

 The single activity format only has 1 section, and allows the teacher to add one activity only to the course. When 

the single activity format is selected, a drop down menu appears for the teacher to choose the activity they wish to use. 

 

 Single activity format with a forum as the activity and social format are very similar. The only difference is when 

the course contains other activities. The single activity format displays them as "orphaned" and for teachers only; the 

social format displays them in an activities block and available for students. 

 2.1.5 Course homepage 

 Standard view of a blank course 

 Our examples will be for a course homepage that is the standard default for a new install on a site. There are 

many course options that determine a course's appearance and make it look very different from our examples. The 

example course has a header, a footer (both content largely determined by a theme) and 3 columns in the middle. 
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 Parts of a course homepage 

 Using the above image, here are the parts of a typical course homepage. It is possible to move and hide parts of 

the page and different themes display blocks in different regions, so not all courses will look like this. 

Column left Course sections - Center Column right 

*1 Course full name *6 Section header & News topic *9 Login information 

*2 Navigation bar *7 Current week - First section *10 Turn editing on button 

*4 Navigation block *8 Future week - Second section *11 Latest news 

*5 Administration block  *12 Upcoming events 

*14 "Switch role to"  *13 Recent activity 

*15 User profile settings   

*16 Site administration   

 Course sections 

 Course sections are displayed in the centre of the course page. 
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 To edit a course section 

1. Turn editing on 

2. Click the edit icon after the section title 

 If Conditional activities are enabled for the site, access to the section (including all activities and resources 

within it) may be restricted. 

 The number of course sections in the centre column may be changed in Administration > Course administration 

> Edit settings or by clicking the plus or minus icons at the bottom of the course page when editing is turned on. 

                   

 To move a course section 

1. Turn editing on 

2. Click the up/down arrow or the crosshairs icon to move the section 

3. Drag the section to where you want to position it and let go 

 Note: The ability to move course sections is controlled by the capability moodle/course:movesections, which is 

allowed for the default role of teacher. 

 Blocks 

 Blocks are displayed in the right and/or left columns of the course page. 

 To add a block to the course page 

1. Turn on the editing by clicking the button top right or the link in "Administration > Course administration 

2. Select a block from the "Add block" dropdown menu (usually situated bottom right of the page) 

 To move a block 

1. Ensure editing is turned on then click onto the block title until the crosshair icon appears 

2. While keeping the block selected, drag it to where you want to position it and let go. 

 Alternatively 

1. Click on the up/down arrow 

2. Click on the place holder (a zone with a dashed border) where you want the block to appear. 



 

                                                                                                                                            
82 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

                           

 Activities and resources 

 To add an activity or resource to the course 

1. Turn on the editing by clicking the button top right or the link in Administration > Course administration. 

2. Click 'Add an activity or resource' to open the new activity chooser. Select an activity or resource then click 

the Add button, or simply double-click on the activity or resource name. 

 Alternatively, certain resources and activities may be added using drag and drop: 

 To add a file, simply drag and drop it onto the course section where you'd like it to appear 

 To add a folder of files, simply zip the folder then drag and drop it onto the course section where you'd like it to 

appear, answer 'Unzip files and create folder' to the popup dialogue, then click the upload button 

 To add a SCORM package, simply drag and drop it onto the course section where you'd like it to appear, answer 

'Add a SCORM package' to the popup dialogue, then click the upload button 

 Editing elements on your course homepage 

 With the editing turned on, each item on your course homepage and each section/block will have icons next to 

it which all perform different functions such as edit/move/copy/delete/hide.  

 Note: Your theme may have icons different from these below: 

  - the pencil icon allows you to edit inline the title of the resource / activity 

  - the open-eye icon means an item is visible to students. It will close when you click on it 
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  - the eye with a strike through icon means an item is hidden from students. It will open when you 

click on it 

  - the duplicate icon allows you to copy an activity or resource. It's done directly on the course page. 

 

 - the move icon allows you to move items or sections by dragging and dropping. (If you have many 

activities to scroll through while moving, see the Tips and Tricks section below for a useful suggestion.) 

  - this move icon appears if you don't have Ajax enabled. 

  - the groups icon allows you to change between no groups or separate/visible groups 

 

- this icon groups actions together for easier editing on smaller screens. Click to reveal the 

options. 
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  - the move here icon appears when moving a course element without 

Ajax. Click into the box to re-locate your item. 

  - the up/down arrows allow you to move course sections up or down and appear if you do not have 

Ajax enabled. 

  - the delete icon will permanently delete something from the course 

  - the groups icon allows you to change between no groups or separate/visible groups 

  - the roles icon allows you to assign roles locally in the item. 

 The following icon only applies to sections 

  - the highlight icon allows you to highlight a section as current. 

 2.2 Editing text 
 The usual way to edit or create text that is part of the visual content of a course is using the Text editor (also 

known as the HTML editor). 

 The way to edit the text in the content area, depends the current role or permissions of the user in a context. 

 A teacher will see many  ("edit settings") icons on a course's home page when "Turn editing on" 

button has been clicked. Or they will see the HTML editor and content area within many activities and 

resources. For example, a teacher can edit the text that appears at the top of a section in a course by 

clicking on the edit hand icon. 

 A student and a teacher will see the HTML tool when they reply to a forum post but will not have the ability 

of changing a topic heading in the course. 
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 2.1 Text editor 

 The text editor (sometimes referred to as the 'HTML editor' has many icons to assist the user in entering 

content. Many of these icons and functions should be familiar to anyone who uses a word processor. 

 Some examples of where you will see the text editor include: Editing Section headings, description of an activity, 

writing an answer to a quiz question or editing the content of many blocks. 

 The default text editor in Moodle is the Atto editor, built specifically for Moodle. There is also a version of 

the TinyMCE editor and a plain text editor. 

 Text editors can be enabled, disabled or a different one set to default from Administration > Site administration 

> Plugins > Text editors > Manage editors. The order of priority may also be specified here. 

 An individual user can select an editor in their profile from Administration > My Profile settings > Edit profile. 

 2.3 Activities 
 An activity is a general name for a group of features in a Moodle course. Usually an activity is something that a 

student will do that interacts with other students and or the teacher. 

 There are 14 different types of activities in the standard Moodle that can be found when the editing is turned on 

and the link 'Add an activity or resource' is clicked. 

 2.3.1 Assignment module 

 The assignment module allows teachers to collect work from students, review it and provide feedback including 

grades. The work students submit is visible only to the teacher and not to the other students unless a a group 

assignment is selected. 

 

 Students can submit any digital content (files), including, for example, word-processed documents, 

spreadsheets, images, audio and video clips. Assignments don't necessarily have to consist of file uploads. Alternatively, 

teachers can ask students to type directly into a text field in Moodle. Or they can ask student to do both, upload a file or 

files and type text directly into Moodle. An assignment activity can also be set up to not accept any student submissions 

and serve as a reminder to students of a 'real-world' assignment they need to complete and to record grades in Moodle 

for activities that don't have an online component. 
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 An assignment has an 'available from' date before which no students can submit anything, and a due date, after 

which teachers can choose not to accept submissions any more. 

 Markers can choose to be notified every time a student submits an assignment, or only for late submissions. 

Markers can choose to give students feedback in the form of text or uploaded files. 

 2.3.2 Assignment settings 

 Adding and editing an Assignment activity 

 To add a new Assignment activity to your course, login with the appropriate access rights (e.g.editing 

teacher, course creator or administrator) and Turn Editing On. Within the required Week or Topic Block click 

Add and Activity or Resource link. 

 In the Add an activity or resource dialogue box that appears, select Assignment and click Add. 

 To edit an existing Assignment activity, login to your course with the appropriate access rights (e.g. editing 

teacher, course creator or administrator) and Turn Editing On. Select the Update icon against the relevant 

Assignment item. 

 Alternatively, after logging into your course simply click on the name of the Assignment activity you wish to 

edit and then click the Edit Settings link under Assignment administration within the Settings block. 

 The following configuration options are available when creating or editing/updating any Assignment activity. 

Only General, Availability and Submission types are open by default; the others are collapsed. To expand everything, 

click the "Expand all" link top right. Click on any screenshot to see it full size. 

 General 

 The General section allows you to give your assignment a name and description. 

 

 Assignment name 

 Give your Assignment a name (e.g. “Report on Topic 1 Content”). The title entered here will be the name that 

learners see in the course content area. Learners will click on this name to view the details of the assignment and, if 

applicable, submit their work. 
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 Description 

 Provide instructions for your students here so they are clear what they have to do. Click the icon on the left to 

expand the toolbar and drag the bottom right of the text box out to expand it. 

 You can also provide information or resources related to the assignment, such as a video clip, an image, or a link 

to a webpage. 

 Display description on course page 

 Enabling this will display the description on the course page just below the link to the assignment activity. 

 Additional files 

 Here a teacher can attach files which may be of help to the students as they do their assignment, such as 

example submissions or answer templates. 
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 Availability 

 

 Allow submissions from 

 The Allow submissions from setting prevents students from submitting their assignment before the shown date. 

A teacher can to set a day, month, year and time (24 hour clock) from which learners can begin to submit their 

assignments. Please note that this setting does not hide the activity from the learners. Instead, the learner will see the 

activity, be able to view the instructions and use any materials you have included in the description, but the learner will 

not be able to submit or complete the assignment until the Allow submissions from date. 

 This setting is enabled (ticked/checked) by default and is set at the day and time you added the assignment. To 

disable this, remove the tick/check. 

 Due date 

 The Due date setting establishes when the assignment is due. Submissions will still be allowed after this date, 

but any assignments submitted after this date are marked as late. 

 This option allows an teacher to set a day, month, year and time (24 hour clock) before which learners must 

submit their assignment. 

 By default the Due date is Enabled (ticked) and is set at 7 days ahead of the day and time you selected Add 

Assignment. To disable this feature, simply ensure the Enable checkbox is not marked.  

 Note: Assignments without a Due date will appear on the My home page with “No Due date” displayed. 

 Cut-off date 

 The Cut-off date is the date beyond which students will not be able to send in their assignment as the button for 

doing so will no longer be displayed. After that date (or time) a teacher may, on request, grant an extension by going to 

the class assignment grading screen, clicking the "Edit" column and choosing "grant extension" for the relevant student. 

 Always show description 

 If the 'Always show description' checkbox is ticked, the assignment description is always shown. If the checkbox 

is not ticked, the assignment description will be hidden until the 'Allow submissions from' date. 
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 If 'Allow submissions from' is disabled, then this setting has no meaning: the assignment description will always 

be visible to students. 

 Submission types 

 

 Here you can decide how you wish students to submit their work to you. 

 Note that if Submission comments are enabled in Administration>Plugins>Activity 

modules>Assignment>Submission plugins then students will be able to add a note to their teacher on submitting work. If 

Blind marking is enabled, student comments display as from "Participant 01 etc" to avoid revealing identities. These 

comments will appear in the grading table in the Submission comments column. 

 Online text 

 Learners can type their response directly in Moodle using the text editor. 

 Text typed into the text editor is automatically saved at regular intervals.  

 It's possible to set a word limit on an online text assignment. Students get a warning if they try to exceed the 

word limit: 

 

 Note: Numbers (such as in addresses) are counted as words; structures such as I'm where an apostrophe 

replaces a part of a word are only counted as one word. 
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 File submissions 

 Learners can upload and edit one or more files of any type the teacher can open. 

 If the student uploads a pdf file, the teacher can annotate it within the browser, and on saving, the annotated 

file is made available to the student.  

 Note: This requires Ghostscript to be enabled on the server. This can be checked in Administration>Site 

administration>Plugins>Activity modules>Assignments>Feedback plugins>Annotate pdf. 

 Maximum number of uploaded files 

 Here you can decide the maximum number of files which may be uploaded by each learner. (It might be helpful 

to display the number in the assignment description.) 

 This setting specifies the maximum size per file of each of the files that the students can upload as part of their 

submission. This maximum upload size may only be equal to or less than the course limit (which in turn may only be 

equal to or less than the site limit). The maximum size of each file is displayed to students at the point where they 

upload files. 

                               

 Feedback types 

             (This setting is collapsed by default) 

 

 Feedback comments 

 Setting this to yes means that markers can leave feedback comments for each submission. It enables the 

Feedback Comments column in the grading table.(To access the grading table, click on the assignment activity and 

then View/Grade all Submissions). Feedback comments are also accessible by clicking on the green tick in the grade 

column on the grading table. 
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 Offline grading worksheet 

 If set to yes, the teacher will have a link to download the grading list as a spreadsheet. They will then be able to 

enter grades and feedback comments offline. (Not working for non English users, yet.) 

 

 

 When the teacher has completed their grading offline, they can then upload the spreadsheet, confirm the 

changes and the grades and comments will be transferred over into Moodle's gradebook: 
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 Feedback files 

 This allows markers to upload files with feedback when marking. These files may be the marked up student 

assignments, documents with comments, a completed marking guide, or spoken audio feedback. It enables the 

Feedback Files column in the grading table. (To access the grading table click on the assignment activity and 

then View/Grade all Submissions)To upload feedback files, click on the green tick in the grade column on the grading 

table and then upload either with drag and drop or using the File picker. 

 Feedback is displayed to students on the assignment submission page. 
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 Uploading multiple feedback files 

 It is also possible to upload multiple feedback files as a zip, from the dropdown above the grading list: 

1. Download the students' assignments using the "Download all submissions" link from the same dropdown 

menu; 

2. Extract the folder offline and add your comments to the student's submissions.Keep the names the same. 

3. Select the students' submissions and zip them into a new folder. Important: Don't just edit them inside their 

original folder and re-zip this; it will not work. The folder name does not matter as long as the feedback files 

have the same names as before. 

4. Upload this newly zipped folder. 

5. You will be presented with a confirmation screen displaying your feedback files. 

 

 

 Comment inline 

 If set to Yes, a teacher can comment directly on the text which a student has submitted as an online text type 

assignment. 
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 Submission settings 

 (This setting is collapsed by default) 

 

 Require students click submit button 

 Students can upload draft versions of the assignment until such time as they are ready to submit.Once they click 

the submit button they indicate to the teacher that they have finished working on the assignment. In earlier versions of 

Moodle this was called "Send for marking".) 

 They can then longer edit their submission. If they need to change it, they must ask the teacher who can revert 

the assignment to draft status. 

 To revert to the draft stage, click on the assignment activity and then View/Grade all Submissions. Locate the 

student and click the action icon in the Edit column. Select Revert the submission to draft. 

 If this setting is No, then students do not have to to click a submit button and are able to make changes to 

uploaded files at any time. 

 If this setting is No but the teacher wishes to grade students work, then you can stop students from making 

further changes by using Prevent submission changes. Prevent submission changes can also be used in cases where 

students have neglected to click the Submit button and grading has commenced. To prevent submission changes, click 

on the assignment activity, then click on the View/Grade all submissions button. On the grading table, locate the 

student and click the action icon in the Edit column. Select Prevent submission changes. 

 To do either of these with a number of students, use the With selected menu at the bottom of the grading table. 

                                    

 

 To do either of these with a number of students, use the With selected menu at the bottom of the grading table. 

 Require that students accept the Submission statement 

 An administrator can define a "Submission statement", ie, a statement where students promise the work is their 

own and which they must agree to before submitting their work. This may be done viaSettings>Site 

administration>Plugins>Activity modules>Assignment. 
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 If preferred, the available default statement which may be used instead: This assignment is my own work, 

except where I have acknowledged the use of the works of other people 

 If the administrator has given teachers the option of using a submission statement or not, then it will be 

available in the assignment settings screen.  

 When this setting is enabled, students will have to check a button before they can submit their assignment: 

 If the administrator has forced the statement throughout the site, a teacher will not have this option in the 

settings but a student will see the statement when accessing their assignment. 

 Attempts reopened 

 This setting allows the teacher to decide how submissions are reopened. The default is "Never", in that students 

may only submit once. However, a teacher can set this to "Manually" and reopen it themselves for the student to 

resubmit, or to "Automatically until pass". The student must then keep trying and resubmitting until they get a pass 

grade. Passing grades are set in the Gradebook. (Note that for this you need to set the assignment so that students have 

to click 'submit for marking'. If not, then, unless you manually lock a student's assignment, then they can continue to edit 

it for as long as they like.) 

 Maximum attempts 

 If a student is allowed to resubmit, this setting will determine how many times they can resubmit before they 

are no longer allowed to do so. (For example, if a student has to keep trying until they get a pass grade, the teacher 

might decide that ten attempts is enough even though they have not yet passed!) 

 Groups submission settings 

 (This setting is collapsed by default) 

 

 Students submit in groups 

 If this box is ticked, then students are able to collaborate on an assignment. This might involve for example, 

working in the same online text area, or one student uploading an MS Powerpoint which another student downloads, 

improves and re-uploads to the common assignment area. 

 When grading, the teacher may choose to give a common grade and feedback to all students in the group or to 

give individual grades and feedback to each member. 

 If no groups have been made, then Moodle will make a default group of every student in the course. (Note also 

that if a student is in more than one group then their submission will be made to the default group.) 
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 Require all group members submit 

 This setting will only appear if the teacher has ticked the "Require students click submit button" earlier. The 

assignment will not be classed as "submitted" until all members of the group have made a contribution. When one 

student has submitted, the other members of the group will be able to see who still has to submit. 

 Grouping for student groups 

 If a particular grouping is selected here, then the gradebook will display any other groups and non-grouped 

students in the "default group", while naming the group(s) that are in the chosen grouping. If "none" is selected, then 

the gradebook will display the names of all groups and put any non-grouped students in the "default group". 

 Notifications 

 (This setting is collapsed by default) 

 

 Notify graders about submissions 

 Teachers will receive a message (of a type they choose) whenever a student submits an assignment. Please note 

if you are using the assignment in Groups Mode (eg Separate or Visible Groups), the teacher will need to be a member 

of the group in order to receive the submission notification. 

 Notify graders about late submission 

 Teachers will receive a message (of a type they choose)whenever a student submits a late assignment. Please 

note if you are using the assignment in Groups Mode (eg Separate or Visible Groups), the teacher will need to be a 

member of the group in order to receive the submission notification. 

 Grade 

 (This setting is collapsed by default) 

 

 Grade 

 Select Points or Scale from the dropdown. If you will not be giving a grade for the assignment, choose No 

Grade. 

 Then select your points or chosen scale. 
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 Grading method 

 There are 3 options: 

 Simple direct grading (entering a grade or scale item) 

 Marking guide 

 Rubric 

 Grade Category 

 Any custom Grade Categories that have been created within your site or course will be listed here and will be 

available for selection. Select the required Grade Category to add this assignment as a Grade item within this Category. 

 Blind marking 

 If this setting is enabled, then a teacher will not see the names of students who have submitted their 

assignments. Instead, they will see randomly generated Participant numbers. (The student view of the assignment does 

not change.) This is also the case if student comments have been enabled. Once they have graded the assignment, it is 

however possible for teachers to see who submitted what by clicking on "Reveal student identities" in the Assignment 

settings. 

 Returning Marks to Students 

 Because of the nature of blind marking, the students cannot see the final grade until all of the students' names 

have been revealed. If you are grading an assignment using an advanced grading method such as a rubric, the rubric will 

also be hidden from students' view until the names are revealed. To reveal student names after you are finished 

grading, look under Assignment Settings > Reveal Student Names. Feedback comments will appear whether or not 

student names are hidden or revealed. 

 Use marking workflow 

 When set to Yes, teachers will be able to specify the stage they are at in their grading of individual assignments 

(as in the screenshot below). 

                  

 One advantage of using marking workflow is that the grades can be hidden from students until they are set to 

'Released'. The actual list of steps are: 

 Not marked (the marker has not yet started) 

 In marking (the marker has started but not yet finished) 

 Marking completed (the marker has finished but might need to go back for checking/corrections) 



 

                                                                                                                                            
98 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 In review (the marking is now with the teacher in charge for quality checking) 

 Ready for release (the teacher in charge is satisfied with the marking but wait before giving students access 

to the marking) 

 Released (the student can access the grades/feedback) 

 Use marking allocation 

 If marking workflow (see above) is set to Yes, it is possible to enable marking allocation. This means that 

teachers can be selected to grade or review the submitted work of specific students. Colleagues can monitor progress 

through the displayed marking workflow states: 

 

 Locally assigned roles 

 In Administration > Assignment administration > Locally assigned roles selected users can be given additional 

roles in the activity. 

 2.3.3 Using Assignment 

 How do students submit their assignments? 

 The first page students will see when they click on the assignment activity link from the course page will display 

the assignment name, description and the submission status. The first time a student views the assignment it will look 

like this: 
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 The submission status section includes: 

 Submission status 

 Grading status 

 Due date 

 Time remaining 

 Last modified 

 Submission details 

 As they progress through the assignment the Submission status and Grading status will update and the Last 

modified date will appear. 

 

 If the student uploaded a pdf file which the teacher has annotated, this will be made available in the feedback 

section. The student can search through the document and filter specific comments. 
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 Submission statuses include: 

 Nothing submitted for this assignment 

 Draft (not submitted) 

 Submitted for grading 

 Grading statuses include: 

 Not graded 

 Graded 

 File submission 

 To submit a file submission, students complete the following steps: 

 Click the ‘Add submission’ button to bring up the file upload page. 

 Upload the relevant file into the submission. They are able to ‘drag and drop’ the file into the submission 

box. 

 Click ‘Save Changes’. 

 There should now be a Last modified date and the file(s) uploaded will also be displayed. 

 Depending on how the assignment is setup the status will either read ‘Submitted for grading’ - in which case 

no further action is need, or ‘Draft (not submitted)’. 

 If changes are required, click on ‘Edit my submission’. 

 Once ready to submit, click ‘Submit assignment’. Note that once the assignment is 'submitted’ no further 

changes are allowed. 
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 Note: Depending on how the assignment is setup students may see both a file submission page and an online 

text editor. 

 Online text 

 To submit online text, students complete the following steps: 

 Click the ‘Add submission’ button to bring up the online text editor page 

 Type the relevant text into the text editor, or paste from a previously written file. 

 Click ‘Save Changes’. 

 There should now be a Last modified date and the first 100 characters entered will also be displayed. 

 Depending on how the assignment is setup the status will either read ‘Submitted for grading’ - in which case 

no further action is need, or ‘Draft (not submitted)’ 

 If changes are required, click on ‘Edit my submission’. 

 Once ready to submit, click ‘Submit assignment’. Note that once the assignment is 'submitted’ no further 

changes are allowed. 
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 Submission comments 

 Depending on how the assignment has been setup, there may be a section where students can leave submission 

comments. 

 

 Submission notifications 

 Moodle allows the sending of a notification to the student when a student submits an assignment. This feature 

provides reassurance to the students that they have correctly submitted their assignments, especially when using 

features like draft submissions and file uploads. Moodle also allows notifications to teachers either when students 

submit assignments, or when students submit assignments late, or both. This feature notifies markers of the presence 

of assignments, or provides a reminder to access assignments submitted after the due date. 

 Why is this useful? 

 Provides a receipt for student that the assignment has been successfully submitted 

 Provides notification to marker that assignment are submitted 

 Notifies of any changes to submission - for student’s record and to notify marker 

 Provides notification to student that assignment feedback is available 

 Note: When blind marking is used, students will receive a notification, but will not see feedback until all 

submissions are marked and reveal student identities is clicked. That releases rubric marks and inline 

comment feedback to all students. 

 When is it sent? 

 If ‘Require students to hit submit button’ is enabled within the assignment which requires students to click a 

final submit button and prevents further changes, only one notification will be sent upon hitting the submit button. 

 If ‘Require students to hit submit button’ is not enabled, and students are allowed to make alterations or 

add/remove files from their submission, this receipt will be sent every time the file is altered - ie once on adding the file, 

once on adding a second file, once on removal of file, once on uploading a new file. 

 Where are these settings? 

 Submission Notification for Grader - Assignment > Edit Settings The grader is given two options: 

 Notify Graders about Submissions - YES/NO 

 Notify Graders about Late Submissions - YES/NO 

 The first option will notify the grader on any/all submissions made. The second will only send a notification for 

assignments submitted after the ‘Due Date’. 

 The Late Submissions option will be greyed out unless ‘Notify Graders about Submissions’ is selected as NO 

because ‘Notify Graders about Submissions’ will also send receipts for assignments submitted after the due date. To 

fully disable the grader receiving notifications, change both options to NO. 
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 Submission Notification for Students - My Profile Settings > Messaging Tickboxes on the messaging page can be 

set by the student depending on their preference. A student can opt to receive notification via email, popup message, 

jabber or -if enabled by admin -mobile phone. 

          

 Assignment notification - On submission of an assignment, the student will receive a notification that their 

assignment has been successfully received. 

 Viewing and grading submitted assignments 

 When students have submitted their assignments, they can be accessed by clicking on the assignment activity. 

This will bring up the Grading Summary page. 

 The Grading Summary page displays a summary of the assignment, including; number of participants, number of 

drafts, number of submitted assignments, due date and time remaining. 

 Clicking on the the ‘View/grade all submissions’ link will bring up the Grading Table. 

 The Grading Table contains columns of information about the student, the status of their submission, a link to 

grade their submission, a link to each submission and feedback comments and files (if enabled). 

 Filtering submissions 

 A dropdown menu accessed from the 'Options' section allows you to filter submissions so you can for example 

quickly see which students have not submitted yet. 

 

 Submission status 

 If you will be assigning grades to student work, you may want to take note of the submission status before you 

begin the marking process. If you have required students click the Submit button, you may find that some submissions 

are still marked as Draft (not submitted), meaning the student has either uploaded a file(s) or entered some text, but 

has not clicked ‘Submit assignment’.      

       If it's after the due date and you are about to commencing marking that you use ‘Prevent submission changes’ 

to stop students from making changes to their assignment. You can do this one by one by using the icon in the Edit 

column. 
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 Or you can select two or more students by putting a tick in the select column and going to 'Lock submissions’ 

from the With selected menu under the grading table. 

 Likewise you can also revert a student's submission to draft if they have uploaded the incorrect file. Instead of 

selecting ‘Prevent submission changes’ select ‘Revert the submission to draft’, or place ticks against selected students 

and choose 'Revert the submission to draft status' from the With selected menu under the grading table. 

 

    

 Quick grading 

 Under Options (scroll to bottom of the page) you can determine your preferences for the number of 

assignments you wish to display per page. You can also filter assignments either to show all (no filter), submitted, or 

requires grading. This is also where you can turn on quick grading. 

Quick grading allows you to enter grades and a feedback comment (if enabled in Assignment settings) directly into the 

grading table. Quick grading is not compatible with advanced grading and is not recommended when there are multiple 

markers. 

1. You can enter grades and feedback comments using quick grading. It is now possible to enter grades in 

decimal format. You will not be able to return a feedback file to your students (if enabled in the Assignment 

settings). 

2. Enter the grades 

3. Scroll to the bottom of the grading table and click 'Save all quick grading changes' 

4. A confirmation screen will appear. 

 Student grading page 

 If you have enabled File Feedback in the Assignment settings and wish to upload either the marked student 

assignment, a completed text based feedback document or audio feedback, click on the green tick in the Grade column 

(or use the icon in the Edit column and select Grade). 

 Here you can enter grades, feedback comments and feedback files (if enabled in the Assignment settings). You 

can use drag and drop to upload feedback files. 
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 Annotating PDF files 

 If the student has uploaded a PDF file you will see a link to Launch the PDF editor on the students' individual 

grading screen. This will display the PDF inline, allowing you to annotate it, using a variety of tools, stamps (if uploaded 

by the admin) and comments which may be saved to a comments bank. When the annotations are complete, clicking to 

save the changes will result in it being displayed to the student as part of their feedback. (Note that simply clicking on 

the file itself will not display it inline for annotating.) 

                                   

 

 Comments may be added and then saved in a quick list for future use. When adding a new comment, click the 

icon top right to access previously saved comments: 
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 Note: The annotate PDF feature requires Ghostscript to be installed on the server. This can be checked 

inAdministration > Site administration > Plugins > Activity modules > Assignments > Feedback plugins > Annotate PDF. 

 Controlling when to notify students of graded work 

 

 A checkbox is available when grading individual students. Choose Yes to notify them immediately or No to grade 

without notifying the student. 

 Downloading student submissions 

 You can download a zip file containing all of the assignment submissions by selecting the ‘Download all 

submissions’ options from the Choose menu at the top of the grading table, or in the settings menu. 

 File submissions will be downloaded in the format uploaded by the student. Online text submissions will be 

downloaded as html files. Each file in the zip will include the student first and lastname at the beginning of the 

filename for identification purposes. 

 Note - the files will have a Moodle unique identifier appended to the name, not your institutional student ID 

number. 

 Keeping records (archiving, exporting, backing up) 

 When students unenrol from a Moodle area, their records become invisible through the Gradebook interface. In 

order to have the information to hand, departments or course teaching teams may need systems in place to keep their 

own records for the data retention period required in their particular context. There are two separate procedures for 

exporting student submissions and marks. 

 To export marks (with or without feedback): 
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1. Go to your course area 

2. From its front page Settings block, select Grades; the Grader Report loads. 

3. From the Grader Report Settings block, select Export; a menu displays. 

4. From the menu, if you need easy viewing and running calculations you probably want to select one of the 

spreadsheet formats; a page of export settings loads 

5. Use the Visible Groups pulldown menu to limit the export to specific groups, as required 

6. In Options, you indicate whether feedback comments are included 

7. In Grade Items To Be Included lists you can, if required, omit particular Activities from the report 

8. When you've finished with the settings, click on Submit; a preview of your export displays 

9. Click on Download to export to the format you chose, and save the file. 

 To download the original student submissions: 

1. In your course area, click the link to the Assignment whose submissions you want to download. 

2. Click on the link to View/Grade all submissions; the Grading Table will load. 

3. Click the link to 'Download all submissions' (either from the Choose menu or from the Settings block), and save 

the file. 

 2.3.4 Chat module 

 The chat activity module allows participants to have a real-time synchronous discussion in a Moodle course. 

 

 This is a useful way to get a different understanding of each other and the topic being discussed – the mode of 

using a chat room is quite different from the asynchronous forums. The Chat module contains a number of features for 

managing and reviewing chat discussions. 

 2.3.5 Chat settings 

 Adding a Chat to your course 

 With the editing turned on,in the section you wish to add your chat, click the "Add an activity or resource" 

link (or, if not present, the "Add an activity" drop down menu )and choose Chat All settings may expanded 

by clicking the "Expand all" link top right. 
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General 

 

 Name of this chat room 

 Whatever you type here will form the link learners click on to enter the chat so it is helpful to give it a name 

that suggests its purpose - for example "Student council discussion" or "Field trip planning meeting". 

 Description 

 Type the description of the chat here. Include precise instructions for students regarding the subject of the chat. 

Click the icon on the left to expand the toolbar, and drag the bottom right of the text box out to expand it. 

 Display description on course page 

 If this box is ticked, the description will appear on the course page just below the name of the Chat. 

 Chat sessions 

 (These settings are collapsed by default.) 
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 Next chat time 

 The day and hour of the next chat session. This will appear in the calendar so students know the schedule 

but it doesn't stop them accessing the chatroom at any other time. 

 If you don't want them in the chatroom at other times, then hide it (with the eye icon) or use Conditional 

activities to restrict access. 

 If you don't wish to schedule chat times then ignore this and choose from the next settings. 

 Note: For courses involving users across different time zones, it is useful to know that the time you set here will 

be adjusted to match the time zone of the user viewing it. 

 Repeat/publish sessions 

 There are four options for scheduling future chat sessions: 

1. Don't publish any chat times- there are no set times and students are welcome to chat at any time. 

2. No repeats - publish the specified time only- only the Next chat time will be published. This could be used 

to schedule special events or meetings or simply to help learners identify a common time in which they can 

expect to find other learners in the chat room. 

3. At the same time every day- Daily chats are useful for scheduling daily office hours or work sessions with 

learners. 

4. At the same time every week--This setting will schedule a chat for the same day and time every week, 

which could be useful for instance for meeting and reviewing key ideas and questions related to the week’s 

content/assessment. 

 Save past chat sessions 

 Choose from the dropdown how many days to save - or save everything by selecting Never delete messages 

 If you have any concerns about discussions that might take place in your chat room, you may want to keep 

transcripts to check the suitablility of what is discussed. If your learners are using the chatroom to collaborate on a 

group project you won't want to delete the messages until the project is complete. 

 Everyone can view past sessions 

 Decide here whether or not allow everyone to view past chat sessions. (Teachers can always view past sessions) 

 Common module settings 

 (These settings are collapsed by default.) 

 On the settings page for many modules, there is a section called "Common module settings". This refers to 

settings that are common to many modules. 

 Restrict access/Activity completion 

 (These settings are collapsed by default) 

 These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

 Locally assigned roles 

 In Administration > Chat administration > Locally assigned roles selected users can be given additional roles 

in the activity, such as the capability to delete chat logs. 

 Role permissions for the activity can be changed in Administration > Chat administration > Permissions. 
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 2.3.6 Using Chat 

 Entering the chat 

 

 As you click the chat link on the course page you see two or three options: 

 Click here to enter the chat now - this takes you to the chat using the chosen site default chat method. 

 Use more accessible interface - this gives a simpler chat room without frames and javascript: 

 

 View past sessions - if this has been enabled and the user is allowed to view past chat sessions, this 

takes them to a list of past sessions with links to the chat. 

 Joining in a chat session 

 In normal view, the screen is in two parts with the participants on the right, the messages on the left and a box 

at the bottom into which users type their message and press "Send" to make their contribution: 
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 Users can change the appearance of the messages by clicking on "Themes" next to the "Send" button. 

Bubbles appears thus: 

 

 The chat module contains some features to make chatting a little nicer. 

 Smilies - Any smiley faces (emoticons) that you can type elsewhere in Moodle can also be typed in here 

and they will be displayed correctly. 

 Links - Internet addresses will be turned into links automatically. 

 Emoting - You can start a line with /me to emote. For example, if your name is Kim and you type /me 

laughs! then everyone will see "Kim laughs!" 

 Beeps - You can send a sound to other people by hitting the "beep" link next to their name. A useful 

shortcut to beep all the people in the chat at once is to type "beep all". 

 HTML - If you know some HTML code, you can use it in your text to do things like insert images, play 

sounds or create different coloured and sized text. 

 Chat reports 

 To view previous chats (if you have permission) click on the 'View past chat sessions' link. Teachers can also 

access past chat sessions from the Chat administration in the Settings block. 
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 This will bring up a listing of each chat session under the current chat topic. The listings include the time the 

chat started and ended, which users participated, and how many messages each user sent. 

 In order for students to see past sessions, the teacher or an administrator must setup the chat to allow 

everyone to view past chat sessions.  

 Why use chat? 

 Chat has an advantage over a Forum in that it takes place in Real Time. It is especially beneficial when the group 

chatting is not able to meet face to face. Examples might be: 

 Regular meetings of staff on large or split campuses to discuss student or curriculum issues; 

 Regular meetings of students doing online courses to enable them to share experiences with others on 

the same course but potentially in a different city (or country) 

 A teacher working with his students even though he is out of school 

 A student temporarily unable to attend in person chatting with their tutor to catch up with work. 

 Students out on work experience getting together to discuss their experiences with each other and their 

tutor 

 Younger children using chat at home in the evenings as a controlled(monitored) introduction to the 

world of social networking 

 Why NOT use chat? 

 Unless a tutor/moderator is permanently present in the chatroom -or unless the chat is hidden and revealed at 

certain times, it is difficult to control what is said once a chat has started. 

 Younger students particularly may find it difficult to stay on task and be prone to adding non-useful comments 

or "beeping" others for the sake of it. 

 In some situations, a forum might be preferred as it allows for reflection before posting and gives a period of 

time where the post might be edited. 
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 2.3.7 Choice module 

 A choice activity is very simple – the teacher asks a question and specifies a choice of multiple responses. It can 

be useful as a quick poll to stimulate thinking about a topic; to allow the class to vote on a direction for the course; or to 

gather research consent. 

 

 Choice requires some preparation time for creating your activity and thinking about what results you would like 

to achieve, but your participation with activity itself is likely to be minimal. 

 2.3.8 Choice settings 

 Choice administration settings 

 With the editing turned on, choose from the"Add an activity or resource" link (or, if not present, the "Add an 

activity" drop down menu) the option Choice. To see all the settings expanded, click "Expand all" top right. 

 General 
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 Choice name 

 A short name of the choice (e.g. "Favourite colour"). This will be displayed on the course's homepage. 

 Description 

 Type the description of the choice activity here. Click the icon on the left to expand the toolbars and drag the 

bottom right of the text box out to expand it. It should contain the question that you want your students to answer. An 

example of the choice text could be "What is your favourite colour?" There is also an option to display the choice 

description on the course page below the link to the activity. 

 Display mode for the options 

Choose "horizontally" if you only have three or four choices maximum; choose "vertically if you have a large number of 

choices. 
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 Options 

 

 Allow choice to be updated 

If this is set to "Yes", students can change their mind after they have voted. If it's set to "No", students cannot change 

their choice. 

 Allow more than one choice to be selected 

If this is set to 'Yes' then users may select more than one choice. The checkboxes display differently according to 

whether this is set to 'Yes' or 'No': 

 



 

                                                                                                                                            
117 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 

 Limit the number of responses 

 Enabling this option allows you to limit the number of participants who can select each particular choice. When 

that number has been reached, no one else can select that choice. 

 Warning!! If you unintentionally check this box but don't add a number then your students won't be able to 

select any choices and will get confused. 

 Option 

 Specify here the options that participants have to choose from. They will become radio buttons when the 

choice is saved. 

 You can leave other options blank or click "Add 3 fields to form" to add more options. 

 If Limits is disabled, then any number of participants can select any of the options. 
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Availability 

(These settings are collapsed by default) 

 

 Restrict answering 

 If you check this box you can set an "open and close" date for your choice. 

 If you leave it, they can respond at any time. 

 Results 

 (These settings are collapsed by default) 

 

 Publish results 

 This determines whether (and when) the students will be able to view the results of the choice activity. They 

may: 

 never see the results of the choice 

 see the results only after they have given the answer themselves 
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 see the results only after the closing date of the choice 

 always see the results 

 Privacy of results 

 If "Publish" was chosen above, then this dropdown in unlocked. You can decide whether to show names of 

students or merely the number who responded but without names. 

 Show column for unanswered 

 If set to "Yes", this will display a column showing how many participants have not answered the choice activity 

yet. If set to "No", the results will only include the participants who have already voted. 

 Restrict access/Activity completion 

 (These settings are collapsed by default) 

 These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

 2.3.9 Using Choice 

 What the student sees 

 When a teacher has created a Choice activity, the student is presented with a number of radio buttons. 

They click one to make their selection. 

 Depending on the teacher's settings, the student may then be able to see the results either anonymously or 

with names (via the "View xxx responses" link) or not see anything. 

 

 What the teacher sees 

 Regardless of how it's been set for students, a teacher will always see user names and choices, via the "View 

xxx responses" link. 

 The teacher is also able to delete selected choices or download them in various formats as in the screenshot 

below: 
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 2.3.10 Database activity module 

 The database activity module allows the teacher and/or students to build, display and search a bank of record 

entries about any conceivable topic. The format and structure of these entries can be almost unlimited, including 

images, files, URLs, numbers and text amongst other things. 
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 2.3.11 Database activity settings 

 Adding a database activity 

 To add a database activity: 

1. With the editing turned on,in the section you wish to add your database, click the "Add an activity or 

resource" link (or, if not present, the "Add an activity" drop down menu )and choose Database All settings 

may expanded by clicking the "Expand all" link top right. 

2. Give your new database a name and a description. 

3. Select your options (see below). 

4. Click the "Save and display" button at the bottom of the page. 

5. Define the fields or use a preset. 

6. Define the templates. 

7. Add one or two same entries then edit the templates as appropriate. 

 General 

 

 Name 

 Choose a helpful name as this will form the link students will click on to access your database. 

 Description 

 Type the description of the database here. Click the icon on the left to expand the toolbar to three lines. 

 Display description on course page 

 If this box is ticked, the description will appear on the course page just below the name of the Database. 

 Entries 

 (These settings are collapsed by default.) 
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 Approval required? 

 If set to "yes", the entry will only be visible once a teacher has checked and approved it. 

 Allow comments on entries 

 If set to "yes", users will be able to comment on database entries. 

 Entries required for completion 

 Select here how many entries you wish the student to add before the activity can be considered "complete". 

 Entries required for viewing 

 Select here how many entries you wish the student to add before they are allowed to see entries by other 

people. Note: If entries are required before viewing, the database auto-linking filter should be disabled. This is because 

the database auto-linking filter can't determine whether a user has submitted the required number of entries. 

 Maxiumum number of entries 

 Select here the maximum number of entries you wish students to make. 

 Availability 

 (These settings are collapsed by default.) 
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 Available from/to 

 Select here when you want the database to be visible to students. 

 Read only from/to 

 If you wish, select here the dates you want students to be able to see entries in the database but not be able to 

add their own. For example you could make a database 'available from' January 1st until March 1st, but 'read only' from 

January 1st to February 1st. This means students can only view entries for a month before being able to add their own. 

 The 'available from/to' settings override the 'read only from/to' settings. So if a database has 'read only' from 

1st January, and "available from" 1st February, students will not be able to view its content during January. 

 Note that it's possible to select a precise time as well as date for these availability settings. 

 Grade 

 (This setting is collapsed by default) Choose the category in which this database will appear if ratings are 

enabled. 

 Ratings 

 (These settings are collapsed by default) 

 Roles with permissions to rate 

 Database entries can be rated using a scale. By default, only teachers can rate database entries, though students 

can be given permission to do so if desired from Administration>Database administration. This is a useful tool for giving 

students participation grades. Any ratings given are recorded in the gradebook. 

 

 

 Restrict access/Activity completion 

 (These settings are collapsed by default) 

 These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

 2.3.12 Building Database 

 After creating a database 
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 Next you define the kind of fields that define the information you wish to collect. For example a database of 

famous paintings may have a picture field called painting, for uploading an image file showing the painting, 

and two text fields called artist and title for the name of the artist and the painting.  

 It is then optional to edit the database templates to alter the way in which the database displays entries. 

 Database fields 

 A field is a named unit of information. Each entry in a database activity module can have multiple fields of 

multiple types e.g. a text field called 'favourite color' which allows you to type in your favourite shade, or a menu called 

'state' that lets you choose one from a list of the 50 that make up the United States of America. By combining several 

fields with appropriate names and types you should be able to capture all the relevant information about the items in 

your database. 

 Note that if you later edit the fields in the databases you must use the Reset template button, or manually edit 

the template, to ensure the new fields are added to the display. 

 Field name and description 

 The name is what is shown when an entry is added. It must be unique and short. The description is for your 

benefit to help identify that field. 

 Field types 

 The following screenshots show "before" and "afters" of setting up fields. The selection in orange shows the 

field as it is displayed for the user when they add an entry. 

 Checkbox - This allows you to offer checkboxes for the user to select. Add the options one under the other. 

The word will appear next to a checkbox when the user clicks to add an entry. They can check more than 

one box. 

 

 Date - This allows a user to enter a date by picking a day, month and year from a drop down list. 
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 File - Users can upload a file from their computer. If it is an image file then the picture field may be a better 

choice. 

 

 Menu - The text entered in the options area will be presented as a drop-down list for the user to choose 

from. Each line become a different option. 

 

 Menu (Multi-select) - The text entered in the options area will be presented as a list for the user to choose 

from and each line become a different option. By holding down control or shift as they click, users will be 

able to select multiple options. This is a fairly advanced computer skill so it may be wise to use multiple 

checkboxes instead. 
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 Number - This allows users to enter any number.  

 

 Picture - This allows a user to upload and display an image file. "Single view" is when the image is viewed on 

its own; "list view" is when it is viewed in with other images. Single view can be larger than list view. 
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 Radio buttons - The user gets radio buttons and can choose only one. They can only submit the entry when 

they have clicked on one button. (Note:If you only have two options and they are opposites (true/false, 

yes/no) then you could simply use a single checkbox instead. However checkboxes default to their 

unchecked status and so people could submit without actively selecting one of the options. This may not 

always be appropriate.) 

 

 Text input - Users can enter text up to 60 characters in length. For longer text, or for text that requires 

formatting such as headers and bullet points, you can use a text area field. 
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 Text area - This allows users to enter a long piece of text using the text editor. 

 

 

 URL - The user can add a link to a website here. If you select autolink then the URL becomes clickable.. If you 

also enter a forced name for the link then that text will be used for the hyperlink. For example in a database 

of authors you may wish people to enter the author's website. If you enter the text 'homepage' as a forced 

name then clicking on text "homepage" will take you to the entered URL. You can choose to have the URL 

open in a new window if so desired. 
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 2.3.13 Using Database 

 Views 

 View list 

 The list view shows multiple entries, possibly in a more abbreviated form to ensure all the information fits. You 

may use the controls at the bottom of the screen to search and sort the contents. 

 View single: one item at a time 

 View list : several items at a time (number is user defined) 

 Add entry : add an item to the database 

 Search  : search the entries 
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 View single 

 Alternatively, you may view only one entry at a time. This might allow you to view more detailed information 

than the list view. 

 Add comment 

 If comments have been enabled, you may add a comment. 

 Rate entries 

 If ratings have been enabled, and made viewable, by the database editor, you may grade other database 

entries, and view these ratings. 

 Adding an entry 

 Go to the "Add entry" tab and fill in the form. 

 Deleting multiple entries 

 In List view, a checkbox will appear next to each entry. Select the entries you wish to delete and click the 'Delete 

selected' button. Alternatively, click the 'Select all' and the 'Delete all' buttons to delete all entries. A warning message 

will appear asking you to verify what you wish to delete. 

 Approving and undoing approval of entries 

 If, during database set up, 'Approval required' was set to 'Yes' then a teacher can approve an entry by clicking on 

the tick/checkmark icon. 

 Once an entry has been approved, it is possible to undo the approval by clicking the circle with a line through it 

icon. 
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 Creative uses 

 You could use the database module to: 

 allow collaboration on building a collection of web links/books/journal references related to a particular 

subject 

 display student created photos/posters/websites/poems for peer comment and review 

 gather comments and votes on a shortlist of potential logos/mascot names/project ideas 

 provide a student file storage area 

 maintain a log of what was done in a face-to-face class each day, so that absent students can get caught up 

themselves. 

 2.3.14 Forum module 

 The forum module is an activity where students and teachers can exchange ideas by posting comments. There 

are four basic forum types. Forum posts can be graded by the teacher or other students. 
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 A forum can contribute significantly to successful communication and community building in an online 

environment. You can use forums for many innovative purposes in educational settings, but teaching forums and 

student forums are arguably the two more significant distinctions. 

 2.3.15 Forum settings 

 Adding and editing a forum 

1. With the editing turned on, in the section you wish to add your forum, click the "Add an activity or 

resource" link (or, if not present, the "Add an activity" drop down menu )and choose Forum. 

2. This will take you to the forum settings page titled "Adding a new forum". 

 You can access an existing forum by clicking the configure icon or clicking on the forum and then Administration 

> Forum administration > Edit settings. 

General 

 

 Forum name 

 A short name of the forum (e.g. "Favourite colour"), which will be displayed on the course homepage. 

 Description 

 Provide instructions for your students here so they are clear what they have to do. Click the icon top left to 

expand the toolbars drag the bottom right of the text box out to expand it. 

 Display description on course page 

Enabling this will display the description on the course page just below the link to the forum. 

 Forum type 

 There are five forum types to choose from: 

 A single simple discussion - A single topic discussion developed on one page, which is useful for short 

focused discussions (cannot be used with separate groups) 

 Standard forum for general use - An open forum where anyone can start a new topic at any time; this is the 

best general-purpose forum 
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 Each person posts one discussion - Each person can post exactly one new discussion topic (everyone can 

reply to them though); this is useful when you want each student to start a discussion about, say, their 

reflections on the week's topic, and everyone else responds to these 

 Q and A Forum - Instead of initiating discussions participants pose a question in the initial post of a 

discussion. Students may reply with an answer, but they will not see the replies of other Students to the 

question in that discussion until they have themselves replied to the same discussion. 

 Standard forum displayed in a blog-like format 

 News forum 

 The News forum is a special forum for general announcements. A course may only have one News forum unless 

it has been imported from another system which supports more than one news forum.  

 This forum is automatically created for each course and for the front page of the Moodle site. By default, it is 

placed in the top of the center section and only teachers and administrators may add posts or reply to posts. Thedefault 

settings force every enrolled person to be subscribed to the News forum. 

 The Latest News block displays a specific number of recent discussions from the News forum. 

 The news forum may be removed from a course as follows: 

1. Delete the news forum from the course homepage 

2. In Course settings set "News items to show" to 0 

3. Delete the Latest news block 

4. Alternatively - hide the news forum 

 Attachments and word count 

 (This setting is collapsed by default) 

 

 Maximum attachment size 

 The maximum file size that may be attached to a forum post will first be determined by the Moodle site settings. 

The teacher may want a smaller size limit for the forum. Server file capacity, student downloading speeds and 

discouraging images in a document centered discussion are a few reasons to limit file size. 
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 Maximum number of attachments 

 The maximum number of attachments a user can add to their forum post (from 0 to 100) can be specified here. 

 Display word count 

 If "Display word count" is enabled, then the number of words in forum posts will be shown at the bottom of 

each post. 

 Subscription and tracking 

 (This setting is collapsed by default) 

 

 Subscription mode 

 When a user is subscribed to a forum it means that they will receive notification (via popup and/or email, 

depending on the user’s messaging settings preferences) of each new posting. By default, posts are recorded about 30 

minutes after the post was first written. Depending upon the email settings of each forum member, they may be sent an 

email immediately after the 30 minute edit window is closed, or in a batch at a time fixed by the site administrator (see 

below). 

 People can usually choose whether or not they want to be subscribed to each forum. However, the teacher can 

choose to force subscription on a particular forum then all course users will be subscribed automatically, even those 

that enrol at a later time. 

 There are 4 subscription mode options: 

 Optional subscription - Participants can choose whether to be subscribed 

 Forced subscription - Everyone is subscribed and cannot unsubscribe 

 Auto subscription - Everyone is subscribed initially but can choose to unsubscribe at any time 

 Subscription disabled - Subscriptions are not allowed. 

 The subscription mode and subscribe or unsubscribe links appear in Navigation>Forum administration when 

viewing the forum. Teachers can quickly change the mode via the 'Subscription mode' options and view the current 

subscribers via the 'Show/edit current subscribers' link. 

 Tips: 

 Forcing everyone to subscribe is especially useful in the news forum and in forums towards the beginning of 

the course (before everyone has worked out that they can subscribe to these emails themselves). 
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 Changing the setting from "Yes, initially" to "No" will not unsubscribe existing users; it will only affect those 

who enrol in the course in the future. Similarly changing "Yes, initially" will not subscribe existing course 

users but only those enrolling later. 

 There is also a "Subscriptions not allowed" setting which prevents Students from subscribing to a Forum. 

Teachers may choose to subscribe to a forum if they wish. 

 Subscribe to individual forum discussions 

 In a forum with optional or auto subscription you can choose which discussions to subscribe to by clicking the 

'dot' icon to the right of the discussion. An envelope tells you are already subscribed. 

 

 Read tracking for this forum? 

 "Read tracking" for a forum allows users to track read and unread forum posts. 

 

 There are three options for this setting: 

 Optional - Students can turn tracking on or off for the forum via a link 'Track / Don't track unread posts' 

inAdministration > Forum administration, or via their profile 'Forum Tracking' option. 

 Off - It is not possible to track unread forum posts 

 Forced - Tracking is always on in this forum, regardless of user preference or setting. No link in is present in 

Administration > Forum administration. This setting is only available when the 'Allow forced read tracking' 

administrative setting is enabled. 
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 Post threshold for blocking 

 (This setting is collapsed by default) 

 

 Time period for blocking 

 Choose here the time period in which can be blocked from posting more than a given number of posts. (To 

make a user exempt, give them the capability mod/forum:postwithoutthrottling) 

 Post threshold for blocking 

 Set the number of posts here that users may add before they are blocked. 

 Post threshold for warning 

 Set the number of posts here after which users will be warned they are about to be blocked. 

 Grade 

 (This setting is collapsed by default)  

 Choose the category in which this forum will appear if ratings are enabled. 

 Ratings 

 (This setting is collapsed by default) 

 

 Roles with permissions to rate 

 Forum posts can be rated using a scale. By default, only teachers can rate forum posts, though students can be 

given permission to do so if desired (see Forum permissions below). This is a useful tool for giving students participation 

grades. Any ratings given in the forum are recorded in the gradebook. 
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 Aggregate type 

 You can set an aggregate type, in other words, decide how all the ratings given to posts in a forum are combined 

to form the final grade (for each post and for the whole forum activity).See Ratings for an explanation of aggregate 

types and which one is best for you. 

 Restrict ratings to items with dates in this range 

 The teacher can allow only posts within a certain date range to be rated. This is useful if the teacher wants to 

keep students focused on the most recent content and maintain a specific pace within the forum or course. 

 Common module settings 

 (These settings are collapsed by default) 

 

 See Common module settings for more information, but note the details below relating specifically to use of 

forums with groups. 

 Group mode 

 The group mode setting has three options: 

1. No groups 

2. Separate groups - each group can only see their own group; others are invisible 

3. Visible groups - each group works in their own group, but can also see other groups 

 If the group mode is set to separate groups: 

 

 Teachers are given the option of adding a new discussion topic for all participants or for a selected group. If 

a teacher adds a new discussion topic for a selected group, then only group members can reply to it. If a 

teacher adds a new discussion topic for all participants, then students can't reply to it. (This is to ensure that 

groups are kept separate.) 

 Students can only start discussions for their own group. 

 Students can only reply to discussions started by other group members or discussions for their own group 

started by a teacher. 
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 If the group mode is set to visible groups: 

 Teachers are given the option of adding a new discussion topic for all participants or for a selected group. If 

a teacher adds a new discussion topic for a selected group, then only group members can reply to it. 

 Students can only start discussions for their own group. 

 Students can only reply to discussions started by other group members or teachers. 

 Teachers, and other users with the capability moodle/site:accessallgroups set to allow, can view and post in all 

forum discussions, regardless of the group mode setting. 

 Note: Single simple discussions cannot be set to separate groups (as this feature is not implemented). Instead, a 

standard forum should be used, with the teacher copying and pasting the same discussion topic for each separate 

group. If required, a permissions override may be set to prevent students from starting new discussions. 

 Restrict access/Activity completion 

 (These settings are collapsed by default) 

 These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

 Locally assigned roles 

 In Administration > Forum administration > Locally assigned roles selected users can be given additional roles in 

the activity. 

 Forum moderator 

 A student can be given the rights to moderate a forum by assigning them the role of non-editing teacher in the 

forum. 

1. In Settings > Forum administration > Locally assigned roles click on student 

2. Select the student from the potential users list on the right, and use the Add button to add them to the 

existing users list on the left. Multiple users may be selected by holding down the Apple or Ctrl key whilst 

clicking on the users' names. 

 Forum permissions 

 Role permissions for the activity can be changed in Administration > Forum administration > Permissions. 

 Common permissions changes include: 

 Enabling students to rate posts 

 Click the Allow icon (+) opposite the capability to rate posts and allow the role of student. 

 Archiving a forum 

 A forum can be closed / archived so that students may no longer start new discussions, nor add replies, but can 

still read all the discussions by clicking the Prevent icon (X) for the student role for the capabilities 'Start new 

discussions' and 'Reply to posts'. 

 Guests and posting in a forum 

 There are certain things, such as posting in a forum, that guests are never allowed to do, despite the 

permissions interface suggesting otherwise. 
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 The guest role has some special functionality, for example when a guest user attempts to post in a forum, they 

obtain the message "Sorry, guests are not allowed to post. Would you like to log in now with a full user account?" 

 (Note: If guests don't obtain the "Sorry, guests are not allowed to post" message because they have no reply 

link, then self enrolment needs enabling in Settings > Course administration > Users > Enrolment methods.) 

 If you wish guests to be able to post in a forum, you can use the Forum poster role. 

 User administration settings 

 Users can choose whether or not to track unread posts in their profile settings under 'Forum tracking'. The 

settings are: 

 Yes: highlight new posts for me 

 No: don't keep track of posts I have seen 

 If the user chooses 'Yes: highlight new posts for me' and the forum administrator has set the 'Read tracking for 

this forum?' to On or Optional then the user will have new posts highlighted for them. 

 

 The posts will be highlighted in the following places: 

 My home page 

 Course page 

 Within the forum itself 

 In forum discussion threads 

 

 2.3.16 Using Forum 

 The teacher can set the format of what the student sees under the introduction by selecting the forum type in 

Forum settings. 

 Views 

 A single simple discussion 

Students will see the text you have placed in the Forum introduction setting as the first post of the discussion. Below 

you will find the replies that have been posted. In the example below, the student sees that their reply was rated. 
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 The view will be basically the same as in the previous case, the only difference being the 'Add a new discussion' 

option. Viewing a forum page, the student will see the text you have written at the 'Forum introduction' space while 

creating the forum, and, if there are any, the discussions that have been started.  

 

 Standard forum for general use 

 In this forum type, students will see the introduction text in a separate space above the discussion field, in 

which you will see the information such as the title of the discussion (which means the forum's title), its author, the 

number of replies and the date of the last post. 
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 Question and Answer forum 

 The Q & A forum is best used when you have a particular question that you wish to have answered. In a Q and A 

forum, teachers post the question and students respond with possible answers. By default a Q and A forum requires 

students to post once before viewing other students' postings.  

 

 

 

 Standard forum displayed in blog-like format 

 

 In the upper right corner of the home forum screen (above the introduction), the student may see the options 

the teacher has set for subscriptions to the forum, and the 'Jump to' field, with which you can 'jump' to any part of the 

course. This is also place where the teacher will find the "Update this forum" button. 
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 2.3.17 Display options 

 A discussion thread may be displayed in four ways. Use the pull down menu at the top of each forum discussion 

to select a display type. 

 Display replies flat, with oldest first 

 Display replies flat, with newest first - The discussion will be displayed in one line and the chronological 

order from the newest to the oldest. This is the same as the above, just a different sort order. 

 Display replies in threaded form - Only the post starting the discussion will be displayed in its full form; 

replies will be reduced to the headlines (including information about its author and date of release) and 

organized chronologically; moreover, replies will be shifted towards the right so that only replies to the 

same post were in the same line. 

 Display replies in nested form - All posts are displayed in their full forms; replies will be reduced to the 

headlines (including information about its author and date of release) and organized chronologically; 

moreover, replies will be shifted towards the right so that only replies to the same post were in the same 

line. 

                         

 

 Forum posting 

 The default content of Subject is usually 'Re: <the name of the 'parent' post>'. You can change it though. 

 When writing text in Moodle there are several formats you can choose to produce your text, depending on your 

expertise and the type of browser you are using.  

 Sharing images through forums 

 When an image is "attached" as a file to a forum message, it is immediately displayed full size after the 

message (i.e. no need to click on an attachment). This an excellent way of sharing images without having to 

go through the process of uploading them as files and linking them from within web pages. 
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 Images may be dragged and dropped into the box as well as uploading via the "add" link and the File picker. 

 

 Sharing sound and video through forums 

 If multimedia filters are enabled, a sound file (mp3) or accepted video file can be attached and it will be 

embedded into the forum post in an appropriate player. 

 As with images in the previous section, multimedia files may be dragged and dropped from the desktop 

instead of uploaded via the File picker. 

 Post length 

 Extra-long posts cause problems when doing a forum search and can be difficult to read on screen. Rather than 

creating a very long post, consider copying and pasting the text into a text file and add it as an attachment to your 

forum post. 

 Post editing time limit 

There is a time limit for editing posts, usually 30 minutes. It is set by an administrator in Administration > Security > Site 

policies. 

 Mail now 

 A mail now checkbox is available for anyone with the capability to manage course activities, normally teachers 

and admins. 

 Checking the "Mail now" box results in a notification being sent immediately  to everyone subscribed to the 

forum, rather than after the post editing time limit. 
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 Note: For users who have enabled email digests in their profile, the notification is NOT sent separately from 

other forum post notifications. 

 Reply to posts via email 

 If enabled by an administrator you can reply to forum posts via email. 

1. Click the Reply by email link in the email. 

 You will see a special unique email address to send your reply to. 

2. Reply using the email address provided. IMPORTANT: Make sure you remove the original email content so that 

your forum post does not contain the quoted text. 

3. You should receive an email saying your reply has been successfully posted. 

4. Your post now appears in the forum. 
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 Moving between forum threads 

 Links top and bottom left and right (where applicable) take you to the previous and next forum discussion in a 

list: 

 

 2.3.18 Glossary module 

 The glossary activity module allows participants to create and maintain a list of definitions, like a dictionary. 

 Glossary can be used in many ways. The entries can be searched or browsed in different formats. A glossary can 

be a collaborative activity or be restricted to entries made by the teacher. Entries can be put in categories. The auto-

linking feature will highlight any word in the course which is located in the glossary. 
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 2.3.19 Glossary settings 

 Adding a glossary 

 To add a glossary: 

 With the editing turned on, in the section you wish to add your glossary, click the "Add an activity or resource" 

link (or, if not present, the "Add an activity" drop down menu ) and choose Glossary. All settings may expanded by 

clicking the "Expand all" link top right. 
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 General 

 

 Name 

 Give your new glossary a descriptive name. 

 Description 

 Describe the purpose of the glossary and provide instructions or background information, links etc. Click the 

icon top left to expand the toolbars, and drag the bottom right of the text box out to expand it. 

 Display description on course page 

If this box is ticked, the description will appear on the course page just below the name of the glossary. 

 Is this glossary global? 

 Administrators can make a global glossary, with entries linking throughout the whole Moodle site. Any course 

may contain a global glossary, though the best practice is to place a global glossary on the site front page. 

 Glossary type 

 Here you can decide whether the glossary will be main or secondary. The glossary system allows you to export 

entries from any secondary glossary to the main one of the course. In order to do this, you should specify which glossary 

is the main one. You can only have one main glossary per course. 

 

 

 

 

 



 

                                                                                                                                            
148 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 Entries 

 (These settings are collapsed by default) 

 

 Approved by default 

 If set to "yes" then new entries appear automatically. If not, then the teacher must approve each one first. 

 Always allow editing 

 If set to "yes", students can edit their entries at any time. If not, then they can only edit for a certain period (as 

defined in Site policies). 

 Duplicate entries allowed 

 This allows the entry of more than one definition for a given word. 

 Allow comments on entries 

 Students and teachers can leave comments on glossary definitions. The comments are available through a link 

at the bottom of the definition. 

 Automatically link glossary entries 

 If the Glossary auto-linking filter is enabled by an administrator (see Filters for further details), then turning this 

on allows individual entries in this glossary to be automatically linked whenever the concept words and phrases appear 

throughout the rest of the same course. This includes forum postings, internal resources, week summaries and so on. 

 

 Note: Enabling linking for the glossary does not automatically turn on linking for each entry - linking needs to be 

set for each entry individually. If you do not want particular text to be linked (in a forum posting, say) then you should 

add <nolink> and </nolink> tags around the text. Note that category names are also linked. 
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 Appearance 

 (These settings are collapsed by default) 

 

 Display format 

 That specifies the way that each entry will be shown within the glossary. The default formats are: 

 Simple, dictionary style - This looks like a conventional dictionary with separate entries. No authors are 

displayed and attachments are shown as links. 

 Continuous without author - Like the simple style. Shows the entries one after other without any kind of 

separation but the editing icons, but only if your theme supports it, you usually have to modify the theme if 

you want an alternative appearance to the simple setting. 

 Full with author - A forum-like display format showing author's data. Attachments are shown as links. 

 Full without author - A forum-like display format that does not show author's data. Attachments are shown 

as links. 

 Encyclopedia - Like 'Full with author' but attached images are shown inline. 

 Entry list - This lists the concepts as links. 

 FAQ - Useful for displaying lists of frequently asked questions. It automatically appends the words 

QUESTION and ANSWER in the concept and definition respectively. 

 Approval display format 

 It is possible to set an alternative display format for when entries are approved that can differ from the display 

format on the course page. This could be useful for instance if a tutor wants to see who made a particular glossary entry 

before approving it but doesn't want the students' name to be displayed for others on the course page. 

 Entries shown per page 

 Decide here how many entries to show per page. 

 Show alphabet links 

 If set to "yes", users can browse the glossary by letters of the alphabet. 
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 Show 'ALL' link 

 If set to "yes", users can browse all the entries at once 

 Show 'Special' link 

 If set to "yes", users can can browse the glossary by special characters, such as @ and #. 

Allow print view 

This provides a printer-friendly version link for students. (Teachers are always provided with a printer-friendly 

version link.) 

Grade 

(This setting is collapsed by default) Choose the category in which this glossary will appear if ratings are enabled. 

Ratings 

(This setting is collapsed by default) 

 

 Roles with permissions to rate 

 Glossary entries can be rated using a scale. By default, only teachers can rate glossary entries, though students 

can be given permission to do so if desired from Administration>Glossary administration. This is a useful tool for giving 

students participation grades. Any ratings given are recorded in the gradebook. 

Restrict access/Activity completion 

(These settings are collapsed by default) 

 The Restrict access and Activity completion settings are visible if Conditional activities and Activity 

completionhave been enabled in the site and the course. 

Glossary permissions 

Role permissions for the activity can be changed in Settings > Glossary administration > Permissions. 

2.3.20 Using Glossary 

Adding a glossary entry 

 To add a glossary entry: 

 When you first create a glossary, click "Save and display" to be taken to the "Add a new entry" screen. 



 

                                                                                                                                            
151 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 Alternatively,click on the glossary link and click the "Add a new entry" button in the centre of the screen or 

the Administration block. 

 

 Enter the word you want to define in the Concept text field. 

 Add the definition of the word or concept. 

 If you want to add an attachment, such as a picture or an article, you can either drag/drop it or click the 

"Add" button to upload via the File picker. 

 

 You can add or edit categories by clicking the "Browse by category" tab: 
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 If there are synonyms you want to include with the entry, add them to the Keyword(s) text area. Enter one 

word per line. 

 Select the auto-linking options (see below) and save the changes. 

 This entry should be automatically linked 

 If site-wide glossary auto-linking has been enabled by an administrator and this is set to "yes", the entry will be 

automatically linked wherever it appears. 

 This entry is case sensitive 

 This setting specifies whether matching exact upper and lower case is necessary when performing automatic 

linking to these entries. For example, if this is turned on, then a word like "html" in a forum posting will NOT be linked to 

a glossary entry called "HTML". 

 Match whole words only 

 If automatic linking is enabled, then turning this setting on will force only whole words to be linked. For 

example, a glossary entry named "construct" will not create a link inside the word "constructivism". 

 Editing glossary entries/Adding categories 

 Categories may be created to help organize your glossary entries. If you've enabled autolinking, the category 

names can be linked along with individual entries. 

 To create a glossary category: 

1. Click the "Browse by category" tab in the main page of the glossary. 

2. Click the "Edit categories" button on the left side of the page. 

3. Click the "Add category" button on the resulting Categories page. 

4. Give the category a name. 

5. Choose whether you want the category name autolinked as well. 

6. Click the "Save changes" button. 

 If you autolink the category name, any occurrence of those words will be linked. When a student clicks on the 

link, they will be taken to the "Browse by category" page of the glossary. 

 Browse options 

 You can browse glossaries according to the following options: 

 Browse by alphabet 

 Browse by category (if there are any categories added) 

 Browse by date (you can sort entries by last update or by creation date) 

 Browse by author 

 

 Search options 

 You can also search for a given word using the Search field. Checking the 'Search full text' option (on the right 

side of the Search box) allows searching for a given word in any position in the text. This can take longer and return 

more entries than you might wish, but it is thorough. If you do not check the "Search full text" box, the search only looks 

for the term names. The index below lets you browse the glossary according to a given letter. 
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 Waiting approval 

 If entries require teacher approval before being publicly posted, the number of entries will appear in a link:  

 

 To approve the teacher clicks the link and then the 'approve' tick/checkmark icon. 

 If an entry is approved by mistake, it can be undone by clicking the 'undo approval' circle with a line through it 

icon. 

 

 Glossary comments 

 If you enabled comments on the glossary entries, users can annotate the definitions in the word list. When you 

look at a word in the glossary list, you'll see a blue "Comments" link in the lower left-hand corner: 

 

 When you click the link, a comments box opens up. Add your comment then click the "Save changes" button. 

 Once you've saved your comment, Moodle will display all of the comments for the entry. When you return to 

the main glossary page, you'll see a new message next to the speech balloon telling you how many comments there are 

for the entry. 

 Turning off links to glossary terms 

 In places such as forum posts and quizzes, terms will be automatically highlighted and linked if they are in the 

glossary. Sometimes, this may be unwanted. To avoid this on a case-by-case basis, click on the blue Filterslink in the 
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activity's Settings block. There you will be able to turn off the glossary auto-linking feature for that particular activity 

while keeping it enabled elsewhere on the course: 

 

 Collaborative glossaries 

 Instead of creating a glossary on your own, why not have the students create them as they encounter unfamiliar 

terms? A collaborative glossary can serve as a focal point for collaboration in a course. Each member of the class could 

be assigned to contribute a term, a definition, or comments on submitted definitions. Multiple definitions can be rated 

by you and by the students, with the highest-rated definitions accepted for the final class glossary. 

 When students are responsible for creating the definitions, they are much more likely to remember the word 

and the correct definition. Engaging in the process of learning, debating, and refining a glossary can go a long way 

toward helping students begin using new terms. 

 You can also structure multiple glossaries over the course of a semester. Break them up by unit, chapter, week, 

or any other organizational structure. 

 If you have a large class, assign student teams to come up with definitions and answers. One strategy for 

managing large courses is to make each team responsible for one week’s worth of definitions, while all the other teams 

must rate and comment. Alternatively, each team could be responsible for one definition per chapter and then rate and 

comment on the other teams’ work. 

 2.3.21 Lesson module 

The lesson module presents a series of HTML pages to the student who is usually asked to make some sort of choice 

underneath the content area. The choice will send them to a specific page in the Lesson. In a Lesson page's simplest 

form, the student can select a continue button at the bottom of the page, which will send them to the next page in the 

Lesson. 
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 There are 2 basic Lesson page types that the student will see: question pages and content pages. There are also 

several advanced navigational pages which can meet more specialized needs of the Teacher. The Lesson module was 

designed to be adaptive and to use a student's choices to create a self directed lesson. 

 The main difference between a Lesson and other activity modules available in Moodle comes from its adaptive 

ability. With this tool, each choice the students makes can show a different teacher response/comment and send the 

student to a different page in the lesson. Thus with planning, the Lesson module can customize the presentation of 

content and questions to each student with no further action required by the teacher. 
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 2.3.22 Lesson settings 

 General 

 

 Name 

 Whatever you type here will form the link learners click on to view the lesson so it is helpful to give it a name 

that suggests its purpose. 

 Description 

 Add a description of your lesson here. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the lesson. 

Appearance 

(These settings are collapsed by default) 

 

 

 

 

 

 

 

 

 



 

                                                                                                                                            
157 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

File pop 

If you want to include a link to a file on the lesson page for students to refer to, upload it here. 

Progress bar 

Choose this to show a bar at the bottom of the page showing how far into the lesson the student has got. 

 For lessons containing only Content pages, once a lesson has been taken to the end, if that same lesson is 

re-taken, the progress bar will not be "reset", i.e. it will show a 100% progress from page 1! 

 For lessons containing Question pages and set to "Re-take" Yes, the progress bar is always "reset" at 0% 

upon re-take. 

 Note that the Lesson Progress bar only works correctly for lessons with a "straightforward" navigation, such 

as page 1 -> page 2 -> page n -> end of lesson. It is not guaranteed to work with pages "jumping all over the 

place". 

 Display ongoing score 

 Choose this to let students see their score as they work through the lesson. 

 Display left menu 

 Choose this if you want to show a list of the pages in the Lesson so a student can see what is coming up. 

 Minimum grade to display menu 

 Choose this if you want the student to go through the lesson once and get a grade before they can (on review) 

see and navigate through all the different pages. 

 Slideshow 

 Slideshow height, width and background colour are set for the whole site by an administrator in Settings > Site 

administration > Plugins > Activity modules > Lesson. 
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 Maximum Number of Answers 

 Here you can set the default number of answer boxes available when you add your question or content pages. 

For instance, if you are only going to use True/False, you would only need 2. You can change this at any time so it's not 

crucial. 

 Use default feedback 

 Choose this if you want to show a set phrase regardless of their answer. If you have set your own default 

feedback such as "well done; correct" or "never mind; better luck next time" etc it will appear. If you have not, then 

Moodle's default feedback will appear. 

 Link to next activity 

 Choose this to give students a link to another activity when they reach the end of the lesson. (Note: this can also 

be achieved using Conditional activities). 

Availability 

(These settings are collapsed by default) 

 

Available from/Deadline 

Here you can set a start and end date and time for your Lesson. 

Time limit 

 This allows you to set a time limit on the lesson. Students will see a countdown counter as they work. The timer 

does not stop them doing the lesson when the time is up, but correct answers are no longer scored. 

 

 Password protected lesson 

 Change to "Yes" and enter the password if you want students only to access it when they know the password. 
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 Prerequisite lesson 

 (These settings are collapsed by default) 

 

 Dependent on 

 This allows access to the lesson to be dependent on students' performance in another lesson in the same 

course. (Note: this can also be achieved with Conditional activities) 

 Time spent 

 Decide here how long you want the student to have spent in the chosen previous lesson 

 Completed 

 Check this box if you want the student to have completed a previous lesson (according to Activity 

completionsettings) 

 Grade better than 

 Enter the grade from the previous lesson which you want the student to have exceeded before they can 

attempt the current lesson. 

 Flow control 

 (These settings are collapsed by default)  
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 Allow Student Review 

 This puts a "Review Lesson" button on the last screen of the lesson to encourage the students to navigate 

through the lesson again from the start. 

Note that the students will not be able to change their answers, only view them. 

 Provide option to try a question again 

 This displays a button after an incorrectly answered question so that the student can try again (but not get 

credit for it) 

 TIP: Leave this off if you are using essay questions.  

 Maximum Number of Attempts 

 Decide here how many times you want students to be able to attempt each question. When they reach the 

maximum, they will be taken automatically to the next page. 

 Action after a Correct Answer 

 Choose here where you want a student to be sent to if they get a question right.  The options are: 

 the next part of the Lesson (default setting) 

 a random, unexpected page 

 a random page which they have not yet answered. 

 Number of pages to show 

 You only need this if you have set "Action after a correct answer" to show an unseen or unanswered page. 

Otherwise, all pages will be seen 

 Grade 

 (These settings are collapsed by default.) 

 

 Set a grade and grade category here. 
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 Practice lesson 

 Use this if you don't need the lesson to be scored/graded but just need students to work through some pages. 

Set this to Yes to have the same ungraded type Lesson in earlier versions of Moodle. 

Custom Scoring 

Use this to give a particular number score (negative or positive) to each answer 

Re-takes allowed 

Choose this if you want your students to be able to do the lesson more than once. 

 Note that this setting only applies to lessons containing Question pages. Lessons consisting only ofContent 

pages can be re-taken even if 'Re-takes allowed' is set to No. 

 Handling of re-take 

 If you allow your students to re-take the lesson, then decide here if the grade for all lesson attempts is the mean 

or the maximum. 

 Note that the Question Analysis always uses the answers from the first tries of the lesson. Re-takes by students 

are ignored. 

 Minimum Number of Questions 

 Set here the minimum number of questions that will be used to calculate a student's score. Students will be told 

how many they have answered and how many more they need to answer. 

 If you are using Content pages, then set this to 0. 

 If you use this setting, then add some explanatory text at the start of the lesson so the student knows how 

many questions they must answer as a minimum. (They may answer more. 

 Restrict access/Activity completion 

 (These settings are collapsed by default) 

 The Restrict access and Activity completion settings are visible if Conditional activities and Activity 

completionhave been enabled in the site and the course. 

 2.3.23 Building Lesson 

 This chapter is about how to structure a Moodle lesson once you have created it with the Lesson settings.  

 Adding content and questions to your lesson 

 When you have set up your lesson with the Lesson settings, click "Save and display" and you will be taken to 

the screen in the screenshot below. 

 If you click "Save and return to course" instead, then click the "update" icon next to the lesson on the page 

and click "edit" in Administration >Lesson Administration 
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 Import questions 

 If you have some questions in the following formats, you can import them to use in your lesson by clicking the 

Import questions link. 

 

 Lesson can only import from a file located on the teachers computer. 

 In edit, using the expanded view 

 Select the position where questions should be inserted into the lesson 
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 Click on the Import question link between the pages. 

 Select the file type 

 Use the browse function to find the file on your computer 

 Import the selected file. 

 

 Add a cluster 

 A cluster is a group of question pages which will be offered randomly to a 

student as they work through the lesson.It is best if you have made the question pages beforehand and can then decide 

where to mark the start and end of the cluster. The start is marked by a "cluster" page and the end by an "end of 

cluster" page. (If you are happy for your learners to see each question page in the same order, then you don't need 

clusters.) 

 Add a content page 

 This is a page where a teacher can provide information to move the lesson forward but without requiring 

the student to answer specific questions. 

 The student sees the page's title, some information and then one or more buttons at the bottom to select. 

 When the student clicks on a button, they go to the next page but their choice is not scored. 

 Page title 

 The title of a content page appears to the student at the top of the page. 

 A teacher will also see the title in the collapsed edit mode when they are working on the Lesson, and they 

will also be able to choose the title (and hence this page) from the drop down "jump" lists. 

 The title in a content page is also used with the "display left menu" setting. 

 Page contents 

 This is where the teacher can add information for the student, making use of the Text editor and its 

multimedia features. 

 Content 

 Here the teacher writes the words they want the student to click on to get to the next part of the lesson. 

 These words will appear to the student as a button. 

 The teacher can check the box to have the buttons appear horizontally, or uncheck it for them to appear 

centered vertically. 

 Format 

 There are 4 format types to choose from when editing text in the content description box. If you wish to 

have the usual rich text editing icons, choose HTML format. (Note - once you have selected an option, you 

cannot then go back and change your mind!) However, if you DO choose HTML format, be warned that the 

student will not see the changes (such as bold or different colours) in the button. 
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 Number of options available 

 How many of these you have depends on your choice in the Maximum Number of Answers setting in Lesson 

settings 

 The Jump 

 Each Description in a Content page has a Jumps menu. "Jumps" take a student from one page to another. 

 A "relative jump" is "next page" or "end of lesson" whereas an "absolute jump" gives the actual name of a 

page. 

 The teacher chooses from the dropdown the correct page to send the student to if they click on the button 

that will be made from this particular description. Any pages created by the teacher will have their titles 

appear in this dropdown, allowing them to be selected. 

 When a student clicks on a description button, they are sent to the page defined in the Jump associated 

with the button. 

 Add a question page 

 From this link you can choose from a variety of question types which will then be added as pages to your lesson: 

 

 

 

 



 

                                                                                                                                            
165 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 (Note: These question types are not the same as the Quiz Question types and are in no way connected with quiz 

questions.) 

 A typical question page could include: 

 Title - the name the student sees at the top of the question page. 

 Page contents - the actual question 

 

 Answer/Response/Jump/Score as in the screenshot below 
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 Moving your lesson forward 

 Once you have added your first content or question page, you reach the next screen which displays your 

page title/type/jumps (ie where the responses take the student to) and actions you can take next: 

 

 The Actions icons allow you to move (if you have more than one), edit, preview or delete your pages. 

 The drop down allows you to create another page of your choice: 
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 Note the different view options: 

 Collapsed view 

 This gives a brief outline of the lesson structure as in the two screenshots above. 

 Expanded view 

 This shows more detail as in the screenshot below: 

 

 Ending your lesson 

 To bring the lesson to a close, select the "End of Lesson" option from the Jump menu on any relevant pages. 

 The student will then see a generic message as in the next screenshot, with a direction back to the main 

course page or to view their grades: 



 

                                                                                                                                            
168 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 2.3.24 Using Lesson 

 This chapter outlines how students and teachers interact with Moodle lessons once they have been created.  

 What the student sees 

 A student clicking on a Lesson will see an introductory page with one or more buttons which they choose 

from to select the path they wish to take. 

 The display may vary according to how the teacher has set up the lesson in Lesson settings. For example; 

there may or may not be a list of pages down the side; there may or may not be an ongoing score. 

 Students progress through the lesson with either content pages (of information, which is not graded) or 

various types of question pages(which may be graded) When a question page is used, the following page 

gives the answer and feedback if offered: 

 

 The lesson is ended when the student has met the criteria set by the teacher. This could be answering a 

certain number of questions correctly, accessing a certain number of pages with content (text, audio or 

video) or following a certain navigational path. A final page appears where the student can check their 

score, if applicable, and return to the main course page. 
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What the teacher sees 

A teacher clicking on a lesson will see tabs at the top offering them the chance to preview, edit, view reports or 

grade essays in the lesson: 

 

Preview 

The lesson opens up in preview mode for the teacher. However, it will not show the score unless the teacher 

switches their role to a student. 

Edit 

The Edit tab allows teachers to alter the lesson once it has been set up. There are two views - Collapsed and 

Expanded.  

Reports 

The reports tab shows the performance of students taking the lesson. There is a general "Overview" and a 

"Detailed Statistics" tab. 

Overview 

 

By clicking on the specific attempt, the teacher can view the student's answers to specific questions. It is also 

possible to delete a student attempt by checking the attempt and using the pull down menu to change "Choose" to 

"Delete". 

 Below the "Overview" can also be seen general statistics: Average score, Average time, High score, Low 

score, High time, Low time. 

 

Detailed Statistics 

More detailed reports on individual questions are available from this tab, as in the following screenshot: 
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Grading lessons 

Note that for a lesson to be graded, it must have at least one question where a student can receive a score and 

the lesson can not be a practice lesson. Grades are calculated when the student has completed a lesson. Grades are 

kept for every student attempt. 

Grading lesson essays 

If a lesson essay question has been included, the teacher can grade it from the Grade essays tab - #1 in the 

screenshot below - or from Lesson administration>Grade essays - #2 in the screenshot below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

                                                                                                                                            
171 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

Completed essays are listed next to the students' names: 
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Ungraded essays are red in colour -#1 in the screenshot below: 

When a teacher clicks on an essay and grades it, the colour changes to a yellow shade - #2 in the screenshot 

below: 

When a teacher clicks 'Email graded essays' to notify the student, the colour changes to a green shade - #3 in 

the screenshot below: 

 

2.3.25 Quiz module 

The Quiz activity module allows the teacher to design and build quizzes consisting of a large variety of Question 

types, including multiple choice, true-false, and short answer questions. These questions are kept in the Question 

bank and can be re-used in different quizzes. 
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2.3.26 Quiz settings 

Creating a new quiz is a two-step process. In the first step, you create the quiz activity and set its options which 

specify the rules for interacting with the quiz. In the second step you add questions to the quiz. This chapter describes 

the options you can set for the quiz activity.  

When you first set up your quiz from Add an activity or resource > Quiz, (or, if you don't have this link, the 

dropdown Add an activity>Quiz) you will get the following settings, (which can also be changed later in the Edit Settings 

link of the Quiz administration settings block) All settings may expanded by clicking the "Expand all" link top right. 

General 

 

Name 

This is the standard name field. This name will appear on the home page of the course, navigation menu and 

other places which will show or provide links to this quiz. 

Description 

Describe the purpose of the glossary and provide instructions or background information, links etc. Click the 

icon top left to expand the toolbars, and drag the bottom right of the text box out to expand it. 

Display description on course page 

If ticked, the quiz description will appear on the course page directly under the quiz name. 
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Timing 

(These settings are collapsed by default) 

 

Open the quiz 

You can specify times when the quiz is accessible for people to make attempts. Before the opening time the quiz 

will be unavailable to students. They will be able to view the quiz introduction but will not be able to view the questions. 

Quizzes with start times in the future diasplay both the open and close date for students. 

Note: You can make the quiz available at different times for different groups or users in the Group or User 

override sections of the Quiz Administration settings block. 

Close the quiz 

After the closing time, the students will not be able to start new attempts. Answers that the student submits 

after the quiz closing date will be saved but they will not be marked. 

Even after the quiz has closed students will still be able to see the quiz description and review their attempts. 

What exactly they will see depends on the settings you choose for review options (see below). 

Time limit 

By default, quizzes do not have a time limit, which allows students as much time as they need to complete the 

quiz. If you do specify a time limit, several things are done to try and ensure that quizzes are completed within that 

time: 
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1. A countdown timer is shown in the quiz navigation block 

2. When the timer has run out, the quiz is submitted automatically with whatever answers have been filled in so 

far 

3. If a student manages to cheat and goes over the allotted time, no marks are awarded for any answers entered 

after the time ran out 

Note: You can make the quiz available last a different period of time for different groups or users in the Group 

or User override sections of the Quiz Administration settings . 

When time expires.. 

There are three options as to what will happen when the time limit is up. Choose the one you need from the 

dropdown menu: 

1. Open attempts are submitted automatically (This is the default) 

2. There is a grace period when open attempts can be submitted, but no more questions answered 

3. Attempts must be submitted before time expires, or they are not counted 

If you select "There is a grace period..." then you can check the box to enable the "Submission grace period" and 

specify a period of time during which learners may still submit the quiz after the time is up. 

Grade 

(These settings are collapsed by default) 

 

Grade category 

If you have categories in your gradebook, select the one you wish the quiz to be in here. 
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Attempts allowed 

Students may be allowed to have multiple attempts at a quiz. This can help make the process of taking the quiz 

more of an educational activity rather than simply an assessment. If the quiz is randomized then the student will get a 

new version for each attempt. This is useful for practice purposes. 

Note: You can change the allowed number of attempts for different groups or users in the Group or User 

override sections of the Quiz Administration settings block. 

Grading method 

When multiple attempts are allowed, there are different ways you can use the grades to calculate the student's 

final grade for the quiz. 

 Highest grade - the final grade is the highest (best) grade in any attempt 

 Average grade - the final grade is the average (simple mean) grade of all attempts 

 First grade - the final grade is the grade earned on the first attempt (other attempts are ignored) 

 Last grade - the final grade is the grade earned on the most recent attempt only 

Layout 

(These settings are collapsed by default) 

 

Question order 

If 'Shuffled randomly' is selected, then the order of questions in the quiz will be randomly shuffled each time a 

student starts a new attempt at the quiz. The intention is to make it a little harder for students to copy from each other. 

New page 

For longer quizzes it makes sense to stretch the quiz over several pages by limiting the number of questions per 

page. When adding questions to the quiz, page breaks will automatically be inserted according to the setting you choose 

here. However, you will also be able to move page breaks around by hand later on the editing page. 

Note that changing this setting has no effect on questions you have already added to the quiz.  

The setting will only apply to questions you add subsequently. To change the page breaks in an existing quiz, you 

need to go to the quiz editing screen, tick the 'Show page breaks' checkbox, then use the repaginate control. 

Navigation method (available by clicking Show More) 

By choosing Sequential instead of Free, the teacher is forcing the student to progress through the questions in 

order without being able to go back to a previous question or skip to a later one. 
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 Question behaviour 

 (These settings are collapsed by default) 

 

Shuffle within questions 

If set to 'yes', then each time the student takes a quiz the parts of the question will be shuffled randomly. 

Each attempt builds on the last (available by clicking "Show more") 

If multiple attempts are allowed and this setting is set to Yes, then each new attempt contains the results of the 

previous attempt. This allows the student on the new attempt to concentrate on just those questions that were 

answered incorrectly on the previous attempt. If this option is chosen then each attempt by a particular student uses 

the same questions in the same order, independent of randomization settings. To show a fresh quiz on every attempt, 

select No for this setting. 

Review options 

(These settings are collapsed by default) 

 

This section controls what information students will be shown when they review their past attempts at the quiz, 

and during the attempt in adaptive mode. It is a matrix with check boxes. 

The various pieces of information that can be controlled are: 

The attempt - Will show how the student responded to each question. 

Whether correct - Displays whether the students response to each question is correct or incorrect. 

Marks - Reveals the marks awarded to the student and the grade for the quiz. 
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Specific feedback - Will show the feedback for the response to the answer as set when adding the question to 

the quiz. Each response to a question can have feedback for both correct and incorrect answers. 

General feedback - Displays the general feedback for the whole question as set when adding the question to the 

quiz. You can use the general feedback to give students some background to what knowledge the question was testing. 

Right answer - Reveals the correct answer to each question, whether the student answered correctly or not. 

Overall feedback - Displays feedback for the entire quiz as set in the quiz settings.  For each of the above items, 

you can determine the timeframe when the students will see them: 

During the attempt  is only available when ‘How questions behave’ has been set to ‘Immediate 

feedback’, ‘Immediate feedback with CBM’ and ‘Interactive with multiple tries’. If set to one of these options then 

a ‘Check’ button will appear below the answer and when clicked the student will submit that response and then receive 

immediate feedback. 

Immediately after the attempt  means within 2 minutes of the student clicking "submit all and finish". 

Later, while the quiz is still open  means after 2 minutes, but before the close date (if the quiz does not have a 

close date, this phase never ends). 

After the quiz is closed  means what it says (you never get here for quizzes without a close date). 

Tip: Checking any of the boxes in the timeframe row, will reveal the test to the student. For example, to allow 

students to see their quiz immediately after taking it but not later, make sure none of the boxes in "Later" or "After" 

rows are checked. The student will be able to see their grade but not get into the quiz. 

Note: Currently, the Answers display is a bit inconsistent between different question types. For example, the 

matching question type shows students which of their responses are correct, but does not tell them the right answer for 

the ones they got wrong. The short answer and multiple choices question types do tell the student what the correct 

answer is. 

Users with the capability 'View hidden grades' moodle/grade:viewhidden (typically teachers and administrators) 

are not affected by these settings and will always by able to review all information about a student's attempt at any 

time. 

In your list of review options, you must have 'The attempt' (the first option in the lists) selected before you can 

enable the options to show 'Whether correct', 'Specific feedback', 'General feedback', and 'Right answer'. If you choose 

not to let the students review the attempt, your only options are to display 'Marks' and 'Overall feedback'. 
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Appearance 

(These settings are collapsed by default) 

 

Show the user's picture 

It is now possible, when displaying the user's profile picture for proctoring purposes, to choose whether a large 

image or thumbnail will be displayed. 

Decimal places in grades 

This option determines how many digits will be shown after the decimal separator  when the grade is displayed. 

A setting of 0 for example means that the grades are displayed as integers. This setting is only used for the display of 

grades, not for the display or marking of answers. 

Extra restrictions on attempts 

(These settings are collapsed by default and are available by clicking "Show more") 
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Require password 

This field is optional. 

If you specify a password in here then participants must enter the same password before they are allowed to 

make an attempt on the quiz. This is useful to give only a selected group of students access to the quiz. 

Enforced delay between attempts 

These two fields are optional. 

You can set a time (from seconds to weeks) between the first and second attempt of a quiz. You can also (or 

alternatively) set a time from seconds to weeks for subsequent attempts after the second attempt. Thus, you might 

allow a student to take the quiz twice immediately with no delay, but if they want to improve their score with a third 

attempt, they are forced to wait a week and use the time for extra revision. 

Overall feedback 

(These setttings are collapsed by default) 
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 Overall feedback is shown to a student after they have completed an attempt at the quiz. The text that is shown 

can depend on the grade the student got. Click "Show editing tools" to display the rich text editor, and drag the bottom 

right of the text box out to expand it. 

 Quiz completion 

 The following automatic activity completion conditions apply to the quiz: 

 Require view - the student clicks on the quiz to view it; 

 Require grade - the student obtains a grade; 

 

 Require a passing grade - a 'Grade to pass' is specified for the quiz in the gradebook. 

 All available attempts completed - a certain number of attempts were allowed on the quiz and the student has 

completed them all. 

 Group and User overrides 

 

 Dates, timing and number of allowed attempts may be changed for individual users or groups by following the 

links Group Overrides or User Overrides in the Quiz Administration settings block. 
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 Group overrides 

 To change a quiz setting for a particular group, click the "add group override" button in Quiz 

Administration>Group overrides, make the changes you wish and save or enter another override. 

 To change a quiz setting for a particular user or users, click the "add user override"button in Quiz 

Administration>Group overrides, make the changes you wish and save or enter another override. 

 

2.3.27 Building Quiz 

The word “quiz” might conjure up for some images of TV game shows, but a Moodle quiz is basically a set of 

questions presented to the learner which may be automatically marked by Moodle or graded later by the teacher. The 

questions may be in sentence or number form or contain various media such as video or sound. They do not all need to 

be the same type of questions: a quiz may contain multiple choice, matching, essays (teacher-graded) and calculated. 

Feedback may be given at any or all stages of the process. 

Once a quiz is made, that’s not the end of it. A Moodle quiz is environmentally friendly: its questions are saved 

in a Question bank and may be recycled for use elsewhere. Thus, Mr Brown could create a Physics Quiz with 20 

questions for his class, Class Brown, and his colleague Mr Smith sharing the course could save himself valuable time by 

resusing 5 of Mr Brown’s questions in his own General Science quiz for Class Smith.  

If you think of a quiz as a book, the Quiz settings are equivalent to the front cover; the quiz itself is contained 

within when the questions are created. (Be careful : once you have chosen the Quiz Settings, it will be “live” on your 

course page, unless you hide it, so your learners could potentially see a quiz with no questions, like a front cover with no 

content.) 

Note that it is possible to create questions directly in the Question bank without first creating a quiz. These 

questions may then be used later. Once a quiz has been added to the course and the Quiz settings established, the 

teacher can start to build the quiz. The teacher can access the quiz to edit the questions by clicking directly on the Quiz 

name on the course home page or by clicking "Edit quiz" in Administration>Quiz administration. 
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 Adding questions 

 Once you have accessed the quiz editing screen as above, you can add questions from a number of locations: 

1. Click the 'Add' link as in the screenshot below.  

2. When it opens up, choose either to add a new question, to select a question from the question bank or to 

add a random question. 

 

 Creating a new question 

1. To make a brand new question, click 'Add' and then '+ a new question'. 

2. From the next screen, choose the question type you want to add and click "Next" 

 NOTE: When you click on a question type on the left, helpful information appears on the right. 



 

                                                                                                                                            
184 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

3. Fill in the question form, making sure to give a grade to the correct answer. 

4.  Click "Save changes". 

 

 Note: If you have a very complex question, and you want to check it as you go along, you can preview it and 

then click "Save changes and continue editing". 
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 Note that when a question has been created, an icon and words display its type (eg multiple choice). It can be 

modified by clicking the edit icon (eg ) and previewed or deleted by clicking the magnifying glass or X 

icons:(eg ). 

 Choosing a pre-made question 

 If other teachers in the course have made questions, or if a teacher made questions in an earlier quiz, these 

can be added to the current quiz by clicking 'Add' and '+ from question bank' . 

 Click the + sign next to one question you want to add it (1 in screenshot below) 

 If you have several questions, or you want to add all the questions, tick the box of each question or the top 

box (2 in screenshot below) and then click 'Add selected questions to the quiz' (3 in the screenshot below). 

 To sort the questions, click the column headings. The default sort order (T) is short for question type. (2 in 

the screenshot below) 

 To ensure all previously made questions are available, make sure to tick the boxes "also show questions 

from sub-categories/old questions". 

 

 

Note: It is also possible to import pre-made questions into your quiz, from Quiz administration>Question 

bank>Import. 

Adding a random question 

As long as you have questions in the question bank, you can add random questions to your quiz by clicking 'Add' 

and then '+ a random question'. This might be useful if you have students in a class taking a quiz at the same time, 

because they are unlikely to get the same questions at the same time. The same question will never appear twice in a 

quiz. If you include several random questions then different questions will always be chosen for each of them. If you mix 

random questions with non-random questions then the random questions will be chosen so that they do not duplicate 

one of the non-random questions. This does imply that you need to provide enough questions in the category from 
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which the random questions are chosen, otherwise the student will be shown a friendly error message. The more 

questions you provide the more likely it will be that students get different questions on each attempt. 

The grade for the randomly chosen question will be rescaled so that the maximum grade is what you have 

chosen as the grade for the random question. 

You can add one or more random questions by choosing the number and category in the question bank. Note 

the die icon to highlight random question selection. 

 

Question categories 

Questions can be stored and retrieved from categories in the Question bank. When you make a new question it 

defaults to the category with the course name. So if you make a quiz in the Senior Physics course, questions will 

automatically be added to "Default for Senior Physics". You can opt to have your quiz questions in a category of their 

own ("Quizname") or to add a subcategory. 

To add a subcategory, go to Administration>Quiz administration>Question bank>Categories.  

Users will have access to different categories according to their permissions. For example, a regular teacher 

might only have access to question categories in his own Physics course whereas his Faculty Head of Science with 

permissions in all science courses might have access to question categories in Biology and Chemistry as well. 



 

                                                                                                                                            
187 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

Quiz layout 

 

 You can also change the layout of the whole quiz by clicking the 'Repaginate' button: 

 

 Questions may be moved by dragging and dropping using the crosshairs icon:  
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 Assigning points to questions 

 Administration > Quiz administration > Edit quiz > Editing quiz 

 You can set how many points each question is worth by changing the number in the box to the right of each 

question and you can change the maximum grade by changing the number in the box top right at the top of the quiz. 

The default is one point per question and 100.00 maximum grade. 

 

 

 The quiz module will do any maths, so for example, a 2 point question will be worth 2 times more when the Quiz 

module determines how many point out of 10 to award the student. 

 Previewing the quiz 

 You can preview individual questions by clicking the magnifying glass icon. 

 You can preview the whole quiz by clicking the "Preview" link in Administration>Quiz administration>Preview 

 The quiz works like a real quiz so you can see your grades and any feedback for correct/incorrect answers just as 

a student would see them. 

After quiz has been attempted 

If one or more students have taken the quiz, you will see a list of all the questions in the quiz and a notice saying 

that you cannot add or remove questions. 

You can change the order of questions, regrade them, preview an individual question and click on an question 

edit link that will allow you to directly edit the question stored in the question bank. 

NOTE: You can delete all quiz attempts by students and then edit the quiz as if no students had attempted it. To 

do this, click the quiz name and then the Results link in the Navigation block. This will present a list of students and their 

scores. Click "Select all" and then "Delete selected attempts". 

Dealing with faulty questions 

There are several ways to deal with "bad" questions in a quiz. 

 Change the grade for the bad question to 0 in the quiz. 

 Edit the question, changing what you will accept as a correct answer, then regrading the exam. Remember 

when changing a question that the next time it is used it will be as it was in the last edit. Also, regrading will only 

affect one quiz at a time. 

 You can edit the question to explain the situation to the student and then you can set the grade for the question 

to zero. After you make such changes you should regrade the quiz by clicking on the Results tab and then 
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the Regrade tab. This will change the grade for all students who have taken the quiz so far. Remember, if the 

question is used by another quiz, your "explanation" will appear as part of that quiz. 

 You can change the grade for the bad question and then move or delete the question from your question 

category. The question will still appear on the quiz. Some places do not like to delete any question, but will 

move them to a "dead" or "bad" question category. 

 When you discover a bad question in your quiz, it may affect the question bank. Remember that a final might be 

made up of a certain number of random questions drawn from different question categories, the same 

categories used in a smaller subject quiz. It can be very important do something about bad or invalid questions 

in a question category when the categories are use in other places. 

 2.3.28 Using Quiz 

 How students take a quiz 

 Click on the quiz link on the course homepage and read the information to check you're in the right quiz. 

 Click on "Attempt quiz now" button. 

 Click on the "Next" button at the bottom of the page to see the next page of questions 

 Click on the "flag" in the box next to the question to put a temporary marker on it 

 

 Notice the Quiz navigation block in the upper right corner. You can use it to jump to any question. Question 

boxes for the current pag are in bold. Flagged questions will have a "red corner" in their box 

 

 To finish the exam,click "Finish attempt" in the navigation block of "Next" on the last page of the exam. 

 The "Summary of attempt" page - reviews the questions and alerts you to questions not attempted. 
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 Click on any question page number or "Return to attempt" to go back to the quiz. 

 Click on "Submit all and finish" to have your quiz scored. A warning will pop up telling you you can no longer 

change your answers. 

 Autosave 

 If Moodle detects that the student's Internet connection has dropped, and the Quiz autosave feature is enabled, 

a warning message is displayed, prompting the student to make a note of recent responses. 

 

 Note: Quiz autosave is enabled by default, with the default time period set to 2 minutes. This autosave period 

can be changed, or the setting disabled completely, from Site administration>Plugins>Activity modules>Quiz>Autosave 

period. 

 How students review a quiz 

 In the quiz navigation block incorrect answers are RED: partially correct answers are YELLOW and correct 

answers are GREEN. The flags are still visible: 



 

                                                                                                                                            
191 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 In the questions themselves, correct answers will be in green with a check mark. Incorrect answers will be in red 

with a cross. will have a green check mark next to your correct answer 

 According to your teacher's settings, you might get general feedback, specific feedback on each question and/or 

overall feedback on your final score. 

 Although the quiz may have been split into multiple pages, the review will show all the questions on a single 

page to make it easier to navigate. You can chose to review the quiz with separate pages as it was when you 

took the quiz. 

 Saving questions and returning later to a quiz 

 If you answer a number of questions and then want to complete the quiz at a later time,click "Finish attempt". 

 When you return to continue the quiz, Moodle will remember which page you were on and allow you to 

continue from there, having saved your previous questions. 

 Retaking a quiz 

 If your teacher has allowed multiple attempts, when you click on the quiz again you will be informed how many 

attempts you have remaining along with your previous scores. 

 How teachers view a quiz 

 Note: Once a quiz has been attempted, it is not possible to add or delete questions unless previous scores are 

removed. 

 When attempts have been made on the quiz, the teacher can click the quiz name and access the reports by 

clicking the link "Attempts - (No. of attempts 

 It is then possible to filter the reports according to preference: 
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 A teacher may also access quiz results by clicking on the quiz name in the Navigation block. This opens up other 

links, enabling them to view by grade, by correct response, by statistics and by manually graded responses: 

 

 Each individual question may be filtered in score order and individual student quiz responses may be viewed by 

clicking "Review attempt" next to their name. 

 Commenting on or regrading responses 

 By clicking on the score of an individual question, a teacher may comment on it or override the grade: 

 

 Messaging students who haven't completed a quiz 

 From the Administration block, click Reports>Course participation 

 From the drop down, choose your quiz. 

 In Show only, choose "Student" and in Actions, choose "post" 

 In the list that appears, tick/check the boxes next to those you wish to message. 

 In the bottom dropdown With selected users, choose "send message". 
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 2.3.29 Quiz reports 

 Administration> Quiz administration > Results.This will open a submenu that offers reports on: 

 Grades report 

 Responses report 

 Statistics report 

 Manual grading 

 You can also get to the quiz reports where you see a summary of the number of attempts that have been made 

like "Attempts: 123". That link also goes to the reports. 

 Grades report 

 The quiz grades report may be viewed by clicking on the quiz and accessing Administration > Quiz administration 

>Results > Grades. 

 The Results Grade link shows the grade, date/time started, completed, time taken for every quiz attempt for a 

specific quiz. There is also a graph which shows all scores. 

 There is a setting form at the top of the page that can be used to control what is displayed. 
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 The teacher can select from: 

 enrolled users who have attempted the quiz; 

 enrolled users who have not attempted the quiz; 

 enrolled users who have, or have not, attempted the quiz; 

 all users who have attempted the quiz 

 

The results can be downloaded in a variety of formats. There is a setting form at the top of the page that can be 

used to control what is displayed. At the bottom of the page is a graph showing the distribution of scores. There are 

check boxes to allow you to individually regrade or delete the selected attempts. By clicking on the score link, you are 

able to look at an individual student exam. 

Deleting attempts 

The grading report can be used to delete selected quiz attempts, which may sometimes be necessary. 

Note that you cannot edit the quiz after it has been attempted, so that is one reason you may wish to delete all 

attempts. 

Responses report 

This is very similar to the Grades report, except that it shows the responses the students gave, rather than the 

marks they earned. 

It is also possible to show the question text or the right answer, to compare with the student's response. This is 

helpful when the question is randomised. 

For quizzes with interactive question behaviour, it is possible to display responses for the first, last or all tries a 

student makes: 
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Statistics report 

The quiz statistics report may be viewed by clicking on the quiz and then accessing Administration > Quiz 

administration> Results > Statistics. 

This report gives a statistical (psychometric) analysis of the quiz, and the questions within it. The top section of 

this report gives a summary of the whole quiz. The next section gives an analysis showing all questions in a table format. 

There are links in this section to edit individual questions or drill down into a detailed analysis of a particular question. 

The last section of this report is a bar graph of the percent of correct answers (Facility index) and the Discriminative 

efficiency index. 

The full report (overview, and detailed analysis of all questions) can be downloaded in a variety of formats, as 

can the quiz structure analysis table. 

Overall quiz statistics 

Here are the details concerning information in this robust report. 

Quiz information 

This section gives some basic information about the test as a whole. You will see: 

 Quiz name 

 Course name 

 Open and close dates (if applicable) 

 Total number of first/graded attempts 

 Average grade for first/all attempts 

 Median grade 

 Standard deviation of grades 

 Error ratio - the variation in the grades comes from two sources. First some students are better than others at 

what is being tested, and second there is some random variation. We hope that the quiz grades will largely be 

determined by the student's ability, and that random variation will be minimised. The error ratio estimates how 

much of the variation is random, and so lower is better. 

 Standard error - this is derived from the error ratio, and is a measure of how much random variation there is in 

each test grade. So, if the Standard error is 10%, and a student scored 60%, then their real ability probably lies 

somewhere between 50% and 70%. 
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 Quiz structure analysis 

 This section lists all the questions in the quiz with various statistics in a table format. 

 Q# - shows the question number (position), question type icon, and preview and edit icons 

 Question name - the name is also a link to the detailed analysis of this question (See Quiz Question Statistics 

below). 

 Attempts - how many students attempted this question. 

 Facility Index - the percentage of students that answered the question correctly. 

 Standard Deviation - how much variation there was in the scores for this question. 

 Random guess score - the score the student would get by guessing randomly 

 Intended/Effective weight - Intended weight is simply what you set up when editing the quiz. If question 1 is 

worth 3 marks out of a total of 10 for the quiz, the the intended weight is 30%. The effective weight is an 

attempt to estimate, from the results, how much of the actual variation was due to this question. So, ideally the 

effective weights should be close to the intended weights. 

 Discrimination index - this is the correlation between the score for this question and the score for the whole 

quiz. That is, for a good question, you hope that the students who score highly on this question are the same 

students who score highly on the whole quiz. Higher numbers are better. 

 Discriminative efficiency - another measure that is similar to Discrimination index. 

 Where random questions are used, there is one row in the table for the random question, followed by further 

rows, one for each real question that was selected in place of this random question. 

 When quiz questions are randomized for each quiz, the quiz module determines a default position. 
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 Quiz statistics chart 

 

 Quiz question statistics 

 Navigation > quiz's name > Results > Statistics (click on any question title) It is possible to see the statistics for 

one question on a single page. This view will also tell you what percentage of quiz takers selected each answer (Analysis 

of responses) and give you basic information about the question. 

 Question information- The basic information about the question, the name of the quiz, the question, the 

question type, the position in the quiz and the question itself. There are preview and edit icons in this page. 

 Question statistics - This repeats the information from the table row from the Quiz structure analysis that 

relates to this question. 

 Report options - You can choose whether to run the report on all attempts, or just the first attempt by each 

student. Some of the calculations used in the report are based on assumptions that may not apply to quizzes 

that allow more than one attempt. 

:Tip: Computing the statistics takes some time, the report will store the computed values and re-use them for up 

to 15 minutes. Therefore, there is a display of how recently the statistics were calculated, with a button to recalculate 

them immediatel 

Analysis of individual question responses 

This gives a frequency analysis of the different responses that were given to each part of the question. The 

details of the analysis depends on the question type, and not all question types support this. For example, essay 

question responses cannot be analyzed. 

 

Manual grading report 

The manual grading report may be viewed by clicking the quiz in question and then accessing Administration> 

Quiz administration >Results > Manual grading. 
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The first screen of the report lists all the questions in the quiz that need to be, or have been, manually graded 

(for example essay questions) with the number of attempts. There is an option to also show the questions that have 

been automatically graded, which if useful if you ever need to edit the grades by hand. 

2.3.30 SCORM module 

The SCORM module enables you (the teacher) to upload any SCORM or AICC package to include in your course. 

 

SCORM (Sharable Content Object Reference Model) is a collection of specifications that enable interoperability, 

accessibility and reusability of web-based learning content. SCORM content can be delivered to learners via any SCORM-

compliant Learning Management System (LMS) using the same version of SCORM. 

2.3.31 SCORM settings 

Adding a SCORM package 

To add a SCORM package to your course 

Quick method: (Note - does not work with versions of Internet Explorer earlier than IE10) 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Drag and drop the SCORM package zip file onto the course section where you'd like it to 

appear 

3. Answer 'Add a SCORM package' to the popup dialogue asking what you want to do with the 

zip file then click the upload button 

4. If necessary, edit the title of the file by clicking the pencil icon, or edit other options (see 

below) by clicking the editing icon 

Note: It is currently not yet possible to add AICC packages using the quick method. 

Longer method: 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Click the 'Add an activity or resource' link in the section you wish to add your SCORM package, then in the 

activity chooser, select SCORM package then click the Add button (or select 'SCORM package' from the 'Add 

an activity' dropdown menu) 

3. Enter a name and a description (which may be required or optional according to the admin settings) 

4. Either drag and drop a SCORM package zip file into the box with an arrow or click the Add button to open 

the File picker menu in order to choose a file from your computer or a repository 
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5. Select display and other options as required (see below) 

6. Click the button 'Save and display' at the bottom of the page 

You can edit or update the SCORM package later by clicking on the edit icon (usually a hand/pen) or by clicking 

on its name and then Settings > SCORM/AICC administration > Edit settings. 

Note: Moodle does not generate SCORM content. Moodle presents the content in SCORM packages to learners, 

and saves data from learner interactions with the SCORM package.  

Course settings 

General 

 

Name 

Whatever you type here will form the link learners click on to access the SCORM package, so it is helpful to give 

it a name that suggests its purpose. 

Description 

Add a description of your SCORM activity here. Click "Show editing tools" to display the rich text editor, and drag 

the bottom right of the text box out to expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the SCORM activity. 

Package 

This setting determines which SCORM package is used by this SCORM activity. Drag and drop or click the icon 

top left to upload your SCORM package. (Note that you must not unzip the package before upload.)The default (1) is to 

be able to upload a file. If your admin has added additional options in Site administration>Plugins>Activity 

modules>SCORM package then these will be available in a dropdown menu. (2) 
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Appearance 

(These settings are collapsed by default) 
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Display package 

Choose from current or new window. Note that if you choose a new window, students need to ensure pop ups 

are enabled. 

Display course structure on entry page 

If this is enabled then the table of contents of the package will be displayed when the students clicks to access 

the package. 

Show Navigation 

This setting determines whether the navigation buttons are shown or not. 

1. No -they are hidden 

2. Under content - they are displayed underneath the SCORM package 

3. Floating - the navigation buttons are floating (with options to choose the position from the left 

and top) 

Display attempt status 

You can choose whether to display a summary of the student's attempts on the entry page, on their My 

homepage or both. This setting is helpful when debugging grading issues - working out why a user got a certain grade. 

The following settings become visible when "Show more" is clicked: 

Width 

Stage size width as a css value, either % or pixels. Default is 100%. You can change to a different percentage by 

putting a % symbol after the number (ex. 80%). You can also set to a pixels value by entering a number higher than 100 

(ex. 800). 

Height 

Stage size height as a css value, either % or pixels. Default is 500 pixels. You can change to a percentage by 

putting a % symbol after the number (ex. 80%). You can also set to a pixels value by entering a number higher than 100 

(ex. 800). 

Options 

There is a series of check boxes for: Allow the window to be resized ad scrolled, displaying directory links, 

location bar, menu bar, toolbar and/or status. 

 Student skip content structure page - never, first access, always 

 Disable preview mode - If this option is set to Yes, the Preview button in the view page of a 

SCORM/AICC Package activity will be hidden. The student can choose to preview (browse mode) the activity 

or attempt it in the normal mode. When a Learning Object is completed in preview (browse) mode, it's 

marked with browsed icon 

 Display course structure in player 
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Availability 

(These settings are collapsed by default.) 

 

Choose here the dates you wish the SCORM package to be available to students. 

Grade 

(These settings are collapsed by default) 

 

Grading method 

o Learning Objects - This mode shows the number of completed/passed Learning Objects for the 

activity. The max value is the number of Package's Learning Objects.  

o  Highest grade - The grade page will display the highest score obtained by users in all passed 

Learning Objects.  

o  Average grade - If you choose this mode Moodle will calculate the average of all scores. 

o Sum grade - With this mode all the scores will be added. 

Maximum grade 

Not applicable if Grading Method is Learning objects. Usual setting is 100. If your SCO 's high score is something 

other than 100, you should adjust this value appropriately. When grading Method is one of the score settings, then the 

gradebook grade is package score divided by this number. 
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Attempts management 

(These settings are collapsed by default.) 

 

Number of attempts 

Defines the number of attempts permitted to users. It works only with SCORM 1.2 and AICC packages. 

SCORM2004 has its own max attempts definition. 

 The option to start a new attempt is provided by a checkbox above the Enter button on the 

content structure page, so be sure you're providing access to that page if you want to allow more than one 

attempt. 

 An attempt is not complete until the cmi.core.lesson_status for the attempt is set to either 

'completed' or 'passed'. After that, the Start new attempt checkbox is available to the learner. 

Attempts grading 

When you permit multiple attempts for students, you can choose how to record the result in gradebook by first, 

last, average or highest settings. 

 Display attempt status - If enabled, scores and grades for attempts are displayed on the SCORM 

outline page. This setting makes the block display more info to the user on the entry page to the SCORM 

and in the course overview block - if you turn it off it will display less info. This setting is helpful when 

debugging grading issues - working out why a user got a certain grade. 

Force new attempt 

If this is enabled then every time the student accesses the package, it will count as a new attempt. 

Lock after final attempt 

If this is enabled then once a student has used up all their attempts, they can no longer access the SCORM 

package. 

Activity completion settings 

If this has been enabled for the course, then SCORM completion may be set based on minimum score or status 

(e.g. "Passed"). 
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2.3.32 Survey module 

The Survey module is a course activity that provides a number of verified survey instruments, including COLLES 

(Constructivist On-Line Learning Environment Survey) and ATTLS (Attitudes to Thinking and Learning Survey), which 

have been found useful in assessing and stimulating learning in online environments. Teachers can use these to gather 

data from their students that will help them learn about their class and reflect on their own teaching. 

 

2.3.33 Survey settings 
Note: Moodle's survey module uses pre-made questions.  

Adding a survey 

With the editing turned on, in the section you wish to add your survey, click the "Add an activity or resource" 

link (or, if not present, the "Add an activity" drop down menu )and choose Survey. All settings may expanded by clicking 

the "Expand all" link top right. 
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General 

 

Name 

Whatever you type here will form the link learners click on to do the survey so it is helpful to give it a name that 

suggests its purpose. 

Survey type 

Choose your survey type here.  

Description 

Add a description of your survey here. Click "Show editing tools" to display the rich text editor, and drag the 

bottom right of the text box out to expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the survey. 

Restrict access/Activity completion 

(These settings are collapsed by default) 

These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

Locally assigned roles 

In Administration > Survey administration > Locally assigned roles, selected users can be given additional roles in 

the activity. 

Survey permissions 

Role permissions for the activity can be changed in Administration > Survey administration > Permissions. 

Types of survey 

The available surveys have been chosen as being particularly useful for evaluating online learning environments 

that use a constructivist pedagogy. They are useful to identify certain trends that may be happening among your 

participants.  

COLLES - Constructivist On-Line Learning Environment Survey 

The COLLES comprises an economical 24 statements grouped into six scales, each of which helps us address a 

key question about the quality of the on-line learning environment: 

 Relevance How relevant is on-line learning to students' professional practices? 

 Reflection Does on-line learning stimulate students' critical reflective thinking? 

 Interactivity To what extent do students engage on-line in rich educative dialogue? 
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 Tutor Support How well do tutors enable students to participate in on-line learning? 

 Peer Support Is sensitive and encouraging support provided on-line by fellow students? 

 Interpretation Do students and tutors make good sense of each other's on-line 

communications? 

Underpinning the dynamic view of learning is a new theory of knowing: social constructivism, which portrays the 

learner as an active conceptualiser within a socially interactive learning environment. Social constructivism is an 

epistemology, or way of knowing, in which learners collaborate reflectively to co-construct new understandings, 

especially in the context of mutual inquiry grounded in their personal experience. 

Central to this collaboration is the development of students' communicative competence, that is, the ability to 

engage in open and critical discourse with both the teacher and peers. This discourse is characterised by an empathic 

orientation to constructing reciprocal understanding, and a critical attitude towards examining underlying assumptions. 

The COLLES has been designed to enable you to monitor the extent to which you are able to exploit the 

interactive capacity of the World Wide Web for engaging students in dynamic learning practices. 

ATTLS - Attitudes to Thinking and Learning Survey 

The theory of 'ways of knowing', originally from the field of gender research (Belenky et al., 1986) provides us 

with a survey tool to examine the quality of discourse within a collaborative environment. 

The Attitudes Towards Thinking and Learning Survey (ATTLS) is an instrument developed by Galotti et al. (1999) 

to measure the extent to which a person is a 'connected knower' (CK) or a 'separate knower' (SK). 

People with higher CK scores tend to find learning more enjoyable, and are often more cooperative, congenial 

and more willing to build on the ideas of others, while those with higher SK scores tend to take a more critical and 

argumentative stance to learning. 

Studies have shown that these two learning styles are independent of each other (Galotti et al., 1999; Galotti et 

al., 2001). Additionally, they are only a reflection of learning attitudes, not learning capacities or intellectual power. 

Wiki module 

A wiki is a collection of collaboratively authored web documents. Basically, a wiki page is a web page everyone 

in your class can create together, right in the browser, without needing to know HTML. A wiki starts with one front 

page. Each author can add other pages to the wiki by simply creating a link to a page that doesn't exist yet. 

 

 

 

 

 

 

 



 

                                                                                                                                            
207 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 

Wikis get their name from the Hawaiian term "wiki wiki," which means "very fast." A wiki is indeed a fast 

method for creating content as a group. It's a hugely popular format on the Web for creating documents as a group. 

There is usually no central editor of a wiki, no single person who has final editorial control. Instead, the community edits 

and develops its own content. Consensus views emerge from the work of many people on a document. 

In Moodle, wikis can be a powerful tool for collaborative work. The entire class can edit a document together, 

creating a class product, or each student can have their own wiki and work on it with you and their classmates. 

2.3.34 Wiki settings 

Adding a wiki 

 With the editing turned on, in the section you wish to add your wiki, click the "Add an activity or resource" 

link (or, if not present, the "Add an activity" drop down menu )and choose Wiki. 

 This will take you to the wiki settings page titled "Adding a new wiki". All settings may expanded by clicking 

the "Expand all" link top right. 

 In an existing wiki, the wiki settings can be found in Administration > Wiki administration > Edit settings. 
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General 

 

Wiki name 

The name you give to your wiki here will appear as the link on the course page for your students to click. 

Wiki description 

Explain the purpose of your wiki here. (This description may or may not be compulsory depending on your 

admin's settings.) 

Display description on course page 

If this box is checked, then the description you added above will appear with the wiki link on the course page. 

Wiki mode 

Choose between "Individual wiki" where each student gets their own, or "Collaborative wiki" where students 

work together on a single wiki. 

First page name 

The name you add here will form the first page of your new wiki. It is a required field and once a name has been 

entered,it can't be changed. 

Format 

(These settings are collapsed by default) 

 

Default format 

Set the default type of editing your wiki will use. Chooose from 

 HTML - editing using the normal text editor 

 Creole - a popular wiki editing language. If this is selected, a small editing toolbar will appear.

 
 NWiki - a wiki editing language used in the contributed NWiki module. 
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Force format 

If you check this box then students cannot choose their own method of editing the wiki. 

Restrict access/Activity completion 

(These settings are collapsed by default) 

These settings are visible if Conditional activities and Activity completion have been enabled in the site and the 

course. 

Locally assigned roles 

In Administration> Wiki administration > Locally assigned roles selected users can be given additional roles in 

the activity. 

Wiki permissions 

Role permissions for the activity can be changed in Administration > Wiki administration > Permissions. 

2.3.35 Using Wiki 

Creating the first page 

Once the wiki is set up, a user will click the link and reach the following screen: 

 

Adding more pages 

 Type the name of your page inside double brackets. (1 in screenshot below) You can preview it by clicking 

the "preview" button towards the bottom of the screen. 

 Press the "save" button. 

 Now click the (red) link for one of the pages (2 in screenshot below) and you will be prompted to create it in 

the same way you create the first page: 

 

 

 

 

 

 



 

                                                                                                                                            
210 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 A page once created has a blue link. 

Hint: 

If you use the New option from the navigation block you will still need to copy and paste the name of the new 

page onto the immediate parent page and surround it with double brackets. This creates a link to your new page and 

makes it accessible from the main Wiki page. Otherwise nobody will recognise the so called lost new page. 

Wiki editing in general 

Depending on the type of the wiki, there are several ways to edit your page. But don't worry: The best thing of a 

wiki is, that nothing is lost. The old version will be there - and if someone changes your version of the page - your 

version will also be there. Note that the options for editing, commenting viewing history, map and files may all be 

accessed both from tabs at the top (1 in screenshot below) and links in the navigation block (2 in screenshot below): 

 

View 

The View tab at the top or link in the navigation block allows users to display and view the wiki page. 
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Edit 

The Edit tab at the top or link in the navigation block allows users to edit the wiki page. 

Comments 

The Comments tab at the top or link in the navigation block allows users to see and add comments about the 

wiki. 

History 

 The History tab at the top or link in the navigation block allows users to see what has been altered in the 

wiki. 

 Compare edits by clicking the "Compare Selected" button. 

 Click the "Restore" button of the version you wish to restore if the latest edit is unsuitable: 

 

Map 

 The Map tab at the top or link in the navigation block allows users to view areas of the wiki such as a list of 

pages (as in the following screenshot), updated or orphaned pages etc. (Orphaned pages are pages not 

linked to anywhere.) 

 To select what you want to see, click the Map menu dropdown box. 
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Files 

 The Files tab at the top or link in the navigation block allows users to access any files which have been 

added to the wiki. 

 By default, the Teacher role can add and manage files to the Files tab, but the Student role can only view 

them. You could change this though with a permissions override to the Manage wiki files capability 

(mod/wiki:managefiles) in any particular wiki. 

Administration 

The Administration tab at the top or link in the navigation block is available to editing teachers in the course so 

they can delete page versions or selected pages. Clicking the "list all" button will list available pages to delete. The first 

page of the wiki cannot be deleted. 

 

Deleting pages 

Teachers and other users with the mod/wiki:managewiki capability can delete any page or page version, with 

the exception of the first page, via the Administration link in the navigation block or the Adminstration tab.  

Why use a wiki? 

Wikis are a simple, flexible tool for collaboration. They can be used for everything from simple lists of web links 

to building entire encyclopedias. As an example, Wikipedia is the largest wiki in the world. In your own class it's 

important to have a plan for your wiki so students know how it fits in with their learning. If it's a individual wiki, will they 

be graded? Is it simply a staging area for group work that will be submitted as assignments later? Will you let the 

students be completely responsible for the work? How will you deal with offensive content? The great advantage of a 

wiki is that all edits are clearly visible and reversible. 

Ideas for using wikis: 

 Group lecture notes - Creating a wiki for group lecture notes after a lecture gives students a chance to 

combine all their notes. Those that missed information can get it from their peers. The group can also 

decide what information is critical and give it proper emphasis. Group lecture notes could be done with the 

entire class, if it is small enough, or with small working groups. Groups can also compare notes for further 

discussion and refinement. 

 Group Project management - A teacher assigning a group project can give students a place to work by 

creating a wiki with the group mode enabled. This will give each group their own space to record research, 

to develop outlines and to create the final product. 

 Brainstorming - Brainstorming is a non-judgmental group creative process in which group members are 

encouraged to give voice to any ideas they personally consider relevant to the group exercise. In a face-to-

face meeting, a brainstorming facilitator will usually stand in front of a big piece of paper and elicit ideas 

from the participants in the room. A teacher can create an online version of this process by setting up a wiki 

for the entire class or for smaller student groups and asking people to submit ideas around a brainstorming 

topic. People can add ideas as they occur and link to other pages for elaboration. 
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2.3.36 Workshop module 

 Workshop is a peer assessment activity with many options. Students submit their work via an online text 

tool and attachments. There are two grades for a student: their own work and their peer assessments of other students' 

work. 

 

Key features 

Workshop is similar to the Assignment module and extends its functionality in many ways. However, it is 

recommended that both course facilitator (teacher) and course participants (students) have at least some experience 

with the Assignment module before the Workshop is used in the course. 

 As in the Assignment, course participants submit their work during the Workshop activity. Every course 

participant submits their own work. The submission may consist of a text and attachments. Therefore, 

Workshop submission merges both Online text and Upload file types of the Assignment module. Support for 

team work (in the sense of one submission per group of participants) is out of scope of Workshop module. 

 The submissions are assessed using a structured assessment form defined by the course facilitator (teacher). 

Workshop supports several types of assessment forms. All of them allows multi-criteria assessment in 

comparison to the Assignment module where only one grade is given to a submission. 

 Workshop supports peer assessment process. Course participants may be asked to assess selected set of 

their peers' submissions. The module coordinates the collection and distribution of these assessments. 

 Course participants get actually two grades in a single Workshop activity - grade for their submission (that is 

how good their submitted work is) and grade for assessment (that is how well they assessed their peers). 
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Workshop activity creates two grade items in the course Gradebook and they can be aggregated there as 

needed. 

 The process of peer assessment and understanding the assessment form can be practised in advance on so 

called example submissions. These examples are provided by the facilitator together with a reference 

assessment. Workshop participants can assess these examples and compare their assessment with the 

reference one. 

 The course facilitator can select some submissions and publish them so they are available to the others at 

the end of Workshop activity (in comparison to the Assignment module where submitted work is available 

only to the author and the facilitator). 

2.3.37 Workshop settings 

Adding a new workshop 

With the editing turned on, in the section you wish to add your workshop, click the "Add an activity or resource" 

link (or, if not present, the "Add an activity" drop down menu ) and choose Workshop. All settings may expanded by 

clicking the "Expand all" link top right. 

General 

The "Adding a new workshop" screen will be displayed. 

 

Name 

Whatever you type here will form the link learners click on to view the workshop, so it is helpful to give it a 

name that suggests its purpose. 

Description 

Add a description of your workshop here. Give an overview of what happens and when, and what students need 

to know or do to succeed. 

To display the rich text editor, click "Show editing tools" and drag the handle bottom right of the editor to 

expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the workshop. 
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Grading settings 

(These settings are collapsed by default) 

 

Grading Strategy 

What you choose here determines the assessment form students will use and also the strategy for grading 

submissions. Note: Grading strategies can't be changed once we have entered the submission phase of a workshop 

 Accumulative grading: Comments and a grade are given regarding the aspects of the workshop specified. 

 Comments: Comments are given but no grade can be given to the specified aspects 

 Number of Errors: A yes/no assessment is used and comments are given for specified assertions 

 Rubric: A level assessment is given regarding specified criteria 

Grade for Submission 

This sets the maximum grade a student can attain from a teacher for a given submission. It is scaled between 0-

100. If you have set up any Grade Categories, you will see a picklist. 

Grade for Assessment 

Sets the maximum grade a student can receive for assessing other students’ work. It is also scaled between 0-

100. If you have set up any Grade Categories, you will see a picklist. 

Decimal places in grade 

Decide here how many decimal places are allowed in the grade. 

Submission settings 

(These settings are collapsed by default) 

 

Instructions for submission 

Students see this when they click on the link to the Workshop. Explain here what they need to do to make a 

successful submission (it may also help to refer them back to general instructions for using the Workshop - how to find 

out when the deadlines are and what they do at each stage). 
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Maximum number of submission attachments 

If you wish students to attach files, select how many here, up to a maximum of 7. If you leave it at 0 then they 

can only enter text. 

If you allow files, then note that some students may choose to enter text - so you may need to stipulate whether 

students should upload files or enter text. If either, then in the Instructions for Review, flag up to students that there 

may be some variation in how they access the submissions. 

Maximum File Size 

Decide here how large a file students can upload. The size will depend on the course upload limit. 

Late Submissions 

Ticking this box will allow students to submit after the deadline. Please note that if late submissions are allowed, 

there is no way to automatically allocate assessors to them. A Teacher will need to manually allocate assessors to these 

late submissions. 

Assessment settings 

(These settings are collapsed by default.) 

 

Instructions for assessment 

Students see these instructions when the Workshop is in Assessment Phase. They are important to students' 

understanding of the task before assessing their classmates’ submissions. 

After these workshop settings have been saved, Teachers can access further settings related to allocating 

assessments.  

Use self-assessment 

Checking this box means that students may be allocated their own work to assess. This will depend on Moodle's 

allocation i.e. the larger the group of students the less likely it is that anyone will be allocated their own work. 

Feedback 

(These settings are collapsed by default.) 
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Overall feedback mode 

If this is enabled, a text box appears at the bottom of each assessment form for reviewers to give an overall 

comment about the submission. Depending on whether is it set to "Enabled and optional" or "Enabled and required", 

reviewers will either have the choice of leaving overall feedback or they will be forced to do so. 

Maximum number of overall feedback attachments 

Choose here how many (if any) files you wish reviewers to attach to their overall feedback, up to a maximum of 

7. 

Maximum overall feedback attachment size 

Decide here how large a feedback file students can upload. The size will depend on the course upload limit. 

Conclusion 

It is possible to add some text which the students will see once they reach the end of the workshop process. It is 

a good idea to signpost students to how they can access the assessments they have received. 

It might also include suggestions on what students should do next. 

Example submissions 

(These settings are collapsed by default.) 

 

There are three options in this drop down menu: The first option means that the assessment of the example 

submission is voluntary, while the second and the third ones make it mandatory, which either requires students to 

assess example submissions before submitting their own work or after their own submission but before peer-

assessment. 

Note: Assessments of the example submission are not counted when calculating the grade for assessment. 

Availability 

(These settings are collapsed by default.) 

 

This section deals with setting submission times and assessment times for the workshop. That is the time when 

students can start submitting as well as the deadline for submitting, and similarly the time assessments for other 

students’ work start and when they must finish assessing other students work. 

All dates - open for submissions from, submissions deadline, open for assessment from and assessment deadline 

- are displayed in the course calendar. 

Availability lets a teacher decide if they want a workshop with a closed schedule or one that is open ended. 

Setting an opening time but leaving the deadline open makes it an ongoing activity. To set the opening time and 
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deadline for either submissions or assessments teachers must click the enable button next to the option they want to 

set. Once the enabled has been checked the 5 drop down boxes will be activated and available for change. 

The first three boxes correspond to the date and we can either set this box by box or by selecting the date in the 

calendar that pops up when any of the date boxes are selected. The last two boxes correspond to the time in 24 hour 

time, the first of the two being hours and the second being minutes. Teachers simply set the desired time for each of 

the sections they wish to activate. 

If teachers check the box "switch to the next phase after the submissions deadline", the workshop will 

automatically switch to the assessment phase after the next cron job. 

Note that even if Switch to the next phase after the submissions deadline is enabled a teacher will need to 

manually move the workshop into Submission Phase and click on Close to conclude the workshop and reveal the 

assessments. 

Set up phase 

 

In order to set the criteria for an assignment, teachers need to fill out an assessment form during the setup 

phase. Students can view this assessment form in the submission phase and focus on what is important about the task 

when working on their assignment. In the next phase-the assessment phase, students will assess their peers’ work 

based on this assessment form. 

According to the grading strategy chosen in the grading settings, teachers will get corresponding original 

assessment form to edit by clicking ‘Edit assessment form’ button in the first page of the workshop setup for the 

assignment. The grading strategy can be one of Accumulative grading, Comments, Number of errors or Rubrics. Teachers 

can set each criterion in detail in the assessment form. 

Submission phase 

Once the workshop has been made we can then set more settings relating to submissions. This is done through 

clicking on the menu highlighted below which is found when you click on the workshop’s link or after clicking “Save and 

Display” on completion of the workshop. To access the menu simply click on “Allocate Submissions”. It is highlighted in 

the picture by the red box. 
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Manual Allocation 

Here,a teacher can manually choose which students review whose work. A student can review work even if they 

have not submitted anything themselves. 

Random Allocation 

The teacher is given 5 settings that determine how the random allocation will work. 



 

                                                                                                                                            
220 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 Number of reviews: Here the teacher picks between 0 and 30 reviews for either each submission or per 

reviewer. That is the teacher may choose to either set the number of reviews each submission must have or 

the number of reviews each student has to carry out 

 Prevent Reviews: If the teacher wishes for students of the same group to never review each other’s work, 

as most likely it is their work too in a group submission, then they can check this box and moodle will ensure 

that they are only allocated other students out of their group’s work to access 

 Remove current allocations: Checking this box means that any manual allocations that have been set in the 

Manual Allocation menu will be removed 

 Can access with no submission: Having this box checked allows students to assess other students’ work 

without having already submitted their own work. 

 Add self assessments: This options when checked make sure that as well as assessing other students’ work 

they must also assess their own. This is a good option to teach students how to be objective to their own 

work. 

Assessment phase 

Examples 

Students can assess example submissions for practice before assessing their peers' work if this feature is 

enabled. They can compare their assessments with reference assessments made by the teacher. The grade will not be 

counted in the grade for assessment. 

Teachers need to upload one or more example submissions and the corresponding reference assessment to 

support this function. 

Teachers can also edit the reference assessment later by clicking the ‘re-assess’ button in the first page. 

Peer assessment 

 

If this feature is enabled, a student will be allocated a certain amount of submissions from his peers to assess. 

He will receive a grade for each assessment, which will be added together with the grade for his own submission and 

this will be used as his final grade for this assignment. 

This is the key feature of workshop: To encourage students to assess the work of their peers and learn from 

each other. Through this, they will see the strengths of their classmates’ submissions and have a better understanding 

about how to do a good job. In addition, the advices they get from their peers will give them a more comprehensive 

view of their own work: The comments from their peers will point out the weakness of their work, which is generally 

difficult to find out by themselves. 

Self-assessment 

If this option is turned on, a student may be allocated his own work to assess. The grade he receives from 

assessment of his own work will be counted into the grade for assessment, which will be added together with the grade 

for submission and used to calculate his final grade for this assignment. 

This setting enables teachers to see whether students can find out the strength and weakness of their own 

submissions and judge them objectively. It is a good way to help students think more comprehensively. 
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Grading evaluation phase 

Grading evaluation settings 

 

Here you can choose your settings for calculation of the grade for assessments. 

Grade calculation method 

This setting determines how to calculate grade for assessments. Currently there is only one option- comparison 

with the best assessment. 

The Comparison with the best assessment tries to imagine what a hypothetical absolutely fair assessment would 

look like. 

For example, a teacher uses Number of errors as grading strategy to peer-assess one assignment. This strategy 

uses a couple of assertions and assessors just need to check if the given assertion is passed or failed. That is, they only 

need to choose ‘yes’ or ‘no’ for each criterion in the assessment form. In this case, there are three assessors, Alice, Bob 

and Cindy. And the assessment form contains three criteria. The author will get 100% grade if all the criteria are passed, 

75% if two criteria are passed, 25% if only one criterion is passed and 0% if the assessor gives ‘no’ for all three 

assertions. Here are the assessments they give to one certain work: 

 

Alice: yes/yes/no  

Bob: yes/yes/no  

Cindy: no/yes/yes  

 

Then the best assessment will be: 

Yes/yes/no  

 

Second, the workshop will give the best assessment 100% grade. Next it will measure the ‘distance’ from other 

assessments to this best assessment. The farther the distance, the lower grade the assessment will receive. 

AndComparison of assessments setting, next to the Grade evaluation setting, will determine how quickly the grade falls 

down if the assessment differs from the best one. 

Note: Comparison with the best assessment method will compare responses to each individual criterion instead 

of comparing the final grades. In the example above, all of the three assessors give 75% to the submission. However, 

only Alice and Bob will get 100% grade for their assessments, while Cindy will get a lower grade. Because Alice and Bob 

agree in individual responses too, while the responses in Cindy’s assessment are different. 

 Comparison of assessments: 

This setting has 5 options: very lax, lax, fair, strict and very strict. It specifies how strict the comparison of 

assessment should be. By using comparison with the best assessment method, all assessments will be compared with 
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the best assessment picked up by workshop. The more similar one assessment is with the best assessment, the higher 

grade this assessment will get, and vice versa. This setting determines how quickly the grades fall down when the 

assessments differ from the best assessment. 

Workshop toolbox 

 

Clear all aggregated grades 

Clicking this button will reset aggregated grades for submission and grades for assessment. Teachers can re-

calculate these grades from scratch in Grade evaluation phase. 

Clear assessments 

By clicking this button, grades for assessments along with grades for submission will be reset. The assessment 

form will remain the same but all the reviewers need to open the assessment form again and re-save it to get the given 

grades calculated again. 

2.4 Resources 
A resource is an item that a teacher can use to support learning, such as a file or link. Moodle supports a range 

of resource types which teachers can add to their courses. In edit mode, a teacher can add resources via the 'Add an 

activity or resource' link. Resources appear as a single link with an icon in front of it that represents the type of resource. 

2.4.1 Book module 

The Book module makes it easy to create multi-page resources with a book-like format. 

Previously created websites can be imported directly into the Book module. Books can be printed entirely or by 

chapter. 

The book module allows you to have main chapters and sub chapters, but it goes no deeper. In other words, sub 

chapters cannot have their own sub chapters, as the module is intended to be a simple resource for teachers and 

students. 

The book module is not interactive. You can, however, link to choices, forums etc., from within a book. Also, 

Flash movies and other multimedia may be included in a book. 

2.4.2 Book settings 

Adding a book 

A teacher can add a book by choosing it from the "Add an activity or resource" link (or, if not present, the "Add a 

resource" drop down menu in course.) All settings may expanded by clicking the "Expand all" link top right. 

General 
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Name 

Use a descriptive name for your book as it will form the link the students will click on to access it. 

Description 

Provide information for your students here so they are clear what the book is about. Click "Show editing tools" 

to display the rich text editor and drag the bottom right of the text box out to expand it. 

Display description on course page 

Enabling this will display the description on the course page just below the link to the book. 

Appearance 

(These settings are collapsed by default.) 

 

Chapter formatting 

The options are: 

 None - chapter and subchapter titles are not formatted at all, use if you want to define special 

numbering styles. For example letters: in chapter title type "A First Chapter", "A.1 Some Subchapter",... 

 Numbers - chapters and subchapters are numbered (1, 1.1, 1.2, 2, ...) 

 Bullets - subchapters are indented and displayed with bullets. 

 Indented - subchapters are indented. 

Custom titles 

If you disallow custom titles, the chapter title (the one that appears on the table of contents) will appear as a 

header at the top of your content (1 below) If you enable custom titles, you will be able to create a title different from 

the one that appears in the ToC or display no title at all (2 below) If you enable custom titles, you will need to enter the 

chapter title as part of the page content. 

 

Adding chapters and subchapters 

Titles of chapters appear as links in the table of contents to the left of your content. Keep your titles short. 
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To add another chapter, click on the + icon in the Table of Contents or first chapter. The new chapter will be 

inserted directly after the chapter whose title is on the same line as the red cross you click. 

 
Note that the sub chapter box is checked. A chapter may have many sub chapters, but sub chapters cannot have 

subchapters. In order to keep this resource simple, you are limited to two levels . 

 

You now see a chapter and a sub chapter. Because we did not elect to number chapters, the fact that the 

second chapter is a sub chapter cannot be seen in the table of contents. Note that you do, however, see this in the title 

above the content. 

By the way, the items in the table of contents are neither numbered nor are they indented only because that is 

the option we chose when setting up the book. We can always go back and change that. 

 

Importing chapters 

To import chapters 

 Create a zip file of HTML files and optional multimedia files and folders. If you wish to upload 

subchapters, add "_sub" to the end of HTML file or folder names. 

 Go to Administration > Book administration > Import chapter 

 Choose whether each HTML file or folder represents one chapter 

 Browse for and select the zip file, either using the Add button or the drag and drop method: 
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 Click the import button 

Note: Relative file links are converted to absolute chapter links. Images, Flash and Java are re-linked too. 

Remember to upload images and multimedia files as well as HTML files. 

2.4.3 Using Book 

Navigate your book 

In addition to the links in the table of contents, you may move through the book using the arrows located to the 

top-left and bottom-left of the content. 

 

 

Uses of the book module 

You can use the book module to present information in a well-structured, user-friendly format. But there are 

other possibilities. Because this module allows one to import individual web pages or folders of web pages, it is useful 

for group work. Example: Each student creates a simple web page about your school and the teacher, (that's you!) 

uploads the pages to the book. Voila! You and your students have created a useful, interesting resource for new 

students and their parents. You could do this to create a class cook book and nutrition guide, a resource about local civic 

organizations, triangles in our daily lives, world leaders, you name it. Alternatively, you could enable students to upload 

pages to the book . 



 

                                                                                                                                            
226 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

Printing a book 

Whole books and individual chapters may be printed by selecting the relevant link in Administration > Book 

administration. 

 

If you do not wish certain roles to be able to print books (e.g. students) then you can remove the capability 

booktool/print:print in Administration > Book administration > Permissions. 

Exporting a book as an IMS content package 

Any user with the export a book as an IMS content package capability (by default nobody except admins) can do 

so via Administration > Book administration > Generate IMS CP. 

2.4.4 File resource 

When you wish to share with your students a simple file such as a Word-processed document or slideshow (eg 

created in MS Word, Powerpoint, or Open Office) you use the file resource type. It allows you to upload and display a 

variety of resources on your course. How your students access them depends on your choices in File resource settings. 

Note also that they will only be able to open your files if they have the appropriate software on their own computers. 
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2.4.5 File resource settings 

Adding a file 

To add a file to your course 

Quick method: (Note - does not work with Internet Explorer 9 or lower) 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Drag and drop the file onto the course section where you'd like it to appear 

3. If necessary, edit the title of the file by clicking the pencil icon, or edit other options (see below) by 

clicking the editing icon 

Longer method: 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Click 'Add an activity or resource' link, then in the activity chooser, select file then click the Add button 

(or select file from the "Add a resource" dropdown menu) All settings may expanded by clicking the 

"Expand all" link top right. 

General 

 

Name 

Whatever you type here will form the link learners click on to view the file so it is helpful to give it a name that 

suggests its purpose. 

Description 

Add a description of your file here if desired (or required.) Click "Show editing tools" to display the rich text 

editor, and drag the bottom right of the text box out to expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the file. 

Content 

 

Either drag and drop your file onto the arrow if you are using an appropriate browser, or click on "Add" and use 

the File picker to upload your file. 
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Appearance 

(These settings are collapsed by default) 

 

Display 

 Automatic - Make the best guess at what should happen (probably what is wanted 99% of the time). 

 Embed - Show the Moodle page with heading, blocks and footer. Show the title/description of the item and 

display the file directly in the page as well (good for images, flash animations, videos?, PDFs). 

 Force download - user clicks on the file, then the web browser pops up with the 'where do you want to save 

this file' box. 

 Open - No Moodle heading, blocks, footer or description - just show the file in the web browser (e.g. shows 

image, PDF, flash animation, taking up the whole browser window) 

 In pop-up - Same as 'Open', but opens a new browser window to show this file (without the Moodle 

heading, blocks, etc) - this browser window also does not have all the menus and address bar in it. 

 The following additional options are only there if you enable them via Site administration > Plugins > Activity 

modules > File: 

 In frame - show the Moodle heading and the file description, with the file displayed in a resizable area below 

(images, PDF, flash, etc. supported). 

 New window - very much like 'in pop-up', but the new window is a full browser window, with menus and 

address bar, etc. 

All of the above is true of items that can be displayed inside the browser directly (e.g. images, text files, PDFs 

(with plugin)). If the file cannot be displayed within the browser (e.g. word documents, without a suitable plugin, or 

other files that need to be loaded by an external program), then the pop-ups or frames, etc. will be created, but then 

the browser will take over and ask if you want to save the file. 

To summarise: 

 Do you want Moodle to sort it all out for you? - Automatic 

 Do you want to force the user to save the file (or open it in a program on their desktop)? - Force download 

 Do you want to show the file as part of the Moodle page (images, PDFs, videos)? - Embed 

 Do you want to show the file in the browser, but without the Moodle page decorations (images, PDFs, videos)? - 

Open 

 Do you want that, but in a new window? - In Pop-up (or possibly 'New window') 
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 Do you want to use a horrible bit of non-strict HTML that should never be allowed in polite company? - In frame 

Show size.type 

To show the file size and/or type on the course page and also on the resource page, simply tick the appropriate 

checkboxes. 

Display resource name/description 

To show the resource name and/or description when clicking to access the file, simply tick the appropriate 

checkboxes. 

Pop-up width/height 

(This setting is visible when "Show more" is clicked.) 

If your file is to be displayed in a pop-up, specify the width and height here. 

Use filters on file content 

(This setting is visible when "Show more" is clicked.) 

If you wish included media such as images and mp3 to appear embedded in the files then select "all files" or 

"HTML files only", according to your file types. (Note that this setting may cause problems for some Flash and Java 

applets.) 

Displaying a website index page 

The file module may be used if you have a folder with linked files such as a website with an index.html file or a 

flash activity with xml/swf and index file. 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Drag and drop the zipped folder onto the course section where you'd like it to appear, answer 'Create file 

resource' to the popup dialogue, then click the upload button 

3. Clicking the editing icon (hand with a pen) then click on the zip file and unzip it 

4. Click on the index.html file or the file you want to start displaying your linked files from then in the popup 

dialogue click the button 'Set main file'. This ensures this file is the one that appears on the course page for 

students to click on. The main file is then indicated with a title in bold. 

5. Click the button 'Save and display' at the bottom of the page 
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2.4.6 Folder resource 

A folder allows a teacher to display several course resources together. The resources may be of different types 

and they may be uploaded in one go, as a zipped folder which is then unzipped, or they may be added one at a time to 

an empty folder on the course page. 

 

Using a folder to display resources is neater than displaying files one by one in a list. It takes up less space on the 

course page. 

The downside is that at present you are forced to download files stored in a folder resource. You cannot have 

(for example) a folder of pictures where the user can view the pictures in Moodle without a download. 
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2.4.7 Folder resource settings 

Adding a folder to your course 

Note: Folders you wish to upload to Moodle have to be "zipped" or "compressed" first. The way you do this 

depends on your computer and operating system. 

If you already have a folder of files you would like to display, there are two methods: 

Quick method 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Drag and drop the folder onto the course section where you'd like it to appear 

3. Click the button of the action you would like to take with the folder (in our case, "Unzip") and click "Upload" 

4. If necessary, edit the title of the folder by clicking the pencil icon 

 

Longer method 

1. Click the 'Turn editing on' button at the top right of the course page 

2. Click 'Add an activity or resource' link, then in the activity chooser; select folder then click the "Add" button (or 

select folder from the "Add a resource" dropdown menu) All settings may expanded by clicking the "Expand all" 

link top right. 

 

 

 For General, add name and a description (which may be required or optional according to the admin 

settings). Click "Show editing tools" to display the rich text editor and drag the bottom right of the text box 

out to expand it. Enabling 'Display description on course page' will show it just below the link to the folder. 

 For Content, either drag and drop a zipped/compressed folder into the box with an arrow or click the Add 

button to open the File picker menu in order to choose a file from your computer or a repository. 

 When the folder thumbnail appears, click on it and select "Unzip": 
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 Click the original (zipped) folder and click the "Delete" button to delete it if you wish 

 Select how you want to display your folder contents, your Common module settings and, if 

enabled,Conditional activities settings and Activity completion and click "Save and return to course" 

 Click the button 'Save and return to course' at the bottom of the page 

Creating and uploading to a new folder 

1. Use this method if you want to create a folder on your Moodle course and then upload files into it. 

2. Click the 'Turn editing on' button at the top right of the course page 

3. Click 'Add an activity or resource' link, then in the activity chooser; select folder then click the "Add" button (or 

select folder from the "Add a resource" dropdown menu) 

4. Enter a name and a description (which may be required or optional according to the admin settings) 

5. Click the "Create folder" link as below; choose a name for your new folder and then click "Create folder" 

6. Click INTO the folder 

7. You can then add individual files into the folder either by dragging and dropping into the box (1 below) or 

clicking the "Add" (2 below) to upload files from the File picker 

8. Choose how you want to display your folder contents, your Common module settings and, if enabled, 

Conditional activities settings 

9. Click "Save and return to course" 

        

2.4.8 IMS content package 

IMS is a body which helps define technical standards for various things, including e-learning material. The IMS 

Content Packaging specification makes it possible to store chunks of material in a standard format which can be re-used 

in different systems, without having to convert the material into new formats. 

The IMS content package in Moodle enables such content packages to be uploaded and included in Moodle 

courses. There are various options for displaying content with a navigation menu or buttons etc. 
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Adding an IMS content package to your course 

You can add an IMS Content package to a course by choosing it from the "Add an activity or resource" link (or, if 

not present, the "Add a resource" drop down menu.) All settings may expanded by clicking the "Expand all" link top 

right. 

General 

 

Name 

Whatever you type here will form the link learners click on to view the IMS content package, so it is helpful to 

give it a name that suggests its purpose. 

Description 

Add a description of your package here. (This may or may not be required according to admin settings.) Click 

"Show editing tools" to display the rich text editor, and drag the bottom right of the text box out to expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the package. 

Content 

In the Content section, drag and drop your IMS Content package into the box with the arrow (1 below) or else 

click the button "Choose a file" to locate and add your IMS Content package via the File picker (2 below). 

 

2.4.9 Label 

A label serves as a spacer on a Moodle course page.It can be used to add text,images, multimedia or code in 

between other resources in the different sections. It is a very versatile resource and can help to improve the appearance 

of a course if used thoughtfully. Banners or descriptions may be added to labels to distinguish between and highlight 

different areas. 

On the other hand, over-use of multimedia (sound,video) in labels can slow down the loading of a course page. 
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Adding a label 

With the editing turned on to a course by choosing Label from the "Add an activity or resource" link (or, if not 

present, the "Add a resource" drop down menu) in the section where you want to add your menu. Click "Expand all" top 

right to see all the settings expanded. 

General 

Type your chosen words or add your resources. 

Note: Because the label has the text editor, it is possible not just to type words but also to add images, links, 

media or code from within the labels' editor.  

Adding images to a label 

Drag and drop images 

Note: this does not work with IE 9, Safari 6 or below or earlier versions of Firefox) 

 Media drag and drop must be enabled in Administration > Site administration > Plugins > Activity 

modules > Label 

 With the editing turned on, drag your image into the section you want it to appear. 

 In the box that follows, choose "add image" 

 It will appear embedded in a label. 
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Conventional method 

 Follow the instructions for adding a label 

 Click the image icon in the text editor 

 

 Click "Browse repositories" 

 Choose and upload your image using the filepicker. 

 Click "Save and return to course" 
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Adding a link to a label 

Conventional method 

As the label uses the Text editor it is straightforward to click the "link" icon and enter your linked URL. It is 

however possible also to drag and drop links directly into a label. 

Drag and drop links 

Note: this does not work with IE, Safari 6 or below and is unreliable with Firefox 

 Drag and drop upload of text/links must be enabled in Administration > Site administration > 

Development > Experimental > Experimental settings 

 Open up a new window with the URL you wish to link to. Select the link in the browser bar. 

 With the editing turned on, drag the URL over to the section you want it to appear. 

 From the box that appears, name the link and then click "upload". 

        

 

Adding sound or video to a label 

If multimedia filters are enabled, a label is a neat way of displaying sound or video in an inline player on the 

course page. 

 Follow the instructions for adding a label 

 Click the media icon in the text editor 

 

 Click "Find or upload an sound,video or applet" 

 Choose and upload your sound or video file using the filepicker.(Details on how to do this here) 

 Note: You can search youtube for a video to embed if your admin has enabled the youtube 

repository. 

 Leave Common module settings at "show" if you wish the label to be visible. 

 Click "Save and return to course". 
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Adding code to a label 

An example of this is the ability to embed a Google map into a label. 

 Follow the instructions for adding a label 

 Expand the toolbar and click the HTML icon in the text editor 

 

 This brings up the screen in code (HTML) view. 
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 Paste the code you grabbed from Google maps into this screen 

 Scroll down and click "Update" 

 

 Leave Common module settings at "show" if you wish the label to be visible. 

 Click "Save and return to course" 

 

Note: The success in adding code to a label depends both on the type of code and the permissions of the user.  

2.4.10 Page resource 

A page resource creates a link to a screen that displays the content created by the teacher. The robust Text 

editor allows the page to display many different kinds of content such as plain text, images, audio, video, embedded 

code or a combination of all these. 
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In certain cases it might be preferable to use the page resource instead of uploading a word-processed 

document, particularly if the document contains text that is just to be read and not downloaded. 

2.4.11 Page resource settings 

Adding a new page to your course 

 From the the "Add an activity or resource" link (or, if not present, the "Add a resource" drop 

down menu), choose Page All settings may expanded by clicking the "Expand all" link top right. 

 In the "Adding a new page" screen that follows, give your page a name and a description (which 

may or may not be required according to admin settings) 

 Add your content to the Page content section. 

General 

 

Name 

Whatever you type here will form the link learners click on to view the page so it is helpful to give it a name that 

suggests its purpose. 

Description 

Add a description of your page here. Click "Show editing tools" to display the rich text editor, and drag the 

bottom right of the text box out to expand it. 
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Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the page. 

Content 

 
Add your page content here. You can use the features of the Text editor to add media, images, links and more. 

Appearance 

(These settings are collapsed by default.) 

 
Choose here whether or not to display the page description along with the page content when a user clicks on 

the page. 

If the administrator has allowed both 'open' and 'pop-up' as display options (from Administration>Site 

administration>Plugins>Activity modules>Page), you will have additional display settings here. 

Why a page and not a file? 

1. Opens seamlessly - no clunky attempts to launch third party software (e.g. Microsoft Word) 

which some users may not be able to access. 

2. Can be accessed by mobile devices e.g. smartphones (again, not all smartphones can handle 

word-processed documents) 

3. Much easier for the Teacher to edit (i.e. saves time) 

4. Much more accessible, and readily configurable for reading (easier to resize text, change 

colours, etc, in the web browser) 

5. Can contain links - e.g. to files, to web pages, or to Glossary entries 

When to use a page rather than a file 

Use a page if: 

 The document doesn't need to be printed 
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 You need to update it fairly often 

 You don't need to impose strict control over the way it looks (for accessibility reasons you should, if 

educationally appropriate, avoid taking control) 

 Your students may need to refer to it (on their smartphone for example) frequently for reference 

e.g. timetable, schedule, tutorial groups, reading list. 

How to create a page 

 Typing directly into the Editor 

 Drag and drop text into a page: It's possible to select text from a website or a word processed 

document and create a page by drag and drop. 

Note: this does not work with IE, Safari 6 or below and is unreliable with Firefox 

1. Drag and drop upload of text/links must be enabled in Administration > Site administration > Development > 

Experimental > Experimental settings 

2. Select the text you wish to use, for example in a Word document. Note: Pasting from MS Word is fraught with 

danger. 

3. With the editing turned on, drag the text over to the section you want it to appear. 

4. From the box that appears, choose "Create a new page resource" 

5. Give it a name and then click "upload". 

                  

 

Pasting from another document 

To safeguard against unpredictable, ugly, and inaccessible results, it's important to take some easy extra steps 

when pasting word processed and other text into web authoring software including Moodle. 

1. Open the document containing the text you want to paste into your new Page, and copy that text ready to 

paste. 

2. Follow steps 1-6 for the section above on 'Typing directly into the editor'. 

3. When you are ready to paste the content into Moodle, you have two choices: 

4. If you want to keep the original formatting then click the Paste From Word icon; a pane loads containing an 

empty text field and you can press your keyboard's Control and V keys to paste what you copied into the 

text field; then click the Insert button; your text appears and can be edited within learn.gold. N.b. if the 

original formatting does not conform to Web accessibility requirements, it won't be transferred. 



 

                                                                                                                                            
242 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

5. Alternatively, if you want to strip away all formatting, rather than the Paste From Word icon you instead 

click the Paste As Plain Text icon and proceed to paste directly. 

6. Follow steps 8-9 for the section above on 'Typing directly into the editor'. 

2.4.12 URL resource 

A URL (Uniform or Universal Resource Locator) is a link on the internet to a website or online file. Teachers can 

use the URL resource to provide their students with web links for research, saving the student time and effort in 

manually typing out the address. The URLS can be displayed in various ways - for example, opening in a new window so 

a student can access and use the URL, close it and return easily to their original Moodle course page. 

 

Adding a URL resource to your course 

1. Turn editing on. 

2. From the the "Add an activity or resource" link (or, if not present, the "Add a resource" drop 

down menu), choose URL. All settings may expanded by clicking the "Expand all/Collapse all" link top right. 

General 

 

Name 

Whatever you type here will form the link learners click on to view the URL so it is helpful to give it a name that 

suggests its purpose. 
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Description 

Add a description of your page here. Click "Show editing tools" to display the rich text editor, and drag the 

bottom right of the text box out to expand it. 

Display description on the course page 

If this box is ticked, the description will appear on the course page just below the name of the URL. 

Content 

 

Either enter the URL in the external URL field or click the "Choose a link" button to open the file picker and 

choose a URL YouTube, Picasa etc. 

Appearance 

(These settings are collapsed by default) 

 

Display 

 Automatic - Make the best guess at what should happen (probably what is wanted 99% of the 

time). 

 Embed - Show the Moodle page with heading, blocks and footer. Show the title/description of 

the item and display the file directly in the page as well 

 Open - No Moodle heading, blocks, footer or description - just show the file in the web browser 

(e.g. shows image, PDF, flash animation, taking up the whole browser window) 

 In pop-up - Same as 'Open', but opens a new browser window to show this file (without the 

Moodle heading, blocks, etc) - this browser window also does not have all the menus in it. 

The above options are the default display options. Additional display options (see below) may be enabled by an 

administrator in Site administration > Plugins > Activity modules > URL. 

Pop-up width/height 

If your URL is to be displayed in a pop-up, specify the width and height here. 
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Display URL name/description 

To show the resource name and/or description when clicking to access the URL, simply tick the appropriate 

checkboxes. 

URL variables 

(These settings are collapsed by default.) 

 

This section allows you to pass internal information as part of the URL. 

This is useful if the URL is actually an interactive web page that takes parameters, and you want to pass 

something like the name of the current user, for example. 

Drag and Drop a URL 

Alternatively, if an administrator has enabled the experimental feature drag and drop upload of text/links 

inSettings > Site administration > Development > Experimental > Experimental settings, a link can be dragged into a 

section of the course and given a name, as shown in the images below. 

 

2.5 Blocks 
Blocks are items which may be added to the left or right or centre column of any page in Moodle. They may also 

be added to the centre of the My Home page.  
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Any block can be made 'sticky' so that it appears in all the contexts below, such as throughout a course or a 

particular activity. 

Blocks can be placed on the side of the screen (if your theme supports it) via the Dock icons.  

 

2.5.1 Block settings 

Adding a block to a page 

Blocks can be added to a page by turning editing on then using the 'Add a block' drop-down menu. 

Note: The ability to add a particular block to a page is controlled by an addinstance capability 

(e.g.block/comments:addinstance), which is allowed for the default role of teacher. 

Block configuration 

After adding a block, click the edit icon in the block header to configure it. 

Block settings 

Certain blocks, such as the HTML block, allow a block title and more to be set. 

 

Where this block appears 

Depending upon the context and user permissions, this area determines where this block will appear. 

 Original block location: provides information about where the block was initially created. 
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 Display on page types: allows the user to set the context that the block can appear in. These 

options will vary depending upon the permissions of the user. For example a site administrator might see a 

setting that will allow the block to appear on Any page, or any type of course main page, while a teacher 

may only see the option to place it on every page in the course. 

 Default region: Usually a right column or left column option 

 Default weight: Where in the column do you want it to appear if there are other blocks in that 

column. -10 will put it at the top, 10 will put it at the bottom. A zero is neutral. 

 

On this page 

 Visible - Yes or No. 

 Region - Here you can override the column preference on this page. 

 Weight - Here you can override the default setting on this page. 

 

Block permissions 

To change role permissions for a block 

1. Turn editing on in the course 

2. Click the Assign roles icon (a face and mask) in the header of the block 

3. In the administration block, go to Block administration > Permissions (ignore the message 'You 

are not able to assign any roles here', which is to be expected, since roles are not generally assigned in the 

block context) 
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2.5.2 Activities block:   

The Activities block lists and allows navigation between the different activities available in your course 

(Forums,Quizzes, Assignments, Lesson module and so forth). The activities list will grow as you add activities to your 

course. Therefore, the first time you enter your course, the only category that is listed is Forums. This is because one 

forum exists by default – the news forum. 

 

Admin bookmarks block 

This block allows an administrator to bookmark site admin pages for easy access. These include the Notifications 

and Add/Edit courses pages. The administrator will then see the pages as a list of links.  

Note: Only site admin pages can be bookmarked i.e. pages accessed via Administration > Site administration.  

When on a page which may be bookmarked, the block shows 'bookmark this page'. 

(1) Once bookmarked, the block shows the page name with a link and "Unbookmark this page". (2) When on a 

different site admin page, other links are shown with 'Bookmark this page' available for the current page. (3) When on a 

bookmarked page, the block shows current bookmarked links and the option to 'Unbookmark this page.' (4) 
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The admin bookmarks block is shown by default on all pages which can be bookmarked. An admin may choose 

to add the admin bookmarks block to their My home page or the front page (selecting 'Display on the front page only'). 

Note: Although an admin can add the admin bookmarks block to the front page of their site and make it display 

throughout the entire site, this is not recommended, since it results in teachers seeing the block when they turn editing 

on in their course. 

2.5.3 Administration block 

The Administration block provides context-sensitive links to settings pages.  

What appears in the Administration block depends upon the Context (Page being shown and user's 

permissions). For example, a site administrator on the front page will have Front page settings while a teacher in a 

course will have more options in Course administration than a student. 

                      

2.5.4 Calendar block 

The Calendar block displays the following events: 

 Site (event viewable in all courses - created by admin users) 

 Course (event viewable only to course members - created by teachers) 

 Groups (event viewable only by members of a group - created by teachers) 

 User (personal event a student user can create - viewable only by the user) 

 

 

 

 

 

 

 

 

 



 

                                                                                                                                            
250 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

2.5.5 Course completion status block 

The course completion status block shows what has been done towards completing the course. The student and 

teacher will both see this block. The "More information" link will lead to a more detailed report. This report can have 

some interactive elements in the form of check boxes for the student and teacher. 

The "Course completion block" must be added to the course in order to see the "Course completion status" 

block. 

Student view of Course completion status block 

The student can see their progress in the course by looking at the content of the block or clicking on the "More 

details" link to see a report. 

The student, if required, can mark an activity as completed on the course's homepage. 
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Teacher view of Course completion status block 

This block shows the status for each student. It is also the place where the teacher (or others) can mark the 

course as complete. 
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Note: The course completion status block will only appear if completion tracking criteria are set in Settings > 

Course administration > Completion tracking 
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 2.5.6 HTML block 

 A HTML block is a standard block used to add text, multimedia, widgets etc to a site front page or course page. 

The title bar may be left blank if desired. 

 

 The block is flexible and can incorporate a variety of functions and uses in the content area. It has the standard 

Moodle Text editor for formatting text, adding images or creating links, switching to code view and allows any valid 

HTML mark-up to be used. This enables embedding video, sounds, Flash, and other files which can add unique elements 

to a course or site page. 

 2.5.7 Latest news block 

 Recent posts made in the News forum are displayed in the Latest news block, along with a link to older archived 

news. 
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 By default, the Latest news block displays 3 news items. This may be changed in Settings > Course administration 

> Edit settings. 

 2.5.8 Logged in user block 

The logged in user block displays certain information about the user who is currently logged in to a Moodle course: 

 

The information which is displayed can be selected by the course teacher by clicking on the "configure" icon of the 

block. A number of dropdown boxes then appear for the teacher to choose which items will appear: 

 

 2.5.9 Main menu block 

 The main menu block can be added to the front page of the site by a site administrator. Resources and activities 

can then be added to the front page,( for example to create a side menu for your Moodle site.) 
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 The main menu block as a side menu 

 It is possible to use the main menu block with Moodle pages to create a side menu for your Moodle site, instead 

of or as well as the custom menu items at the top of your site. Thus you could have pages "About", "Contact" and so on. 

1. Turn on the editing on the front page 

2. From the "Add block" dropdown, add the main menu block if it is not already present 

3. From "Add an activity or resource" choose Page and add your information. 

4. Repeat for other pages. 

 When the editing is turned off the menu block appears as in the screenshot below: 

 

 2.5.10 Messages block 

 The message block displays a list of new messages you have received, with a link to your Messages window. 

 

 To add a Messages block to your course page: 

1. Click on the "Turn editing on" button. 

2. Select Messages from the Add blocks menu. 

3. If appropriate, move the Messages block up and/or left, using the arrow icons under the block title. 
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 2.5.11 Navigation block 

 The navigation block appears on every page of the site. It contains an expanding tree menu which includes My 

Home, Site Pages, My Profile, and Courses. What appears in the navigation block depends on the role of the user, where 

they are in the Moodle site, and any settings that have been applied globally.  

 Overview 

 The navigation block has links which can be expanded or collapsed.When logged in, a regular user will see the 

following as default: 

 

 My home 

 This takes the user directly to their personal dashboard, My home. 

 Site pages 

 This expands to show pages and resources available site wide, for example, user blogs and a calendar. Any items 

which have been added to the front page, such as resources/activities from the Main Menu block, or the Site News will 

also appear here. Other items depend on the role of the user, so an administrator will see reports and notes, for 

instance. 
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 My profile 

 This expands to allow regular users to view (and, if allowed, edit) their profile, view their forum posts, view and 

add and blog entries and messages and access their private files, providing these features have been enabled by the 

administrator. The administrator will also have a link here to Notes and Activity reports. 

 

 My courses 

 This takes the user to their My Home page where they see the courses they are enrolled in. An administrator 

sees this link as "Courses", which expands to the course categories. 

 Navigation inside a course 

 Current course 

When user is in a course, this link expands to show each section of the current course and any activities/resources which 

are in that section. 

 My courses 

When a non-admin user clicks this link in a course, it takes them to their My home page where they will see other 

courses they are enrolled in. 

 Courses 

If the administrator has enabled "show all courses" in Settings>Site administration>Appearance>Navigation, then 

clicking on this link in a course will take the user to the courses index page course/index.php. 
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 Navigation block settings 

 An administrator can change navigation settings, such as the default home page, and whether to show course 

categories in the navigation, in Settings > Site administration > Appearance > Navigation.  

 2.5.12 Online users block 

 The Online users block shows a list of users who have been logged into the current course. The list is updated 

on a regular basis (the default is every 5 minutes but this may be changed - see below). 

 

 Note that even though a user may have been logged into a course within the last 5 minutes, it does not 

necessarily mean that this user is still online. 

 If you hold the cursor over somebody's name, you will see how long ago that person was last "seen" in the 

course 

 If you click on the envelope icon next to somebody's name, you will be able to send a private message to that 

person (using Moodle's messaging system) 
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 Note: If separate groups are enabled in a course and this block is added onto the course page, only members of 

the group will be displayed in the list. 

 Site administration settings 

 The online users block has one setting which may be changed by an administrator in Administration > Site 

administration > Plugins > Blocks > Online users. 

 block_online_users_timetosee - The number of minutes after which users will not be displayed in the list. 

The default is 5 minutes. You may want to adjust this if the list of users displayed is too long or too short. 

 2.5.13 Recent activity block 

 You know that game where everybody except one leaves a room, the person who's left changes just one thing, 

then everybody comes back and has to spot the thing that changed? 

 Enabling the Recent Activity Block will show participants updates since they last accessed the course. 

 Without it (unless you go out of your way to notify them) students and colleagues are prone to miss the changes 

you make e.g. modifications or additions, because they don't have an exact memory of that course as they last left it 

and because they have no way of knowing when to look for a change. 

 The Recent Activity Block can relieve a lot of anxiety in students who are worried about missing something 

important. 

 The Recent activity block lists course activity, such as updated resources and activities, forum posts and 

assignment submissions, since the user last accessed the course. 

                                 

 Full report of recent activity 

 A full report of recent activity can be accessed via a link in the recent activity block. This will lead to a screen 

which has a time filter and organizes activity by course sections. 

 The advanced search button or link has more filter options. These include selecting all or a specific: participant, 

activity, since date. It also allows the list to be sorted in course order, oldest to recent or recent to oldest date. There is 

a link to return to the Normal search screen. 



 

                                                                                                                                            
260 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 Search forums block 

 The Search forum block allows you to search the course forums for a word or phrase. Type the word or phrase 

you want to find in the text field space. 

 

 For basic searching of one or more words anywhere in the texts, just type them separated by spaces. All words 

longer than two characters are used. If you want to use advanced search options you can either move to the Advanced 

Search page (clicking Advanced Search in the Search Forums block) or use 

 To force exact matching of a word, use the plus sign, and the minus sign if there are particular exact words you 

don't want included in the search. To search for a particular phrase, use double quotes around it. To search for texts by 

a particular user, prefix a word from their name with "user:". If you know the user id of a particular user, you can search 

for them like this. To search for a word within the subject or title of a text only, prefix the word with "subject:". 

 You can also use the Advanced forum search options. 

 Advanced forum search 

 To use the advanced search options press the Advanced search button or the search button without typing 

anything in the Search field. You will see a complete form that makes it easier to do advanced searches. 

 These words can appear anywhere in the post works in the same way as the Search field: one or more words 

you type in here will be found in all the places in the post they appear. 

 This exact phrase must appear in the post searches for an exact phrase in the post 

 You should use These words should NOT be included if there are any particular words you don't want 

included in the search 

 Posts must be newer / older than this narrows down the number of posts searching according to time limits. 

 Choose which forums to search allows searching only in one forum 

 These words should be in the subject narrows down the number of posts found to those containing a given 

word/phrase in the forum subject 

 This name should match the author allows searching for the posts by one author 

 2.5.14 Self completion block 

 The self completion block provides a link for students to declare that they have completed the course. This 

maybe part of the Course completion requirements. 

 When a student believes they have completed the course, they click on the "Complete course" link in this block. 
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 Using the self completion block 

 To allow a student to decide for themselves when they have completed a course, there are two requirements: 

 The completion tracking setting must have the "Manual Self Completion" box checked. 

 The Self completion block must be added to the course. 

 The student may then click the "complete course link" in the block. 

 They are then asked to confirm they have completed the course and the course status will change to "complete" 

after the next Cron job. 

 

 2.5.15 Social activities block 

 This block enables additional activities to be added to a course in social format. 

 

 Note: it is not available for other course formats. 

 2.5.16 Upcoming events block 

 The Upcoming events block displays future events in a summarized list. The number of days in advance is 

determined by the calendar_lookahead setting in Site Administration > Appearance > Calendar. BUT it seems the look-

ahead has a setting in Preference on the user page when logged in. This setting, when logged in, seems to over-ride the 

setting described above. It is not clear if there is a way to extend Calendar > Preference look-ahead setting, beyond the 

20 days that it offers. 
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 Events are generated directly from the calendar and/or activity deadlines, providing a link to full details or 

directly to the activity. 

 There are also links to Go to calendar... and add a New Event.... 

 If you click on a date, you will go to the day-view calendar for that day. If the title of the event is a link, and you 

click on it, you will be taken to that event. 

 2.6 Questions 
 Questions can be created in Moodle for use in quizzes and for import into lessons. 

 2.6.1 Question types 

 Calculated 

 Calculated questions offer a way to create individual numerical questions by the use of wildcards (i.e you can 

use common variables names as x , y enclosed in curly braces to create the wildcards {x} and {y}) that are substituted 

with individual values when the quiz is taken.   

 For example, if you want to create a large number of "Calculate the area of a rectangle" problems to drill your 

students, you could create a question with two wildcards (i.e. {base}, {height} created from the 

common base,height variable names) and put in the "Correct Answer Formula=" input field {base} * {height} ( * being 

the multiplication sign ). 

 When a student takes the test, Moodle will randomly select values for {base} and {height} and grade the 

response using the result of the Correct Answer Formula. 

 The test will very rarely appear the same way twice. 
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Wildcards and datasets 

When Moodle delivers a Calculated question to the student, the wildcards are replaced with randomly-selected 

values. However, these values are not completely random - rather, they are randomly selected from a pre-

defined dataset of possible values. This allows you some control over the possible values chosen - for example, in order 

to make sure the numbers are realistic. 

These datasets can be private or shared - private datasets are used by one wildcard within one calculated 

question; shared datasets are used by one wildcard within all calculated questions that use it. 

Question set-up 

To create (or modify) a calculated question there are three pages to work through. The instructions below take 

you through the pages, step by step: 

Page 1. Editing a Calculated question 

1. Select the question category 

2. Any shared wildcards for this category are listed beneath. If you change category, you'll need to click the 

"Update the category" button to refresh this list. There may not be any shared wildcards yet - if not, you can 

create them later if you wish. 

3. Give the question a descriptive name - this allows you to identify it in the question bank. 

4. Enter the question text. This should be the question you want the student to answer, and it must include all the 

information they need to calculate an answer. Therefore it must contain at least one wildcard, inside curly 

braces. For example, if you wanted the student to sum numbers A and B, the question text might read: "What is 

{A} + {B}?" You may also include quantities computed from wildcards using the syntax "{=...}: for example, the 

question "What is {={A}+{B}} - {A}?" with wildcard values A=4 and B=3 would display as "What is 7 - 4?" 

5. Select an image to display if you want to add a picture to the question. For the student, it appears immediately 

after the question text and before the choices. If you want more control over how the image appears, include it 

in the question text above, using the HTML editor. 

6. Set the default question grade (i.e. the maximum number of marks for this question). 

7. Set the Penalty factor (see Penalty factor below). 

8. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

9. Next add the formula for the answer. This formula must contain at least the wildcards that appear in the 

question text. See Correct answer formula syntax for further details. 

10. Choose the grade that the student will get for this question if they give this answer. This should be a percentage 

of the total marks available. For example, you could give 100% for a correct answer, and 50% for an answer that 

is nearly right. One of the answers must have a 100% grade. 

11. Determine the tolerance for error that you will accept in the answer. The tolerance and tolerance type settings 

combine to give a range of acceptable scores. So, if tolerance = t, correct answer = x and the difference between 

the user's answer and the correct answer is dx, then the tolerance types are as follows: 

a. Nominal - mark correct if dx <= t 

b. Relative - mark correct if dx / x <= t 

c. Geometric - mark correct if dx² / x² <= t² 

12. The next 2 settings, "Correct answer shows" and "Format" determine the precision of the answer. Use these to 

select the number of decimal places or significant figures you want to use. 

13. Add some feedback which the student will see if they enter this answer. 

14. You can specify as many answer formulae as you like - click "Add another answer blank" to add more. 
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15. You can also specify units for the answers. For example, if you enter a unit of 'cm' here, and the accepted 

answer is 15, then the answers '15cm' and '15' are both accepted as correct. If you add more than one unit, you 

can also specify a multiplier. So, if your main answer was 5500 with unit W, you can also add the unit kW with a 

multiplier of 0.001. This means that the answers '5500', '5500W' or '5.5kW' would all be marked correct. Note 

that the accepted error is also multiplied, so an allowed error of 100W would become an error of 0.1kW. 

16. Finally (!) you can click "Next page" to save what you've done and move on. If you are editing an existing 

question, you can click "Next page (new question)" to create a completely new question based on an existing 

one. 

Penalty factor 

The 'penalty factor' only applies when the question is used in a quiz using adaptive mode - i.e. where the 

student is allowed multiple attempts at a question even within the same attempt at the quiz. If the penalty factor is 

more than 0, then the student will lose that proportion of the maximum grade upon each successive attempt. For 

example, if the default question grade is 10, and the penalty factor is 0.2, then each successive attempt after the first 

one will incur a penalty of 0.2 x 10 = 2 points. 

Tolerance 

As for numerical questions it is possible to allow a margin within which all responses are accepted as correct. 

The "Tolerance" field is used for this. However, there are three different types of tolerances. These are Relative, 

Nominal and Geometric. If we say that the correct answer at quiz time is calculated to 200 and the tolerance is set to 0.5 

then the different tolerance types work like this: 

Relative: A tolerance interval is calculated by multiplying the correct answer with 0.5, ie in this case we get 100 

so for this tolerance the correct response must be between 100 and 300. (200 ± 100) This is useful if the magnitude of 

the correct answer can differ greatly between different wildcard values. 

Nominal: This is the simplest tolerance type but not very powerful. The correct response must be between 

199.5 and 200.5 (200 ± 0.5) This tolerance type can be useful if the differences between different correct answers are 

small. 

Geometric: The upper limit of the tolerance interval is calculated as 200 + 0.5*200 and is the same as for the 

relative case. The lower limit is calculated as 200/(1 + 0.5). The correct response must then be between 133.33 and 300. 

This is useful for complex calculation that must have great tolerances where relative tolerances of 1 or more would be 

used for the upper limit but clearly not acceptable for the lower limit as it would make zero a correct answer for all 

cases. 

The field Significant Figures does only relate to how the correct answer should be presented in the review or the 

reports. Examples: If it is set to 3 then the correct answer 13.333 would be presented as 13.3; 1236 would be presented 

as 1240; 23 would be presented as 23.0 etc. 

Page 2. Choose dataset properties 

Each wildcard that you specify in the answer formula must have an associated set of possible values - this is 

itsdataset. Each of the wildcards is listed on this page along with a choice of dataset: 

 private i.e. only used by this question 

 shared i.e shared with other calculated questions in the same category 

 Using a shared dataset can save time when you are creating a lot of similar calculated questions. 
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Note that even when creating a question for the first time, this page may say that your wildcard "will use the 

same existing private dataset as before." This just means that Moodle has already tentatively created a private data set 

for that wildcard: if a private dataset is what you want, leave this choice selected. 

If there is anything in the question text that looks like a wildcard, but does not appear in any of the answer 

formulae, you can specify whether or not this is meant to be a wildcard. If it is, you can choose whether it should use a 

private or shared dataset. 

To continue, simply choose your preferred dataset for each wildcard, then click "Next Page". 

Page 3. Edit the datasets 

Now we need to create the set of possible values that each wildcard can take. Warning - this page is a bit 

confusing! 

There are two ways of creating values - you can type them in yourself and add them to the list, or you can have 

Moodle generate them for you. 

Adding/deleting your own values 

Adding individual values to the list is easy: 

1. In the 'Param' field for each wildcard, enter the value you want 

2. Scroll down to the 'Add' section and click the Add button (leaving the number of items set to 1) 

3. Repeat the above steps as many times as necessary (the maximum number of items is 100) 

 To delete values from the list: 

1. In the 'Delete' section, select the number of items to delete 

2. Click the Delete button 

 Letting Moodle create values 

1. Start with the "Range of Values" fields, and enter the lower and upper limits for the values you would accept 

2. Choose a number of decimal places for the value 

3. Choose the distribution of values between the limits - 'uniform' means any value between the limits is equally 

likely to be generated; 'loguniform' means that values towards the lower limit are more likely. 

4. Now move down to the 'Add' section and click on "force regeneration" 

5. In the menu next to the Add button, choose the number of sets of random values (items) you wish to add to the 

list. (Note that the maximum total number of items in your list is 100.) 

6. Finally, click Add to append the new values to the list 

7. Note: If you want more control over the items that Moodle adds, you can do them one at a time and preview 

the values before you add them. Click the "Get New Item to Add" button to make Moodle generate new values 

in the "Item to Add" section at the top. If you like them, click "Add" for 1 item; if not, click "Get New Item to 

Add" again to get new values. 

 Finishing off 

 Once your list of items (values) is complete, you are finished. It's up to you how many values you add - the more 

values you add, the more a question can be used by the students without them seeing the same values repeatedly. 
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Note that if you delete values from the list, you can put them back again. Change the "Next Item to Add" option 

to "reuse previous value if available", then the next time you add items, Moodle will restore your previously-deleted 

items from the dataset. 

Once your list of values is complete, you can click 'Save changes' to finish. 

What does the 'Update the datasets parameters' button do? 

Warning: This button can affect several questions, so be careful before using it. Assume you have selected 

dataset parameter for {a} to be any value between 1-10 and generated a question. In the second question also you 

decide to use a SHARED wildcard called {a}. Inherently, it will show a value between 1-10. However, your need here 

changes and you want to make it 11-100 instead. Then, you change them in the range and click this button. Voila! the 

values change and you can add new items here using the 'Get New item to add'. However, if you go back to your 

previous question, you will see that values would change there too, because it is a shared dataset. If you do not update 

parameters, then this may not happen and will generate a new set of values and displays them in the "Item to Add" 

section. 

Correct answer formula syntax 

DO NOT PUT THE = sign in the formula. 

In the recent versions of the calculated question type, you could have more than one answer formula and 

applied a specific grading value to each of them as long as there is at least one 100% correct answer formula. 

As a general rule, write these formulas like you would in a calculator e.g. 3 + 5 * sin(3/{x}) A notable exception is 

exponentiation, where x3 cannot be entered as {x}^3, but instead should be entered aspow({x}, 3). 

Each function's placeholders and other arguments should be in parentheses (brackets). For example, if you want 

students to calculate the sine of one angle and cosine of two times another angle, you would entersin({a}) + 

cos({b}*2) or sin({a}) + cos(2*{b}). 

It's usually better to have too many parentheses (brackets) than too few. The server won't care, and the more 

specific you are about what you mean, the more likely it will like your complex formulas. 

There is no implicit multiplication. To you, the human editor, "5(23)" or "5x" may seem perfectly obvious. To the 

server doing the math, it's crazy talk and won't be understood. Always use the "*" for multiplication. 

Any special mathematical function must have parentheses around its values. Take the sine function in the first 

bullet point for instance. Notice that the 3 / x is wrapped in parentheses (brackets)--this is so the server can understand 

it properly. Without those parentheses, the server won't know if you mean "(sin 3) / x" or "sin (3 / x)" and will reject the 

entire formula accordingly. 

Available functions 

Calculated questions can use more than simple arithmetic operators. 

Function Explanation 

abs Absolute value 

acos Arc cosine -- output in radians. 
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acosh Inverse hyperbolic cosine -- output in radians. 

asin Arc sine -- output in radians. 

asinh Inverse hyperbolic sine.-- output in radians. 

atan2 Arc tangent of two variables -- pass in two values like (y, x), and you'll get the atan(y/x), 

adjusted to the proper quadrant. (Note: The variables are in the reverse order to 

atan2(x,y) in Excel) Output is radians. 

atan Arc tangent -- output in radians. 

atanh Inverse hyperbolic tangent-- output in radians. 

bindec Binary to decimal 

ceil Round fractions up 

cos Cosine -- in radians!!! Convert your degree measurement to radians before you take the 

cos of it. 

cosh Hyperbolic cosine -- in radians!!! Convert your degree measurement to radians before 

you take the cosh of it. 

decbin Decimal to binary 

decoct Decimal to octal 

deg2rad Converts the number in degrees to the radian equivalent 

exp Calculates the exponent of e 

expm1 Returns exp(number) - 1, computed in a way that is accurate even when the value of 

number is close to zero 

floor Round fractions down 

fmod Returns the floating-point modulus of two numbers - i.e. the remainder when the first is 

divided by the second. 

is_finite Finds whether a value is a legal finite number 

is_infinite Finds whether a value is infinite 

is_nan Finds whether a value is not a number 

log10 Base-10 logarithm 

log1p Returns log(1 + number), computed in a way that is accurate even when the value of 
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number is close to zero 

log Natural logarithm (ln) 

max Find highest value 

min Find lowest value 

octdec Octal to decimal 

pi() Get value of pi - the function does not take an argument, like in Excel. 

pow (numberToRaise, 

NumberRaisedTo) 

Exponential expression 

rad2deg Converts the radian number to the equivalent number in degrees 

rand Generate a random integer 

round Rounds a float 

sin Sine -- in radians!!! Convert your degree measurement to radians before you take the sin 

of it. 

sinh Hyperbolic sine -- in radians!!! Convert your degree measurement to radians before you 

take the sinh of it. 

sqrt Square root 

tan Tangent -- in radians!!! Convert your degree measurement to radians before you take the 

tan of it. 

tanh Hyperbolic tangent -- in radians!!! Convert your degree measurement to radians before 

you take the tanh of it. 

 

Predefined constants 

Actually there is NO Predefined constant that is allowed other than pi() as a function without parameter. 

Synchronization 

You could use shared wild cards to get the same values across questions in a quiz. 

A simple example will be to use the same radius in a first question asking for the perimiter of a circle of 

{radius}cm and a second question asking for the surface of a circle of {radius}cm. 

When the quiz will be shown to the student the two questions will shown the same {radius} value. 

However the synchronization will work ONLY if the questions are kept in the SAME category and have the SAME 

NUMBER OF DATASETS . 
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If you need to move the synchronized questions to another category, you need to do it by editing the questions. 

Calculated multi-choice 

Calculated multichoice questions are like multichoice questions with the additonal property that the elements 

to select can include formula results from numeric values that are selected randomly from a set when the quiz is taken. 

They use the same wildcards than Calculated questions and their wildcards can be shared with other Calculated 

multichoice or regular Calculated questions. 

The main difference is that the formula is included in the answer choice as {=...} i.e if you calculate the surface of 

a rectangle {={l}*{w}}. 

The value will be displayed as set by the Correct answer shows (0,1,2 etc) and Format (decimals, significant 

figures). 

So a Choice text could be 

The rectangle surface is {={l}*{w}} cm2. 

If {l} = 4,0 , {w} = 2,5 , Correct answer shows 1 and Format decimals 

The choice will display as 

The rectangle surface is 10.0 cm2 

Simple calculated question type 

Simple calculated questions offer a way to create individual numerical questions whose response is the result of 

a numerical formula which contain variable numerical values by the use of wildcards (i.e {x} , {y}) that are substituted 

with random values when the quiz is taken. 

The simple calculated questions offers the most used features of the calculated question with a much simpler 

creation interface. 

My first Simple calculated question 

As a first example you will create a question asking for the surface of a rectangle. Here are the quick steps we 

will go over in detail: 

 Create the question content with variables shown in {} 

 Enter the formula using the variables and set the tolerance 

 Determine the range of the generated set of variables that will appear in the question content 

 Review the generated set of question contents 

 Since it is your first, check your work from a student's view 

 Initiating the creation process 

 Go to the Question bank, select "create a new question" and in the pop-up window select the Simple calculated. 

The Simple calculated question interface will appear. Give a name to your question in the title. 

 The question text 

 Fill the question text (note that the {param} names can be chosen at will.  
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 The Correct Answer Formula 

 Fill the Correct Answer Formula using the {param} names used in the question text.  

 

 Other answer and response parameters 

 You will set the Grade to 100%, as this is the only answer in this question. 

 Leave the other parameters as they appears ( 0.01 relative means ±1% tolerance). 

 Find the {param} in the formula 

 In simple calculated only the {param} that are in the formula will be used. 

 In the question text , the {param} that are in the formula will appear with there numerical values i.e 6.7 . 

 Any other {enclosed text} will appear as is i.e. {enclosed text}. 

 

 Click on the button 

 On reload the two {b} and {h} will be displayed. 

 Set the minimum and maximum values 

 Here the {b} range has been set to a 15-20 range and the {h} range has been set to a 5-10 range as we want a 

rectangle with a larger base than height. 
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 Select the number of sets to generate (here 10) and to display(here 2) 

 Just to illustrate that you can control the number of values displayed which is useful if you create 100 sets. 

 Also note the (red) warning that a valid question needs at least one set of {wild card} values. You will not be 

allowed to save the question if you don't do the next step. 

 Click on the generate butto 

 

 

 

 

 Note the sets are shown in reverse order so the the number indicates how many sets were created. 
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 The two sets illustrate that the variability defined by the Min and Max values. 

 Note that the formula result is analyzed and the tolerance limit (here 1% relative) is shown 

 The correct response that will be shown to the student is also shown. 

 The 2 decimals where defined are the default values defined as the last parameter under the Correct formula. 

 Click on the Save button 

 Test your first Sinple calculated question 

 On the question bank click on the preview icon. 

 Enter the result you have calculated yourself or click on the Fill with Correct button. 

 The values should be identical...  

 

 Click on the submit button. 
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 Editing a Simple Calculated question: Additional comments 

 Set the default question grade (i.e. the maximum number of marks for this question). 

 Set the Penalty factor. 

 Choose the grade that the student will get for this question if they give this answer. This should be a percentage 

of the total marks available. For example, you could give 100% for a correct answer, and 50% for an answer that 

is nearly right. One of the answers must have a 100% grade. 

 Determine the tolerance for error that you will accept in the answer. The tolerance and tolerance type settings 

combine to give a range of acceptable scores. So, if tolerance = t, correct answer = x and the difference between 

the user's answer and the correct answer is dx, then the tolerance types are as follows: 

o Nominal - mark correct if dx <= t 

o Relative - mark correct if dx / x <= t 

 The next 2 settings, "Correct answer shows" and "Format" determine the precision of the Correct answer 

shown. They are not used for grading. 

 Add some feedback which the student will see if they enter this answer. 

 You can specify as many answer formulae as you like - click "Add another answer blank" to add more. 

 You can also specify units for the answers. For example, if you enter a unit of 'cm' here, and the accepted 

answer is 15, then the answers '15cm' and '15' are both accepted as correct. If you add more than one unit, you 

can also specify a multiplier. So, if your main answer was 5500 with unit W, you can also add the unit kW with a 

multiplier of 0.001. This means that the answers '5500', '5500W' or '5.5kW' would all be marked correct. Note 

that the accepted error is also multiplied, so an allowed error of 100W would become an error of 0.1kW. 

 Description 

 This question type is not actually a question. It just prints some text (and possibly graphics) without requiring an 

answer. This can be used to provide some information to be used by a subsequent group of questions, for example. 

 Essay 

 This allows students to write at length on a particular subject and must be manually graded. 
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It is possible for a teacher to create a template to scaffold the student's answer in order to give them extra support. The 

template is then reproduced in the text editor when the student starts to answer the question.  It is also possible to 

include grading information for teachers marking the essay to refer to as they assess the essays.

     

 

 Matching 

 Matching questions have a content area and a list of names or statements which must be correctly matched 

against another list of names or statements. For example "Match the Capital with the Country" with the two lists 

"Canada, Italy, Japan" and "Ottawa, Rome, Tokyo". In the Quiz Module, each match is equally weighted to contribute 

towards the grade for the total question. 

 Question set-up in Question bank 

1. Select the question category 

2. Give the question a descriptive name - this allows you to identify it in the question bank. 

3. Enter some instructions in the 'Question text' field to tell the students what they are matching. 

4. Set the 'Default mark' (i.e. the maximum number of points for this question). 

5. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

6. Check the 'shuffle' box if you want the answers in the drop-down menus to be shuffled. Note: The Quiz display 

setting must also be set to shuffle within a questions for this to work. 
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7. For the first matching item, enter the question and a matching answer. 

8. Fill in at least two questions and three answers. Click 'Blanks for 3 more questions' to add more. You can enter 

as many as 10 items. You can provide extra wrong answers by giving an answer with a blank question. 

9. Set the 'Penalty for each incorrect try'. 

10. Click Save changes to add the question to the category. 

 Grading 

 Each sub-question is equally weighted to contribute towards the grade for the total question. For example a 

student who correctly matches 3 of the 4 possible matches will receive 3/4 or 75% of the total possible score for that 

question. 

 The 'penalty factor' only applies when the question is used in a quiz using adaptive mode - i.e. where the 

student is allowed multiple attempts at a question even within the same attempt at the quiz. If the penalty factor is 

more than 0, then the student will lose that proportion of the maximum grade upon each successive attempt. For 

example, if the default question grade is 10, and the penalty factor is 0.2, then each successive attempt after the first 

one will incur a penalty of 0.2 x 10 = 2 points. 

 Repeated entries 

 It is possible to have repeated entries in one of the lists but care should be taken to make the repeats identical. 

For example "Identify the type of these creatures" with the lists "Ant, Cow, Dog, Sparrow" and "Insect, Mammal, 

Mammal, Bird". 

 Ordered questions 

 In the Quiz module, it is possible for both the question list and the answer list to be shuffled. The answer list is 

always shuffled. The "shuffle within questions" must be "Yes" as a quiz setting under Display AND the shuffle question 

box must be check on the individual question. 

 Consider the question "Match the letter with its position in the alphabet" with the question list "1, 2, 3, 4" and 

answer list "A, B, C, D". The answer list is always shuffled for each student in the pull down list of the possible matches. 

However, only when both the quiz and individual question shuffles are turned on, will the question list be shuffled to 

something like "2,4,1,3". 

 Lesson Module matching questions 

 Matching questions are also used in the Lesson Module. However, while they look similar to the student, they 

are different for the teacher. Quizzes don't have jumps. 

 In the Lesson Module, all matches must be right for the question to be scored as correct. 

 What is called the question list in a Quiz, does not shuffle in the Lesson Module. In the earlier example, A, B, 

C , D will always be in that order and 1,2,3,4 will always be shuffled in the Lesson Module. 

 Lesson Module has an "answer" and a "matching answer" instead of a "question" and "answer". 

 In Lesson Module there has to be matching pairs. It is not possible to have 4 items in one list to match with 

1 of 5 items in another list. Both lists will be equal in their number. 

 Ordered questions in Lesson Module 

 In the Lesson Module, unlike Multiple choice questions or the Quiz Module, the question list is always the same 

order and the choices are shown in a random order. 
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 Tips and tricks 

 Matching questions look better on screen if you put the longer piece of text in the question and not the 

match. For example, when vocabulary matching put the single word in the match and the definition 

sentence in the question. Otherwise the drop down for long questions will be awkward to use and difficult 

to read. 

 Matching questions in a Lesson module are slightly different than in a Quiz module when the teacher is in 

edit mode. For example, there are scoring differences and a quiz does not use jumps. 

 Embedded Answers  

 Embedded answers (Cloze) questions consist of a passage of text (in Moodle format) that has various answers 

embedded within it, including multiple choice, short answers and numerical answers. 

 Question set-up 

1. Select the question category 

2. Give the question a descriptive name - this allows you to identify it in the question bank. 

3. Enter the passage of text (in Moodle format - see Format below) into the 'question text' field. 

4. Select an image to display if you want to add a picture to the question. For the student, it appears 

immediately above the question text. 

5. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

6. Set the 'Penalty factor'. 

7. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

8. The editor has been modified and allows you to test if your syntax is good. The different questions elements 

decoded will be displayed and syntax errors pinpoint. However, it cannot check if the question decoded is 

two questions in one because of an error syntax. 

9. Click Save changes to add the question to the category. 

 The grading for the cloze question applies the penalty to each subpart of the question as a whole. For example, 

if you have three fill in the blanks each worth 1 point each, then the penalty will only be incurred on the incorrect parts, 

not the questions as a whole. 

 Format 

 Questions consist of a passage of text (in Moodle format) that has various sub-questions embedded within it, 

including 

 short answers (SHORTANSWER or SA or MW), case is unimportant, 

 short answers (SHORTANSWER_C or SAC or MWC), case must match, 

 numerical answers (NUMERICAL or NM), 

 multiple choice (MULTICHOICE or MC), represented as a dropdown menu in-line in the text 

 multiple choice (MULTICHOICE_V or MCV), represented as a vertical column of radio buttons, or 

 multiple choice (MULTICHOICE_H or MCH), represented as a horizontal row of radio-buttons. 

 The structure of each cloze sub-question is identical: 

 { start the cloze sub-question with a bracket (AltGr+7) 

 1 define a grade for each cloze by a number (optional). This used for calculation of question grading. 
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 :SHORTANSWER: define the type of cloze sub-question. Definition is bounded by ':'. 

 ~ is a seperator between answer options 

 = marks a correct answer 

 # marks the beginning of an (optional) feedback message 

 } close the cloze sub-question at the end with a bracket (AltGr+0) 

 Now a very simple example: {1:SHORTANSWER:=Berlin} is the capital of Germany. 

 NB: Be careful when copying a cloze type question into the WYSIWYG HTML editor, as line breaks tend to get 

added, which destroys the question. 

 If the correct answer contains } # ~ / " or \ you will have to escape them by putting a \ in front of each such 

character. The { shouldn't be escaped, this can be vital in getting TeX expressions to work. In the feedback ~ and } must 

be escaped otherwise it will be interpreted as the next answer or end of the short answer section respectively. 

Quotation signs: " can lead to trouble anyhow in both places. Use the HTML entity: & quot; (without the space 

between & and quot;). If you want to have Mathematical symbols there can be problems with the \ used in TeX 

expressions. One alternative can be to use unicode characters. 

 Example 1 

 The following text creates a simple embedded-answers question: 

 Match the following cities with the correct state: 

* San Francisco: {1:MULTICHOICE:=California#OK~Arizona#Wrong} 

* Tucson: {1:MULTICHOICE:California#Wrong~%100%Arizona#OK} 

* Los Angeles: {1:MULTICHOICE:=California#OK~Arizona#Wrong} 

* Phoenix: {1:MULTICHOICE:%0%California#Wrong~=Arizona#OK} 

The capital of France is {1:SHORTANSWER:%100%Paris#Congratulations! 

~%50%Marseille#No, that is the second largest city in France (after 

Paris).~*#Wrong answer. The capital of France is Paris, of course.}.  

And the result will be: 
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 Some things to note: 

 The individual embedded answers are represented by the code in braces {}. 

 The number at the start is the 'weight', so in this case each answer contributes an equal share of the overall 

grade. 

 The correct option in each case is preceded either by an = sign or by %100%. 

 The text appearing after the # that follows each option is the feedback that the student will see if they 

choose that option. 

 If the student enters 'Marseille' in the final example, they score 50% of the total grade. 

 The asterisk * preceding the "Wrong answer" feedback in the final example means that the student will see 

this feedback if they enter anything other than "Paris" or "Marseille". 

 For multiple choice vertical or horizontal rendering there is no automatic numbering, though can added at 

each answer. 

 Detailed syntax explanations 

1. all question items within a cloze-type question are coded inside curled braces { } 

2. the number which appears between the opening brace and the colon {1: is the weighting of that item; if it is set 

at 1 for all the items, it needs not be specified, so you can have {: 

3. after the colon we have the item question type: MULTICHOICE, SHORTANSWER, NUMERICAL 

4. the syntax for MULTICHOICE and SHORTANSWER is the same; the only difference is in the displaying of the item 

to the student 

5. the order of the various answers is indifferent (except if you want a catch-all for wrong answers, see #13 below) 

6. a correct answer is preceded with the equal sign = or a percentage (usually %100%) - Note: The equal sign (=) 

doesn't seem to work with SHORTANSWER. 

7. a wrong answer is preceded with nothing or a percentage (usually %0%)but you can even use negative points by 

preceding with ~%-25% [not before Moodle 2.0]) 

8. you can allocate some points between 0 and 100 to some answers, if you put the appropriate percentage 

9. all answers except the first one are separated from one another by the tilde ~ sign 

10. answers can be followed by an optional feedback message, preceded with the # sign; if there is no feedback 

message, the # sign can be present or absent, it does not matter 

11. in the SHORTANSWER type you may want to put a catch-all (wrong) answer in order to send a "wrong, try again" 

feedback; you can do this by inserting an asterisk * as the very last expected answer in your formula 

12. in the MULTICHOICE question type the answers are automatically scrambled 
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 Online Cloze Question quiz generator 

There is a website to generate CLOZE quizzes for Moodle (1.9 and 2.x versions) and/or to try out the CLOZE 

editor integration for Moodle. 

This editor was built at the Chair of Applied English Linguistics at Universitaet Tuebingen, Germany, by Andreas 

Glombitza (andiglombitza(at)googlemail.com) and Achim Skuta (achim.skuta(at)googlemail.com). 

The authors are currently maintaining this software and webservice as a private project. 

Website: http://projects.ael.uni-tuebingen.de/quiz/htmlarea/index.php 

Multiple Choice question type 

Moodle provides teachers with a lot of flexibility when creating this common question type. You can create 

single-answer and multiple-answer questions, include pictures, sound or other media in the question and/or answer 

options (by inserting HTML) and weight individual answers. Remember that Lesson module questions behave 

differently. 

There are two types of multiple choice questions - single answer and multiple answer. 

Single-answer questions 

These questions allow one and only one answer to be chosen by providing radio buttons next to the answers. 

You can specify negative or non-negative marks for each answer, usually zero marks for wrong answers, maximum 

marks for correct answers and partial marks for partially correct answers. 

Multiple-answer questions 

The teacher can select "multiple answers are allowed" in a Multiple Choice question type. "Multiple answers" 

questions types in a quiz allow one or more answers to be chosen by providing check boxes next to the answers. Each 

answer may carry a positive or negative grade, so that choosing ALL the options will not necessarily result in good grade. 

If the total grade is negative then the total grade for this question will be zero. 

Feedback can be associated either with specific answers, or with the question as a whole. 

Question set-up 

1. Select the question category 

2. Give the question a descriptive name. You'll use the name to track your questions later so "Question 1" isn't a 

good idea. The name will be used in the question lists on the quiz editing page or in the lesson as a page title. It 

will not be shown to the students, so you can choose any name that makes sense to you and possibly other 

teachers. 

3. Create the question text. If you're using the HTML Editor, you can format the question just like a word 

processing document. 

4. Select an image to display if you want to add a picture to the question. The available images are those you have 

uploaded to the main Moodle files area (they cannot be in folders). For the student, the image appears 

immediately after the question text and before the answer options. 

a. Alternatively, if you used the HTML editor to create the question text, you can click the image icon. This 

will pop up the Insert Image window. You can choose to upload an image into your files area from this 

window, or you can add the URL of an image on the web. If you add a file to your files area, click the 

name of the file after you upload it to insert the link into the URL text entry at the top of the screen. 

Then click OK. 
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5. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

6. Set the 'Penalty factor'(see Penalty factor). 

7. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

8. Choose whether students can only select one answer or multiple answers 

9. Choose whether to shuffle the answer options 

10. Write your first answer in the Choice 1 text field. Inserting HTML into this area also makes it possible to add an 

image or a sound file. 

11. Select a grade percentage for the answer. This is the percentage of the total points for the question that 

selecting this response is worth. You can select negative percentages as well as positive percentages. So, 

selecting a correct response in a multiple answer question may give you 50% of the possible points, while 

selecting a wrong answer may take away 10%. Note that in a multiple-answer question, the grades must add up 

to 100%. 

12. If you wish, you can add feedback for each response. It may be a bit more work, but it’s good practice to tell the 

students why each answer is right or wrong using the feedback area. If students know why an answer is right or 

wrong, they can analyse their own thinking and begin to understand why an answer is correct. Your feedback 

will only be displayed if you select Show Feedback in the quiz body options. 

13. Fill in the rest of the response choices in the rest of the form. Any unused areas will be ignored. 

14. Fill in the overall feedback fields if you wish. 

15. Select the "Save Changes" button at the bottom of the screen. 

General feedback 

General feedback is some text that gets shown to the student after they have attempted the question. Unlike 

feedback, which depends on the question type and what response the student gave, the same general feedback text is 

shown to all students. 

You can control when general feedback is shown to students using the "Students may review:" check-boxes on 

the quiz editing form. 

You can use the general feedback to give students some background to what knowledge the question was 

testing. Or to give them a link to more information they can use if they did not understand the questions. 

Overall feedback 

The option overall feedback for correct/partially correct/incorrect responses is particularly useful for multiple-

response questions, where it is difficult to control what feedback students see just using the answer-specific feedback. 

So, when the student submits the question, they will see the answer-specific feedback next to the option(s) they 

selected, the overall feedback in a box below the options, and if applicable, the general feedback underneath everything 

else. 

Lesson module multiple choice questions 

This page was created for the Quiz module. A Lesson Multiple Choice or Multianswer question type looks the 

same to the student but is very different in the teacher's edit mode. A lesson question offers the teacher the chance to 

both grade a student's answer, give feedback and also to send the student to another specific page based upon the 

student's choice. 
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There are other differences. Quiz has a more robust scoring system that is similar to "Custom Scoring" in the 

Lesson module. Even with custom scoring turned on, Lesson will not give percentage credit of a question's score for an 

answer. And students must select all the correct answers to receive any credit for the multianswer question in the 

Lesson module. 

Calculated multichoice question type 

The Calculated multichoice question type are like multiple choice questions with the additonal property that the 

elements to select can include formula results from numeric values that are selected randomly from a set when the quiz 

is taken. They use the same wildcards than Calculated questions and their wildcards can be shared with other Calculated 

multichoice or regular Calculated questions. 

The main difference is that the formula is included in the answer choice as {=...}. 

Short-Answer question type 

In a short answer question, the student types in a word or phrase in response to a question (that may include a 

image). Answers may or may not be case sensitive. The answer could be a word or a phrase, but it must match one of 

your acceptable answers exactly. It's a good idea to keep the required answer as short as possible to avoid missing a 

correct answer that's phrased differently. 

The Quiz and Lesson modules both have short answer question types. The analysis of the question given below 

works for both modules. However there is another analysis type available for Lesson which is not available in a Quiz. 

Question set-up 

1. Select the question category 

2. Give your question a descriptive name. 

3. Create the question text. If you're using the HTML Editor, you can format the question just like a word 

processing document. 

a. Tip: if the answer is intended to fill a gap in the text, use underscores (5 or more) to indicate where the 

gap is. 

4. Select an image to display if you want to add a picture to the question (see step 4 in Multiple Choice question 

type for more detail). 

5. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

6. Set the 'Penalty factor' (see Penalty factor). 

7. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

8. Choose whether the answers are case-sensitive. Case sensitivity can be tricky where capitalization is important. 

Will you accept Ban Ki-moon as well as ban ki-moon as an answer? 

9. Next, fill in the answers you will accept. You could give common misspellings partial credit with this option. For 

example will you accept "Ban Ki moon"? Use wildcards to allow for variants on a word pr phrase. 

10. Add grade for each answer. 

11. Create feedback for any and all answers. This will appear if the student enters that answer. 

a. Note: It is good practice to add a single wild card * for the last answer, so you can create a feedback 

response and a score for all other answers students might have. 

12. Click Save Changes to add the question to the category. 
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Wildcard usage 

You can use the asterisk character (*) as a wildcard to match any series of characters. For example, use ran*ing 

to match any word or phrase starting with ran and ending with ing. If you really do want to match an asterisk then use a 

backslash like this: \* 

If you want one question with the two answers fuel and oxygen, you ought to be able to limit the number of 

variants by writing fuel*oxygen 100%. This would accept "fuel oxygen", "fuel, oxygen", "fuel; oxygen", "fuel and 

oxygen", "fuel & oxygen" "fuel oxygen", "fuel und oxygen" "fuel&&oxygen". It would even accept "fuel or oxygen", "fuel 

but not oxygen" "fuel|oxygen" which might not be so good but you can never be completely safe! 

Here are some answers and scores for a question "What does a rocket burn?". 

oxygen*fuel with a score 100%  

*fuel* with a score 50% 

*oxygen* with a score 50% 

*air* with a score 40%  

* with a score of 0% 

The order of the answers is important. The answers are evaluated from 1st to last. When a match is found the 

process stops. If no match is found the question is scored wrong and the general response is used. It is a good practice 

to put a wild card as the last answer so the evaluation process knows what to do when nothing above it matches. 

Without wildcards, the answers are compared exactly, so be careful with your spelling! 

Feedback for wrong answers 

When you wish to have short answer type questions, you naturally have a limited number of variations that 

would be acceptable. So in case you wish to give a feedback in case of a wrong answer, you must spell out the right 

answers exactly and then use * as a final answer which will have grade as zero, and feedback will be the one for wrong 

answer. 

Effectively, ANYTHING other than the specific answers mentioned by you will be treated as this option due to 

wildcard and will be deemed wrong; it'll give 0 marks and show the feedback for a wrong answer. 

Here is an example: 

What is a rabbit? 

answer1: animal 

feedback: right 

grade: 100% 

answer2: mammal 

feedback: right 

grade: 100% 
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answer3: vertebrate 

feedback: right 

grade: 100% 

answer4: * 

feedback: ouch! that was wrong 

grade: none 

 Remember: you cannot do negative marking in this type and ANYTHING other than your right answer will be 

treated as option 4 due to the wildcard and given that feedback and zero marks. 

 Numerical question type 

 From the student perspective, a numerical question looks just like a short-answer question. The difference is 

that numerical answers are allowed to have an accepted error. This allows a fixed range of answers to be evaluated as 

one answer. 

 For example, if the answer is 30 with an accepted error of 5, then any number between 25 and 35 will be 

accepted as correct. 

 You are able to 

 grade independently the number and the unit, 

 choose to handle the unit response either as 

o a text input element or as 

o a multichoice radio element, 

 just grade the number with the option to write the unit close to the input element, 

 put the unit either 

o at right of the number as the most common occurence 

o or at left as in $ 100,00. 

 Furthermore your valid number formats and specific intructions on how to answer will be put near the answer 

input element.  

 Questions may have different answers with different levels of accuracy. That lets you create questions like 

"What is a root of x^2 - 3x + 2?" and award different levels of credit depending on the accuracy of the answer. 
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 Numerical question set-up 

1. In Quiz or Question bank 

2. Select the question category 

3. Give the question a descriptive name - this allows you to identify it in the question bank. 

4. Enter a question in the 'question text' field. This can include an equation.  

5. Select an image to display if you want to add a picture to the question. For the student, it appears 

immediately after the question text and before the choices. 

6. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

7. Set the 'Penalty factor' (see Penalty factor). 

8. Add general feedback. This is text that appears to the student after he/she has answered the question. 

9. Now enter the first accepted answer(s). Note: Floating point numbers, e.g. 23.4, may also be written as 23,4 

or 2.34E+1. 

10. Enter an accepted error for this answer. This is the range above or below the answer that Moodle will 

accept as a match. For example, if the correct answer is 5, but you will accept 4 or 6 as answers, your 

accepted error is 1. 

11. Enter a grade for this answer. 

12. Enter feedback for the accepted answer. This is the text that the student will see if they enter a number 

within the accepted error of the answer. 

13. Repeat for each of the answers you want to accept. You can provide feedback for all wrong answers by 

using a wildcard, i.e. the asterisk character (*), as an answer with grade 'None'. 

14. Units can also be specified. For example, if you enter a unit of 'cm' here, and the accepted answer is 15, 

then the answers '15cm' and '15' are both accepted as correct. You can also specify a multiplier. So, if your 

main answer was 5500 with unit W, you can also add the unit kW with a multiplier of 0.001. This means that 

the answers '5500', '5500W' or '5.5kW' would all be marked correct. Note that the accepted error is also 

multiplied, so an allowed error of 100W would become an error of 0.1kW. 

15. Click 'Save changes' to add the question to the category. 

 Tips and tricks 

 Remember that numerical questions in the Quiz module are slightly different than those in the Lesson module. 
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 Error messages 

 "One of the answers you entered was not a valid number." The decimal point used must be a . not a , which is 

used in some countries. 

 Random Short-Answer Matching question type 

 From the student perspective, the Random Short-Answer Matching question looks just like a Matching question. 

The difference is that the sub-questions are drawn randomly from the Short Answer questions in the current 

category (including or not subcategories from the current category). 

 After an optional introduction, the respondent is presented with two or more sub-questions, each with a drop-

down menu box opposite listing the same number (or fewer if several sub-questions have the same answer) of 

available answer options. 

 The respondent must select an answer option to match each sub-question. 

 Each sub-question is equally weighted to contribute towards the grade for the total question. 

 The questions and answers are randomly drawn from the pool of short-answer questions in the current 

category (and in its subcategories if this option was selected). 

 You must make sure that the category contains enough short-answer questions, otherwise the student will get 

an error message. The more short-answer questions you add to the category, the more likely it is that students 

will see a new selection on each attempt. Short answers questions used in a previous attempt to the same 

question or in another Random Short-Answer question of the same quiz are not excluded, so you should ensure 

there are enough Short Answer questions in the category to mitigate the risk of a student getting the same 

questions and answers. 

 Note that the answer options are taken from the correct (having a 100% grade) answers of each contributing 

short-answer question. If there are several answers to the sort-answer question with a 100% grade, the first one 

is used. Therefore, if the short-answer questions in this category are on different topics, this question type will 

not be useful, as the correct option will be obvious. 

o An example that doesn't work - suppose the category contains 2 short-answer questions, as follows: 

1. What is the capital of France? 

Correct answer: Paris 

Other recognised answers: Lyon, Marseilles, * 

2. What vegetable is called 'løk' in Norway? 

Correct answer: Onion 

Other recognised answers: Leek, * 

o The resulting Random Short-Answer Matching question will appear as follows: 

What is the capital of France? 

 - Options: Paris, Onion. 

What vegetable is called 'løk' in Norway? 

 - Options: Paris, Onion. 

o An example that does work - the 2 short-answer questions in the category are as follows: 

1. What is the capital of France? 

Correct answer: Paris 

Other recognised answers: Lyon, Marseilles, * 

2. In what city is Le Corbusier's "Unite d'Habitation"? 
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Correct answer: Marseilles 

Other recognised answers: Paris, Lyon * 

o The resulting Random Short-Answer Matching question will appear as follows: 

What is the capital of France? 

 - Options: Paris, Marseilles. 

In what city is Le Corbusier's "Unite d'Habitation"? 

 - Options: Paris, Marseilles. 

 Question set-up 

3. Select the question category. 

4. Give the question a descriptive name - this allows you to identify it in the question bank. 

5. Enter the question text to tell the students what they are matching. 

6. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

7. Set the 'Penalty factor' (see Penalty factor). 

8. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

9. Select the number of questions you want to add to the matching question - make sure this is less than or equal 

to the number of short-answer questions available in this category (a verification will be done when the 

question is saved). 

10. Select if you want questions to be drawn also from subcategories of the current category 

11. Click Save changes. 

 True/False question type 

 A student is given only two choices for an answer in this kind of question: True or False. The question content 

can include an image or html code. 

 When feedback is enabled, the appropriate feedback message is shown to the student after the answer. For 

example, if the correct answer is "False", but they answer "True" (getting it wrong) then the "True" feedback is shown. 

 Note that the True/False question type in a Lesson module is quite different. It is effectively the same as the 

Multiple Choice question type in a Lesson, but with only 2 responses.  

 Question set-up 

1. Select the question category 

2. Give the question a descriptive name - this allows you to identify it in the question bank. 

3. Enter a question in the 'question text' field. 

4. Select an image to display if you want to add a picture to the question. For the student, it appears immediately 

after the question text and before the choices. 

5. Set the 'default question grade' (i.e. the maximum number of marks for this question). 

6. Set the 'Penalty factor' (see Penalty factor). 

7. If you wish, add general feedback. This is text that appears to the student after he/she has answered the 

question. 

8. Select the correct answer - true or false. 

9. Finally, provide feedback for each of the answers 'true' and 'false'. 
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10. Click 'Save changes' to add the question to the category. 

 2.6.2 Managing questions 

 Questions are stored in the course Question bank in Administration > Course administration > Questions 

 Questions can be organised into Question categories and shared with other teachers 

 Moodle has a number of different formats that can be used to import or export questions 

 Managing question types 

 An administrator (or manager or any user with the capability moodle/question:config) can manage question 

types available across the site in Administration > Site administration > Plugins > Question types > Manage question 

types. 

 

No. questions 

This shows the number of questions of that type in the entire Moodle site. If the number is non-zero, it will be a 

link to a report that shows you where in the question bank (which contexts) those questions are. 

Version 

If the question type has its own database tables, then the version of those tables is displayed here. 

Requires 

Some question types rely on others to operate correctly. If so, the required question types are listed here. 

Available? 

If you make a question type unavailable, then users will no longer be able to create new questions of that type. 

However, existing questions of that type will continue to work, so existing quizzes will continue to work, and old quiz 

attempts can be reviewed. 

The up and down arrows let you control the order of the question types in the list where teachers select which 

type of question they wish to create. 

Delete 

If 

 there are no questions of a particular type, and 

 if this question type is not required any any other question type, and 

 if this question type is neither Random nor Missing type, which are required by the question type system, 

 then you can uninstall it by clicking on the delete link. 
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Settings 

Some question types have configuration options. If so, a settings link will appear in this column. 

2.6.3 Question bank 

This feature allows a teacher to create, preview, and edit questions in a database of question categories. The 

categories can be limited to being used on the site, course or quiz level. The questions in a category can be added to 

a Quiz or to a lesson activity via an export process. The teacher enters the question bank by creating or editing a quiz 

activity or via Settings > Course administration > Question bank. 

Select a category 

Questions are organised into categories. Initially each course has only one category called "Default". It is good 

practice to create more categories to organize your questions. This not only makes it easier to find questions, but makes 

the use of random questions and matching question easier. You can create a hierarchy of categories because you can 

create subcategories inside parent categories. To add or edit categories click on the "Categories" tab. 

The question editing screen shows the questions from the currently selected category. You choose this category 

from the Category: drop-down menu. Using the tick box below that menu you determine whether to also show the 

questions from all subcategories. 

Categories are shared in contexts 

There are separate question category trees in each different 'context' in which questions are shared. The 

contexts available to you depend on whether you access the question bank from an activity or from a course and 

depend on the permissions assigned you for access to questions.  

Add a new question 

1. Click the Questions tab to access the Question Bank page, if not there already. 

2. From the Category drop-down menu, select a category you want to add a question to. 

3. The page will change to show the questions already in that category 

4. Select the question type you want to create from the Create new question drop-down menu. 

5. Fill in the form for the question type you are creating. Each question type has its own form and has its own 

options. 

6. Click Save Changes at the bottom of the form. 

 Edit, duplicate, preview, delete and move 

 

 Each question in the question bank has four icons which allow you to edit, quickly duplicate, preview and delete 

the question. (The question may not be deleted if it is already in use elsewhere.) To move a question into a different 

category or subcategory, click into the box on its left; scroll down to "With Selected..." and choose "Move to.." 

 Tips and tricks 

 Put the answer into the question name so you can quickly see the answers when students are asking for 

answers. This is especially useful if you're dealing with large sets of questions! (No option yet for viewing 

category or answer of question in the list of questions.) 
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 Export questions in GIFT or Moodle XML formats, then import them into a Lesson. (Future versions of 

Moodle will make Question bank available to both Lesson and Quiz activities.) 

 Remember that while some of the same question types can be found in both the Quiz and Lesson modules, 

they can be very different. Scoring and grading each student's choice is more robust in a Quiz. On the other 

hand, each Lesson question answer also has a jump associated it. 

 Use GIFT or other export modes to print questions and answers in a category. Hint, clever use of word 

processor macros, using search and replace, can tidy up a GIFT file for printing. 

 The question title is useful in sorting and making notes. For example, "ZZ remove 2010-3 Why did the 

Moodler cross", will put this question at the bottom of the list. Or where you want a 'the' questions in a 

category to appear in a specific order, use letters or numbers, knowing that AA will come first, AB will be 

second in the list. 

 Do a copy and paste from a PDF file into the question content area. Reduces "other" hidden code which 

Word, Open Office and other programs can insert. 

Sharing and Managing Question banks 

Be default, teachers can manage only the questions in the context of the courses they are in. You can set up a 

role to allow teachers to share and manager questions on a larger scale. 

You can also use this role to create a special system-wide "Question bank Manager" instead of giving admin 

level or site-wide Manager access to a person managing the Questions. 

Question sharer 

Creating a new role 

1. As an administrator, go to Site administration>Users>Permissions>Define roles and click the 'Add a new role' 

button at the bottom of the screen. 

2. On the next screen, ignore archetypes and presets and click 'Continue' 

3. Give the role a name and if desired a description and tick the "System" context: 
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4. In the filter, type "question" 

5. Set the following capabilities to 'allow': 

 moodle/question:add 

 moodle/question:editall 

 moodle/question:managecategory 

 moodle/question:moveall 

 moodle/question:viewall 

 moodle/question:useall 
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6. Click the 'Create this role' button. 

 Assigning the role to a teacher 

1. As an administrator, go to Site administration > Users > Permissions > Assign system roles. 

2. You should now see your newly created role here 

3. Assign the role to the required course teacher(s).(Note that the users still need to have the teacher role 

in their courses.) 

 Note that you can also assign the role to a user in a course category if you only wish them to share questions in 

that category. To assign a role to a user within the scope of a particular category only: 

1. Log in as an administrator. 

2. From the site's homepage, click on the desired course category. 

3. From inside the desired course category, click on "Assign roles" in the Administration block. 

4. Click on the role you wish to assign to the user. 

5. Select and add the user to the role. 

 Sharing questions 

 A normal teacher in a course can only see the question category for their own course when they access the 

question bank. This teacher for example can only see her US Film course questions and can only add her questions to 

there (or any sub-category she might create): 

 



 

                                                                                                                                            
292 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

 However, when she has been given the Question sharer role she can then access any questions which have been 

added at category level ('Miscellaneous') and for the whole site ('System') 

 

 She can also save her questions to there, allowing them to be shared by other teachers with the Question sharer 

role. 

 Note that she can also add questions from Administration>Front page settings>Question bank. (but she has no 

higher administrative powers.) 

 What are these categories? 

 The categories you will see relate to course categories. For example, 'Miscellaneous' is the default category 

available on a new install of Moodle (which can be renamed) 

 So a teacher of French with the Question sharer role might see 'Category - Languages' , assuming her French 

course resides with the Spanish and German course in a category called 'Languages', for example. If she 

saves her quiz questions to the 'Languages' category, then her Spanish and German teacher colleagues with 

the role can also access them from their respective courses. 
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 She can edit the names by clicking on Course administration>Question bank>Categories and then clicking 

the edit icon: 

                                         

 Sharing questions site-wide 

 From a course, go to Course administration>Question bank>Categories 

 Click 'Add category' and select System as the parent category. 

 Create your category and add questions to it. 

 The questions in this category will be available anywhere on the site for teachers with the question sharer 

role to access. 

 2.6.4 Question categories 

 A question category can contain individual questions or other question categories. They can be found by using 

the Question bank or when building a quiz. 

 What are question categories? 

You can imagine a question category as a folder on your desktop computer. Then, questions are stored in these 

categories in a similar way as your files are stored in a file system. 
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 Each category must have a name and you can include a short description of the category. You can create 

a category hierarchy. For example, you can specify a parent category for each category or the 'Top' as the parent, when 

a category has no parent. 

 Tip: Creating question categories and sub categories is a good practice. It is better than keeping all your 

questions in one big list in the quiz module. The hierarchy feature enables you to separate categories into sub categories 

and sub categories into sub sub categories etc. indefinitely. Categories and sub categories, etc., are very powerful when 

combined with random questions that can select either from one category or from a category or any of its sub 

categories. 

 

 Question Sharing 

 You can share questions in several different contexts. Sharing categories in the 'System' contex or 'Course' 

context has a similar effect to publishing the category so others can see them or hiding a question category from specific 

users. See the Question contexts page for more infromation. 

 By default a course teacher cannot see or use any Question context above the course level. 

 Note: "Core System" and "System" refer to the same thing when we are describing or showing screen shots of 

question categories. "System" is the current term you will see in 2.x releases of Moodle. 

 Category Set Up and Management 

 Open the question bank. Either : 

o Click on the Questions link in the 'Administration' block click on the 'Questions' link. 

o Or open the Editing a quiz page - when logged in as a teacher or someone with appropriate permissions 

open a quiz and then click on the 'Edit' tab. 

 Click on the 'Categories' tab. 

 Below the list of current categories you will see a form to add a new category. 

 Choose the 'parent' category in which your new category will be placed. See image of 'Parent' selector image to 

right. 

o Placing your category in another category makes it a sub-category of the parent. 

o Choosing 'Top' means that your category is a top level category, not a sub category. When more than 

one sharing context is available you can place your category as a top level category in any of the 

contexts. 
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o Notice you can choose to make your category a 'top level' category in any context (see Question 

contexts) that is available to you. Or you can choose to add your category as a sub category of another 

category in the same context as the 

 Type the name of your new question category in the text box. 

 Add an optional meaningful description in the category info area. 

 Click the 'Add Category' button. Your new question category will appear in the list of current categories. 

 Deleting Categories 

 Categories can also be created or deleted at will. However, if you try to delete a category containing questions, 

then you will be asked to specify another category to move them to. You cannot delete or move the last category in any 

context, there must always be one category in a context. 

 Using Arrow Icons for Moving Categories 

 You can also arrange the categories in a hierarchy so that they are easier to manage. 

 The up/down arrow icons lets you change the order in which category 'peers' are displayed. 

 The up / down icons are also used to move a top-level category between contexts. If you move a category to be 

the first or last category in a context and then press the arrow key again then it will be moved to the next 

context. 

 The right arrow icon allows you to move a category to be a child category of the category listed immediately 

above it. 

 The left arrow icon allows you to move a category up one category level (to be a peer of it's parent category). 

 See the tool tip that appears when you place the mouse pointer above these icons if you're not sure what action 

an icon will perform. You cannot move the last category in any context, there must always be at least one category left 

in all contexts. 

 2.6.5 Question contexts 

 We can share questions in different contexts. Context may be an unfamiliar word. Think of a context as an area 

within your Moodle site. Each different context has a separate question category hierarchy. So, now you can choose the 

'context' within which your questions will be shared. And also an administrator can give their users different 

permissions within different context areas. 

 See the diagram illustrating the relationship of the different contexts below. Different colours denote different 

context types (though there are two hues of green, both denote the same type). Notice how question contexts contain 

each other. Notice also that Course category contexts can be nested. In this example we have two contexts nested 

within each other 'Humanities' and 'Languages'. We could have a third course category 'English' and fourth and so on. 

Course categories can be nested infinitely and so you can set up a very flexible system of question contexts for sharing 

questions and assigning question sharing permissions. 

 As described at Question categories, questions are stored in a hierarchical structure similar to folders at the 

filesystem. You can imagine question context as a place where the tree of question categories is actually placed. By 

default, every teacher can create new questions in the course context (the blue one in the diagram) and the activity 

module context (the white one). We will discuss how to allow a teacher to create questions in higher contexts below. 
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 Question contexts are just as a subset of the Roles and Permissions contexts. A context contained by another 

context inherits the permissions of the containing context. You can access question categories in any containing context 

if you have permission to do so. Remember, you can access the question bank in two ways: from within an activity (now 

only the quiz activity), or from the link in the Course admin menu to 'Questions'. When you access the question bank 

from the : 

 Activity. If you have permissions you can access question categories in : 

o that activity's context and containing contexts. 

o the course in which the activity module is contained. 

o the course categories in which the course that contains the activity module is contained. 

o the core system context. 

 Course. If you have permissions you can access question categories in : 

o that course. 

o the course categories in which the course is contained. 

o the core system context. 

 So questions contexts are accessible as follows : 

 Activity context : questions only available to one activity module. 

 Course context : questions available to all activity modules in a course and within the course from the 

'Questions' link in the course administration block. 
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 Course category contexts : questions available to all activity modules and courses in the course category 

(remember one course category can contain other course categories, you can share your questions in any 

parent course category). 

 Core System context : questions available in all courses and activities on your site. 

All Question capabilities are tested in the relevant context. So, for example, to add a question to a category you 

must have the add capability for that context. If you don't have permission to do anything in a context, then the 

categories in that context will not be visible to you. 

2.6.6 Importing questions from an existing file 

It is possible to import questions from a file on your network/computer or from a file that has been saved or 

uploaded into your course files. The underlying character encoding of this file is important. 

Note: Moodle XML format is the recommended import question type format as it enables the maximum amount 

of question data (such as question feedback) to be imported. 

Question bank import process 

The question bank allows you a great deal of flexibility when importing questions. To import questions into 

Moodle's Question bank, use the Questions link in the course administration and select the import tab. In most versions 

of Moodle it is also possible to get to this screen (produced by ../question/import.php) while editing an existing quiz. 

 

 Select import tab 

 Select the question type to import 

 General: pick the category, determine if the context and category information that maybe contained in a GIFT or 

XML file should be used. 

 Select what should happen if there are no grades or an error is detected in the import process. 

 Determine the file to import 

o Import from file upload. Use the browse function to import a file from your computer. Use the "Upload 

this file" button to import the questions. 

o Import from file already in course files. A popup window will take you to the course files start page. Use 

the "Import from this file" button. 
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 Character encoding 

 It is important that the imported file is encoded in the UTF-8 standard. 

 If this is not adhered to you may get import errors and/or strange characters in the imported materials. If the 

file is not UTF-8, an external tool must be used to change the encoding. Note that if only basic 'latin' characters are 

used, then the coding issue can generally be ignored. Be particularly careful when creating questions using Microsoft 

Word. For reasons best known to themselves, Microsoft used their own encoding for some characters (incompatible 

with UTF-8) and this is likely to break the import. 

 Match grades 

 Imported grades must exactly match one of the fixed list of valid grades, as follows: 

100, 90, 80, 75, 70, 66.666, 60, 50, 40, 33.333, 30, 25, 20, 16.666, 14.2857, 12.5, 11.111, 10, 

5, 0 

negative values of the above list are also permitted. 

 There are two settings for this switch. They affect how the import routine treats values that do not exactly 

match one of the values in the above list 

 Error if grade not listed - If a question contains any grades not found in the list an error is displayed and that 

question will not be imported. 

 Nearest grade if not listed - If a grade is found that does not match a value in the list, the grade is changed to 

the closest matching value in the list 

 Note: some custom import formats write directly to the database and may bypass this check. 

 Tips and tricks 

 TIP: It may be easier and faster to type many questions into a single text file, than to create a series of Quiz or 

Lesson question pages. Some teachers report that once they master creating questions in one of the formats to 

import, they do not have to wait for their Moodle site screen to refresh and the process of selecting the next 

question type to create. 

 TIP: Want to use questions from your quiz in a Lesson? Export the question category in say a GIFT format, then 

use a text editor to delete questions, or perhaps use a search and replace function to change names or places. 
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 2.6.7 Export questions 

 Questions may be exported from the Quiz module and the Question bank in any one of 3 formats: 

 GIFT format 

 Moodle XML format 

 XHTML format 

 Process 

 Click Settings>Quiz Administration>Question bank>Export. 

 

 Select the output type required for the exported file. 

 Use the pulldown menu to select the question category you want to export 

 Check if you want the category name to exported and/or the context to be included. This only applies to some 

formats and is used to restore this information on import. 

 Click on the export questions to file button 

 You are invited to download the file to your computer. 

2.6.8 Question behaviours 

How questions behave 

The following question behaviours are available when creating a quiz (also when previewing questions): 

Deferred feedback 

Students must enter an answer to each question and then submit the entire quiz, before anything is graded or 

they get any feedback. 

Adaptive mode and Adaptive mode (no penalties) 

Allows students to have multiple attempts at the question before moving on to the next question. This 

behaviour requires that the "Whether correct" box is ticked under "During the attempt" in the "Review options" section, 

at a minimum. 

Manual grading 
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Used for essay questions (irrespective of what the quiz is set to) but you can now choose to have every question 

in the quiz manually graded, if you wish. 

Interactive mode 

After submitting one answer, and reading the feedback, the student has to click a 'Try again' button before they 

can try a new response. They can be given hints to help them. Once the student has got the question right, they can no 

longer change their response. Once the student has got the question wrong too many times, they are just graded wrong 

(or partially correct) and get shown the feedback and can no longer change their answer. There can be different 

feedback after each try the student makes. The number of tries the student gets is the number of hints in the question 

definition plus one. 

Immediate feedback 

Similar to interactive mode in that the student can submit their response immediately during the quiz attempt, 

and get it graded. However, they can only submit one response, they cannot change it later. 

Deferred feedback or Immediate feedback with Certainty-based marking (CBM) 

With CBM, the student does not only answer the question, but they also indicate how sure they are they got the 

question right. The grading is adjusted by the choice of certainty, so that students have to reflect honestly on their own 

level of knowledge in order to get the best mark. 

Certainty-based marking 

When a student answers a question they also have to state how sure they are of the answer: not very (less than 

67%); fairly (more than 67%) or very (more than 80%). Their grading is then adjusted according to how certain they are, 

which means that for example if they answered correctly but were only guessing, their mark is adjusted from 1 to 0.33. 

If they answered wrongly but were very sure, their mark is adjusted from 0 to -2. 
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 Managing question behaviours 

 An administrator can manage question behaviours available across the site in Administration > Site 

administration > Plugins > Question behaviours > Manage question behaviours. 

 Deferred feedback with explanation 

 Deferred feedback with explanation is an additional question behaviour, that is just like deferred feedback, but 

with an additional input box where students can give a reason why they gave the answer they did. No attempt is made 

to automatically grade the explanation, nor is it required. 

 It may be used in various ways, for example: 

 The teacher may want to manually edit the grades where the student gave a wrong answer, to give partial credit 

if the student used the right method or approach. 

 The student might want to explain their thinking, so that later, when the results and feedback are revealed, they 

are reminded of what they were thinking at the time, and so can reflect more deeply. 

 2.7 Course enrolment 
 Course enrolment is the process where authenticated site users can be registered as course participants. 

 2.7.1 Enrolled users 

 All course participants are enrolled in the course and assigned an appropriate role. 

 Enrolled users: 

 Can be assigned to groups 

 Have grades 

 Can submit assignments 

 Are visible in the list of participants 

 Can subscribe to forums 

 Can participate in choices 

 Only enrolled users are true participants in course. 

 The enrolled users page Administration > Course administration > Users > Enrolled users lists all users enrolled in 

the course, together with their last access time, roles, groups and enrolment methods. 
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 Roles 

 To assign an enrolled user a role, click the 'Assign roles' icon (a plus sign) in the roles column then select the 

desired role. 

 To remove a role assignment, click the delete icon (a cross) next to the role name. 

 Notes: 

1. Only roles which can be assigned in the course context type are available to select. The course context type may 

be set by an admin by editing the role via 'Administration > Site administration > Users > Permissions > Define 

roles. 

2. Only roles which a user is allowed to assign are available to select. 

 Groups 

 To add a user to a group (requires at least one group to have been created previously), click the 'Add to group' 

icon (a plus sign) in the groups column, select the desired group then click the 'Save changes' button. 

 Searching enrolled users 

 The search facility allows a teacher to search for specific enrolled users. This is useful when a course has many 

users enrolled with different methods. 

 

 Editing enrolment start and end dates 

 Enrolment start and end dates for particular users can be edited as follows: 

1. Click the edit icon in the enrolment methods column 

2. Edit dates as required, then click the 'Save changes' button. 

 2.7.2 Enrolment methods 

 Depending upon which enrolment methods are enabled for the site (by an administrator in Administration > Site 

administration > Plugins > Enrolments > Manage enrol plugins), some or all of the following are available within a 

course: 

 Manual enrolment 

 This enables users to be enrolled manually in Administration > Course administration > Users > Enrolled 

users. 
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 It allows the teacher of the course to manage individual or collective enrolment to their course themselves - 

for example: if a new student arrives to class unexpectedly with just a login to the site, they may be enrolled 

by the teacher into their course without any input from an administrator. 

 Self enrolment 

 This allows users to enrol themselves into a course, either directly or via an enrolment key ("course 

password") The teacher does not then have to manually add students. 

 More than one instance of the self enrolment method can be used so that when users enrol themselves 

they are assigned different roles e.g. certain users can be assigned the role of student and other users can 

be assigned the role of non-editing teacher 

 The self-enrolment method also allows for users to enrol themselves into groups by using a group 

enrolment key. 

 Guest access 

 This allows those with the guest role to view the contents of a course. 

 Users with the "guest role" may be visitors who do not have an account on your Moodle, or users who do 

have an account ("authenticated users") but who would just like to explore your course. 

 It is possible to add an enrolment key so that only those guest users you wish to grant access can enter the 

course 

 Entering a course with guest access doesn't allow a user to participate in any activities; they can only view 

information. 

 Cohort sync 

 A cohort is a set of users which has been added either to the site as a whole or to a particular category and 

which can then be made available in a course through the cohort-sync enrolment plugin. 

 Only an administrator or a manager can use this plugin. 

 Managing enrolment methods 

 

 Managers and teachers (and any other users with the capability moodle/course:enrolconfig) can manage 

enrolment methods in Settings > Course administration > Users > Enrolment methods. 

 To add a new method, select it from the dropdown menu. 



 

                                                                                                                                            
304 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 To remove any unused enrolment method, click the delete icon (X) opposite it. 

 To temporarily disable an enrolment method, click the show/hide icon (an eye) opposite it. (This ensures 

that the settings are remembered if the enrolment method is later re-enabled.) 

 To change the order in which the enrolment methods are checked, use the up/down arrows. If a user can 

enrol via more than one enrolment method, the one highest in the list wins. Example needed here please! 

 2.7.3 Unenrolment 

 Unenrolment is the process of removing users from a course. It is controlled by one or more of the following: 

 The enrolment duration, which suspends students after the specified time has elapsed. Some plugins 

include the option to unenrol users after enrolment expiration 

 For self enrolment, the 'Unenrol inactive after' setting in Administration > Course administration > Users > 

Enrolment methods > Self enrolment can be set to specify a time after which a student is automatically 

unenrolled from a course if they haven't accessed it in that time 

 An enrolment plugin may decide that the enrolment has expired, for example, if a user for a course is not 

present in an LDAP database, or if a Flat file is processed by Cron. 

 In addition, users with the appropriate permission can unenrol themself from a course. 

 Enrolment duration 

 The default enrolment duration for manual enrolment can be set in Administration > Course administration > 

Users > Enrolment methods > Manual enrolment. It can be amended from the default value when enrolling users 

manually in Administration > Course administration > Users > Enrolled users. 

 The enrolment duration for self enrolment can be set in Administration > Course administration > Users > 

Enrolment methods > Self enrolment. 

 Bulk unenrolment 

Users who were previously manually enrolled may be unenrolled in bulk via Administration > Course administraton > 

Users > Enrolment methods then clicking on the 'Enrol' users icon. 

 Unenrolment and grade history 

 When a user is unenrolled, their grade history is not deleted. If a user is unenrolled accidentally, their grades can 

be restored by going to Administration > Course administration > Users > Enrolled users, clicking 'Enrol users' and 

making sure that the 'Recover user's old grades if possible' checkbox is ticked in the enrolment options before re-

enrolling the user. 

 Users enrolled with methods other than manual will have their grades restored depending on the value of 

"recovergradesdefault" in Administration > Site administration > Grades > General settings. 

 Suspended or Unenrolled? 

 Suspended users are not longer able to access any of their courses on Moodle but their data is preserved, so it 

is possible for them to return to their course at a later time. This might be useful for example, for keeping safe the work 

of students who have left the establishment but whose data might be needed for inspection in future years. Suspended 

users currently still appear in the gradebook but a teacher can select in their Grader report preferences to show only 

active users or all users (including suspended users).  
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 Note: A single user may be suspended by an admin user or manager by editing the user's profile and selecting 

"Suspended account". Groups of users may be suspended from "Users > Enrolled users". With the manual enrolments 

selected, choose "Edit user enrolments" and "Alter status > Suspended". 

 It is also possible to suspend users from courses via csv/text file from Site administration > Users > Accounts > 

Upload users using the enrolstatus field, where 1 against a user means they are suspended (and leaving blank means 

they are still enrolled.) 

 2.7.4 Other users 

 Users can be assigned a role in a course without enrolling them in Administration > Course administration > 

Users > Other users. 

 This means they can carry out tasks relevant to their permissions but they don't appear in the Participants list. 

An example of this would be assigning a user to a Principal, Manager or Helpdesk type role to provide them access 

without confusing the participants list. 

 This page also lists users who have been assigned a similar role at Site or Category level. 

 Note: By default, the only role which can be assigned to other users is the manager role. To enable other roles, 

such as teacher to be assigned, the capability moodle/course:view "View courses without participation" should be 

allowed for the role. 
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 2.8 Grouping users 

 2.8.1 Groups 

 In the course level can you assign a user to one (or more) groups. In a course you can assign a context(activity) 

to a group. When members of the group leave the course, they lose their identity with the group. 

 Why use groups? 

 You are a teacher in a course where you have several classes and you want to filter your activities and 

gradebook so you only see one class at a time. 

 You are a teacher sharing a course with other teachers and you want to filter your activities and gradebook 

so you don’t see the students from your colleagues’ classes. 

 You want to allocate a particular activity, resource or topic section to just one class or set of users and you 

don’t want others to see it. 

 Group levels 

 A group or grouping can be used on two levels: 

 

 Course level - The group mode defined at the course level is the default mode for all activities defined 

within that course. To use groups you need first to set a group mode inAdministration > Course 

administration > Edit settings. 
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 Activity level - Each activity that supports groups can also have its own group mode defined. If the course 

setting "Force group mode" is set to "Yes" then the option to define the group mode for individual activities 

is not available. If it is set to "No", then the teacher may change the group mode: 

 Group modes 

 There are three group modes 

 No groups - There are no sub groups, everyone is part of one big community 

 Separate groups - Each group can only see their own group, others are invisible. 

 Visible groups - Each group works in their own group, but can also see other groups. (The other groups' work is 

read-only.) 

 For example, enabling either separate or visible groups on an assignment drop-box enables staff to filter the 

student submissions to see only those from a particular tutor group. With visible groups, students can see which other 

groups are doing the same activities as they are; with separate groups, they do not know which other groups are doing 

the same activities. 

 Using groups with discussion forums allow teachers to restrict interaction between students. Separate groups 

mean only students in the same group can see and participate in discussions within a particular forum. Visible groups 

allow students to see other group's discussions, but only participate in their own group's discussions. 

 Creating a group 

1. Click the 'Create group' button in Administration > Course administration > Users > Groups 

2. Add a group name and optional description (displayed above the list of group members on the participants 

page), enrolment key and picture (displayed on the participants page and next to forum posts) 

3. Click the 'Save changes' button 

4. Select the group to which you want to add participants, then click the 'Add/remove users button 

5. In the "Potential members" list, select the users you want to add to the group. Multiple users may be selected 

using the Crtl key. 

6. Click the Add button to add the users to the group 

 An optional group ID number (an advanced setting) may be added for matching the group against external 

systems. Group ID numbers are not displayed anywhere on the site. Within a course, all group ID numbers must be 

unique. Thus it's not possible to create a group with a duplicate group ID number. 

 Auto-create groups 

Groups may be created automatically via the 'Auto-create groups' button in Administration > Course administration > 

Users > Groups. To see all the settings, click the Expand all link top right. 
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 General 

 A naming scheme can be created automatically. # is replaced by sequential numbers, and @ by letters. For 

example: 

 Group @ will create group with a naming scheme Group A, Group B, Group C . . . 

 Group # will create group with a naming scheme Group 1, Group 2, Group 3 . . . 

 You can specify if you would like to create 

 x number of Groups or 

 each group contain x number of students 

 When selecting Members per group the Prevent last small group will allocate additional members to an existing 

group rather then create a new group with fewer members than x. This setting is found by clicking on the Show More 

link. 

 Group members 

 Select members from ... allows you to choose from roles assigned within the course, available cohorts, groups or 

groupings. Specify andGroup/Member count work together. 

 The setting 'Select members from cohort' lists all cohorts which users enrolled on the current course are part of. 

The number in brackets is the number of users enrolled on the course in that cohort. 

 The 'Ignore users in groups' checkbox should be ticked to only select group members from users that are NOT 

already in a group in the course. 

 Grouping 

 Create in grouping and Grouping name allows you to create a new grouping and allocate the new auto-created 

groups to be created to it. 
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 Prior to creating the groups, you can view the groups. 

 Restricting an activity, resource or course topic to a particular group 

 To be able to restrict an activity, resource or course topic to a group, Conditional activitiesmust be enabled. This 

will result in a 'Restrict access' section in the activity, resource or topic settings and a group restriction can then be 

added. 

 

 Groups and enrol plugins 

 Where groups are created automatically with enrol plugins such as IMS Enterprise, members cannot be 

unenrolled manually via the groups screen inside a course. This has to be done from the plugin. Additionally, when 

group members are owned by a plugin like this, there is information below their name on the groups screen. 

 Groups overview 

 A overview of groups and groupings is available via the Overview tab in Administration > Course administration 

> Users > Groups. 

 The table may be filtered to display particular groupings or groups. 

 2.8.2 Import groups 

 Groups import provides a simple, easy way to create groups from a spreadsheet (CSV). 

 To import groups 

 Click the 'Import groups' button in Administration > Course administration > Users > Groups 

 Upload the CSV file (see below for file format) either by dragging and dropping into the box with the arrow 

(1 below) or by clicking "choose a file" and uploading from the File picker. (2 below) 
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 Click the 'Import groups' button 

 CSV file fieldnames 

 The CSV file has just one required fieldname (groupname), but can include default and/or optional fieldnames 

 Each line of the file contains one record 

 Each record is a series of data separated by commas 

 The first record of the file is special, and contains a list of fieldnames. This defines the format of the rest of the 

file. 

 Required fieldnames - These fields must be included in the first record, and defined for each column 

groupname 

 Default fieldnames - These are optional - you may specify idnumber and/or course short name of another 

course 

idnumber,coursename 

 Optional fieldnames 

groupidnumber,description,enrolmentkey 

 (Note: The field "picture" and "hidepicture" will produce a "not a valid fieldname" error when uploaded.) 

 If the groupingname is included, the imported groups will be allocated to those groupings. The groupings will be 

created if they do not already exist: 

groupingname 

 Separation between the comma and the text can not be a blank. 

 Commas within the data should be encoded as &#44 - the script will automatically decode these back to 

commas. 

 For Boolean fields, use 0 for false and 1 for true. 

 Either idnumber or coursename can be used to identify the course. Idnumber overrides coursename. If 

neither is specified, the groups will be added to the current course. 

 Coursename is the course shortname. 

 Group ID numbers are for matching groups against external systems. Within a course, all group ID numbers 

must be unique. 

 The file must be in ANSI encoding, at least not be saved in UTF-8 encoding. 

 Note: If a group is already registered in the Moodle database for a particular course, this script will return the 

group name for that group. Teachers are only allowed to upload groups in courses they are authorized to edit. 

 A sample file looks like this: 

groupname,description,groupidnumber,enrolmentkey  

Team 1,Group Assignment Team 1,team1,orange  

Team 2,Group Assignment Team 2,team2,purple  
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Team 3,Group Assignment Team 3,team3,green 

 2.8.3 Groupings 

 Groupings are a collection of groups. If you had 10 groups, you could combine or mix and match the smaller 

groups into 2 or more groupings. You can assign a grouping to a context like an assignment. 

 Visualising groupings: the Olympics 

 Olympic metaphor: at the Olympics, there are different sports (gymnastics, swimming, track) and many 

countries. There are two ways to think of an Olympian athlete: by the sport they compete in, and by their nationality. To 

be part of the United States Olympic Team, you must first be a swimmer, a gymnast, or a runner. You cannot be in the 

US Team without first being an athlete in a specific sport. The sport is your group. Your country is your grouping. You 

must belong to a group before joining a grouping. 

 Adding groups to a grouping 

 To add groups to a grouping: 

 In your course, click Administration > Course administration > Users > Groups. 

 Click the groupings tab: 

 

 If necessary, create a new grouping by clicking the create grouping button on the groupings page. 
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 An optional grouping ID number (an advanced setting) may be added for matching the grouping against external 

systems. Grouping ID numbers are not displayed anywhere on the site. Within a course, all grouping ID numbers must 

be unique. Thus it's not possible to create a grouping with a duplicate grouping ID number. 

 Click the "Show groups in grouping" people icon in the edit column: 

 

 On the add/remove groups page, select the group(s) you want to add to the grouping from the "Potential 

members" list. 

 Click the arrow button that points towards the "Existing members" list. 

 

 Click the "Back to groupings" button. The group(s) you added to the grouping will now be listed in the table on 

the groupings page. 

 Existing groupings can be edited and/or deleted using the appropriate icons in the edit column of the table on 

the groupings page. 

 Setting the default grouping 

 Once some groupings have been created, a default grouping for course activities and resources may be set. 

1. Follow the settings link in the course administration block. 

2. In the groups section in the course settings, select the default grouping. 

 The default grouping is used on the Participants page. 

 Selecting a grouping for an activity 

 To use a particular grouping in an activity: 

1. In the "edit settings" link of the Settings block for the activity, click the "Show advanced" button in the common 

module settings section. 

2. Ensure that the group mode is set to separate or visible groups. 

3. Select the grouping from the grouping dropdown menu. 
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4. Click the "Save changes" button at the bottom of the page. 

 Students will only see the activities they have been assigned to. Teachers will see the name of the grouping in 

brackets after the activity name on the course page. A count of activities assigned to each grouping is kept on the 

groupings page. 

 Please note that the grouping option appears by default only in activities that support group modes. 

 Restricting an activity, resource or course topic to a grouping 

 To be able to restrict an activity, resource or course topic to a grouping, Conditional activities must be enabled. 

This will result in a 'Restrict access' section in the activity, resource or topic settings and a grouping restriction can then 

be added. 

 

2.9 Cohorts 
Cohorts are site-wide or category-wide groups. Cohorts enable all members of a cohort to be enrolled in a 

course in one action, either manually or synchronised automatically. 

2.9 Creating a cohort 

Cohorts can be created by site administrators and other users with appropriate permissions. 

 Access Administration > Site administration > Users > Accounts > Cohorts 
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 Click the Add button 
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 NOTE In the dropdown you can choose between making your cohort available throughout the site "system" or 

in a named category. 

 Cohorts are visible to teachers by default but unchecking the 'Visible' link will mean they are not available for 

teachers to use in their courses. 

 Complete the details and save the changes. 

 Follow the assign link opposite the cohort name in the list of available cohorts. 

 

 Select potential users from the list then click the Add button. 

To synchronise cohort members with course participants, the Cohort sync enrolment plugin should be enabled in 

Administration > Site administration > Plugins > Enrolments > Manage enrol plugins. 

Creating cohorts in bulk 

1. Cohorts can be created with a csv file upload to the system or to a named category from Site 

administration>Users>Accounts>Cohorts>Upload cohorts. More detailed information can be found on 

the Upload cohorts page. 

2. Category managers can upload csv files to create cohorts from the Cohorts link in the Administration block of 

their category. 

3. An example file is below. The 'Students 2014-15' cohort will be created in the system and the 'History' cohort 

will be created in the (already existing) Humanities category: 

 

Adding users to a cohort in bulk 

1. Access Administration > Site administration > Users > Accounts > Bulk user actions 

2. Find users by setting an appropriate filter 

3. Add users from the available list to the selected list 

4. Choose 'Add to cohort' with selected users 

Uploading users to a cohort 

An administrator can upload users via CSV file to existing cohorts as follows: 

1. Access Administration > Site administration > Users > Accounts > Upload users 

2. Upload a text file with the following format: 

username,password,firstname,lastname,email,cohort1 

tomjones,Pass1234*,Tom,Jones,tomjones@example.com,year3 

marysmith,Pass1234*,Mary,Smith,marysmith@example.com,year4 
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where year3 and year4 are the cohort ids of existing cohorts (i.e. not their names). 

Note: If the users already exist on the system, then you only need their username with the chosen cohort in your 

csv file. 

It is also possible to create the cohort at the same time as the users are uploaded to the system. 

username,password, firstname,lastname,email,cohort1 

jackbrown,Pass5678,Jack,Brown,jbrown@example.com,London Contingent 

In the above example, the cohort named London Contingent will be created upon upload of the csv file. 

Searching cohorts 

When a site has a large number of cohorts, keywords may be entered into the Search Cohorts box to search for 

or filter the available cohorts. 

An All Cohorts screen accessed from Site administration>Users>Accounts>Cohorts allows an administrator to 

view and search through system and category cohorts. 

 

Managing category cohorts 

Cohorts which have been created for a category rather than the system can be located by selecting the 

appropriate category and then clicking the Cohorts link in Administration>Category (name)>Cohorts. 

2.10 Grades 

2.10.1 Grader report 

All the grades for each student in a course can be found in the course gradebook, or 'Grader report' 

inAdministration > Course administration > Grades. 
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The grader report collects items that have been graded from the various parts of Moodle that are assessed, and 

allows you to view and change them as well as sort them out into categories and calculate totals in various ways. When 

you add an assessed item in a Moodle course, the gradebook automatically creates space for the grades it will produce 

and also adds the grades themselves as they are generated, either by the system or by you. 

The grades displayed are initially displayed as the raw marks from the assessments themselves, so will depend 

on how you set those up e.g. an essay out of 36 will appear as however many raw marks that student got, not a 

percentage (although this can be changed later, see below). 

Note that various default options for the gradebook are set at system level by the administrator in and can be 

marked as being overridable by you, or fixed. This means that the options will not always be set up the same way for 

every user when they see the grader report for the first time. 

Hiding settings globally 

New settings hide parts of the user interface: 

 Site administration>Grades>General settings: 'Show minimum grade' . If this setting is disabled, the minimum 

grade will default to zero and cannot be edited. 

 Site administration>Grades>Grade category settings: 'Allow category grades to be manually overridden'. If this 

setting is disabled, users cannot override category grades. 

Scrolling through the gradebook 

The gradebook allows for smooth and stable scrolling horizontally and vertically through grades. It uses the whole 

window, making it accessible on all platforms.( Note: horizontal scrolling is at the bottom of the browser window, and 

there is no horizontal scrollbar at the top.) 
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Display 

Along the top of the grader report are several rows: first the course, then the category, then the columns for 

each graded activity (for example: Assignment, Quiz, Lesson). Any activities settings which were left "uncategorised" will 

appear in the general category which is named after the course by default (any category name can be changed). 

 

You can add a row showing the range of possible scores by selecting 'Show ranges' in 'My report preferences. 
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There are three ways that the categories can be displayed: 

 Grades only - without the category totals column 

 Aggregates - Category total column only 

 Full view - grades and the aggregates (the totals column for the category) 

Each section has a small icon immediately to the right of its name. Clicking this will cycle through these display 

modes for that category; 

 

Sorting by columns 

You can sort by any column. Click the  symbol near the top of a column to sort by that column (1 below). 

This will change the symbol to a single down arrow. Clicking again will sort lowest-to-highest, changing the symbol to an 

up arrow. The arrows will toggle between these two states until you click on a different column. 

You can also access the Single view by clicking the pencil icon next to the arrows (2 below). 

 

You can sort the students by clicking the arrow (1 below), access individual user reports by clicking the icon (2 

below) and similar to the grade items you can access Single view by clicking the pencil icon (3 below). 

 

Searching and filtering the gradebook 

If you change the course settings Group mode to Visible groups or Separate groups a drop-down menu will 

appear in the gradebook to allow you to filter your students by groups. 

It is also possible to search students by first name and last name: 
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Editing 

Note: Editing anything in the gradebook refers to editing the grades only and none of the available operations 

bear any relationship to editing the main course page i.e. the appearance of your course page cannot be influenced by 

anything you do in the gradebook. The "Turn editing on" button functions separately from the main course one, so 

editing can be on in the gradebook, but simultaneously off when you switch back to course view. This is because editing 

grades and editing the course page are separate capabilities. Roles such as 'non-editing teacher' may only have one or 

the other. 

Altering the grades 

You can click "Turn editing on" at the top right to show an edit icon next to each grade. Clicking on the icon will 

bring up the editing screen for that grade which will allow you to set the grade, its written feedback and a number of 

other attributes. 

Alternatively, you can choose "Quick grading" and "Quick feedback" in 'My preferences' to make the report 

appear with editable boxes containing each grade, so you can change many at once. This capability can be a real time 

saver, but make sure to save at reasonable intervals lest a pageful of changes be lost. 

Note: If you make changes here, they are then shown highlighted to indicate grades which have been manually 

changed. 

Hiding columns or individual grades 

Turning on editing then clicking the "Show show/hide icons" link will give you the familiar show/hide eye icon 

next to each grade and at the top of each column. For more information, read about grade hiding. 

Recalculating 

If you change any part of an assessment e.g. alter the maximum grade for one of the questions in a quiz, you 

may find that the columns do not yet reflect the change you have made. Click Turn editing on twice to force the 

gradebook to re-check. 

Gradebook capabilities 

There is just one gradebook capability, View the grader report, which is allowed for the default roles of 

manager, teacher and non-editing teacher. 
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2.10.2 Grade settings 

Course grade settings 

Course grade settings determine how the gradebook appears for all participants in the course. 

Course grade settings are found in Administration > Grade administration > Course grade settings or via the 

gradebook Settings tab. 

The default course grade settings are set by an administrator in Administration > Site administration > Grades. 

 

Grader report preferences 

Teachers can set their preferences for the grader report via 'My preferences' These settings will apply to all 

courses for that teacher. The teacher may change them at any time. 

For example it's possible to set the grader report to only show active participants or all participants (including 

suspended users) from the Show only active enrolments setting. 

The default grader report preferences are set by an administrator in Administration > Site administration > 

Grades > Report settings > Grader report. 
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Site administration settings 

Default values for all grade settings can be set by an administrator. The easiest way to do so is to log in as admin 

then browse a course gradebook and follow the 'Change defaults' links. 

The following additional grade settings can be found in Administration > Site administration > Grades > General 

settings. The settings will affect all gradebooks used by all teachers. 

Graded Roles 

Graded roles are the type of user that will appear in the gradebook. Most of the time "student" is the only one 

needed. 

User profile report 

The default user profile report setting has just one option, 'User report', unless a custom user report has been 

added to the site. 

Teachers can view the user reports for all or selected students in the course in Administration > Grades 

administration > User report. 

Include scales in aggregation 

Scales can be included as numbers in all aggregated grades across all gradebooks in all courses. Changing this 

setting will force all aggregated grades to be recalculated. 

If this is checked (and it is by default) then all custom scales will have a corresponding value that is assigned 

based on the number of options in the scale (ie. three values will have values of 1,2,3) and this will be included in the 

grade aggregation. 

Enable publishing 

Grade publishing is a way of importing and exporting grades via a URL without being logged in to Moodle. Grade 

publishing is intended for administrators only. Security implications should be thoroughly considered before allowing 

non-admin users to publish grades. 

Grade publishing may be enabled by checking the gradepublishing box. If enabled, administrators are provided 

with grade export publishing settings in each course gradebook. 

 

Recover grades default 

When manually enrolling a student in a course, there is an option 'Recover user's old grades if possible', 

however this checkbox is easy to miss. Enabling 'Recover grades default' results in 'Recover user's old grades if possible' 

being ticked for every course. 
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Unlimited grades 

Teachers can enter grades over 100% directly in the gradebook if the unlimitedgrades setting is enabled. 

Grade point maximum/Grade point default 

The administrator can set here the maximum point value in activities, and also the default point value which will 

appear when a teacher uses points for activities in their course. (Both these are set to 100 initially) 

 

2.10.3 Managing grades 

Grade items 

A grade item is a unit (typically an activity) where course participants are assessed through a grade or mark. As 

such, a grade item is a container for grades and a set of settings applied to these grades. The settings affect the 

calculation and display of the grades in the gradebook reports and exports. 

Grade items may refer to course activities (e.g. a quiz, an assignment etc.), Outcomes or manual grades. 

Grade items and gradebook 

The three building blocks of the Gradebook are: 

1. The grade item 

2. The grade category 

3. The grade 

Grade items are represented by columns in the grader report. 

Within a category, a grade summary is also a grade item itself. Summary grade items for a category can show up in 

reports, and can be used in the calculation of the grade for the parent category. 
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Activity-based grade items 

A number of activities such as Assignment,Workshop, Lesson, Quiz and others communicate their grades to the 

gradebook. The generated grade item can later be directly from Course administration>Grades, but this will then freeze 

it in the activity itself, meaning a teacher who has edited an assignment grade in the gradebook will not be able then to 

change it from the assignment, unless they unlock it in the gradebook. 

 

Here is a list of the settings that can be edited for an activity-based grade item: 

 Item name The name given to this item, for example the assignment name 

 Item info: General information about the grade item. Optional. 

 Grade to pass: Specify the minimum grade a student must achieve to be considered to have passed this item. 

This must be in real grades, not a percentage. Once this is done, grades will be highlighted in red for fail and 

green for pass in the gradebook. 

 Grade type: There are 4 grade types: 

1. None - No grading possible 

2. Value - A numerical value with a maximum and minimum 

3. Scale - An item in a list 

4. Text - Feedback only 

Only value and scale grade types may be aggregated. The grade type for an activity-based grade item is set on the 

activity settings page. 

 Overall decimal points: This specifies the number of decimal points to display for each grade. It has no effect on 

grade calculations, which are made with an accuracy of 5 decimal places. 
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 Multiplicator: Factor by which all grades for this grade item will be multiplied, with a maximum value of the 

maximum grade. For example, if the multiplicator is 2 and the maximum grade is 100, then all grades less than 

50 are doubled, and all grades 50 and above are changed to 100. 

 Offset: Number that will be added to every grade for this grade item, after the Multiplicator is applied. (Can be a 

negative number.) 

 Hidden: Whether this grade item should be hidden from students. 

 Hidden until: An optional date after which the grade item will no longer be hidden (i.e. a grades release date) 

 Locked: Whether or not to lock this grade item. A locked grade item doesn't accept changes to its settings or 

grades from its related module. 

 Locked after: A date after which the locking will be effective, usually after the grades release date. 

Outcome items 

An outcome item is in most respects the same thing as a grade item. The main difference between the two is that 

the purpose of a outcome item is to rate students on a particular outcome/competency/goal, whereas grade items are 

used for grading students, usually with the intention of aggregating the results as a measure of the student's 

performance in the course activities. 

An outcome item is always linked with an outcome, which itself is linked to a scale. The scale may represent a 

quantitative measure, its values being arranged from lowest to highest; or it may represent a qualitative measure, in 

which the order of the scale values is irrelevant. The first type can be aggregated, but the second type shouldn't (we 

wouldn't want to fail a student because her favourite colour is "blue"!). 

An outcome item may optionally be linked to an activity. This activity may or may not appear in the gradebook (for 

example, a wiki is usually not graded, so does not appear). Linking an outcome item with an activity creates a grade item 

with the icon of the linked activity, but there is no other way to see which activity it is linked with. For this reason, it is a 

good idea to include the activity name in the name of the outcome item (e.g. Wiki 1: Participation). 

These can either be generated by the creation of a new activity module (by selecting Outcomes in the module 

creation form), or manually created like manual grade items. A grade outcome item uses a course outcome as its 

grading type, so such an outcome must be made available at the course level before a grade outcome item can be 

manually created. 

The settings of the grade outcome item edit form are identical to those of manual grade items, with the addition of 

two settings: 

 Outcome: The course outcome represented by this item 

 Linked activity: The optional activity module to which this item will be linked 

Manual grade items 

These grade items are created manually fromCourse administration>Grades>Set up>Categories and items. The "Add 

grade item" button is clicked, and the form appears. Several options are available here; 

 Item name: The display name of your grade item 

 ID Number: An arbitrary string of characters used to refer to this grade item in Formulas. If set, it must be 

unique. 

 Grade type: The type of grade: None (no grading possible), Value (a numerical value), Scale (an item in a list) 

or Text (arbitrary text). 
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 Scale: Which scale to use for grading: available only when the Scale grade type is selected. 

 Maximum grade: The maximum grade that can be given (for scales: the number of items in the scale - 1) 

 Minimum grade: The minimum grade that can be given (for scales: 0) 

 

Manual grade items are recognised in the Grader report by their icon like a pencil: 

 

Note that this icon is not clickable; to edit the manual grade item you have to click the edit icon just below it. 

Grade item settings 

Site defaults 

Grade item settings, accessed from Administration > Grades > Grade item settings, are the various settings that 

the administrator is able to edit for the grader report used by teachers. These settings will change what items are 

displayed for each grade. As administrator, you would turn on or off various settings and the teacher would input the 

actual data. 
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Grade display type 

This is the type of grade that is to be shown for each individual grade. Different school districts use different 

grading systems so this can be changed to suit your district. 

 Real - Grade from minimum to maximum range indicating total points received. Default from 0-100 but may 

be arbitrary. 

 Percentage - Grade from 0 - 100% indicating the total points received divided by maximum possible amount 

times 100. 

 Letter- Grade in the form of a letter representing a range of percentages. 

Overall decimal points 

This setting is for display purposes only. Grade calculations are made with an accuracy of 5 decimal places and 

grade letters, if used, are assigned accordingly. 

If rounding of grades in grade calculations is required, the round(number, count) function may be used. 

Advanced grade item options 

You can determine here what will be displayed when a teacher clicks on the 'Show more' link. These features 

can be set or viewed: 

 Item info 

 ID Number 

 Grade Type 

 Scale 

 Minimum Grade 

 Grade to pass 

 Offset 

 Multiplicator 

 Grade display type 

 Overall decimal places 

 Hidden 

 Hidden until 

 Locked 

 Locked after 

 Maximum Grade 
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Grade letters 

What are grade letters? 

Grade letters, also called letter grades, are symbols used to represent a range of grades. For example "A" could 

be used to represent grades of 80% and above, "B" to represent grades between 70 and 80%, "C" to represent grades 

between 50 and 70%, and so on. Alternatively, you could have "Pass" for grades above 50% and "Fail" for grades below 

50%. 

 

Displaying grade letters 

To change particular grade items, category and course summaries (called aggregations) in the grader report and 

user reports to display letter grades: 

1. Follow the grades link in the course administration block. 

2. Select "Categories and items" from the gradebook dropdown menu. 

3. Click the edit icon for Category total or Course total. 

4. From the Grade display type menu, select letter. 

5. Click the "Save changes" button at the bottom of the page. 

Repeat this for any other totals that you want displayed as letters. 

Alternatively, to display ALL grades as letter grades: 

1. Follow the grades link in the course administration block. 

2. Select "Course settings" from the gradebook dropdown menu. 

3. From the Grade display type menu, select letter. 

4. Click the "Save changes" button. 
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Editing course-level grade letters 

Grade letters are set initially at site level. To use different grade letters in a particular course: 

1. Follow the grades link in the course administration block. 

2. Select Letters from the from the gradebook dropdown menu. 

3. Click the edit tab in the middle of the page. 

4. Check the override site defaults box. 

5. Change grade letters and/or boundaries as required. (You may wish to use words, for example Below Pass, Pass, 

Merit, Distinction, rather than letters.) 

6. Scroll to the bottom of the page and click the "Save changes" button. 

Setting grade letter site-level defaults 

To set grade letter site defaults: 

1. Login as an administrator. 

2. Access Site administration > Grades > Letters. 

3. Change grade letters and/or boundaries as required. 

4. Scroll to the bottom of the page and click the "Save changes" button. 

 

Forcing grade letter site-level defaults 

To force grade letter site-level defaults in all courses i.e. remove the ability for teachers to override site defaults and 

edit grade letters in their courses: 

1. Login as an administrator. 

2. Access Administration > Users > Permissions > Define roles 

3. Edit the role of teacher and change the capability moodle/grade:manageletters from Allow to Not set. 

4. Scroll to the bottom of the page and click the "Save changes" button. 

Accuracy of grade calculations 

Grade calculations are made with an accuracy of 5 decimal places and grade letters assigned accordingly. The 

overall decimal points setting (in the system grade item settings and for individual grade items) is for display purposes 

only and is not used when assigning grade letters. 

Grade categories 

Grades can be organised into grade categories. A grade category has its own aggregated grade which is calculated 

from its grade items. There is no limit to the level of nesting of categories (a category may belong to another category). 

However, each grade item may belong to only one category. Also, all grade items and categories belong to at least one, 

permanent category: the course category. 

Adding a grade category 

To add a grade category: 
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1. Select "Categories and items" from the gradebook dropdown menu. 

2. Click the "Add category" button near the bottom of the page. 

3. Give the grade category a meaningful name. 

4. Select grade category settings as appropriate. Advanced settings may be made available by clicking the "Show 

advanced" button. 

5. Click the "Save changes" button. 

Editing a grade category 

To edit a grade category: 

1. Select "Categories and items" from the gradebook dropdown menu. 

2. Click the edit icon opposite the grade category you wish to edit. 

3. After editing the grade category, click the "Save changes" button. 

 

Grade calculations 

A grade calculation is a formula used to determine grades, based (optionally) on other grade items. Note that 

this is not the same as Calculated question types. 

Calculations for the gradebook follow the pattern of formulas/functions in popular spreadsheet programs. They 

start with an equal (=) sign, and use common mathematical operators and functions to produce a single numerical 

output. This output is then used as the computed value for the grade item you are editing. 
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Setting a grade calculation 

 

To set a grade calculation: 

1. Login as teacher or other user with permission to edit grades 

2. Click on Grades in the course administration block 

3. Click the 'Categories and items' 

4. Click the 'Edit settings' and then 'Edit calculation'. N ote: if you don't see this, then it must be enabled in Site 

administration>Grades>Report settings>Grader report 

5. Start with an equal sign (=) 

6. Choose a function; Example: =sum() 

7. Plug in your ID numbers enclosed in double square brackets, for example =sum([[item1]][[item2]][[item3]]) 

8. Separate each ID number with a comma, for example =sum([[item1]],[[item2]],[[item3]]) 

9. Click the "Save Changes" button 

Assigning ID numbers 

You can include the values of other grade items by using their ID number as references in your formulas. The ID 

number is surrounded by double square brackets, for example if you have a grade item with Quiz.3 as ID number, you 

will refer to this item as [[Quiz.3]] in your calculation. 

Below the calculation field is a list of your course with its grade categories and grade items. Next to each item or 

category's total is displayed the ID number you can use in your calculation (already surrounded with double square 

brackets). However, since the ID number is optional, some items may not yet have one. These items without an ID 

number have instead a form field which lets you enter an ID number directly. 

As soon as you have assigned the ID numbers you need, you can click the "Add ID numbers" button, and the 

page will reload and show you the same list with the ID numbers you have just assigned. 

Calculation functions 

Every calculation must start with an equal sign (=). Following is a list of the functions supported by the 

calculation. The comma (,) character is used to separate arguments within function brackets. The comma can also be 

used to separate different functions. (The separator character could be a semicolon (;) in other languages, see below). 

 average([[item1]], [[item2]]...): Returns the average of a sample 

 max([[item1]], [[item2]]...): Returns the maximum value in a list of arguments 

 min([[item1]], [[item2]]...): Returns the minimum value in a list of arguments 

 mod(dividend, divisor): Calculates the remainder of a division 

 pi(): Returns the value of the number Pi 
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 power(base, power): Raises a number to the power of another 

 round(number, count): Rounds a number to a predefined accuracy 

 floor(number): Maps a real number to the largest previous integer 

 ceil(number): Maps a real number to the smallest following integer 

 sum([[item1]], [[item2]]...): Returns the sum of all arguments 

 an asterisk (*) gives the product of two items: [[item1]]*[[item2]] 

 

Grade history 

What is Grade history? 

Accessed from Course administration > Grade administration > Grade history, the Grade history report allows 

teachers to select specific students, grade items and/or graders and view the grading history for certain dates. 

It is possible to view only revised grades and to download the data in various format such as .csv or an 

Excel/Libre Office spreadsheet. 

 

 

 

 

 

 

 

 

 

 

 

Grader 

Note: Currently, if your course contains quizzes or workshops, then you will see your students listed in the 

'Grader' dropdown. This is expected as they are graders in a workshop and are self-grade in a quiz.  
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Site administration settings 

The administrator can decide how many history entries will be displayed per page in the Grade history report by 

specifying a number in Site adminstration > Grades > Report settings > Grade history. The default is 50. 

Disabling grade history 

Grade history may be disabled, or the history only kept for a specified period, by editing the settings in Site 

administration > Server > Cleanup. Diabling grade history may speed up the server a little and conserve space in the 

database. 

2.10.4 Scales 

Scales are a way of evaluating or rating a students' performance. Administrators can create standard scales 

which are available across the site, and teachers can create custom scales just for their own course. (If you prefer, you 

can use grade points or no grade at all.) 

Scales may be used in Forums, Glossaries and Assignments for rating and/or grading a student's activity. 

Creating a new scale 

New scales can be created by teachers with editing rights or by administrators or by any user with the manage 

scales role capability. 

Creating course scales 

 Click the "Add a new scale" button in Course administration > Grades > Scales. 

 On the next page give your scale a name in the Name box that will identify it among other scales. 

 'Standard' scale is a scale which can be applied to every course in Moodle. Only those with site permissions such 

as administrators can make a new scale 'standard'. A regular teacher can only create a scale for their own 

course. 
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 In the Scale box, create your scale. Each item in the scale should be separated by a comma. You can use as many 

options here as you require. You must order the comma separated elements in increasing order of value. For 

example, an A,B,C,D scale must be entered as D,C,B,A. 

 Write a detailed description in the Description box to remind you (or other teachers) of how the scale is to be 

used. 

 Save the changes. 

Single rating scale 

Only selecting one option allows you to create a "Like" scale similar to Facebook or a "Useful" scale similar to that 

on Moodle.org. 

 

 

Creating a standard scale 

An administrator can create a standard scale which can be used in any course in Administration > Site administration 

> Grades > Scales 

Using scales 

A teacher may select a scale by going to the Edit settings screen of an activity, for example an assignment,scrolling 

to 'Grade' and then selecting 'Scale' from the Type dropdown: 

 

This will then open up the 'Scale' dropdown, allowing them to choose the scale they wish to use. 

Editing a scale 

If a scale has not yet been used, you will see an edit, move, and delete icon in the edit column. 
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Once a scale is used for an activity, it is no longer possible to move or delete it, and you can only edit the scale 

name and description. 

Example scales 

 The Cool Scale - Not cool, Not very cool, Fairly cool, Cool, Very cool, The coolest thing ever! 

o (Valued as 0/5pts, 1/5pt, 2/5pts, 3/5pts, 4/5pts, and 5/5pts respectively in any normalized aggregation 

method) 

o (Valued as 1, 2, 3, 4, 5, and 6 respectively in the sum aggregation method) 

 General Introductions (The Affirmative Scale) - Welcome!, Glad to have you here!, Great post! 

o (Valued as 0/2pts, 1/2pt, and 2/2pts respectively in any normalized aggregation method) 

o (Valued as 1, 2, and 3 respectively in the sum aggregation method) 

 If you would like two options in your scale (incomplete and complete) type "incomplete, complete" in the scale 

box. 

o (Valued as 0/1pts and 1/1pt respectively in any normalized aggregation method like weighted mean, 

mean, simple weighted mean, etc.) 

o (Valued as 1 and 2 respectively in the sum aggregation method) 

 Generic Social Forum (This scale only worked prior to the averaging function) - Please clarify., I don’t 

understand., Hmmm. Tell me more., Interesting, Very cool., Awesome! 

o (Valued as 0/6pts, 1/6pt, 2/6pts, 3/6pts, 4/6pts, 5/6pts, and 6/6pts respectively in 

any normalizedaggregation method) 

o (Valued as 1, 2, 3, 4, 5, 6, and 7 respectively in the sum aggregation method) 

 "Refer", pass, merit, distinction 

o (Valued as 0/2pts, 1/2pt, and 2/2pts respectively in any normalized aggregation method) 

o (Valued as 1, 2, and 3 respectively in the sum aggregation method) 

 "Hesitant" Fail, Acceptable, Average, Excellent 

o (Valued as 0/3pts, 1/3pt, 2/3pts, and 3/3pts respectively in any normalized aggregation method) 

o (Valued as 1, 2, 3, and 4 respectively in the sum aggregation method) 

 "Stars" ☆----, ☆☆---, ☆☆☆--, ☆☆☆☆-, ☆☆☆☆☆ 

o (Valued as 0/4pts, 1/4pt, 2/4pts, 3/4pts, and 4/4pts respectively in any normalized aggregation 

method) 

o (Valued as 1, 2, 3, 4, and 5 respectively in the sum aggregation method)  

Values calculated as percentage scores 

Moodle uses the last entry to determine the number of points in the scale for computing percentages. For example, 

if your scale is 0,5,6,7,8,9,10 then Moodle will use a 0-6 or 1-7 point scale depending on your chosen aggregation 

method. 

 When using a normalized aggregation method, 0 will become 0/6, 5 will become 1/6, 6 will become 2/6, 7 will 

become 3/6, 8 will become 4/6, 9 will become 5/6, and 10 will become 6/6 for grade computation, respectively. 

 When using the sum aggregation method, 0 will become 1, 5 will become 2, 6 will become 3, 7 will become 4, 8 

will become 5, 9 will become 6, and 10 will become 7. 

Either way, the numbers you enter for your scale are NOT calculated as entered, the system calculates the number 

of non-zero entries and then creates a scale from 0 to the total number of entries (n) with their values calculates as 0/n, 

1/n, 2/n, 3/n.... 
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TIP: If your scale is a custom non-value (not a number), Moodle's behavior in combining or averaging the scores into 

a percentage value is unpredictable. When an average or aggregate is important, then it is a good idea to stick with the 

standard 100% scale to compute an overall grade. 

Tip: Some sites do not like the "0" (zero) in any normalized aggregation method. 

2.10.5 Outcomes 

Outcomes are specific descriptions of what a student has demonstrated and understood at the completion of an 

activity or course. Each outcome is rated by some sort of scale. Other terms for outcomes areCompetencies and Goals. 

In simple terms outcomes are similar to sub components of a grade. A grade is an assessment of overall 

performance that may include tests, participation, attendance and projects. Outcomes assess specific levels of 

knowledge through a series of statements, that maybe coded with numbers or letters. Thus an overall grade can be 

given for a course, along with statements about specific competencies in the form of outcomes. 

Enabling outcomes 

Go to Site administration > Advanced features and ensure that Enable outcomes is checked (by default, it isn't). 

Using outcomes 

1. Choose or define some outcomes for your course (see below). 

2. For each activity, choose which of these outcomes apply using the tickbox in the activity's settings page. 

3. When grading that activity, grade each student using the Outcome scales. Note: You can also edit the grades in 

the Grader report (useful for modules that don't feature inbuilt grading). 

4. Use the outcomes as part of the assessment for students, or look at the Outcomes report for some useful 

feedback on how students in the class in general are performing. 

Outcomes report 

The outcomes report in Administration > Course administration > Grades > Outcomes report helps teachers monitor 

their students' progress using outcomes. It lists site-wide outcomes and custom outcomes used in the current course, 

their overall average (each outcome can be measured through many grade items). It will show the name, course and 

site wide average, the activity, the average values and the number of "grades" given. 

The outcomes report is a table with 6 columns: 

 Short name - the short name of the outcome used in this course. 

 Course average -shows two values representing the average scores given to students for each outcome used in 

this course. 

 Site-wide - Whether the outcome is a site-wide outcome or not. 

 Activities - This lists the activities that use this outcome in this course. A new row is created for each activity, 

and the activity name is linked to the activity's page. 

 Average - the average score for each activity using the outcome in this course. 

 Number of Grades - The number of grades given to students for each activity using the outcome. 

Outcomes used in course 

Outcomes may be set at site and/or course level. To choose outcomes for use in your course: 

1. View available standard outcomes in Administration> Course administration > Outcomes or via the gradebook 

Outcomes tab 
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2. Add outcomes from the standard available list (right side), and use the left-facing arrow button to add them to 

outcomes used list (left side). Multiple outcomes may be selected by holding down the Apple or Ctrl key whilst 

clicking on the individual outcomes. 

Adding course-level outcomes 

 

To add a course-level outcome: 

1. Click the 'Edit outcomes' link in Administration > Course administration > Outcomes 

2. Click the 'Add a new outcome' button. 

3. Complete the form then click the 'Save changes' button. 

Adding standard outcomes 

An administrator can add standard outcomes, which are available site-wide, in Administration > Site administration 

> Grades > Outcomes. Multiple standard outcomes can be added using the import outcomes functionality (see below). 

Removing selected outcomes for activities 

Previously selected outcomes are greyed out on the update activity page; however, they can be removed via the 

gradebook on the categories and items page. They will appear in the list either below or above the activity they have 

been enabled in and will have the same icon as that activity. Note that if you have renamed the outcome since you 

assigned it to the activity, the orginal name will be displayed. Deleting the outcomes from this list will result in the 

outcomes being deselected on the update activity page. 

2.10.6 Grade import 

Importing grades 

Grades may be imported as a CSV or XML file, or (new in 2.8 onwards) by pasting from a spreadsheet. 

The import file format is the same as the corresponding export format. 

Note: Grade import is equivalent to manual grading in the grader report. Thus, if grades for a particular Moodle 

activity such as an assignment are imported, they can no longer be edited via the assignment submission page. 
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To import grades into the gradebook: 

1. Decide on an import format - CSV or XML file, or paste from spreadsheet (see below) - then export some 

grades using the corresponding export format. 

2. Edit the export file as appropriate and save it. 

3. Tip: If you opened your exported file in Excel, don't add columns there because Moodle will reject the import if 

there are new columns that didn't exist in the exported file. If you need to add columns, do that in Moodle 

BEFORE you export your gradebook. 

4. Select your chosen import format from the gradebook dropdown menu. 

5. Browse and upload your previously saved file. 

6. Set options as required. 

7. Click the "Upload grades" button. 

8. CSV import only: Preview the grade import and choose the column mapping then click the "Upload grades" 

button to complete the grade import. 

 Tip: By default "Map from" is set to First Name, and "Map to" to userid. Change both dropdowns to: 

"Email Address" to "useremail", or to "Id Number" to "useridnumber" (assuming that your users have ID 

number fields filled in in their profiles). 

You need two permissions to import grades: (1) general permission to import grades and (2) permission to 

import grades in a particular format. For example, to import CSV grades you need moodle/grade:import ("Import 

grades") = Allow and gradeimport/csv:view ("Import grades from CSV") = Allow 

CSV import 

CSV import is more flexible than XML import, as you may choose the column mapping. 

Grade Mapping 

After selecting your CSV for import you'll be prompted to map user fields and grade items to the new column 

headers to ensure that there is a match. More than one item can be mapped to the same grade item in your destination 

course so be mindful of the mapping to ensure that grade data is imported properly, any collisions (i.e. if two or more 

fields are mapped to the same but duplicate data exists) will cause an error. User grade data for users not yet enrolled 

to the destination course will be noted (and once enrolled their grade data will display). 

Encoding 

If you are unsure of the encoding of your CSV file, try selecting the second option in the encoding dropdown 

menu. If you've used Excel to produce the CSV file the second option WINDOWS-xxx encoding is probably the correct 

one. The grade import preview will tell you if you guessed the encoding correctly. 

Verbose scales 

Scales can be either specified as a raw id - eg. 0, 1, 2, 3, etc. or as a string, eg. "good", "bad", "not very bad". The 

later format is called "verbose". 



 

                                                                                                                                            
339 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

Force import 

A column 'Last downloaded from this course' displaying the time stamp of the exported date is present on every 

exported file. 

This prevents grade overriding during the grade importing in a scenario where more than one teacher exports 

the course grades and then re-imports them. If a second teacher exports the grades and tries to import them, the 

following error message will be displayed and the grade importing procedure will be aborted: 

(''Student name'') grades have not been imported because the grades in the import file are older 

than in the grader report. To proceed with the grade import anyway, use the force import option. 

It will not be possible to import a file that had been exported file longer than a year ago, one with dates in the 

future. However, in cases where a teacher needs to import the grades regardless, they should use the Force import. 

option. This will then import the grades irrespective of the dates. 

Paste from spreadsheet 

Grades may be pasted directly from a spreadsheet such as Excel or Libre Office: 

1) Ensure you have the correct column names for your grades (eg the assignment title or manual grade) It might help to 

download and edit the relevant students and graded information by using the Grade export feature. 

2) For the students you need either their username, their ID or their email address. Add the grades you need and copy 

the relevant section: 

 

3) In your course, go to Grade administration>Import>Paste from spreadsheet and paste: 

 

4) In the preview, ensure you match up the identifier you used for the students -so if you used 'username', ensure it 

maps to 'username'. Do the same for your graded activities: 



 

                                                                                                                                            
340 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

 

 

5) If everything has been correctly mapped (See grade mapping above), you should get a success message and the 

grades will have been added, displaying in a different colour to show they were imported directly into the gradebook: 

 

 

Paste from a spreadsheet requires similar permissions to a csv file import: (1) general permission to import 

grades and (2) permission to import grades in a particular format i.e. moodle/grade:import ("Import grades") = Allow 

and gradeimport/direct:view ("Import grades from spreadsheet") = Allow 
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XML import 

Before importing an XML file you will need to ensure that all of the students that you want to alter grades for 

have their ID number field filled out. This is located in the "Optional" section of the user edit profile page. You will also 

need to set the ID number of the activity as well. You can find this under "Common module settings" when editing the 

activity. 

The format for the XML should be as follows: 

 

2.10.7 Grade export 

Grades can be exported to Excel spreadsheet, OpenDocument spreadsheet, plain text file or XML file, or 

published via a URL. 

Grade export is NOT intended for students. 

How to export grades 

To export grades from the gradebook: 

1. Choose an export format from the gradebook dropdown menu or in the Administration block under Grade 

administration > Export. 

2. Set options as required. 

3. If the course uses groups, select whether to export grades for all participants or for a particular group. 

4. Select the grade items to be included. Note that ID numbers are required for all activities for XML file export. An 

ID number field can be found in the common module settings for each activity. 

5. Click the export button. 
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XML file export 

To export grades to XML file, you need to ensure that: 

1. Users have ID numbers (an optional field in the user profile) 

2. Activities have ID numbers (an optional field in the common module settings) 

Export new or updated grades only 

To export only new or updated grades you need to enable XML File in Grades > General settings > Primary grade 

export methods (gradeexport). 

After this setting has been enabled, the XML File option will then set and use a "last exported" field for every grade. 

The result will export the records with the <state> tag being identified as new or regraded. 

This means the report will track the last exported date. If you export and then try again, it will not show any results 

because there are no new or updated grades since the last export. 

Default grade export settings 

The grade export display type and grade export decimal points site-wide defaults may be set by an administrator 

in Site administration > Grades > General settings. 

User profile fields export 

An administrator can specify user profile fields and custom profile fields to be included in the grade export inSite 

administration > Grades > General settings. 
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Grade publishing 

 

Grade publishing is a way of importing and exporting grades via a URL without being logged in to Moodle. Grade 

publishing is intended for administrators only, due to the security implications. 

Grade publishing is disabled by default. It can be enabled by an administrator by checking the gradepublishing 

box in Administration > Site administration > Grades > General settings. Users with grade publishing capabilities 

(normally managers only) will then be able to access the grade publishing options. 

To publish grades from the gradebook: 

1. Follow the first four steps above for 'How to export grades'. 

2. In the grade publishing options, choose 'Create a new user key' or select a key generated previously. 

3. Click the export button. A download URL will then be displayed. 

Tips and tricks 

Export grades in a spreadsheet format. Then copy and paste that information into another file that has worksheet 

("raw grades"). Create other worksheets which are custom reports which take their data from "raw grades". This works 

if graded activities are not moved around to different positions in the course. This allows you to create a standard 

printed report(s). For example a compact landscape report of all students and all grades for each activity, a report of just 

quizes, another of lessons, another of assignments. A pivot table of students by scores, generated from a report 

worksheet, which gets its data from the raw data. 

Mailmerge exported grades into custom documents. For example, a document that is given to a department to file 

as a proof of training, with scores for every subject quiz. 

2.11 Tracking progress 

2.11.1 Conditional activities 

Conditional activities enable teachers to restrict the availability of any activity or even a course section according to 

certain conditions such as dates, grade obtained, group or activity completion. When it is enabled by the administrator, 

a "Restrict access" setting appears in the settings of activities or resources and also when editing a course section. 

Conditional activities settings 

Enabling the use of conditional activities 

To use conditional activities, the feature must be enabled by an administrator by checking the "Enable conditional 

access" box in Administration > Site administration > Advanced features. A restrict access section will then appear for 

teachers on the Activity settings screen, with an 'Add restriction' button. 

Restricting access 

After clicking the 'Add restriction' button, a choice of conditions appears: 
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Restriction can be based upon Activity completion, date, grade, the group or grouping the students are in or 

user profile fields. The 'Restriction set' button also allows for more complex criteria requiring nested conditions. 

Activity completion 

See Activity completion. Note that this button only appears if you have Activity completion enabled in your 

course. 

Date 

Access can be restricted from or until a certain date and time. 

Grade 

You can specify a condition on any grade in the course: the full course grade, the grade for any activity, or a custom 

grade that you create manually. You can enter either a minimum value (at least percentage), a maximum value (less 

than percentage), both, or neither. The activity will only appear if the student has a value for the specified grade, and if 

it falls within any specified number range. You can add more than one grade condition. All conditions must be met in 

order for the activity to appear. 

1. The range numbers can be fractional (with up to five decimal places) if necessary. 

2. Be careful with the maximum value; if the maximum is 7, a student who scores exactly 7 will not see the activity. 

You could set it to 7.01 if you really wanted to include 7. 

3. If creating several different activities that appear according to grade ranges, use the same number for the 

maximum of one activity, and the minimum of the next. For example, you might create one activity with a 

maximum of 7 and another with a minimum of 7. The first would appear to everyone scoring between 0 and 

6.99999, and the second would appear to everyone scoring 7.00000 to 10. This guarantees that everyone with a 
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grade will see one or other.To remove a grade condition, set the assessment name to 'none' and remove the 

range number values 

Group and groupings 

If groups or groupings are used in the course, it is possible to restrict the activity to a certain group or grouping. 

 

User profile 

Instructions 

 Conditional access must be enabled  

 When adding or editing an activity, resource or course section scroll to the the 'Restrict Access' section and click the 

button Add restriction. 

 

 Click the button User profile 

 Choose the settings and profile fields you want to add restrictions for: 

 

 Save the settings. 

 Note that clicking the eye icon will hide the condition completely, whereas leaving it as "open" will give a greyed out 

message about the restriction: 
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User fields 

You can restrict by using one of the user fields that are located in the Moodle user table. Not all the user fields are 

included, as not all of them would make sense in this context. The ones included are listed below. 

 AIM ID - This is the value in the 'aim' column 

 Address - This is the value in the 'address' column 

 City/town - This is the value in the 'city' column 

 Country - This is the value in the 'country' column 

 Department - This is the value in the 'department' column 

 Email Address - This is the value in the 'email' column 

 First name - This is the value in the 'firstname' column 

 ICQ number - This is the value in the 'icq' column 

 ID number - This is the value in the 'idnumber' column 

 Institution - This is the value in the 'institution' column 

 Interests - This is the value in the 'interests' column 

 MSN ID - This is the value in the 'msn' column 

 Mobile phone - This is the value in the 'phone2' column 

 Phone - This is the value in the 'phone1' column 

 Skype ID - This is the value in the 'skype' column 

 Surname - This is the value in the 'lastname' column 

 Web page - This is the value in the 'url' column 

 Yahoo ID - This is the value in the 'yahoo' column 

Custom profile fields 

These are all the custom profile fields that have been created on the Moodle site.  

Operators 

The operators define the relationship between the field chosen and the value entered. For example, when the 

user's email must contain @school.com, the field chosen is 'Email address', the operator is 'contains' and the value is 

'@school.com'. 

 Contains - This operator restricts access to those whose chosen field contains the value provided. 

 Does not contain - This operator restricts access to those whose chosen field does not contain the value provided. 

 Is Equal To - This operator restricts access to those whos chosen field equals the value provided. 

 Starts With - This operator restricts access to the activity to those whos chosen field starts with the value provided. 
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 Ends With - This operator restricts access to the activity to those whos chosen field ends with the value provided. 

 Is Empty - This operator restricts access to the activity to those whos chosen field is empty. Note, if any value is 

provided in this case, it is ignored. 

Restriction set 

This allows you to add a set of complex restrictions to apply complex logic. See Using Conditional activities for an 

example. 

Hiding the conditions 

 If the eye is SHUT then students who do not meet that part of the condition will not see the activity at all. 

 If the eye is OPEN the students who do not meet that part of the condition will see the activity but it will be greyed 

out and have information about why they can't access it yet. 

The shut eye takes precedence. For example, you could have 2 conditions, one based on date (with eye shut) and 

one based on completing a previous activity (with eye open). That way, the activity will not appear at all until the date; 

then it will appear, but tell you that you need to complete the other activity; then when you complete the other activity 

you can access it. 

For OR and NOT AND type conditions, you only get a single eye icon instead of one for each condition 

 

ALL or ANY Conditions 

Further restrictions may be added by clicking the 'Add restriction' button again, and it is possible to specify that 

ALL the conditions or ANY of the conditions are required before the activity is made available. Thus, it is possible to use 

'Or' as well as 'And' conditions.  
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Restricting access to course sections 

It is possible to restrict access to activities within a whole course section by specifying the conditions in the 

settings for that particular section. 

Site administration settings 

Administrators can disable selected restriction settings if desired from Site administration>Plugins>Availability 

restrictions>Manage restrictions. 

 

Using Conditional activities 

A basic example 

Students are required to undertake 4 tasks in a precise order. According to their score in a quiz, the fourth task - a 

Moodle lesson - is either at a lower or more advanced level. They must 

 view a page explaining the course 

 post an introductory message in a forum 

 take a quiz 

 move onto a lesson tailored to their performance in the quiz. 

Here is the teacher view. 
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Students will only see the first task (the webpage)with the second task (the forum) greyed out. The other tasks 

only appear once the conditions have been met. The activities are displayed as links to make it easy for students to 

locate and complete them in order to move on. 

 

How's it done? 

 Task 1, the page must be read (or at least viewed) before students can access the forum. In task 1 the activity 

completion condition is set to require view 

 

 Task 2, the forum, needs to have the restrictions set such that the page Read This First must be marked complete. 

The "open" eye icon means the forum is greyed out until available: 
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 Task 3, the quiz, needs to have the restrictions set such that the forum must be marked complete. The "crossed out 

eye" icon means the quiz is completely hidden until a student has posted in the forum: 

 

 The student must get a grade in the quiz for the activity to be complete: 

 

 Task 4 is two lessons - either at level 1 (basic) or level 2 (advanced). If the student scores less than 50% in the quiz 

they do Level 1; if they score more, they do Level 2. In the Level 1 lesson, the restriction is set such that students can 

only access it if they get under 50% in the quiz 
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The Level 2 lesson has the restriction set such that students can only access it if they get 50% or more: 

 

An example of "all or any" 

 It's possible to set conditions such that a particular activity is available if one or more previous activities are marked 

complete, rather than all of them. In this screenshot, the Advanced task will become available either if the student 

gets above a certain grade in the quiz or if they receive a grade in the assignment. 

 

 When the first restriction is set, the teacher can then click the "Add restriction" button again to add a second (and 

subsequent) restrictions. The teacher can then change the "all" to "any" , thus changing the "and" to "or": 

 

An example of a Restriction set 

 The Restriction set button offers the possiblity of creating several criteria using all/any to create complex 

conditions. In the screenshot below, students can only access the Assessment and Feedback section of the course if 

they have EITHER completed the work on Monet OR if they completed all the work on Pissarro. 
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 The actual settings for this are as follows: 

 

Tricks and techniques 

With a bit of lateral thinking, you can achieve some interesting results beyond the most obvious uses of the 

system. Here is one example: 

Project allocation 

Imagine that you let students choose one of two projects. Each project has its own activities (a forum for all the 

people doing that project, resources with information about the project, etc). You want it to hide all the activities that a 

student isn't doing. 

This can already be achieved in Moodle using the Groupings system. However, conditional activities gives another 

way to set this up which might be preferable in some cases. Here's how: 

1. Create two forums called 'Frog project sign-up forum' and 'Zombie project sign-up forum'. 

2. Set both forums to be automatically marked complete once the user makes 1 post. 

3. Set each forum to be conditionally available only if the other forum is NOT complete. 

4. Create other activities for the frog and zombie projects. For each Frog activity, set it to be conditionally available 

only if the Frog sign-up forum is marked complete. For each Zombie activity, set it to be conditionally available 

only if the Zombie sign-up forum is marked complete. 
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When a student first visits the site, they see the frog and zombie sign-up forums and none of the project activities. 

As soon as they post in one of the forums, the other forum will disappear, and all the activities for their preferred 

project will appear. (If they want to change their mind, they can delete their forum post so that it isn't marked complete 

any more, and it'll be back to square one.) 

Should you really use conditional activities? 

Conditional activities are a way for you to force your students to do things in a certain order. Is that really what you 

want? The answer will depend on your particular circumstances, but it is worth taking a moment to reflect upon the 

degree to which conditional activities are appropriate for your course.It is certainly good course design to make it clear 

to your students what they are expected to do next, to give good guidance. Conditional activities can be used to create 

alternative pathways and to introduce repetition. As course sizes grow, such mechanisms can allow teachers to offer 

learning experiences that cater more to individuals, providing reinforcement when it is needed. However, some may still 

prefer to use labels and layout rather than locks and keys to direct the learning path. 

2.11.2 Activity completion 

Activity completion allows the teacher to set completion criteria in a specific activity's settings. A check (tick) 

appears against the activity when the student meets this criterion. The criterion might be viewing, receiving a certain 

score or a student marking it as complete. 

Site administration > Advanced features > Completion tracking must be enabled on the site. 

Note: If Completion tracking has been enabled, the teacher will see the Activity completion group in their course 

settings. However, it is possible to track activity completion without using the Course completion feature. It is also 

possible to use this feature with the Conditional activities feature. These 3 features can be used separately or in various 

combinations in an activity. 

 

Activity completion settings 

Activity settings 

Depending on the type of activity, there are different completion requirements. For example, a Page might have 

the requirement to require view; a Quiz might have the requirement to require grade while a Forum might have the 

requirement to require posts/discussions/replies. 
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Completion tracking 

There are three options: 

 Do not indicate activity completion - this will not show checks (ticks) next to the activity 

 Students can manually mark the activity as completed - students press the check (tick) to change it. (Note: 

they can do this even without doing the activity!) 

 Show activity as complete when conditions are met - the selected completion criteria must be met before 

the check (tick) will change style 

Require view 

When this option is turned on, students have to view the activity in order to complete it. 

 In most cases, clicking the link is enough to 'view' the activity. 

 You should usually not turn on the 'view' condition if you have other requirements - this makes extra work for 

the server and it's unlikely that a student could meet any other conditions without viewing the activity. 

Require grade 

When this option is turned on, students have to get a grade on the activity in order to complete it. For example, 

a quiz would be marked completed as soon as the user submits it (so long as it doesn't contain any "essay" questions). 

It does not matter how well the student did. Getting any grade will mark the activity completed. 

Setting a grade to pass for a quiz 

It is possible to distinguish between 'pass' and 'fail' grades so that a quiz becomes 'completed, passed' or 

'completed, not passed' instead of just 'completed'. These results show a different icon and alternative text. 

To set this up, you need to specify the pass value for the quiz activity's individual grade: 

1. Go to the course gradebook by clicking the 'Grades' link on the course administration block 

2. Go to 'Categories and items' under Setup 

3. Click the Edit settings link for the grade item for the quiz 

4. In the Grade item section click 'Show more...' 

5. Enter a grade value (e.g. 5.0) in the 'Grade to pass' box 

6. Click the 'Save changes' button 

Once you have done this, anybody submitting the quiz will receive either the pass or fail completion icon. If the 

quiz can be taken multiple times, the completion icon will automatically update whenever the grade does. 
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There is one limitation: this only works if grades are immediately visible to students. The grade must be neither 

permanently hidden, nor hidden until a certain date. If a grade is hidden then only the standard 'completed' state will be 

displayed - even once the hidden date has passed. 

Quiz completion settings 

The following settings are specific to the quiz: 

 

Require passing grade 

If a 'Grade to pass' is set for the quiz then it will be marked complete once the student obtains this grade. 

All available attempts completed 

If a certain number of attempts are allowed, the quiz may be marked complete once the student has done them 

all (even if, for example, they did not achieve the passing grade.) 

Require submission 

This setting appears in assignments and means that an assignment may be considered as completed once the 

student has submitted - but before the teacher has had time to grade it. 

Expect completed on 

The date is not shown to students and is only displayed in the Activity completion report. 

Require posts 

This setting is seen in forums. For the forum to be classed as "complete" the student must either start a 

discussion or reply to a discussion. The number of posts they must make can be specified in the box. 

Require discussions 

This setting is seen in forums. For the forum to be classed as "complete", the student must start a discussion 

topic. The number of posts they must make can be specified in the box. 

Require replies 

This setting is seen in forums. For the forum to be classed as "complete" the student must reply to a discussion. 

The number of posts they must make can be specified in the box. 

Locked completion options 

If at least one person has completed an activity, completion options are 'locked'. This is because changing these 

options may result in unexpected behaviour. For example, if somebody has ticked an activity as manually completed, 

and you then set it to automatic completion, the activity will become unticked - very confusing for the student who had 

already ticked it! 
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Tip: It is best not to unlock options unless you are sure it won't cause problems - for example, if you know that 

students don't have access to the course yet, so it will only be staff who have marked the activity completed when 

testing. 

What happens when you unlock 

Once you unlock options and then click 'Save changes', all completion information for the activity will be deleted 

and, if possible, regenerated according to the new settings. 

 If the new completion option is manual, everyone will be set to 'not completed' regardless of any previous 

setting. 

 If it is automatic then, depending on the options chosen, the system may or may not be able to construct a 

correct current value for everyone. 

o The 'viewed' requirement will not work - even if a student has viewed the activity before, it will not be 

marked completed until they view it again. 

o Most other options will be recalculated successfully. 

If you change completion options while a student is logged in, they may not see the changes for some minutes. 

Required site settings 

To use activity completion, the feature needs to be enabled for the site by an administrator as follows: 

 In Administration > Site administration > Advanced features check the "Enable completion tracking" box. 

 The admin may also set the default completion tracking setting when adding new activities, choosing from 

'Do not indicate completion' or ' Use activity default' 

 

 Click the 'Save changes' button 

Tip: The default Cron trigger for activity completion is every 10 minutes. Students and Teachers often think any 

course completion should instantly show up in a report. 

Required course settings 

Administration > Course administration > Edit settings and look for the Completion tracking section. 

You must enable this setting. 

Using Activity completion  

Why use Activity completion? 

 If this feature is enabled, it is a helpful way for students to be able to track their progress in a course. The 

student has an easy to see checklist of what they have done so far. 

 It can also be linked to Course completion in order to allow both students and teachers to watch progress 

through a course. As each activity is checked off as "complete", the student moves futher towards final 

completion of the course. 

 It can also be linked to Conditional activities in order to allow the teacher to set criteria upon which a 

student is allowed to progress through a course and access materials. 
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Activity completion icons 

 manual - not yet marked as complete 

 manual - enabled 

 manually completed 

 automatically completed 

 automatically failed 

 automatic - not completed 

 automatically passed 

 automatic - enabled 

Activity completion report 

Activity completion info can be viewed by managers, teachers and non-editing teachers (and any other users 

with the capability report/progress:view) in Administration> Course administration> Reports > Activity completion. 

 

2.11.3 Course completion 

Course completion shows if a course has been completed. It can show the progress a student is making towards 

finishing the course according to specific criteria. The criteria can include meeting an activity's grade level or a manual 

checking "complete" by either the student and/or teacher. The report can also show if the student has completed 

another course(s) that is marked as a "completion dependent" course. 
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Course completion does not have a "restrict access" function. It is best thought of as a report. 

Course completion settings 

Enabling course completion 

An administrator can enable course completion for the site by ticking the 'Enable completion tracking' checkbox 

in Administration > Site administration > Advanced features. 

A teacher can then enable course completion for their course by setting 'Enable completion tracking' to Yes in 

Administration > Course administration > Edit settings. (This also enables the use of Activity completion.) 

A 'Course completion' link will then be shown under Course administration in the Administration block. 

Course completion settings 

General 

 

Choose here how you wish to mark the course complete -whether you want Any or All of the requirements that 

follow to count towards completion. 

Condition: Activity completion 

(These settings are collapsed by default.) 

 

Tick the boxes of the activities you wish to count towards completion of the course. (You need to have Activity 

completion enabled to be able to do this. You can decide whether ALL of the activities must be completed or ANY one of 

them. 

Condition:Completion of other courses 

(These settings are collapsed by default.) 

                        

 This setting allows you to make "the completion of another course" as a condition for 

completing the course you are currently working in. This does not block the student from your current course; it simply 

means that the current course will not be marked complete until the first course has been marked complete. Thus, 

completion of the current course is dependent upon completion of an earlier course. Just select one or more courses in 

the "Courses available box". Note: 
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Once you have selected a course, it's not currently possible to remove it.  

Condition: Date 

(These settings are collapsed by default.) 

 

If you tick the Enable box you can then set a date after which the course will be declared complete. 

Condition: Enrolment duration 

(These settings are collapsed by default.) 

 

If you tick the Enable box you can then choose a number of days after enrolment upon which the course will be 

marked complete. 
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Condition: Unenrolment 

(This one setting is collapsed by default.) 

If you tick "Enable" here then the course will be marked complete once the student is unenrolled. 

Condition: Course grade 

(These settings are collapsed by default.) 

 

If you tick the Enable box, you can set a passing grade for the course. 

Condition: Manual self-completion 

(These settings are collapsed by default.) 

 

If this is enabled then a student can mark the course complete themselves from the Self completion block. 

Condition: Manual completion by others 

(These settings are collapsed by default.) 

 

Users with selected roles may mark the course as complete if their role is ticked here. The roles listed are ones 

for which the capability Mark users as complete in course completion is allowed. 

ALL means that each role must mark the course complete before; ANY means that it will be classed as complete 

once one role has marked it complete. 

Course administration settings 

Course administration > Edit settings 

 Completion tracking must be enabled. 

Site administration settings 

Use Site administration > Advanced features > Enable completion tracking (check enabled) in order to allow 

completion tracking on your site. 

You can set Completion tracking as On or Off in new courses as a course default in Site administration > Courses > 

Course default settings. 
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Using Course completion 

Ways of using course completion 

Course completion can be used in many ways. It is important to remember that this feature is only a reporting 

feature. 

While course completion will not lock a student out of another course, it will allow a teacher to see if a student has 

completed the recommended prerequisite courses. 

It can also work with Activity completion to show students the activities they have completed. This can be via a 

check mark next to the activity on the course's home page, or by looking at the Course completion status block. 

It is a way to ensure that the teaching team's members sign off that a student has completed the course. For 

example, Teacher B is the instructor for Course2, which has a recommended prerequisite for completing Course1. 

Teacher B, is the non-editing teacher in Course1 and must check the box that indicates the student has completed the 

course. 

 

 

In the Example 1 image, the teacher has not checked off that "Test User1" has finished this course. 

Courses can be linked via their course completion criterion. 

Note: The course completion feature works with Cron. Thus changes in reports may not appear until after 

cron.php has run. 

Manual completions 

Depending upon the settings, course completion can require that an activity or the entire course be manually 

marked as complete. The settings will allow any number of combinations. For example, an activity might require the 
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student to receive a minimum score and have the non-editing teacher manually check complete. Or merely require the 

student to check an activity or the course as complete. 

Manual marking by student examples 

A course completion setting may require the student to confirm they have completed the course. Students do 

this by using the Self completion block. 

 

A course completion setting may require a student to manually mark an activity when they believe they have 

finished it. On the course homepage, the student may see a box to check as a self completion of the activity. See 

Example 1 above. 

Manual marking by teacher examples 

In order for a teacher (or non editing teacher, Manager or other role) to mark a course as complete, the 

appropriate box in the Manual Completion by.. section must be checked in the completion tracking settings. 

The teacher then accesses the Course completion status block and checks the names of the students who are 

deemed to have completed the course. 
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Course completion based on specified criteria 

It is possible to have a course marked as complete dependent on a combination of specified criteria such as 

activities completed, grade achieved or length of time spent in the course. This is decided in the overall criteria type 

aggregation. 

The settings for automatic course completion are described in more detail in Course completion settings and these 

include: 

 activities completed 

 date 

 duration after enrolment 

 grade 

 unenrolment 

Course completion report 

Course completion info can be viewed by managers, teachers and non-editing teachers (and any other users with 

the capability report/completion:view) in Administration> Course administration > Course completion or via a link in the 

Course completion status block. 

2.12 Reusing activities 
There are several ways to reuse a course or parts of a course. Most of them involve or are similar to a backup and 

restore process. 

2.12.1 Activity backup 

Backing up individual activities 

It is possible to make a copy or backup of individual activities in a Moodle course and then re-use these activities in 

a different Moodle site or in a different course on the same Moodle. (Note that if you wish to re-use activities within the 

same Moodle it might be simpler to use the import function.) 

To make a backup of an activity, ensure you are logged in with editing rights, as a teacher for example, and click on 

the activity you wish to backup. The settings block to the side will have a link Backup as with the assignment in the 

following screenshot: 

 

In the next screen, check/tick the type of item you wish to backup - in this case, just activities 
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Click Next and on the next screen, check the activity you wish to backup - in this case, our assignment: 

 

Click Next and on the next screen, if you wish, rename the filename (keeping its .mbz extension), check you have 

included the correct activity and click Perform backup. 

You will get a message saying the backup file was successfully created. Click Continue and you will find your 

backup in the User Private backup area of the next screen: 

 

You can download your file from here and then restore it to a course in another Moodle site. See Activity 

restore for infomation on how to do this. 

NOTE: For security reasons, those with the teacher role are not able to backup user information belonging to 

activities so there will be a red cross and padlock next to any user information. 

Backing up whole courses 

It is also possible to make a copy or backup of a whole course and re-use it elsewhere. The process is the same 

as backing up a single activity as we have done here. 
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2.12.2 Activity restore 

Restoring individual activities 

It is possible to bring in or "restore" into a new Moodle activities that have been copied or backed up in a 

different Moodle. (Note that if you wish to re-use activities within the same Moodle it might be simpler to use the 

import function.) 

To restore an activity you have backed up from another Moodle, ensure you have your backup file available (eg, 

on your computer or a USB pen) and ensure you are logged in with editing rights, as a teacher for example, and click 

the Restore link in the Course administration block: 

 

On the next screen, either drag and drop your backed up activity into the box with the arrow (1 below) or else 

click Choose a file to add it via the File picker (2 below); upload your backed up activity and click Restore. 

 

On the next screen, click Continue and then select the course into which you wish to restore your activity. 

Click Continue and then click Next. You will see your chosen activity: 
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Click Next and on the next screen, click Perform restore. Your activity will be added to your chosen course. 

2.12.3 Import course data 

Course activities and resources may be imported from any other course that the teacher has editing permissions 

in. This will allow teachers to re-use instead of re-creating one or more activities or resources. 

Import course data is similar to a backup and restore process and does not include any user data. 

How to import activities or resources 

 In Administration > Course Administration, click on the Import link: 

 

 Select the course you wish to import from and click Continue. 

 You will be presented with the "backup settings" page. Use the check boxes for import activities, blocks and or 

filters as types of items which will show on the next screen. 
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 Select the elements you want to include in the import in the Schema settings step. 

 

 Review and click Perform import or click the cancel or previous buttons. The confirmation page will place green 

check marks and red marks next to the backup settings and include item list for you to review. 

 

Examples and tips 

 Importing a quiz from course A to course B, will also add the questions to the question bank so you can use 

them in new quizzes. 

 Tip: Groups can also be imported as a batch from a file. 

2.12.4 Reset course 

Overview 

This allows you to empty a course of user data, while retaining the activities and other settings. Please be warned 

when choosing items you will delete your chosen user data from this course forever! 

You can select which user data to remove at a granular level under the categories of General, Roles, Gradebook, 

Groups and Activity data. 

Note: Only users with the reset course capability (by default managers and teachers) can reset a course. 

How to Reset - step by step 

1. Log in and go to the course area you want to reset 
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2. Resetting a given activity is irreversible, so ensure that you have taken a Backup of your area including the 

user data - this is a snapshot and can be reinstated if necessary 

3. In your area's Administration block, click on Reset 

4. Click any Show Advanced button to show all options for that category 

5. Make your selections based on the options (see below for more on these) 

6. Click the Reset button 

7. Return to your area and check that things are as you want them. 

General Reset Options 

(Before you reset) You will need to make sure that you back up the information that you have within your 

course before you reset. When you back up the course make sure that you back it up with the user information. That 

way you will have a back up data on the ones that have taken your course before you reset it for another group or 

department. 

Course start date 

You can set a new Course Start Date for the freshly reset course, delete all Calendar events, comments, course 

AND activity completion data and user notes attached to the course. Note that course logs are not deleted. 

NOTE: If you set a new course start date, then all course dates will be shifted by the same amount. 

Role Reset Options 

These Role Reset options allow you to unenrol all users with a particular role within a course (e.g students) as 

well as remove all role overrides and role assignment specific to the course. This does not affect user role assignments 

outside the context of the course. 

Gradebook Reset Options 

The Gradebook reset options allow you to delete all gradebook items and categories and/or delete all recorded 

grades within the course. There are two options for gradebook reset: 

Delete all grades - Removes all manually added grade items within the course together with grades and data on 

overridden, excluded, hidden and locked grades. Please note activity grade items are not removed in this option. 

Delete all items and categories - Remove all categories and related manually added grade items together with 

grades and data on overridden, excluded, hidden and locked grades. Please note activity grade items are not removed in 

this option. 

Note that these grades are still recorded against a user's account. 

Group Reset Options 

The Group reset options provides you with the ability to delete all groups created in the course and/or remove 

all users from any groups within the course. 

You can also delete all groupings created in the course and/or remove all users from any groupings within the 

course. 

Activity Reset Options 

Depending on the activities used within a course, you will be provided with the option to remove the user data 

associated with these learning objects. This includes responses to Choices, Quiz attempts, Feedback Responses, Forum 

posts (from selected Forum types), Glossary entries etc. 
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You can remove all attempts from all quizzes. 

For Workshop you can: 

 delete all submissions 

 delete all assessments 

 switch to the setup phase 

You can also specify a new course start date. 

3. Managing content 
Moodle is not primarily a content management system but it does offer a range of ways to import, export and 

manage digital content of any kind to enable and support learning. The following links will provide more information: 

3.1 Working with files 
Moodle provides an easy way for a teacher to present materials to their students. These materials may take the 

form of files such as word-processed documents or slideshow presentations. The materials can be displayed on the page 

either as individual items or bundled together inside folders. One teacher might for instance wish to share a single 

research document in pdf format; another might have a folder of sample past examination papers for students to 

download. 

Most types of files can be uploaded and accessed through Moodle but the student needs to have the correct 

software to be able to open them. 

3.1.1 Adding files 

To add files to a Moodle course, you must first ensure you have the editing turned on. 

Drag and drop 

If you are using a modern browser, you can simply click, hold and drag and drop a file directly onto your course 

page. You will know if drag and drop is available to you because you will (briefly) see a message at the top of your 

screen: 

 

To drag and drop a folder, you must first compress/zip it using whichever program your computer has. 

Add a resource or activity 

Instead of drag and drop, you can click the link 'Add an activity or resource' and select either File or Folder from 

the activity chooser (or choose from the 'Add a resource' drop down menu, if this is present instead. 
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The screen for uploading and displaying a file (or folder of files) includes an "add" button. Clicking on this button 

takes you to the File picker which is the name given to the file storage and access area within Moodle. Find out more 

about the places you can upload or add files from in the File picker page. 

There is also a block (with an arrow) into which you can drag and drop a file straight from your desktop into 

Moodle.(Note that this currently doesn't work with Internet Explorer.) 

 

3.1.2 Viewing uploaded files 

 Once uploaded, files appear as thumbnails in the file manager for easy recognition. 

 Files view can be easily toggled between icons view or a table view with sizes and dates, or a hierarchical list 

view. 
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3.1.3 Editing or updating uploaded files 

Clicking on the name of an uploaded file opens up a pop up dialogue box which allows file details quickly to be 

altered. 

 

3.1.4 Creating an alias/shortcut 

When an uploaded file - or a file from the Private files, Dropbox, File system - is re-used elsewhere on Moodle, 

the teacher has the option to make a copy (a new, unconnected version) or to create a shortcut or alias.  

If an alias is created, then when the original file is updated, it will change in all instances of the alias. So a 

teacher might add course notes to their private files for example, and then add them into a number of courses. When 

the teacher makes an alteration in the file in their private files, this alteration will be reflected in all instances of the 

course notes. 

An alias can be recognised by its thumbnail. See the difference in the screenshot below between the original file 

(left) and the alias (right): 

 

To update a file, go to its orginal location (for example Private files) and upload your new version with the same 

name . You will be prompted to override or rename the file. Choose "override" and this file will replace your original file 

and the alisase/shortcuts will remain and all be updated to your latest version. 
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Areas in which aliases cannot be made 

An alias cannot be made in the following areas of Moodle: 

 an assignment submission 

 a forum post attachment 

 a workshop submission 

 a quiz essay 

 a database activity file field 

This is to prevent cases such as a student uploading an item for assessment and then subsequently changing the 

original in their private files. When a student uses a file from their private files in one of these instances, they do not see 

the options to "copy" or "create an alias". Below is an example of a file added to an assignment: 

 

3.2 Repositories 
Repositories in Moodle enable users to upload files, access previously uploaded files and to easily bring content 

into Moodle from external repositories, such as Flickr or Google Docs. Enabled repositories are available in the File 

picker. (Note that you cannot upload files into a repository from Moodle.) 

Repositories enabled by default: 
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 Upload a file - you use this for browsing for and uploading a file from your computer or USB. 

 

Recently uploaded files may be accessed by clicking on the recent files link in the file picker. 

 Server files - The server files repository enables teachers and managers to access files used within a course and 

elsewhere on the site which they have permission to access. Activity modules for which files are available in the 

server files repository are: 

o File resource 

o Folder resource 

o Database 

o Forum 

o Glossary 

o Lesson 

 

When a file from the server files repository is re-used elsewhere on Moodle, the teacher has the option to make 

a copy (a new, unconnected version) or to create a shortcut or alias.  

The capability View server repository, which is allowed for the default roles of manager, course creator, teacher and 

non-editing teacher, ensures that the server files repository is listed in the file picker. This capability should be allowed 

together with the manage files capability to enable users to access files used within a course. 

 Recent files - the last 50 files you have uploaded, according to the context. 

 Private files - your own personal storage area for files. 
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 Youtube videos - search for and display Youtube videos. The option needs to be enabled by the administrator 

before it is available for teachers and students (Got to Administration>Site 

administration>Plugins>Repositories>Manage Repositories;).  

 URL downloader - enables users to enter the URL of an image (any type e.g. png, jpg) for copying into Moodle. It 

may also be used to obtain all images from a web page by entering the web page address.  

                        

 Wikimedia - enables a user to search Wikimedia and copy a selected file into Moodle. When a file is chosen, 

Moodle displays the image dimensions, license, author, last modified date (and file size if it is smaller than the 

maximum dimension specified). 

Additional repositories may be enabled by a site administrator in Administration > Site administration > Plugins> 

Repositories > Manage repositories. 

3.2.1 Private files 

The private files area 

Each user has a private files area for uploading and managing a set of files. If enabled by the administrator, users 

can also email files to their private files area (new in 2.8). 

The private files area can be accessed via Navigation > My home > My profile > My private files or the My private 

files block. If the private files repository is enabled by a site admin, it is available as a source within the filepicker when 

selecting files to use in a course. 

Private files management 

To add a file to your private files area 

1. On the Navigation menu, click My profile > My private files 

2. The file manager will appear. 

3. If desired, create a folder for your file(s) 

4. Click on the Add button to upload from the File picker or drag and drop from your desktop. It will look like 

the files are already there, but they aren't until you do the next step! 

5. Click the 'Save changes' button 
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Once uploaded, files will appear as thumbnails. Clicking the icons top right will display them in table or list view 

as an alternative. 

 

Making an alias/shortcut to a file in the private files area 

If a file is uploaded into your private files area, it is possible when using it elsewhere on Moodle to select it as an 

alias/shortcut. This means that if you update the file in your private files area, it will automatically update elsewhere on 

Moodle. 

 

Private files size limit 

The size limit for each user's private files area is set by a site administrator in User quota in Administration > Site 

administration > Security > Site policies. 

Preventing access to Private files 

To prevent all users having access to Private files, the administrator should disable the repository 

inAdministration>Site administration>Plugins>Repositories>Manage repositories. and in Administration>Site 

administration>Users>Permissions>Define Roles edit the authenticated user role and set the capabilities 

'moodle/user:manageownfiles' and 'repository/user:view' to prohibit. 

If only students are to be prevented from accessing private files (but teachers etc, allowed) then a new role 

should be made and assigned system wide. 
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3.3 Working with media 
Moodle includes a wide variety of ways in which both teachers and students can add media. A teacher, for 

example, might include a video or sound file in a Lesson or Quiz which could then form the basis of a set of questions. 

A student could add an image to a forum discussion, glossary or database. It is also possible (with certain 

restrictions) to embed code from sites such as Google Maps or Voki. 

3.3.1 Video 

Video is a very powerful tool to use in a Moodle course, allowing students, for example to catch up on lectures 

they missed, learn from a "how to" screencast, or improve their language skills by watching native speakers interact. 

Where to host the videos 

Whenever possible, it is preferable to upload your videos to Moodle, storing them on your own server as you 

retain ultimate control. However, when server space or upload limits are restricted, it is convenient to upload videos to 

an online site like youtube or Vimeo. They can easily be embedded inside Moodle from such sites and privacy can still be 

maintained if you choose their private video sharing option. 

Cross domain video hosting 

Flash video players require permission to play videos hosted on a different URL, e.g. yourmoodle.org needs 

permission to play video files hosted at yourvideo.org. The permission files are stored on the root domain of where the 

video files are hosted, e.g. yourvideos.org/crossdomain.xml. If yourvideos.org does not have a cross domain policy file 

that permits yourmoodle.org to play videos, Flash Player will not permit it. Further details are available here. 

Many public video hosting services, such as YouTube.com, already have catch-all cross domain policy files in 

place and so videos can be played from them via your Moodle without any cross domain security issues arising. 

Ways of displaying video 

Linking to a video online elsewhere 

 If your video is hosted elsewhere online (such as youtube) you can simply link to the relevant page by 

choosing Add a resource>URL and pasting in the relevant link. 

 Note that, in an establishment where certain video sharing sites might be banned, your students might not be 

able to access your video through Moodle. 

Uploading a video for students to download 

 Choose this option if you wish to upload your video to Moodle and give users the option to download it to their 

own computers. 

 Choose Add an activity or resource>File 

 Note that the way the video will display depends on the software the user has on their own computer. This 

could mean that some students might be unable to view your video. 

Embedding a video in its own player 

 Moodle has an inbuilt video player called Flowplayer.  

 Anywhere that Moodle's text editor is available, it is possible to embed a video, for example in a label or a page, 

a course topic summary, a quiz description or a lesson. 

 One exception seems to be MP4 files. They don't seem to play in Flowplayer unless hacked.  

Using the Moodle media icon 

 With your editing turned on, click into the HTML editor where you wish to embed your video. 

 Click the Moodle media icon as in the following screenshot: 
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 Click Browse repositories 

 

 The file picker will appear: 

 

 Either click Upload a file to upload from your computer or choose the appropriate repository from which you 

wish to bring in your video. (What you see will depend on what the Moodle admin has enabled) 

 Change the save as/author/license settings if desired and click upload this file or select this file 

 Your video will appear in a preview player. Click Insert at the bottom 
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 Don't panic! You will now only get a blue text link of your video: 

 

 When you click save changes to return to the main course page, your video will display: 

 

Using embed code to display external videos 

 Go to your chosen video sharing site and find the embed code of the video you wish to display. Copy this code. 

 With your editing turned on, click into the HTML editor where you wish to embed your video. 

 Click the HTML code icon as in the following screenshot: 

 

 Paste your embed code into the box: 

 

 Scroll down and click "update". 

 Your video will be previewed in the HTML editor. Click save changes for it to display on the page. 
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3.3.2 Audio 

Note: This chapter covers audio (sound files) which are added to a course by the teacher for students to listen to. 

Audio is a very powerful tool to use in a Moodle course, allowing students, for example to catch up on lectures they 

missed, learn from podcasts, or improve their language skills by listening to native speakers interact. To use audio in 

Moodle to best effect, audio players such as the MP3 player should be enabled in Administration > Site administration > 

Appearance > Media embedding in addition to the Multimedia plugins filter.  

Types of audio (sound) files 

Moodle will accept the following audio file formats.If you want your sound file to play in its own player (embedded) 

on a page then choose mp3 format. 

 .mp3 

 .aac 

 .wma (Windows Media Audio) 

 .rm (Real Media) 

Ways of displaying audio 

Linking to a sound file online elsewhere 

 If your audio file is hosted elsewhere online (such as Grooveshark) you can simply link to the relevant page by 

choosing Add a resource>URL and pasting in the relevant link given you by the site. 

 Note that, in an establishment where certain sharing sites might be banned, your students might not be able to 

access your sound file through Moodle. 

Uploading audio for students to download 

 Choose this option if you wish to upload your sound file to Moodle and give users the option to download it to 

their own computers. 

 Choose Add a resource>File 

 Note that the way the audio will display depends on the software the user has on their own computer. This 

could mean that some students might be unable to access your audio. 

Embedding a sound file in its own player 

 Moodle includes a built-in mp3 player. If the relevant Multimedia plugins filter is enabled by the 

administrator and within the course, sound files embedded into the text editor will play inline. 

 Anywhere that Moodle's text editor is available, it is possible to embed a sound file, for example in a label or 

a page, a course topic summary, a quiz description or a lesson. The next section explains how: 

Using the Moodle media icon 

 With your editing turned on, click into the HTML editor where you wish to embed your sound file. (It needs to 

be mp3) 

 Click the Moodle media icon as in the following screenshot: 

 

 Click Find or upload a sound,video or applet 

 The file picker will appear: 
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 Either click Upload a file to upload an mp3 file from your computer or choose the appropriate repository from 

which you wish to bring in your sound file. (What you see will depend on what the Moodle admin has enabled) 

 Change the save as/author/license settings if desired and click upload this file or select this file 

 Your sound file will appear in a preview player. Click Insert at the bottom 

 Don't panic! You will now only see a blue text link of your mp3 file 

 When you click Save changes to return to the main course page, your mp3 file will display: 

 

3.3.3 Images 

Moodle allows teachers and students to upload and display images from a variety of sources via the image icon 

of the text editor.Course pages can be enhanced with images (or banners) in each section. Assignments can include 

images for extra clarification. Images attached to forum posts or quiz questions will appear embedded. 

Moodle accepts .jpg,.png,.svg and .gif formats. 

Uploading and displaying an image from your computer 

 Note: It is a good idea to resize your image before uploading, rather than altering its dimensions online. 

 With the editing turned on, access the text editor where you want to display your image (eg, in a course 

summary,label or page) 

 Click the image icon as below 

 

 Either enter the URL of an image which is already online or click 'Browse repositories' to access the File picker 

 

 Click Upload a file. Browse for and upload your image.  

 Either add a description of the image or tick/check the box 'Description not necessary'. 

 Alter the size and alignment if needed and save the image 
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Editing an uploaded image 

 If you need to edit the image once it has been uploaded,you can double-click on the image from within text 

editor and access the image properties window. Note it is much better to upload an image of the desired size 

rather than modifying it afterwards. 

Dragging and dropping an image 

 Images may be dragged and dropped directly into a label onto the course page if you are using a supported 

browser (not IE 9, Safari 6 or below or earlier versions of Firefox) and 'media drag and drop" is enabled in 

Administration > Site administration > Plugins > Activity modules > Label and verify the box 'media drag and 

drop' setting is ticked. 

 As you drag the image, a prompt box appears where you choose "add image to course page" rather than "create 

a file resource" 
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Displaying an image already online 

If you have images available elsewhere online, you can display them too without the need to upload to Moodle. 

Note: If the image is taken offline, it will be replaced by a red X on your course page. Also, so-called hot-linking to 

images online if you don't own them yourself is not recommended. 

Method 1 

 Follow the instructions for Uploading and Displaying an image as above. 

 Paste the URL of the image you have online into the Enter URL box. 

 Add a description of the image or tick/check the box for no description 

 

 

 

 

 

 

 Save the image. 

Method 2 

It is possible to copy and paste an online image into the text editor in the same way that some students might copy 

and paste into a presentation. Care must be taken however that images pasted this way are not subject to copyright, 

and also that the image doesn't come with an unwanted hyperlink. 

3.3.4 Media embedding 

Embedding audio and video 

Audio and video may be embedded in a course in the following ways: 

 As a file resource 

 As a URL resource with embed as the display option 

 In a lesson popup 

 In any text area using the Moodle media button in the text editor or simply by typing the URL of media file 

The media file link is then replaced with an appropriate multimedia player which can play the resource. 

Enabling media embedding 

To enable the embedding of media files, an admin must enable 

1. Appropriate media players (see below) 

2. The Multimedia plugins filter - unless you only want to allow embedding in File, URL and Lesson modules. 

Site administration settings 

An administrator can enable selected media players in Administration> Site administration > Appearance > Media 

embedding. 



 

                                                                                                                                            
383 

Tel/Fax: +40 262 226 778 
Web: http://www.holisun.com ● E-mail: info@holisun.com 

 

Document CONFIDENTIAL   

Available players 

 YouTube (displays videos hosted on youtube) 

 Vimeo (displays videos hosted on vimeo) 

 .mp3 - MPEG Audio Stream, Layer III 

 .flv - Flash video 

 .f4v - Flash video 

 .swf - Macromedia Flash animation File (Adobe, Inc.) 

Note: Only used in trusted texts as it has potential security issues 

 .ogg - HTML 5 audio 

 .acc - HTML 5 audio 

 .mp3 - HTML 5 audio 

 .webm - HTML 5 video 

 .m4v - HTML 5 video 

 .ogv - HTML 5 video 

 

 

  

 


